Subject: [Teas-ns-dt] Contribution to new NS Framework draft

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 7 Feb 2020 17:02:32 +0000

Eric, Jari and all,

As per our discussion during yesterday’s DT meeting, attached are my contribution to the new NS Framework draft. A few notes:

  *   I was not able to add these to GitHub. As a result, I wrote them in XML. Both XML and TXT versions are attached.
  *   Eric and Jari, please add them to master document in GitHub
  *   After merge, please review and send your comments/feedbacks in mailing list.
  *   There are still a few sections that I would like to contribute. I will do it later.

Thanks,

Reza

---

From: John E Drake <[email-masked]>
Date: Fri, 7 Feb 2020 19:11:08 +0000

Hi,

There seems to be way too much emphasis on E2E slice management.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas-ns-dt <[email-masked]> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Friday, February 7, 2020 12:03 PM
To: Eric Gray <[email-masked]>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>; Kiran Makhijani <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]; Jari Arkko <jari.arkko=[email-masked]>; Shunsuke Homma <[email-masked]>; Jeff Tantsura <[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: [Teas-ns-dt] Contribution to new NS Framework draft

Eric, Jari and all,

As per our discussion during yesterday's DT meeting, attached are my contribution to the new NS Framework draft. A few notes:

Thanks,

Reza

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 7 Feb 2020 19:58:33 +0000

All,

FYI, I am currently working on following sections as well:

-          Transport Slice Controller Mapping Functions

-          Transport Slice Controller SBI Interfaces

-          Transport Slice Monitoring and assurance

-          Transport Slice Optimization

Reza

From: Reza Rokui <[email-masked]>
Date: Friday, February 7, 2020 at 12:02 PM
To: Eric Gray <[email-masked]>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>, Kiran Makhijani <[email-masked]>, Sergio Belotti <[email-masked]>, "[email-masked]" <[email-masked]>, Jari Arkko <jari.arkko=[email-masked]>, Shunsuke Homma <[email-masked]>, Jeff Tantsura <[email-masked]>
Cc: Reza Rokui <[email-masked]>
Subject: [Teas-ns-dt] Contribution to new NS Framework draft

Eric, Jari and all,

Thanks,

Reza

---

From: Eric Gray <[email-masked]>
Date: Mon, 10 Feb 2020 12:51:37 +0000

I agree with John, at least to the extent that we should limit discussion of "end-to-end" slice management to just that much that we need to know to understand that there will likely be a higher-level management/configuration/orchestration/controller/etc. system that needs specific support for creating/modifying/removing Transport Slices - likely at several points in an "end-to-end" network slice, whatever that might mean.

I don't think we even need to - or should - define what an "end-to-end" network slice is, except as possible examples to provide a background for the remainder of our work, because we simply do not need to know that.

--
Eric

From: John E Drake <[email-masked]>
Sent: Friday, February 7, 2020 2:11 PM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; Eric Gray <[email-masked]>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>; Kiran Makhijani <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]; Jari Arkko <jari.arkko=[email-masked]>; Shunsuke Homma <[email-masked]>; Jeff Tantsura <[email-masked]>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft
Importance: High

Hi,

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Friday, February 7, 2020 12:03 PM
To: Eric Gray <[email-masked]<mailto:[email-masked]>>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>; Kiran Makhijani <[email-masked]<mailto:[email-masked]>>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>; Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: [Teas-ns-dt] Contribution to new NS Framework draft

Eric, Jari and all,

Thanks,

Reza

---

From: Eric Gray <[email-masked]>
Date: Mon, 10 Feb 2020 13:51:51 +0000

Reza,

              Thanks for providing this contribution.

              There was an earlier branch (pull available at https://github.com/teas-wg/teas-ns-dt/pull/5/commits/36ba2d290d9952a7642dc2a6dd6f44c35025700b) created for the framework draft, by Dhruv Dhody, specifically to provide a mapping to ACTN.  We need to discuss that – either via the mailing list, or on one of our conference calls – to determine a disposition for the text Dhruv provided.

              Jari mentioned this at the last conference call meeting, last Thursday.

              If possible, we should look at Dhruv’s contribution, and your own, on today’s call – though I believe you had said you would likely be unable to attend.  If the discussion on the conference call gets to be too complicated there, we should take it off-line and resolve it either via continued E-Mail discussion, or perhaps (just to get a handle on what the intention is) a later call with a smaller number of people to propose some way forward that we might be able to take significant steps toward in time to meet our objective time-line before the March IETF meeting.

              As a provisional summary (please verify – or correct – my understanding):

  1.  Dhruv proposed the addition of 4 references, and 3 paragraphs, to the controller section that essentially provides a description of the relationship of the terminology used in ACTN to the “controller” we describe in this framework draft.
  2.  Your proposal is considerably more complicated in that you provide a table of contents (which I don’t personally see as being especially useful, except as evidence of the complexity of you contribution, which includes six major subsections (with many further subdivisions) and stretches over 10 pages.

              Note that – in the current draft – the section on the controller is a subsection already (subsection 3.3), but I suspect that your intention is that your proposed text would be added (at least) as a separate major section (perhaps between current section 3 (Framework) and 4 (Considerations).

              If we were to keep (mostly) to the current draft structure, adding this text as a new high-level section would seem to require the addition of other new sections corresponding to current sections 3.1, 3.2, 3.4 and 3.5.

              On the other hand, even if we kept this as part of the current subsection (3.3), without some flattening, this would result in addition of new sections along the following lines:
              3.3.1
                             3.3.1.1
                             …
                             3.3.1.4
              3.3.2
              …
              3.3.5
                             3.3.5.1
              3.3.6
                             3.3.6.1
                             …
                             3.3.6.6
                                           3.3.6.6.1
                                           …
                                           3.3.6.6.3
                             3.3.6.7
                                           3.3.6.7.1
                                           3.3.6.7.2

In addition, the added text would more than double the current content of the framework draft.

Again, this would seem to argue that – for balance – we would need to add similar quantities of text for the remaining subsections of section 3.

Remember that there was some agreement that this framework draft should be relatively light.  I doubt that many people would consider a 50-page draft “light.”

--
Eric

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>

Eric, Jari and all,

Thanks,

Reza

---

From: Eric Gray <[email-masked]>
Date: Mon, 10 Feb 2020 16:11:22 +0000

Hi Reza.

Not sure why we need to know that, mostly from a perspective of orthogonality.  We (in terms of defining a Transport Slice) only need to know what the requirements are for a specific application, where the fact that the application may be a higher-layer control function for an “end-to-end” network slice does not even rise to the level of interesting information.

--
Eric

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Sent: Monday, February 10, 2020 8:57 AM
To: Eric Gray <[email-masked]>; John E Drake <[email-masked]>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>; Kiran Makhijani <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]; Jari Arkko <jari.arkko=[email-masked]>; Shunsuke Homma <[email-masked]>; Jeff Tantsura <[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas-ns-dt] Contribution to new NS Framework draft
Importance: High

Thanks Eric and John for your comments.

In my opinion we need to have some materials to show clearly how “Transport Slice” is related to the overall e2e network slice. And also shows that “Transport Slice” is not same as “e2e network slice” and they are different.

We can revise the exiting text to make it more concise. Everyone can help with this.

Reza

From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 10, 2020 at 7:51 AM
To: John E Drake <[email-masked]<mailto:[email-masked]>>, Reza Rokui <[email-masked]<mailto:[email-masked]>>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>, Kiran Makhijani <[email-masked]<mailto:[email-masked]>>, Sergio Belotti <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>, Shunsuke Homma <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft

I agree with John, at least to the extent that we should limit discussion of “end-to-end” slice management to just that much that we need to know to understand that there will likely be a higher-level management/configuration/orchestration/controller/etc. system that needs specific support for creating/modifying/removing Transport Slices – likely at several points in an “end-to-end” network slice, whatever that might mean.

I don’t think we even need to – or should – define what an “end-to-end” network slice is, except as possible examples to provide a background for the remainder of our work, because we simply do not need to know that.

--
Eric

From: John E Drake <[email-masked]<mailto:[email-masked]>>
Sent: Friday, February 7, 2020 2:11 PM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Eric Gray <[email-masked]<mailto:[email-masked]>>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>; Kiran Makhijani <[email-masked]<mailto:[email-masked]>>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>; Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft
Importance: High

Hi,

Yours Irrespectively,

John

Eric, Jari and all,

Thanks,

Reza

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 10 Feb 2020 13:56:55 +0000

Reza

From: Eric Gray <[email-masked]>
Date: Monday, February 10, 2020 at 7:51 AM
To: John E Drake <[email-masked]>, Reza Rokui <[email-masked]>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>, Kiran Makhijani <[email-masked]>, Sergio Belotti <[email-masked]>, "[email-masked]" <[email-masked]>, Jari Arkko <jari.arkko=[email-masked]>, Shunsuke Homma <[email-masked]>, Jeff Tantsura <[email-masked]>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft

--
Eric

Hi,

Yours Irrespectively,

John

Eric, Jari and all,

Thanks,

Reza

---

From: Eric Gray <[email-masked]>
Date: Wed, 19 Feb 2020 19:49:13 +0000

Reza,

              Thanks for your response.  I will look at what you’ve added.

              I suspect there is a disconnect here, however.  An important design consideration in any relationship between entities, is to minimize unnecessary interactions.

              In terms of having material that clarifies the relationship between a transport slice and an end-to-end network slice, it is only necessary to state that each transport slice is a subset of the end-to-end network slice.  Note that I do not say a “proper subset” because I am certain that there will be applications where the transport slice is exactly the same thing as the end-to-end network slice.

              Going any further in “clarifying the relationship” is likely to introduce restrictions in the applicability of transport slices – i.e. – if we say that the relationship is some function (pick your favorite) or characteristic in common, we eliminate all applications that might otherwise benefit from the network slice abstraction, but don’t necessarily require this relationship.

              I agree that details are helpful in determining if a transport slice is doing its part in supporting an end-to-end network slice, but I suspect that this would be an implementation concern.  And I doubt it is very important in any general description of the problem we are trying to solve.

              Like I said, however, I will need to see what you have changed in your contribution.  It seems likely that I am reading more into what you’ve said than you intended.

--
Eric

Sent: Wednesday, February 19, 2020 11:40 AM

Hi Eric,

Good point but I explained it in my contribution why we need them. It is basically needed not for creation of the transport slice but for monitoring and assurance. It will be a tremendous help for debugging and troubleshooting of a transport slice when we know how it is mapped to e2e network slice. I have added this to my contribution I sent last week.

Cheers,

Reza

From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 10, 2020 at 11:11 AM
To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, John E Drake <[email-masked]<mailto:[email-masked]>>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>, Kiran Makhijani <[email-masked]<mailto:[email-masked]>>, Sergio Belotti <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>, Shunsuke Homma <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft

Hi Reza.

--
Eric

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 10, 2020 8:57 AM
To: Eric Gray <[email-masked]<mailto:[email-masked]>>; John E Drake <[email-masked]<mailto:[email-masked]>>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>; Kiran Makhijani <[email-masked]<mailto:[email-masked]>>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>; Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas-ns-dt] Contribution to new NS Framework draft
Importance: High

Reza

--
Eric

Hi,

Yours Irrespectively,

John

Eric, Jari and all,

Thanks,

Reza

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 19 Feb 2020 16:39:54 +0000

Eric,
Thanks for your response.

In general, I am ok to move my contributions to different sections but since I was not able to add them directly to the GitHub, I wrote them in XML format.

Jari, any decision on this as it would be a good idea to finalize the structure of this draft  in tomorrow’s meeting.

Cheers,

Reza

From: Eric Gray <[email-masked]>
Date: Monday, February 10, 2020 at 8:51 AM
To: Reza Rokui <[email-masked]>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>, Kiran Makhijani <[email-masked]>, Sergio Belotti <[email-masked]>, "[email-masked]" <[email-masked]>, Jari Arkko <jari.arkko=[email-masked]>, Shunsuke Homma <[email-masked]>, Jeff Tantsura <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft

Reza,

--
Eric

Eric, Jari and all,

Thanks,

Reza

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 19 Feb 2020 16:40:11 +0000

Hi Eric,

Cheers,

Reza

From: Eric Gray <[email-masked]>
Date: Monday, February 10, 2020 at 11:11 AM
To: Reza Rokui <[email-masked]>, John E Drake <[email-masked]>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>, Kiran Makhijani <[email-masked]>, Sergio Belotti <[email-masked]>, "[email-masked]" <[email-masked]>, Jari Arkko <jari.arkko=[email-masked]>, Shunsuke Homma <[email-masked]>, Jeff Tantsura <[email-masked]>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft

Hi Reza.

--
Eric

Reza

--
Eric

Hi,

Yours Irrespectively,

John

Eric, Jari and all,

Thanks,

Reza

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 20 Feb 2020 13:09:02 +0000

Hello all,

Based on the discussions with Eric, Jari and others, I have posted 4 post-requests for Framework draft. I’ve shortened the sections I have previously submitted.
Please take a look and send your comments.

Eric and Jari, please merge these contributions to the draft.
We can discuss these today during our DT session.

Cheers,
Reza

From: Eric Gray <[email-masked]>
Date: Wednesday, February 19, 2020 at 2:49 PM
To: Reza Rokui <[email-masked]>, John E Drake <[email-masked]>, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>, Kiran Makhijani <[email-masked]>, Sergio Belotti <[email-masked]>, "[email-masked]" <[email-masked]>, Jari Arkko <jari.arkko=[email-masked]>, Shunsuke Homma <[email-masked]>, Jeff Tantsura <[email-masked]>
Subject: RE: [Teas-ns-dt] Contribution to new NS Framework draft

Reza,

--
Eric

Hi Eric,

Cheers,

Reza

Hi Reza.

--
Eric

Reza

--
Eric

Hi,

Yours Irrespectively,

John

Eric, Jari and all,

Thanks,

Reza