Subject: [Teas-ns-dt] Notes from Feb 24th call & deadline

From: Jari Arkko <[email-masked]>
Date: Tue, 25 Feb 2020 07:26:21 +0000

The notes are now available here: https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-02-20.md Let me know if there are any changes needed.

I would also like to underline the importance of working on the two documents and their issues now on the mailing list. It feels like we are now making rapid progress. However, we only have 13 days left. It is important that we check the discussion daily so that we have enough email roundtrips to finish the issues we’re discussing. And contributions on both documents are also needed. You can suggest changes by sending mail to the list.

The drafts in their current form are at

  https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/draft-rokui-teas-transport-slice-definition-00.txt
  https://github.com/teas-wg/teas-ns-dt/blob/master/framework/draft-ejj-teas-ns-framework-00.txt

But there are also a number of big contributions discussed, see the notes for pointers.

Jari

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 25 Feb 2020 08:19:51 +0000

Hi Jari, Reza as co-author of definition draft, all,
I read again draft definition and in the new version is still missing the proposed new definition of transport slice as for my pull request sent 25 days ago.
Is there any objection to the adoption of my proposed text? If not, I suggest editor to provide a new version including the text contained in
https://github.com/teas-wg/teas-ns-dt/pull/4.

Thanks
Sergio

Sergio Belotti
Senior System Engineer and Standardization Architect
IP/Optical Networks, Optics BU
Nokia
M: +39-335761776
Via Energy Park, 20871 Vimercate (MB) , Italy
[email-masked]<mailto:[email-masked]>

From: Teas-ns-dt <[email-masked]> On Behalf Of Jari Arkko
Sent: Tuesday, February 25, 2020 8:26 AM
To: [email-masked]
Subject: [Teas-ns-dt] Notes from Feb 24th call & deadline

Jari

---

From: Kiran Makhijani <[email-masked]>
Date: Tue, 25 Feb 2020 16:44:47 +0000

Hello Sergio,
It is my bad! I assumed through conversations in meetings it was clear not to change the definition.

  *   The current definition has a wide consensus from the group. I am afraid we might undo what we agreed upon 5-6 months ago.
  *   We also had discussions on why we would not use the term virtual network (to not to exclude physical/dedicated network, resources – abstract was the best term). I highlight my concerns in your proposed definition, please see below (essentially, it is too verbose- we tried to keep it to the point).

“A transport network slice is a virtual network with a particular

   network topology and a set of shared or dedicated network resources,

[KM] We capture this essence in SLOs. See discussion on SLO section

   which are used to provide the network slice consumer with the

   required connectivity, appropriate isolation and

[KM] We use “topology connecting…”, therefore, no point repeating this.

   specific Service Level Agreement (SLA) or Service Level Objective (SLO).”

^^^^

[KM] in IETF 106, we decided to distinguish between SLA and SLO. SLO are more accurate. If we use both SLA and SLO – the definition is vague.

How about we make it sound like below?

"A transport slice is an abstract network topology connecting a
   number of endpoints and a set of shared or dedicated network resources, with expected objectives specified through a set
   of service level objectives (SLO)".

If you would like to propose some text outside the definition which you think could help, please suggest.
HTH,
Kiran

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tuesday, February 25, 2020 at 12:19 AM
To: Jari Arkko <jari.arkko=[email-masked]>, "[email-masked]" <[email-masked]>, "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Cc: Kiran Makhijani <[email-masked]>
Subject: RE: Notes from Feb 24th call & deadline

Hi Jari, Reza as co-author of definition draft, all,
I read again draft definition and in the new version is still missing the proposed new definition of transport slice as for my pull request sent 25 days ago.
Is there any objection to the adoption of my proposed text? If not, I suggest editor to provide a new version including the text contained in
https://github.com/teas-wg/teas-ns-dt/pull/4<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fpull%2F4&data=02%7C01%7Ckiranm%40futurewei.com%7C0bad100fc6cb45847dda08d7b9cb7e58%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182155959468964&sdata=2hC8HaNlywBaFkuA7KntBK4llSwP2FEkZLfq4qFBmdE%3D&reserved=0>.

Thanks
Sergio

Sergio Belotti

The notes are now available here: https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-02-20.md<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fnotes%2Fnotes-2020-02-20.md&data=02%7C01%7Ckiranm%40futurewei.com%7C0bad100fc6cb45847dda08d7b9cb7e58%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182155959468964&sdata=LH54VedrNDrA%2F3M1K9swHnhrWSX7cYjFrGNiC2VJ7Ro%3D&reserved=0> Let me know if there are any changes needed.

  https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/draft-rokui-teas-transport-slice-definition-00.txt<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fdefinitions%2Fdraft-rokui-teas-transport-slice-definition-00.txt&data=02%7C01%7Ckiranm%40futurewei.com%7C0bad100fc6cb45847dda08d7b9cb7e58%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182155959478919&sdata=0xwFzDv3Pyw0eX421EolRMU3E9Cf8Y%2BlCqtFowdNLFs%3D&reserved=0>
  https://github.com/teas-wg/teas-ns-dt/blob/master/framework/draft-ejj-teas-ns-framework-00.txt<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fframework%2Fdraft-ejj-teas-ns-framework-00.txt&data=02%7C01%7Ckiranm%40futurewei.com%7C0bad100fc6cb45847dda08d7b9cb7e58%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182155959478919&sdata=5cDKu8PtHbJI5buiNObDeH0CAyO61YWcp9cmRYnq9mI%3D&reserved=0>

Jari

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 25 Feb 2020 18:21:02 +0000

Hi Kiran,
Please see in line.
I disagree on your comments and I’d like a general discussion on the topic instead of just your opinion.
As reported below my proposal exactly is following the request from Jari.

Regards
Sergio

From: Kiran Makhijani <[email-masked]>
Sent: Tuesday, February 25, 2020 5:45 PM
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Jari Arkko <jari.arkko=[email-masked]>; [email-masked]; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: Notes from Feb 24th call & deadline

Hello Sergio,

SB> It would be interesting to understand form what you perceived this.
This is an extract of the discussion held on January https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-01-27.md
“The discussion converged on referring to existing RFCs (and aligning both enhanced-vpn and design team documents). There was strong support for reusing existing definitions.
But then it was somewhat unclear what specific definition exists for instance in Section 4 (abstractions) of RFC 7926. Or in RFC 8453. And Jari commented that while he is happy with the definition in the Enhanced VPN draft in general, in his opinion in one way it has an issue, as it picks up dedicated resources and isolation, and does not consider the full set of characteristics like the design team definitions draft version does. This might be fixable of course.
This discussion did not finish during the call. We decided to:

  *   Have the different proponents (at least Sergio, Jeff, Jari, Shunsuke, and definitions draft authors) each look at RFC 7926, 8453, Enhanced VPN draft and other sources and suggest specific replacement definition that uses a reference to earlier work. “

SB> There is nothing in the discussion than can conclude any acceptance of the present definition , while what I did is to report a definition strictly related to both ACTN (and the text Dhruv proposed for framework) and RFC 7926 , in which it is clearly define the difference between virtual network and abstract network , motivating why in the ACTN we use the term VN in accordance as slice.

I’ve already put in the issue https://github.com/teas-wg/teas-ns-dt/issues/3 my comments and why your definition is not good.

  *   The current definition has a wide consensus from the group. I am afraid we might undo what we agreed upon 5-6 months ago.
SB> I haven’t seen any agreement on that a shown by extract above. And I’d like to have real discussion not just your opinion on my proposal, since no comments also on my issue was raised.

  *   We also had discussions on why we would not use the term virtual network (to not to exclude physical/dedicated network, resources – abstract was the best term). I highlight my concerns in your proposed definition, please see below (essentially, it is too verbose- we tried to keep it to the point).
SB> VN definition does exclude nothing of you’re saying , RFC 8453 is explaining very well the concept and usage of VN.

^^^^

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 25, 2020 at 12:19 AM
To: Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>
Cc: Kiran Makhijani <[email-masked]<mailto:[email-masked]>>
Subject: RE: Notes from Feb 24th call & deadline

Thanks
Sergio

Sergio Belotti

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Jari Arkko
Sent: Tuesday, February 25, 2020 8:26 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Teas-ns-dt] Notes from Feb 24th call & deadline

Jari

---

From: Kiran Makhijani <[email-masked]>
Date: Tue, 25 Feb 2020 19:05:33 +0000

Sergio,
to keep discussion simple, is your main problem right now about abstract vs logical/virtual network?
-Kiran

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tuesday, February 25, 2020 at 10:21 AM
To: Kiran Makhijani <[email-masked]>, Jari Arkko <jari.arkko=[email-masked]>, "[email-masked]" <[email-masked]>, "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Subject: RE: Notes from Feb 24th call & deadline

Hi Kiran,
Please see in line.

Regards
Sergio

Hello Sergio,

This is an extract of the discussion held on January https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-01-27.md<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fnotes%2Fnotes-2020-01-27.md&data=02%7C01%7Ckiranm%40futurewei.com%7C7326accfb91c4e02883208d7ba1f7aef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182516692349007&sdata=nBmaVlWmfzQY4Oax1GII4HoXx4Yevmjuf%2Bzv2Lbk1Jw%3D&reserved=0>

I’ve already put in the issue https://github.com/teas-wg/teas-ns-dt/issues/3<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fissues%2F3&data=02%7C01%7Ckiranm%40futurewei.com%7C7326accfb91c4e02883208d7ba1f7aef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182516692359010&sdata=8I7EX%2FtMJ7FT2Pb78A8vrx8gsf4yusl1gtkJb8O2%2FXY%3D&reserved=0> my comments and why your definition is not good.

^^^^

Hi Jari, Reza as co-author of definition draft, all,
I read again draft definition and in the new version is still missing the proposed new definition of transport slice as for my pull request sent 25 days ago.
Is there any objection to the adoption of my proposed text? If not, I suggest editor to provide a new version including the text contained in
https://github.com/teas-wg/teas-ns-dt/pull/4<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fpull%2F4&data=02%7C01%7Ckiranm%40futurewei.com%7C7326accfb91c4e02883208d7ba1f7aef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182516692368998&sdata=hlMh0vr1V8k9ERr2Ydk2pZma0yADU0UPB5TR%2BmZWs5c%3D&reserved=0>.

Thanks
Sergio

Sergio Belotti

The notes are now available here: https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-02-20.md<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fnotes%2Fnotes-2020-02-20.md&data=02%7C01%7Ckiranm%40futurewei.com%7C7326accfb91c4e02883208d7ba1f7aef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182516692368998&sdata=KEjMh%2FQEQrq2OL%2FQloOgVNJvhGC%2BvHeExADuFsNxyWw%3D&reserved=0> Let me know if there are any changes needed.

  https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/draft-rokui-teas-transport-slice-definition-00.txt<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fdefinitions%2Fdraft-rokui-teas-transport-slice-definition-00.txt&data=02%7C01%7Ckiranm%40futurewei.com%7C7326accfb91c4e02883208d7ba1f7aef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182516692378994&sdata=NcPrlFyX7xaSJoF6rN4Ev1a1GBUdi%2FyMVrY1g8nmm%2Fk%3D&reserved=0>
  https://github.com/teas-wg/teas-ns-dt/blob/master/framework/draft-ejj-teas-ns-framework-00.txt<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fframework%2Fdraft-ejj-teas-ns-framework-00.txt&data=02%7C01%7Ckiranm%40futurewei.com%7C7326accfb91c4e02883208d7ba1f7aef%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637182516692388988&sdata=kNpTIN3KIdJmD%2FWMJzbHowDjJ1MUn0a%2B%2BNRG2%2BrqoJM%3D&reserved=0>

Jari

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Thu, 27 Feb 2020 08:23:09 +0000

Kiran,
I think I’ve followed the github procedure, expressing my concern about the present definition in the  issue #3 . I repeat myself once again:

  1.  The present definition is not align with actual work in TEAS (under the hat this design team is) not considering virtual network concept
  2.  No mention of resources providing the requested connectivity
One of the basic point of the design team was to start and possibly exploit what already defined in TEAS. In TEAS , authors/contributors of ACTN spent a lot of time and efforts to discuss a lot of what mentioned in the definition draft and I have string objection to put confusion modifying definitions that are  already present in the IETF library.

Regards
Sergio

From: Teas-ns-dt <[email-masked]> On Behalf Of Kiran Makhijani
Sent: Tuesday, February 25, 2020 8:06 PM
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Jari Arkko <jari.arkko=[email-masked]>; [email-masked]; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas-ns-dt] Notes from Feb 24th call & deadline

Sergio,

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 25, 2020 at 10:21 AM
To: Kiran Makhijani <[email-masked]<mailto:[email-masked]>>, Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Notes from Feb 24th call & deadline

Hi Kiran,
Please see in line.

Regards
Sergio

From: Kiran Makhijani <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, February 25, 2020 5:45 PM
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>; [email-masked]<mailto:[email-masked]>; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: Re: Notes from Feb 24th call & deadline

Hello Sergio,

^^^^

Thanks
Sergio

Sergio Belotti

Jari