Subject: Re: [Teas-ns-dt] Isolation

From: Kiran Makhijani <[email-masked]>
Date: Mon, 10 Feb 2020 23:03:22 +0000

John,
Thanks for kick starting isolation dialogue.
I have concerns though. I think performance isolation doesn’t sound right. To me, in a transport slice if an objective is no met - performance is not met. As for the reachability isolation, even without a slice, mis-delivery of packets is a no-no. the way I read it means - guarantee of packets being delivered to right destination. This is too fundamental to be called out as an isolation.

I looked at enhanced-vpn draft and was not entirely convinced with the text there either. 
In my opinion, isolation can be associated to any network resource used by a transport slice. For instance, how to isolate bandwidth, port, FIB, policy, ACLs, (VNF - CPU, memory - etc.) -   physically or logically.

-Kiran

On 2/10/20, 5:19 PM, "Teas-ns-dt on behalf of John E Drake" <[email-masked] on behalf of jdrake=[email-masked]> wrote:

    My list currently consists of:
    
    Protection isolation - a failure in the network will not impact a customer's service for longer than X seconds, where X is a number in the range 50 msecs to some number of seconds, as specified in the SLO
    
    Reachability isolation - a customer's packets will not be misdelivered to another customer with a probability of X, where X is a percentage in the range 100 to some lower percentage, as specified in the SLO
    
    Performance isolation - a customer's performance related SLO parameters will not be degraded by more than X, where X is a percentage in the range of 0 to some higher percentage, as specified in the SLO
    
    Yours Irrespectively,
    
    John

    Juniper Business Use Only
    
    -- 
    Teas-ns-dt mailing list
    [email-masked]
    https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteas-ns-dt&amp;data=02%7C01%7Ckiranm%40futurewei.com%7Cb7a9e35df627453a14c508d7ae44f40c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637169483487700284&amp;sdata=7Ah9D2GrBbWfoehEsEtNC%2FEWP9Lu%2FQRFjWUc87aA4hE%3D&amp;reserved=0

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 11 Feb 2020 03:43:32 +0000

Hi Kiran and John,

IMO the first thing we need to reach consensus is "isolation from what". In a shared network, a customer's requirement on isolation is to isolate from other customers in the same network. 

The description about protection isolation in John's mail seems like the requirement on protection switching of one traffic flow, while maybe we need to consider the isolation between different customers during the protection switching.

Reachability isolation is described as soft isolation in VPN+ framework draft, which is to avoid the endpoints of one customer being reached by traffic of other customers. This is a basic requirement which can be provided using overlay VPNs. 

Performance isolation is something can be required by some emerging services, it requires to quantify and limit the impact from other services on one customer's service performance. It is described as hard isolation in VPN+ framework as it implies some set of resources in the underlying network needs to be allocated.

Best regards,
Jie

> -----Original Message-----
> From: Teas-ns-dt [mailto:[email-masked]] On Behalf Of Kiran
> Makhijani
> Sent: Tuesday, February 11, 2020 7:03 AM
> To: John E Drake <jdrake=[email-masked]>; [email-masked]
> Subject: Re: [Teas-ns-dt] Isolation
> 
> John,
> I have concerns though. I think performance isolation doesn’t sound right. To
> me, in a transport slice if an objective is no met - performance is not met. As
> for the reachability isolation, even without a slice, mis-delivery of packets is a
> no-no. the way I read it means - guarantee of packets being delivered to right
> destination. This is too fundamental to be called out as an isolation.
> 
> In my opinion, isolation can be associated to any network resource used by a
> transport slice. For instance, how to isolate bandwidth, port, FIB, policy, ACLs,
> (VNF - CPU, memory - etc.) -   physically or logically.
> 
> -Kiran
> 
> On 2/10/20, 5:19 PM, "Teas-ns-dt on behalf of John E Drake"
> <[email-masked] on behalf of
> jdrake=[email-masked]> wrote:
> 
>     Protection isolation - a failure in the network will not impact a customer's
> service for longer than X seconds, where X is a number in the range 50 msecs
> to some number of seconds, as specified in the SLO
> 
>     Reachability isolation - a customer's packets will not be misdelivered to
> another customer with a probability of X, where X is a percentage in the range
> 100 to some lower percentage, as specified in the SLO
> 
>     Performance isolation - a customer's performance related SLO parameters
> will not be degraded by more than X, where X is a percentage in the range of 0
> to some higher percentage, as specified in the SLO
> 
>     Yours Irrespectively,
> 
>     John
> 
> 
> https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> etf.org%2Fmailman%2Flistinfo%2Fteas-ns-dt&amp;data=02%7C01%7Ckiranm
> %40futurewei.com%7Cb7a9e35df627453a14c508d7ae44f40c%7C0fee8ff2a3b
> 240189c753a1d5591fedc%7C1%7C0%7C637169483487700284&amp;sdata=
> 7Ah9D2GrBbWfoehEsEtNC%2FEWP9Lu%2FQRFjWUc87aA4hE%3D&amp;reser
> ved=0
> 
> 
> --
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt