Subject: [Teas-ns-dt] Call time change for Thursday April 2nd

From: Jari Arkko <[email-masked]>
Date: Tue, 7 Apr 2020 13:11:22 +0000

I plan to shift the call time from 5pm CET to 6pm based on requests. The calendar update will be sent tomorrow morning.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Tue, 7 Apr 2020 15:17:52 +0000

Sorry – this was somehow delayed email from my mobile device. I don’t know why it didn’t go out last week… but never mind in any case. There’s no change in this week schedule, and we’ve already had the meeting anyway yesterday :-)

From: Jari Arkko <[email-masked]>
Date: Tuesday, 7 April 2020 at 16.11
To: "[email-masked]" <[email-masked]>
Subject: Call time change for Thursday April 2nd

Jari