Subject: [Teas-ns-dt] Solicit comments on updated draft-wd-teas-transport-slice-yang-01

From: "Wubo (lana)" <[email-masked]>
Date: Sat, 18 Apr 2020 03:07:36 +0000

Hi Jari and all,

We have just updated the draft of Transport slice YANG data model, and hope to get your feedback.
It is available at the link https://tools.ietf.org/html/draft-wd-teas-transport-slice-yang-01 , or the attachment.

To Jari:
As the discussion of last call, could you please help us to create a new nbi-model folder on github and upload the draft to this folder?

Thanks,
Bo

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Mon, 20 Apr 2020 12:58:38 +0000

Hi Bo, co-authors, 

These are my not-completed review of the draft (I would need some more time to review Yang details). 

Introduction:
*	Transport Slice definition : There is a definition document , please refer to it for TS definition . The definition in this draft is hiding completely an essential part of the concept of slice that is to assure to have dedicated/shared resources to provide the connectivity between the logical end point . This is indicated in the definition draft and here reported in a different way.
*	Ts-Endpoint: while the old version of definition was a bit heavy in wording appeared to me more complete. I think a mix of the new one and old one would be better . This is my proposal " is a logical identifier at an external interface to identify the logical access to which, a particular subset of traffic traversing the external interface, is mapped to a specific TS." 
*	TS-Member: Could you elaborate a little since the definition is not totally clear. TS-member should provide the link association between the end point of a slice respecting the SLO conditions. Is correct?  In the previous version of the draft there was also this definition "A TS Member is an abstract entity which represents transport
   resources mapped to this particular Transport Slice". This is more clear definition of TS Member respect the one above that I've already mentioned. Is it possible to have only one clear definition maybe encompassing the two piece of text not losing the link to resources that is essential in slicing?
*	

Section 5.1
*	The options represented confused me with respect the definition of end point. My understanding of TS End Point was that it is a logical identifier representing always the logical point to which customer traffic will be connected to a TS towards Transport Network. So TS End point has always need node-id, tp-id and ts-traffic-criteria . And in fact Yang is proposing not different options  i.e. there is no choice . So text description seems not aligned with what Yang is proposing.  
*	"A number of slice interconnection parameters must be agreed with a customer site and the transport slice, and one TS End Point's attributes may not be same with another TS End Point's. " Do you mean here that the characteristics of various TS- End Point can be different one to the other ? Would be good to make some example of attributes you're referring .

What do you mean here: are you referring to TS End point configuration or TS configuration . The wording is confused .
*	"At the external Interface, the particular subset of the transport is
identified either by a separate interface or by the combination of
   interface and fields in the packet" . Which external Interface ? What do you mean with "subset of the transport "??

I had not too much time to review Yang details , I would need some more time. 
But these some remarks:

ts-endpoints list:

container protocol description is confused : " Describes protocal between access potin and site"
status-params: the description is ambiguous and is technology specific mentioning VPN-node

I will complete review of Yang very soon.

Thanks
Sergio

Sergio Belotti
Senior System Engineer and Standardization Architect
IP/Optical Networks, Optics BU
Nokia 
M: +39-335761776
Via Energy Park, 20871 Vimercate (MB) , Italy
[email-masked]

-----Original Message-----
From: Teas-ns-dt <[email-masked]> On Behalf Of Wubo (lana)
Sent: Saturday, April 18, 2020 5:08 AM
To: Jari Arkko <jari.arkko=[email-masked]>; [email-masked]
Subject: [Teas-ns-dt] Solicit comments on updated draft-wd-teas-transport-slice-yang-01

Hi Jari and all,

To Jari:

Thanks,
Bo