Subject: [Teas-ns-dt] issue discussion: NF resource

From: Kiran Makhijani <[email-masked]>
Date: Thu, 28 May 2020 19:06:38 +0000

Hi All,
To kick off discussion on this topic.

During earlier discussions several of us asked for network functions should be part of the slices. For me the value of doing this is to be able to express different nuances of a service through single set of objectives. Then in NBI and implementation there is one controller to monitor the performance.

At the entry and exit of transport slices, these NF can be supplied to enforce access control, policies, etc. on transport slice traffic. It is also safe to assume that they will be virtual.

The objective is to apply those function on  traffic flows.
2 examples are  (1) use of firewall at entry point with the rules described by the user of transport slice. (2) Caching or DPI function on exit endpoints.

Regards
Kiran

---

From: John E Drake <[email-masked]>
Date: Thu, 28 May 2020 20:43:44 +0000

Hi,

The below description is a consistent with the definition of a transport slice endpoint as being on the customer equipment, in which case these network functions are within the provider network and are not transport slice endpoints.  These network functions as well as more complicated functions such as service function chains would be specified via the northbound interface - it would be useful to mention this in our drafts.

This then suggests that section 4.2, which defines a transport slice endpoint as being on the provider equipment, needs to be updated.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas-ns-dt <[email-masked]> On Behalf Of Kiran Makhijani
Sent: Thursday, May 28, 2020 3:07 PM
To: [email-masked]
Subject: [Teas-ns-dt] issue discussion: NF resource

[External Email. Be cautious of content]

Hi All,

Regards
Kiran

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 28 May 2020 15:15:09 -0700

Hi Kiran,
I think that an NF can be realized as a physical device or a VM. Would you
agree? If that is the case, then, in my opinion, we cannot consider only
the VNF case but add the PNF case as well.
Also, I don't see the real benefit to have NF, in all their variety now and
more in the future, as part of a TS. I think that NF is either part of the
TS implementation and thus is selected by an operator based on the SLO. Or
part of a service that uses the TS. In the model I have in mind, a client
of the TS does not specify which NFs should compose the TS but only what is
the functional behavior and performance provided by the TS.

On Thu, May 28, 2020 at 12:06 PM Kiran Makhijani <[email-masked]>
wrote:

> During earlier discussions several of us asked for network functions
> should be part of the slices. For me the value of doing this is to be able
> to express different nuances of a service through single set of objectives.
> Then in NBI and implementation there is one controller to monitor the
> performance.
>
>
>
> At the entry and exit of transport slices, these NF can be supplied to
> enforce access control, policies, etc. on transport slice traffic. It is
> also safe to assume that they will be virtual.
>
>
>
> 2 examples are  (1) use of firewall at entry point with the rules
> described by the user of transport slice. (2) Caching or DPI function on
> exit endpoints.
>
>
>
>
>
> Regards
>
> Kiran
>
>
> --
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt
>

---

From: Kiran Makhijani <[email-masked]>
Date: Thu, 28 May 2020 23:56:49 +0000

Hi Greg,
You are right. I should not have used term ‘virtual’ – I was visualizing a NF container in NBI data model. A user of transport slice just asks for a NF and associated properties. Whether it’s V- or P- is a realization time decision.

I see NFs adding a lot of value from higher-layer perspective, without getting bogged down about network details users can attach app specific firewalls, IDS, and caching type of functions on the endpoints. These are all good examples for use of NFs in slices. Secondly you will be able to express your requirement from a single place instead of dealing with different interfaces.

<your quote>
the TS does not specify which NFs should compose the TS but only what is the functional behavior and performance provided by the TS.
^^^
I hope you agree that there’s a need for some “functional behavior”. If user can leverage provider network for that behavior, then why not?
-Kiran

From: Greg Mirsky <[email-masked]>
Sent: Thursday, May 28, 2020 3:15 PM
To: Kiran Makhijani <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas-ns-dt] issue discussion: NF resource

Hi Kiran,
I think that an NF can be realized as a physical device or a VM. Would you agree? If that is the case, then, in my opinion, we cannot consider only the VNF case but add the PNF case as well.
Also, I don't see the real benefit to have NF, in all their variety now and more in the future, as part of a TS. I think that NF is either part of the TS implementation and thus is selected by an operator based on the SLO. Or part of a service that uses the TS. In the model I have in mind, a client of the TS does not specify which NFs should compose the TS but only what is the functional behavior and performance provided by the TS.

On Thu, May 28, 2020 at 12:06 PM Kiran Makhijani <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,
To kick off discussion on this topic.

Regards
Kiran

--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteas-ns-dt&data=02%7C01%7Ckiranm%40futurewei.com%7Ca14d6c44b9374396c97808d803549d8e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637263009257392006&sdata=coPUWaFZ60QdkKHtkxe2%2FHh7MTX%2B0gEQ7M%2FywEcXA4A%3D&reserved=0>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 28 May 2020 18:36:34 -0700

Hi Kiran,
thank you for your kind consideration of my comments. If we agree that a
customer of a TS may specify a certain TS behavior that is externally
observable on data packets, then I don't find where elements like "memory",
"computing power" fit. I think that these are important to an operator when
choosing the most economical and efficient method to realize the TS
according to the specific LSO.
What do you think?

Regards,
Greg

On Thu, May 28, 2020 at 4:56 PM Kiran Makhijani <[email-masked]>
wrote:

> Hi Greg,
>
> You are right. I should not have used term ‘virtual’ – I was visualizing a
> NF container in NBI data model. A user of transport slice just asks for a
> NF and associated properties. Whether it’s V- or P- is a realization time
> decision.
>
>
>
> I see NFs adding a lot of value from higher-layer perspective, without
> getting bogged down about network details users can attach app specific
> firewalls, IDS, and caching type of functions on the endpoints. These are
> all good examples for use of NFs in slices. Secondly you will be able to
> express your requirement from a single place instead of dealing with
> different interfaces.
>
>
>
> <your quote>
>
> the TS does not specify which NFs should compose the TS but only what is
> *^^^*
> I hope you agree that there’s a need for some “functional behavior”. If
> user can leverage provider network for that behavior, then why not?
>
> -Kiran
>
>
>
>
>
> *From:* Greg Mirsky <[email-masked]>
> *Sent:* Thursday, May 28, 2020 3:15 PM
> *To:* Kiran Makhijani <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Teas-ns-dt] issue discussion: NF resource
>
>
>
> Hi Kiran,
>
> Also, I don't see the real benefit to have NF, in all their variety now
> and more in the future, as part of a TS. I think that NF is either part of
> the TS implementation and thus is selected by an operator based on the SLO.
> Or part of a service that uses the TS. In the model I have in mind, a
> client of the TS does not specify which NFs should compose the TS but only
> what is the functional behavior and performance provided by the TS.
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteas-ns-dt&data=02%7C01%7Ckiranm%40futurewei.com%7Ca14d6c44b9374396c97808d803549d8e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637263009257392006&sdata=coPUWaFZ60QdkKHtkxe2%2FHh7MTX%2B0gEQ7M%2FywEcXA4A%3D&reserved=0>
>
>