Subject: Re: [Teas-ns-dt] The word "transport"

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 13:52:44 +0000

Adrian,
Thanks for your response. Please see inline.

In summary, as you pointed out at the end of your email, I will include the definition of the Transport. I looked at VPN+ draft as well as you suggested
              >>>>  But perhaps we can cut through all of this with some simple clarity. Text to describe the context and meaning of ‘transport’. Since the terminology document has so cheerfully plundered the enhanced VPN framework draft for some text, you might look there (in the Introduction) for suitable context-setting text.

  *   Transport: This term embraces various technologies such as IP, Optical, Ethernet, TDM, etc  that carry packets and traffic and might span multiple administrative domains.

With this definition, the Term “Transport Slice” should make more sense.

Cheers,
Reza

From: Adrian Farrel <[email-masked]>
Organization: Old Dog Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Thursday, April 30, 2020 at 3:31 PM
To: Reza Rokui <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: FW: The word "transport"

Reza,

Thanks for forwarding this email.

I appreciate and understand the way that 3GPP use the term “transport”. It makes a lot of sense in the 3GPP context: they are talking about connectivity in their realm, and anything that provides that connectivity (such as an IP network) counts as “transport”.

But we are not the 3GPP and our terminology needs to be consistent. As I noted, we already have multiple meanings of transport:

  *   The transport layer (traditional from the OSI model) that includes TCP, UDP, etc.
  *   Transport networks (a term also used in the ITU-T) that embraces Ethernet, TDM, and optical technologies that carry packets for us. This term is most often seen in CCAMP, TEAS, and PCE.
  *   MPLS-TP (possibly deriving from the ITU-T’s T-MPLS) that refers to the use of MPLS as a technology to build transport networks as described in the previous bullet
  *   Transport as a verb (such as in HTTP) meaning simply ‘to carry’
In the ACTN work, we moved from ‘transport’ to ‘TE’ recognising that ACTN was applicable to any network type where paths could be computed and imposed, and resource partitioned and reserved.

[Reza] Reference to 3GPP was just an example since you and Joel explicitly asked about it.
I agree that we at IETF should be consistent. Your summary is clear.

Now, you say Transport networks (which are technology specific) are used to realized “Transport Slices” which would appear to imply that IP cannot be used to realise a transport slice. I don’t know if that is your intention.
[Reza] Not sure how you came up with this conclusion but IP will be part of technology to realize Transport Slices.

You also say They [3GPP] did not define anything related to Transport but you say that immediately under a figure you have copied from 3GPP TS 28.530 that clearly shows transport slices, so that leaves me more than a little confused.
[Reza] Let me clarify. 3GPP TS 28.530 refers to transport slice as “Connectivity within Transport Network” as shown below.
They did not use term “Transport Slice”

Additionally, you say…
VPN is one of the  solutions to realize the transport slices in IP networks.

…which is fine by me since I am not (here) talking about solutions but services. Actually, I think you would do well to distinguish between VPN as a service and the technologies used to realise a VPN.

[Reza] My reference was VPN as a technology to realize the transport slice, e.g. L3 VPN

Then…

However, The idea of Transport Slice is to allow a high-level system (or consumer or an Orchestrator) to ask for a various connections (i.e. Transport slices)

… This is pretty meaningless the way you have worded it. You have said “the idea of a transport slice is to all a request for transport slices...

across  IP, Optics, PON, Microwave or any combination of these networks. We shall not limit ourselves to IP VPN.

…Yes, indeed. I wonder where the idea of such a limitation came from…

Note that the definition of the Transport slice is technology agnostic.

…I know. It comes from draft-ietf-teas-enhanced-vpn. That originated in draft-king-teas-applicability-actn-slicing. I believe I drafted it…

[snip]

In summary, since the connectivity between various endpoints are across transport network (i.e. IP, Optics, PON, Microware etc.), it is logical to assume the Connections are called Transport Slice.
…which is fine except that you have moved the problem to the definition of “transport network”. The IETF will struggle, I think, with the idea that an IP network is a transport network unless, in the context of these documents, you give a very clear explanation of what these documents mean by that term.

But perhaps we can cut through all of this with some simple clarity. Text to describe the context and meaning of ‘transport’. Since the terminology document has so cheerfully plundered the enhanced VPN framework draft for some text, you might look there (in the Introduction) for suitable context-setting text.
[Reza] Good point Adrian. I have included my definition of Transport above

That, of course, leads me to a separate question that I have, which is why the design team is reproducing and/or copying material from an existing WG document rather than working with that document to refine it and/or split it into multiple documents. A different question, but one the chairs might like to comment on.

Best,
Adrian

From: Teas-ns-dt <[email-masked]> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: 30 April 2020 16:23
To: [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: [Teas-ns-dt] FW: The word "transport"

All,

I thought I sent this to TEAS and TEAS-NS-DT team before. Forwarding the response to everyone.

Cheers,
Reza

From: Reza Rokui <[email-masked]<mailto:[email-masked]>>
Date: Saturday, April 25, 2020 at 11:37 PM
To: Dhruv Dhody <[email-masked]<mailto:[email-masked]>>, Jari Arkko <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Reza Rokui <[email-masked]<mailto:[email-masked]>>
Subject: Re: The word "transport"

Hi all,

Please see inline for some clarifications.

Reza

On 2020-04-24, 1:31 AM, "Dhruv Dhody" <[email-masked]<mailto:[email-masked]>> wrote:

    Hi Reza,

    I am putting the relevant text here -

    ==

    [14:28:42] <adrianfarrel> I'm getting very confused by everyone

    talking about "transport networks" and "transport slices". Is this

    something coming out of 3GPP?

[Reza] Please note that the “Transport Slice” from IETF point of view is not only limited to 5G network slicing.

5G network slicing is just one use-case of transport slicing as described in Transport Slice definition draft.

Regarding 5G use-case, the following figure is taken from 3GPP TS 28.530 where the “Transport slice” is described as “Connectivity” across transport network.

This is the reason that what has been described in our draft for “Transport Slices” is a set of Connections between various endpoints with certain SLOs.

Note that 3GPP did not define the Transport slice explicitly.

    [14:29:06] <adrianfarrel> Seems to me that we (for example, ACTN) went

    through a lot to clarify that "transport network" was sub-IP

    [14:29:17] <adrianfarrel> ...maybe even sub-MPLS

[Reza] Transport networks (which are technology specific) are used to realized “Transport Slices”. Please see draft for more info.

    [14:31:39] <Joel Halpern> "Transport Network" is the industry

    terminology for the network that connects the radio (and related gear)

    to the packet core (and related gear).

    [14:32:03] <Joel Halpern> It is indeed a different usage.  I wish it

    were not overloading.  But they didn't ask me.

    [14:32:47] <Joel Halpern> Which part it refers to in a fixed access

    network is even less clear.

[Reza] The following figure is taken from 3GPP TS 28.530 where it shows various “Transport slices”.

Note that the “Transport Slices” are not only used for RAN to Core. Depends on the deployment, we can have

Transport slices in RAN for midhaul and fronthaul, in 5G Core or for application. All these transport slices are shown below.

] 

    [14:39:54] <adrianfarrel> I understand why 3GPP uses the term. I don't

    understand why we use the term. We could talk about 'Foobar slices'

    and add one line that says "In the 3GPP, the term 'Transport Slice' is

    used for what we call a 'Foobar Slice'."

[Reza]  Note that 3GPP used the term “slice subnet” when describing it in context of 5G Core and RAN (i.e Core Slice Subnet and RAN Slice Subnet).

They did not define anything related to Transport. As indicated above, 3GPP refer it to “Connectivity”.

We did not want to use Subnet because in IP,  subnet has a very clear definition and using term “Transport Subnet” is completely misleading. So, we chose Transport Slice.

Also since the connectivity between various endpoints are across transport network (i.e. IP, Optics, PON, Microware etc.), it is logical to assume the Connections are called Transport Slice.

    [14:40:18] <adrianfarrel> We *already* have two definitions of

    "transport" in the IETF. We really don't need three

[Reza] Please provide links to these two definition.

    [14:59:00] <adrianfarrel> Well, I picked "foobar' in order to not jump

    immediately to a strawman solution. I think we are talking about

    providing slices as a service across the Internet. Same level of entry

    as a VPN: that is, the consumer provides a packet stream to the

    service entry point, and expects the packets to be delivered to the

    service exit point. Obviously, the consumer of the service may see the

    service as a transport (cf. pseudowires), but we would be 'alarmed' to

    hear a L3VPN described as a 'transport VPN.'

[Reza] VPN is one of the  solutions to realize the transport slices in IP networks.

However, The idea of Transport Slice is to allow a high-level system (or consumer or an Orchestrator) to ask for a various connections (i.e. Transport slices) across  IP, Optics, PON, Microwave or any combination of these networks. We shall not limit ourselves to IP VPN.

Note that the definition of the Transport slice is technology agnostic. For example in 5G you can realize a transpot slice in midhaul (please refer to picture above) which is a set of connections between 5G RAN nodes using PON or Optical connection. In this case there is no IP VPN.

In summary, since the connectivity between various endpoints are across transport network (i.e. IP, Optics, PON, Microware etc.), it is logical to assume the Connections are called Transport Slice.

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html

    ==

    More inline..

    On Thu, Apr 23, 2020 at 10:27 PM Rokui, Reza (Nokia - CA/Ottawa)

    <[email-masked]<mailto:[email-masked]>> wrote:

    > Hi Dhruv,

    > As far as I remember, we did not have any argument about term "transport". It was agreed that the term "Transport" is suited in context of network slicing.

    > The initial discussion was "Transport network slicing" which later we agreed to remove "network" since it causes confusion since IETF do not cover the e2e network slicing but rather the transport part.

    > I was not clear about Adrian's comment regarding term "transport". IMHO, this term is well suited since it convers any underlying technology for L0 to L3.

    In CCAMP/TEAS circles, the transport network term might not be used

    for L3 (and thus the confusion). And then there are the Transport

    Protocols! Definition draft should include some clarity on what do we

    mean when we say transport network at the least!

    It would be good to get this resolved sooner as we develop multiple

    documents that uses the same terminology!

    Thanks!

    Dhruv

    > Reza

    > On 2020-04-23, 12:35 PM, "Dhruv Dhody" <[email-masked]<mailto:[email-masked]>> wrote:

    >     Hi,

    >     Adrian gave some comments on jabber about using the word "transport".

    >     During RFC8453 devolpment, this came up where TN in ACTN was transport

    >     networks and it was changed to TE networks to avoid using the

    >     overloaded term "transport".

    >     We need to find a way to justify using this term and maybe describe

    >     this more in the definition draft - and just saying that 3GPP uses

    >     that term may not work I guess!

    >     Was this discussed in the design team earlier, i joined the effort

    >     much later.

    >     Thanks!

    >     Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 14:01:52 +0000

Adrian and all,

As suggested, this is the definition of term “Transport” :

  *   Definition of term Transport: This term embraces various technologies such as IP, Optical, Ethernet, TDM, etc  that carry packets and traffic and might span multiple administrative domains.

With this definition, the Term “Transport Slice” should make more sense.
Please provide your suggestion to refine this definition.

Cheers,
Reza

From: Adrian Farrel <[email-masked]>
Organization: Old Dog Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Thursday, April 30, 2020 at 5:50 PM
To: 'Kiran Makhijani' <[email-masked]>, Reza Rokui <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Teas] FW: The word "transport"

Hey,

Not sure if you mean “the relationship to the existing document” or “the relationship to VPN+”.

The relationship to VPN+ is really about how you view a service that is network slice: i.e., a collection of end-points, the connectivity between them, the level of service. Enhanced VPN is simply another way of thinking about a network slice.

Probably, as I said to Reza, there is confusion between “VPN as a service” and “VPN as a set of technologies for delivering a service.” As engineers we often get confused between the two concepts, but we shouldn’t.

Yes, you’re right: if we describe ‘transport’ in our context this will help avoid confusion. That’s what I was trying to suggest in my email. I was also suggesting that suitable text can be found in the enhanced VPN draft, just the way that suitable text for describing a slice was found there.

The relationship to the existing document is a different question. I would like to understand how we resolve that so that we can put our efforts into the right documents.

Best,
Adrian

From: Kiran Makhijani <[email-masked]>
Sent: 30 April 2020 21:58
To: [email-masked]; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]>
Cc: [email-masked]
Subject: RE: [Teas] FW: The word "transport"

Hello Adrian,
Thanks for many interesting points below.
If we describe what ‘transport’ is in the context of the slices, (use hyphenated  transport-slice 😊) perhaps it’s ok?  (The enhanced VPN relationship is a lengthier discussion).
-Kiran

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of Adrian Farrel
Sent: Thursday, April 30, 2020 12:32 PM
To: 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Teas] FW: The word "transport"

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: 30 April 2020 16:23
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: [Teas-ns-dt] FW: The word "transport"

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fjabber%2Flogs%2Fteas%2F2020-04-23.html&data=02%7C01%7Ckiranm%40futurewei.com%7C5fb387d7a551444584ca08d7ed3d5097%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637238719923636105&sdata=%2FZXF3AwTmx4qHpY3PzQURpylcyZ2CnMYAKMRm9F8%2FEA%3D&reserved=0>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 14:13:05 +0000

John and all,

This is where I disagree with term “Underlay Network Slice”. It brings lots of other questions since we (IETF) do not deal with network slice as clearly described in our draft.

As I send in another email thread, as per Adrian’s suggestion, we define the term “Transport” as follows and would like to keep the term “Transport Slice”

Cheers,
Reza

From: Adrian Farrel <[email-masked]>
Organization: Old Dog Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, May 1, 2020 at 5:23 AM
To: 'John E Drake' <jdrake=[email-masked]>, Reza Rokui <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Teas] FW: The word "transport"

Yeah, ‘underlay’ seems good because it is a relative term and usefully recursive.

A

From: Teas <[email-masked]> On Behalf Of John E Drake
Sent: 30 April 2020 20:59
To: [email-masked]; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas] FW: The word "transport"

Hi,

How about ‘underlay network slice’?  It’s describing exactly what we are doing and is congruent with the Enhanced VPN draft.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas <[email-masked]> On Behalf Of Adrian Farrel
Sent: Thursday, April 30, 2020 3:32 PM
To: 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]>
Cc: [email-masked]
Subject: [Teas] FW: The word "transport"

[External Email. Be cautious of content]

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    understand why we use the term.. We could talk about 'Foobar slices'

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://urldefense.com/v3/__https:/www.ietf.org/jabber/logs/teas/2020-04-23.html__;!!NEt6yMaO-gk!WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI$>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

Juniper Business Use Only

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 1 May 2020 15:30:38 +0100

Hi Reza,

I don’t understand “we (IETF) do not deal with network slice”.

Why do we have a “TEAS Network Slicing Design Team”?

Cheers,

Adrian

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]> 
Sent: 01 May 2020 15:13
To: [email-masked]; 'John E Drake' <jdrake=[email-masked]>; [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas] FW: The word "transport"

John and all,

Cheers,

Reza

From: Adrian Farrel <[email-masked] <mailto:[email-masked]> >
Organization: Old Dog Consulting
Reply-To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Date: Friday, May 1, 2020 at 5:23 AM
To: 'John E Drake' <jdrake=[email-masked] <mailto:jdrake=[email-masked]> >, Reza Rokui <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Subject: RE: [Teas] FW: The word "transport"

A

From: Teas <[email-masked] <mailto:[email-masked]> > On Behalf Of John E Drake
Sent: 30 April 2020 20:59
To: [email-masked] <mailto:[email-masked]> ; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [Teas] FW: The word "transport"

Hi,

Yours Irrespectively,

John

From: Teas <[email-masked] <mailto:[email-masked]> > On Behalf Of Adrian Farrel
Sent: Thursday, April 30, 2020 3:32 PM
To: 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> 
Subject: [Teas] FW: The word "transport"

Reza,

Additionally, you say…

Then…

[snip]

Best,

Adrian

From: Teas-ns-dt <[email-masked] <mailto:[email-masked]> > On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: 30 April 2020 16:23
To: [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]> >
Subject: [Teas-ns-dt] FW: The word "transport"

All,

Cheers,

Reza

From: Reza Rokui <[email-masked] <mailto:[email-masked]> >
Date: Saturday, April 25, 2020 at 11:37 PM
To: Dhruv Dhody <[email-masked] <mailto:[email-masked]> >, Jari Arkko <[email-masked] <mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Cc: Reza Rokui <[email-masked] <mailto:[email-masked]> >
Subject: Re: The word "transport"

Hi all,

Reza

On 2020-04-24, 1:31 AM, "Dhruv Dhody" <[email-masked] <mailto:[email-masked]> > wrote:

    Hi Reza,

    ==

 

] 

 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html <https://urldefense.com/v3/__https:/www.ietf.org/jabber/logs/teas/2020-04-23.html__;!!NEt6yMaO-gk!WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI$> 

    ==

    More inline..

    <[email-masked] <mailto:[email-masked]> > wrote:

    Thanks!

    Dhruv

    > On 2020-04-23, 12:35 PM, "Dhruv Dhody" <[email-masked] <mailto:[email-masked]> > wrote:

---

From: John E Drake <[email-masked]>
Date: Fri, 1 May 2020 15:08:19 +0000

Hi,

Comments inline.

Yours Irrespectively,

John

Juniper Business Use Only
From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Sent: Friday, May 1, 2020 10:13 AM
To: [email-masked]; John E Drake <[email-masked]>; [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas] FW: The word "transport"

John and all,

This is where I disagree with term "Underlay Network Slice".

[JD]  The terms 'underlay network' and 'overlay network' are pretty well understood in the IETF, and other work in this area over the past several years has typically defined a slice as a specific subset of shared or dedicated resources in the underlay network.  As Adrian correctly points out, the term 'transport network'  has a lot of baggage and is mainly used outside the IETF.

It brings lots of other questions

[JD]  What exactly doe this mean?

since we (IETF) do not deal with network slice as clearly described in our draft.

[JD]  This is demonstrably incorrect.  E.g., what is the topic of your draft?

As I send in another email thread, as per Adrian's suggestion, we define the term "Transport" as follows and would like to keep the term "Transport Slice"

Cheers,
Reza

From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Organization: Old Dog Consulting
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 1, 2020 at 5:23 AM
To: 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>, Reza Rokui <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas] FW: The word "transport"

Yeah, 'underlay' seems good because it is a relative term and usefully recursive.

A

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of John E Drake
Sent: 30 April 2020 20:59
To: [email-masked]<mailto:[email-masked]>; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] FW: The word "transport"

Hi,

How about 'underlay network slice'?  It's describing exactly what we are doing and is congruent with the Enhanced VPN draft.

Yours Irrespectively,

John

Reza,

I appreciate and understand the way that 3GPP use the term "transport". It makes a lot of sense in the 3GPP context: they are talking about connectivity in their realm, and anything that provides that connectivity (such as an IP network) counts as "transport".

  *   The transport layer (traditional from the OSI model) that includes TCP, UDP, etc.
  *   Transport networks (a term also used in the ITU-T) that embraces Ethernet, TDM, and optical technologies that carry packets for us. This term is most often seen in CCAMP, TEAS, and PCE.
  *   MPLS-TP (possibly deriving from the ITU-T's T-MPLS) that refers to the use of MPLS as a technology to build transport networks as described in the previous bullet
  *   Transport as a verb (such as in HTTP) meaning simply 'to carry'
In the ACTN work, we moved from 'transport' to 'TE' recognising that ACTN was applicable to any network type where paths could be computed and imposed, and resource partitioned and reserved.

Now, you say Transport networks (which are technology specific) are used to realized "Transport Slices" which would appear to imply that IP cannot be used to realise a transport slice. I don't know if that is your intention.

Additionally, you say...

...which is fine by me since I am not (here) talking about solutions but services. Actually, I think you would do well to distinguish between VPN as a service and the technologies used to realise a VPN.

Then...

... This is pretty meaningless the way you have worded it. You have said "the idea of a transport slice is to all a request for transport slices...

...Yes, indeed. I wonder where the idea of such a limitation came from...

...I know. It comes from draft-ietf-teas-enhanced-vpn. That originated in draft-king-teas-applicability-actn-slicing. I believe I drafted it...

[snip]

In summary, since the connectivity between various endpoints are across transport network (i.e. IP, Optics, PON, Microware etc.), it is logical to assume the Connections are called Transport Slice.
...which is fine except that you have moved the problem to the definition of "transport network". The IETF will struggle, I think, with the idea that an IP network is a transport network unless, in the context of these documents, you give a very clear explanation of what these documents mean by that term.

But perhaps we can cut through all of this with some simple clarity. Text to describe the context and meaning of 'transport'. Since the terminology document has so cheerfully plundered the enhanced VPN framework draft for some text, you might look there (in the Introduction) for suitable context-setting text.

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

[Reza] Please note that the "Transport Slice" from IETF point of view is not only limited to 5G network slicing.

Regarding 5G use-case, the following figure is taken from 3GPP TS 28.530 where the "Transport slice" is described as "Connectivity" across transport network.

This is the reason that what has been described in our draft for "Transport Slices" is a set of Connections between various endpoints with certain SLOs.

[Reza] Transport networks (which are technology specific) are used to realized "Transport Slices". Please see draft for more info.

[Reza] The following figure is taken from 3GPP TS 28.530 where it shows various "Transport slices".

Note that the "Transport Slices" are not only used for RAN to Core. Depends on the deployment, we can have

] 

[Reza]  Note that 3GPP used the term "slice subnet" when describing it in context of 5G Core and RAN (i.e Core Slice Subnet and RAN Slice Subnet).

They did not define anything related to Transport. As indicated above, 3GPP refer it to "Connectivity".

We did not want to use Subnet because in IP,  subnet has a very clear definition and using term "Transport Subnet" is completely misleading. So, we chose Transport Slice.

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Kiran Makhijani <[email-masked]>
Date: Fri, 1 May 2020 15:17:07 +0000

John,
We have defined transport slice as an independent construct. There's a high level description of it, the way a customer or user of a transport slice will see it and then there's the realization part. The 'underlay' for me only covers the realization.
To answer your second question, Chapter 6 has "transport slices" and "other slices". They are short for "transport network slice" (our scope) and "other network slices"(ran, core etc.).
Hth,
Kiran

From: Teas-ns-dt <[email-masked]> On Behalf Of John E Drake
Sent: Friday, May 1, 2020 8:08 AM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Teas-ns-dt] [Teas] FW: The word "transport"

Hi,

Comments inline.

Yours Irrespectively,

John

Juniper Business Use Only
From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, May 1, 2020 10:13 AM
To: [email-masked]<mailto:[email-masked]>; John E Drake <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] FW: The word "transport"

John and all,

Cheers,
Reza

Reply-To: "adrian@olddog..co.uk<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say...

Then...

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    understand why we use the term... We could talk about 'Foobar slices'

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.ietf.org%2Fjabber%2Flogs%2Fteas%2F2020-04-23.html__%3B!!NEt6yMaO-gk!WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI%24&data=02%7C01%7Ckiranm%40futurewei.com%7C2da97b2bd71e492743c608d7ede18524%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637239425181165830&sdata=X1Vq52rJ2cudS1V5e%2BydfBJ4judunst%2FTt5INZHU9zA%3D&reserved=0>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: John E Drake <[email-masked]>
Date: Fri, 1 May 2020 15:30:47 +0000

Hi,

Comments inline.

Yours Irrespectively,

John

Juniper Business Use Only
From: Kiran Makhijani <[email-masked]>
Sent: Friday, May 1, 2020 11:17 AM
To: John E Drake <[email-masked]>; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Teas] FW: The word "transport"

John,

[JD] I don't agree.  The high level description is simply a way for the customer to specify the underlay network resources they want their slice to provide them without having to know underlay network's details.

To answer your second question, Chapter 6 has "transport slices" and "other slices". They are short for "transport network slice" (our scope)

[JD]  Using your logic, the term 'transport network slice'  also a describes a realization.

and "other network slices"(ran, core etc.).
Hth,
Kiran

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of John E Drake
Sent: Friday, May 1, 2020 8:08 AM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas-ns-dt] [Teas] FW: The word "transport"

Hi,

Comments inline.

Yours Irrespectively,

John

John and all,

Cheers,
Reza

Reply-To: "adrian@olddog...co.uk<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say...

Then...

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    understand why we use the term.... We could talk about 'Foobar slices'

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fwww.ietf.org*2Fjabber*2Flogs*2Fteas*2F2020-04-23.html__*3B!!NEt6yMaO-gk!WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI*24&data=02*7C01*7Ckiranm*40futurewei.com*7C2da97b2bd71e492743c608d7ede18524*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637239425181165830&sdata=X1Vq52rJ2cudS1V5e*2BydfBJ4judunst*2FTt5INZHU9zA*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!UAWs2L6xk_N_UrJ26uhBCAj0u1g8P6CLLksUuGrZ1lmYbn1vG6UVNzZvIzKRsvs$>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 15:34:53 +0000

Reza,

              Your definition mostly looks good, but I have some questions about the part that says “… packets and traffic and …”

              1st, from a strictly grammatical perspective, having “and X and” is problematic.  The sentence meaning does not appear to change if you replace the second “and” with “that.”  But this change is not needed if the bigger issue is addressed as suggested below.

              The bigger issue is with the phrase “packets and traffic” – which is strange since the relationship between “packets and traffic” can be summed up as:

  *   Not all traffic is in the form of “packets.”
  *   Most, if not all, packets are some form of “traffic.”

              I believe that this might be what you are trying to say by including both, but there other constructions that are not as strange.  For example, we could say:

Transport: This term embraces various technologies (such as IP, Optical, Ethernet, TDM, etc.) that carry data and might span multiple administrative domains.

From: Teas-ns-dt <[email-masked]> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Friday, May 1, 2020 9:53 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas-ns-dt] The word "transport"

Adrian,

Cheers,
Reza

To: Reza Rokui <[email-masked]<mailto:[email-masked]>>

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 15:37:49 +0000

Adrian,

>>>>>> I don’t understand “we (IETF) do not deal with network slice”.

Please refer to Figure 4 of the draft.
In summary, an E2E network slice is the logical network from End user X to End use Y and comprises of:

  *   One or more Transport slices (TS)
  *   One or more Other Slices (OS)

Just as an example for “Other Slices”, in 5G these slices are RAN slices and 5G Core Slices.
Referring  this Figure, it is clear that IETF deals with Transport slice which is part of an E2E network slice and “Other slices” are outside scope of IETF.
Please make a clear distinction between Transport Slices and e2e network slices. They are different.
IMHO, any reference to “Network Slice” in IETF drafts means “Transport slice” .

>>>>>>.  Why do we have a “TEAS Network Slicing Design Team”?
Good question. The correct name can be “TEAS Transport Slicing Design Team”

Reza

From: Adrian Farrel <[email-masked]>
Organization: Old Dog Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, May 1, 2020 at 10:30 AM
To: Reza Rokui <[email-masked]>, 'John E Drake' <jdrake=[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Teas] FW: The word "transport"

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 15:45:45 +0000

Possibly it would be better to clarify this in terms of what the IETF does deal with?

The IETF deals with “packetized” (more specifically, where packetization uses IETF defined packet formats) transport of otherwise arbitrary data.

Here you can replace transport with “carrying” – but this is essentially the standard English meaning of transport.

Sent: Friday, May 1, 2020 11:38 AM

Adrian,

Reza

To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi Reza,

Cheers,
Adrian

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Sent: 01 May 2020 15:13
To: [email-masked]<mailto:[email-masked]>; 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] FW: The word "transport"

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://protect2.fireeye.com/v1/url?k=d4f6bc46-8a560628-d4f6fcdd-86b1886cfa64-dd8e4ff74c5dda87&q=1&e=b15230b3-e6dc-4732-83e3-00354fdc75ae&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.ietf.org%2Fjabber%2Flogs%2Fteas%2F2020-04-23.html__%3B%21%21NEt6yMaO-gk%21WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI%24>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 15:49:20 +0000

>>>>>>>> Possibly it would be better to clarify this in terms of what the IETF does deal with?

I meant that IETF does not address the other aspects of an e2e network slice like RAN and Core slice (aka Other Slices).
A transport slice is just a piece of an e2e network slice. Any reference to “network slice” is not correct since IETF does not deal with Other Slices.

Reza Rokui, Ph.D.
Director, NSP Product Management
Nokia Canada
IP/Optical Network Automation
T:  +1-613-784-1762
M: +1-613-979-6986
600 March Road, Kanata, Ontario, K2K 2E6
[email-masked]<mailto:[email-masked]>

From: Eric Gray <[email-masked]>
Date: Friday, May 1, 2020 at 11:45 AM
To: Reza Rokui <[email-masked]>, "[email-masked]" <[email-masked]>, 'John E Drake' <jdrake=[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Teas] FW: The word "transport"

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 15:52:36 +0000

John,
Please see inline.

Cheers,
Reza

From: John E Drake <[email-masked]>
Date: Friday, May 1, 2020 at 11:08 AM
To: Reza Rokui <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Teas] FW: The word "transport"

Hi,

Comments inline.

Yours Irrespectively,

John

John and all,

This is where I disagree with term “Underlay Network Slice”.

[JD]  The terms ‘underlay network’ and ‘overlay network’ are pretty well understood in the IETF, and other work in this area over the past several years has typically defined a slice as a specific subset of shared or dedicated resources in the underlay network.  As Adrian correctly points out, the term ‘transport network’  has a lot of baggage and is mainly used outside the IETF.

[Reza] The question is not overlay vs. underlay. My argument was that this term “Underlay network slice” is confusing. I just responded to Adrian in other email thread but this is the summary. Please refer to that thread for more info.
IETF does not deal with e2e network slice because an E2E network slice is the logical network from End user X to End use Y and comprises of:

  *   One or more Transport slices (TS)
  *   One or more Other Slices (OS)
Since Other slices are not in IETF scope, we should refrain from using “network slice” at IETF. IETF is part of the e2e network slice solution.

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: John E Drake <[email-masked]>
Date: Fri, 1 May 2020 15:52:41 +0000

Hi,

Comment inline

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas-ns-dt <[email-masked]> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Friday, May 1, 2020 11:49 AM
To: Eric Gray <[email-masked]>; [email-masked]; 'John E Drake' <jdrake=[email-masked]>; [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas-ns-dt] [Teas] FW: The word "transport"

I meant that IETF does not address the other aspects of an e2e network slice like RAN and Core slice (aka Other Slices).
A transport slice is just a piece of an e2e network slice. Any reference to "network slice" is not correct since IETF does not deal with Other Slices.

[JD]  This is back to Adrian's original point, viz, 'transport slice' is a term coined by another standards body.

Reza Rokui, Ph.D.

From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 1, 2020 at 11:45 AM
To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas] FW: The word "transport"

The IETF deals with "packetized" (more specifically, where packetization uses IETF defined packet formats) transport of otherwise arbitrary data.

Here you can replace transport with "carrying" - but this is essentially the standard English meaning of transport.

Adrian,

>>>>>> I don't understand "we (IETF) do not deal with network slice".

Just as an example for "Other Slices", in 5G these slices are RAN slices and 5G Core Slices.
Referring  this Figure, it is clear that IETF deals with Transport slice which is part of an E2E network slice and "Other slices" are outside scope of IETF.
Please make a clear distinction between Transport Slices and e2e network slices. They are different.
IMHO, any reference to "Network Slice" in IETF drafts means "Transport slice" .

>>>>>>.  Why do we have a "TEAS Network Slicing Design Team"?
Good question. The correct name can be "TEAS Transport Slicing Design Team"

Reza

Hi Reza,

I don't understand "we (IETF) do not deal with network slice".
Why do we have a "TEAS Network Slicing Design Team"?

Cheers,
Adrian

John and all,

This is where I disagree with term "Underlay Network Slice". It brings lots of other questions since we (IETF) do not deal with network slice as clearly described in our draft.

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say...

Then...

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://urldefense.com/v3/__https:/protect2.fireeye.com/v1/url?k=d4f6bc46-8a560628-d4f6fcdd-86b1886cfa64-dd8e4ff74c5dda87&q=1&e=b15230b3-e6dc-4732-83e3-00354fdc75ae&u=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fwww.ietf.org*2Fjabber*2Flogs*2Fteas*2F2020-04-23.html__*3B*21*21NEt6yMaO-gk*21WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI*24__;JSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!Ss83mQtEVqDRzJaflsjI0IuUspo1qru8LEP6d7EHAVACW_rPFMRhTgGzcd8fvSc$>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 1 May 2020 15:56:24 +0000

>>>>> [JD]  This is back to Adrian’s original point, viz, ‘transport slice’ is a term coined by another standards body.

As far as I know there is not any SDO which defines “Transport slice” at least at the time that we wrote the draft. If not so, please provide the reference.
We at IETF started using this term.

Reza

From: John E Drake <[email-masked]>
Date: Friday, May 1, 2020 at 11:52 AM
To: Reza Rokui <[email-masked]>, Eric Gray <[email-masked]>, "[email-masked]" <[email-masked]>, 'John E Drake' <jdrake=[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Teas] FW: The word "transport"

Hi,

Comment inline

Yours Irrespectively,

John

[JD]  This is back to Adrian’s original point, viz, ‘transport slice’ is a term coined by another standards body.

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 15:57:11 +0000

Reza,

This is where you will likely get us into some trouble.

I mostly agree about the RAN slices part of your argument, but I am highly suspicious of your assertion relative to Packet Core.

That is why I suggested that we stick to a definition with a focus on the part about generic slicing (network slicing, transport network slicing, etc.) that requires “packetization” and forwarding as defined in IETF specifications.

--
Eric

Importance: High

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: John E Drake <[email-masked]>
Date: Fri, 1 May 2020 15:58:32 +0000

Hi,

Comment inline

Yours Irrespectively,

John

Juniper Business Use Only
From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Sent: Friday, May 1, 2020 11:53 AM
To: John E Drake <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas] FW: The word "transport"

John,
Please see inline.

Cheers,
Reza

From: John E Drake <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 1, 2020 at 11:08 AM
To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas] FW: The word "transport"

Hi,

Comments inline.

Yours Irrespectively,

John

John and all,

[Reza] The question is not overlay vs. underlay. My argument was that this term "Underlay network slice" is confusing. I just responded to Adrian in other email thread but this is the summary. Please refer to that thread for more info.
IETF does not deal with e2e network slice because an E2E network slice is the logical network from End user X to End use Y and comprises of:

  *   One or more Transport slices (TS)
  *   One or more Other Slices (OS)
Since Other slices are not in IETF scope, we should refrain from using "network slice" at IETF. IETF is part of the e2e network slice solution.

[JD]  'Transport Slice' is a term coined outside the IETF and if we use it we will have to explain what we mean by it in the context of the IETF.

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say...

Then...

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: John E Drake <[email-masked]>
Date: Fri, 1 May 2020 16:12:17 +0000

Hi,

That was not my understanding but if that's true then we are responsible for developing a rather bad term.  As Adrian detailed in his original email, 'transport' is a term typically used by other standards bodies and that within the IETF it carries a lot of baggage.

Yours Irrespectively,

John

Juniper Business Use Only
From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Sent: Friday, May 1, 2020 11:56 AM
To: John E Drake <[email-masked]>; Eric Gray <[email-masked]>; [email-masked]; 'John E Drake' <jdrake=[email-masked]>; [email-masked]; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas] FW: The word "transport"

>>>>> [JD]  This is back to Adrian's original point, viz, 'transport slice' is a term coined by another standards body.

As far as I know there is not any SDO which defines "Transport slice" at least at the time that we wrote the draft. If not so, please provide the reference.
We at IETF started using this term.

Reza

From: John E Drake <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 1, 2020 at 11:52 AM
To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, Eric Gray <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas] FW: The word "transport"

Hi,

Comment inline

Yours Irrespectively,

John

To: Eric Gray <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say...

Then...

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 16:15:03 +0000

Reza,

              I’ve removed Adrian (at least as an explicit addressee, as I do not know if he is part of the DT mailing list), and the TEAS WG from this exchange, as we do not need to add to any perception that we are nowhere near a resolution in this discussion.

              As you may recall, I objected to inclusion of “other slices” in very early stages, and have seen absolutely nothing to change my mind about the need to include this concept – at least in the long term – since.

              For context setting, the “transport slice” user may have some arbitrary data (PDU, Message, Payload, etc.) that they need to have encapsulated for packetized transport, using some specific IETF technology, from one point to another, or multiple other points (i.e. from one end-point to one or more other end-points).  In this context, the expression “end-to-end” will never be anything other than ambiguous.

              There is nothing to gain but complication and confusion from even making the attempt to explain why this is needed in some subset of all possible applications which share this need.

              I have not repeated my objections because I had hoped that it would become more obvious with time.  Hopefully I will eventually turn out to be right.

😊
--
Eric

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 16:23:39 +0000

John,

              Actually, "Transport Slice" was "coined" by us on the design team.  I am not sure who actually 1st used this expression, but the design team agreed to use it in defining terminology to be used in this effort.

              The expression used in 5G/3GPP, for instance, is "transport network slice."  The expression I've seen used in DCN is just "network slice."

              I believe that we coined the expression "transport slice" explicitly to avoid tying it too closely to either 5G/3GPP (if we used "transport network slice") or DCN (if we used "network slice").

              As a design team, I believe we should have the ability to make decision like this.  Where we have likely failed is in making the intent and usage of this expression very clear.

--
Eric

--
Eric

From: John E Drake <[email-masked]>
Sent: Friday, May 1, 2020 11:53 AM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; Eric Gray <[email-masked]>; [email-masked]; 'John E Drake' <jdrake=[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [Teas] FW: The word "transport"
Importance: High

Hi,

Comment inline

Yours Irrespectively,

John

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say...

Then...

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://protect2.fireeye.com/v1/url?k=ec407f85-b2e0c5eb-ec403f1e-86b1886cfa64-0a240ff7f16b3c02&q=1&e=3c877a55-7b82-4a55-844d-d1981954de61&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fprotect2.fireeye.com%2Fv1%2Furl%3Fk%3Dd4f6bc46-8a560628-d4f6fcdd-86b1886cfa64-dd8e4ff74c5dda87%26q%3D1%26e%3Db15230b3-e6dc-4732-83e3-00354fdc75ae%26u%3Dhttps%2A3A%2A2F%2A2Furldefense.com%2A2Fv3%2A2F__https%2A3A%2A2Fwww.ietf.org%2A2Fjabber%2A2Flogs%2A2Fteas%2A2F2020-04-23.html__%2A3B%2A21%2A21NEt6yMaO-gk%2A21WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI%2A24__%3BJSUlJSUlJSUlJSUlJSUlJQ%21%21NEt6yMaO-gk%21Ss83mQtEVqDRzJaflsjI0IuUspo1qru8LEP6d7EHAVACW_rPFMRhTgGzcd8fvSc%24>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: John E Drake <[email-masked]>
Date: Fri, 1 May 2020 16:23:59 +0000

Hi,

I agree w/ Eric.  We are defining a generic capability that can be used by a multiplicity of use-cases, most of which we have yet to understand.  It is the responsibility of the standards body that is defining a given use-case to describe how they would use our generic capability in their use-case; it is not our responsibility.

Yours Irrespectively,

John

Juniper Business Use Only
From: Eric Gray <eric.gray=[email-masked]>
Sent: Friday, May 1, 2020 12:15 PM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; John E Drake <[email-masked]>; [email-masked]
Subject: RE: [Teas] FW: The word "transport"

Reza,

😊
--
Eric

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://urldefense.com/v3/__https:/protect2.fireeye.com/v1/url?k=d4f6bc46-8a560628-d4f6fcdd-86b1886cfa64-dd8e4ff74c5dda87&q=1&e=b15230b3-e6dc-4732-83e3-00354fdc75ae&u=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fwww.ietf.org*2Fjabber*2Flogs*2Fteas*2F2020-04-23.html__*3B*21*21NEt6yMaO-gk*21WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI*24__;JSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!Wo0kitLosTTfpc-UszoaX2FIfBXNFY4pZZlnVZmd6BPdCplwQvjYumpr1RA_mOk$>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 16:29:48 +0000

Reza,

              This pretty much sums up why we have no business even mentioning “other slices” or – for that matter – any context in which someone would like to include some arbitrary definition of what end-to-end means outside of that which is in scope for the IETF.

--
Eric

John,
Please see inline.

Cheers,
Reza

Hi,

Comments inline.

Yours Irrespectively,

John

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://protect2.fireeye.com/v1/url?k=76b30006-2813ba68-76b3409d-86b1886cfa64-400c255c349a4e99&q=1&e=cb08a6b8-65af-4861-b991-81c8c25d39e0&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.ietf.org%2Fjabber%2Flogs%2Fteas%2F2020-04-23.html__%3B%21%21NEt6yMaO-gk%21WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI%24>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 17:53:46 +0000

Yes, the word “Transport” does carry a lot of baggage – here in the IETF and elsewhere.  Think of it as “baggage transport.” 😊

But that has not stopped us before.  You no doubt know what the “TP” stands for in MPLS-TP.

We cannot rule out use of terms that are pretty much in line with their English language interpretation, just because they are used ambiguously in another context, or in a general context.

I think that – if we were just calling it “Transport” – this would be a serious problem.  But we do not (AFAIK) use this in any context where we do not combine it with “Slicing” and we define “Transport Slicing.” Which should be enough to avoid issues with the fact that the separate terms are ambiguous.

Provided, of course, that it is sufficiently clear what we mean by “Transport Slicing.”

Quite frankly, I find it surprising that we are debating the terminology choices that were made by a design team at the working group level.  It is one thing if it can be argued that the choices are counter-intuitive – though I can think of numerous cases where that has not carried much weight.

What makes sense to discuss at the WG level is whether we define the terminology with sufficient clarity, and then use the terminology as we defined it.

--
Eric

From: John E Drake <[email-masked]>
Sent: Friday, May 1, 2020 12:12 PM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; Eric Gray <[email-masked]>; [email-masked]; 'John E Drake' <jdrake=[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [Teas] FW: The word "transport"
Importance: High

Hi,

That was not my understanding but if that’s true then we are responsible for developing a rather bad term.  As Adrian detailed in his original email, ‘transport’ is a term typically used by other standards bodies and that within the IETF it carries a lot of baggage.

Yours Irrespectively,

John

To: John E Drake <[email-masked]<mailto:[email-masked]>>; Eric Gray <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Reza

Hi,

Comment inline

Yours Irrespectively,

John

Reza Rokui, Ph.D.

Adrian,

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    Full logs - https://www.ietf.org/jabber/logs/teas/2020-04-23.html<https://protect2.fireeye.com/v1/url?k=d85f249f-86ff9ef1-d85f6404-866038973a15-79480ef04dd7bd36&q=1&e=3885d79e-3893-4913-8634-bfacad730074&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fprotect2.fireeye.com%2Fv1%2Furl%3Fk%3Dd4f6bc46-8a560628-d4f6fcdd-86b1886cfa64-dd8e4ff74c5dda87%26q%3D1%26e%3Db15230b3-e6dc-4732-83e3-00354fdc75ae%26u%3Dhttps%2A3A%2A2F%2A2Furldefense.com%2A2Fv3%2A2F__https%2A3A%2A2Fwww.ietf.org%2A2Fjabber%2A2Flogs%2A2Fteas%2A2F2020-04-23.html__%2A3B%2A21%2A21NEt6yMaO-gk%2A21WrvQt2QtERG2EFnE6CPHr8TzNjoFggUjNzUFGwWmlw2KiRSR42MiO2N4YtwhZJI%2A24__%3BJSUlJSUlJSUlJSUlJSUlJQ%21%21NEt6yMaO-gk%21Ss83mQtEVqDRzJaflsjI0IuUspo1qru8LEP6d7EHAVACW_rPFMRhTgGzcd8fvSc%24>

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Fri, 1 May 2020 18:13:12 +0000

Fully agree

De: Teas-ns-dt <[email-masked]> En nombre de Eric Gray
Enviado el: viernes, 1 de mayo de 2020 19:54
Para: John E Drake <[email-masked]>; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]; 'John E Drake' <jdrake=[email-masked]>; [email-masked]; [email-masked]
Asunto: Re: [Teas-ns-dt] [Teas] FW: The word "transport"

--
Eric

From: John E Drake <[email-masked]<mailto:[email-masked]>>
Sent: Friday, May 1, 2020 12:12 PM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Eric Gray <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] FW: The word "transport"
Importance: High

Hi,

Yours Irrespectively,

John

Reza

Hi,

Comment inline

Yours Irrespectively,

John

Reza Rokui, Ph.D.

Adrian,

Please refer to Figure 4 of the draft.
In summary, an E2E network slice is the logical network from End user X to End use Y and comprises of:
-          One or more Transport slices (TS)
-          One or more Other Slices (OS)

Reza

Hi Reza,

Cheers,
Adrian

John and all,

Cheers,
Reza

A

Hi,

Yours Irrespectively,

John

Reza,

But we are not the 3GPP and our terminology needs to be consistent. As I noted, we already have multiple meanings of transport:
-          The transport layer (traditional from the OSI model) that includes TCP, UDP, etc.
-          Transport networks (a term also used in the ITU-T) that embraces Ethernet, TDM, and optical technologies that carry packets for us. This term is most often seen in CCAMP, TEAS, and PCE.
-          MPLS-TP (possibly deriving from the ITU-T’s T-MPLS) that refers to the use of MPLS as a technology to build transport networks as described in the previous bullet
-          Transport as a verb (such as in HTTP) meaning simply ‘to carry’
In the ACTN work, we moved from ‘transport’ to ‘TE’ recognising that ACTN was applicable to any network type where paths could be computed and imposed, and resource partitioned and reserved.

Additionally, you say…

Then…

[snip]

Best,
Adrian

All,

Cheers,
Reza

Hi all,

Reza

    Hi Reza,

    ==

] 

    ==

    More inline..

    <[email-masked]<mailto:[email-masked]>> wrote:

    Thanks!

    Dhruv

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 2 May 2020 12:18:26 -0700

+1

Regards,
Jeff

> On May 1, 2020, at 11:13, LUIS MIGUEL CONTRERAS MURILLO <[email-masked]> wrote:
> 
> 
> Fully agree
>  
> [email-masked]
> Definition of term Transport: This term embraces various technologies such as IP, Optical, Ethernet, TDM, etc  that carry packets and traffic and might span multiple administrative domains.
>  
> From: Reza Rokui <[email-masked]>
> To: Dhruv Dhody <[email-masked]>, Jari Arkko <[email-masked]>, "[email-masked]" <[email-masked]>
> Cc: Reza Rokui <[email-masked]>
> On 2020-04-24, 1:31 AM, "Dhruv Dhody" <[email-masked]> wrote:
>  
>     Hi Reza,
>  
>     <[email-masked]> wrote:
>     >
>     > Hi Dhruv,
>     >
>     > On 2020-04-23, 12:35 PM, "Dhruv Dhody" <[email-masked]> wrote:
>     >
>     >     Hi,
>     >
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt