Subject: [Teas-ns-dt] Github?

From: Eric Gray <[email-masked]>
Date: Fri, 1 May 2020 15:18:11 +0000

I was going to start looking into the XML version for the definitions draft via github, and discovered that - if you are using an XML version to generate your text version - it is not in our github repository.

Trying to put in a "pull" against the Text version is very much unnecessarily complicated (mostly because of the editing changes associated with getting the right pagination, footer and header information placement, etc. - which would, among other things, make merging multiple changes very messy and is the main advantage in using either the Markdown and/or XML formats).

So I guess I will just focus on compiling a set of specific editing suggestions for the definitions draft.  Note that this too will be messy, making the realistic assumption that not all of the suggested changes will be accepted as proposed, because it will be necessary to produce a summary of the changes that are acceptable to everyone, after allowing for discussion and responses.

Hopefully, I will complete those editing suggestions today.

--
Eric

---

From: Kiran Makhijani <[email-masked]>
Date: Fri, 1 May 2020 15:22:33 +0000

Here’s the xml - would you like to pull from here?

https://github.com/s-homma/draft-nsdt-teas-transport-slice-definition?

Any other way I can make it easier for you?
Regards
Kiran

________________________________
From: Eric Gray <[email-masked]>
Sent: Friday, May 1, 2020 8:18:11 AM
To: Kiran Makhijani <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Github?

I was going to start looking into the XML version for the definitions draft via github, and discovered that – if you are using an XML version to generate your text version – it is not in our github repository.

Trying to put in a “pull” against the Text version is very much unnecessarily complicated (mostly because of the editing changes associated with getting the right pagination, footer and header information placement, etc. – which would, among other things, make merging multiple changes very messy and is the main advantage in using either the Markdown and/or XML formats).

--

Eric

---

From: Shunsuke Homma <[email-masked]>
Date: Sat, 2 May 2020 10:15:49 +0900

Hi Eric,

The authors were managing the XML for the definition draft on my personal
github repository, because it was an individual work.

Now, the draft is published as NS-DT's contribution, and it may be a good
timing for moving XML into the nsdt github repository.

Regards,

Shunsuke

2020年5月2日(土) 0:22 Kiran Makhijani <[email-masked]>:

> ------------------------------
> *From:* Eric Gray <[email-masked]>
> *Sent:* Friday, May 1, 2020 8:18:11 AM
> *To:* Kiran Makhijani <[email-masked]>
> *Cc:* [email-masked] <[email-masked]>
> *Subject:* Github?
>
>
> I was going to start looking into the XML version for the definitions
> draft via github, and discovered that – if you are using an XML version to
> generate your text version – it is not in our github repository.
>
>
>
> Trying to put in a “pull” against the Text version is very much
> unnecessarily complicated (mostly because of the editing changes associated
> with getting the right pagination, footer and header information placement,
> etc. – which would, among other things, make merging multiple changes very
> messy and is the main advantage in using either the Markdown and/or XML
> formats).
>
>
>
> So I guess I will just focus on compiling a set of specific editing
> suggestions for the definitions draft.  Note that this too will be messy,
> making the realistic assumption that not all of the suggested changes will
> be accepted as proposed, because it will be necessary to produce a summary
> of the changes that are acceptable to everyone, after allowing for
> discussion and responses.
>
>
>
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt
>

---

From: Eric Gray <[email-masked]>
Date: Mon, 4 May 2020 14:12:15 +0000

I agree.  Who has write permission to that part of the repository?

If you would prefer, I can take the current sync’d version of the XML file and add it to the repository under “definitions” – most likely as a pull, which whoever is the “owner for that can then “merge” into the folder.

If I do that, I would also add a README.md file and a Makefile (which would be similar to the one under framework) which could be used to verify the results of any proposed pull against that part of the repository.

The README.md file would (as it does under the framework folder) mostly describe the process for using “make” (among other things).

The main thing – for using XML only – would be to get the local version of both “make” and “xml2rfc.”  That would almost certainly mean working with a UNIX/Lynux-like environment (which can be done on a MS Windows platform, using Cygwin).

But there would remain the option to resolve changes using E-Mail…

--
Eric

--
Eric

From: Shunsuke Homma <[email-masked]>
Sent: Friday, May 1, 2020 9:16 PM
To: Kiran Makhijani <[email-masked]>
Cc: Eric Gray <[email-masked]>; [email-masked]
Subject: Re: [Teas-ns-dt] Github?

Hi Eric,

The authors were managing the XML for the definition draft on my personal github repository, because it was an individual work.

Now, the draft is published as NS-DT's contribution, and it may be a good timing for moving XML into the nsdt github repository.

Regards,

Shunsuke

2020年5月2日(土) 0:22 Kiran Makhijani <[email-masked]<mailto:[email-masked]>>:
Here’s the xml - would you like to pull from here?

https://github.com/s-homma/draft-nsdt-teas-transport-slice-definition?<https://protect2.fireeye.com/v1/url?k=600a3aad-3eaa80c3-600a7a36-869a14f4b08c-dd98bd8b43c3e9e2&q=1&e=43eb935f-6beb-4d72-82e7-77c23db3dd7b&u=https%3A%2F%2Fgithub.com%2Fs-homma%2Fdraft-nsdt-teas-transport-slice-definition%3F>

________________________________
From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Sent: Friday, May 1, 2020 8:18:11 AM
To: Kiran Makhijani <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Github?

--

Eric
--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt

---

From: Kiran Makhijani <[email-masked]>
Date: Mon, 4 May 2020 14:55:56 +0000

Done. You can find xml under definitions folder. Since the version changes are visible in the directory. I did not add -02 to the file.
Feel free to open the issues or edit otherwise.
Thanks
-Kiran

From: Eric Gray <[email-masked]>
Sent: Monday, May 4, 2020 7:12 AM
To: Shunsuke Homma <[email-masked]>; Kiran Makhijani <[email-masked]>
Cc: [email-masked]
Subject: RE: [Teas-ns-dt] Github?

--
Eric

--
Eric

From: Shunsuke Homma <[email-masked]<mailto:[email-masked]>>
Sent: Friday, May 1, 2020 9:16 PM
To: Kiran Makhijani <[email-masked]<mailto:[email-masked]>>
Cc: Eric Gray <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas-ns-dt] Github?

Hi Eric,

Regards,

Shunsuke

https://github.com/s-homma/draft-nsdt-teas-transport-slice-definition?<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fprotect2.fireeye.com%2Fv1%2Furl%3Fk%3D600a3aad-3eaa80c3-600a7a36-869a14f4b08c-dd98bd8b43c3e9e2%26q%3D1%26e%3D43eb935f-6beb-4d72-82e7-77c23db3dd7b%26u%3Dhttps%253A%252F%252Fgithub.com%252Fs-homma%252Fdraft-nsdt-teas-transport-slice-definition%253F&data=02%7C01%7Ckiranm%40futurewei.com%7C81f46a40b0bb4be2533708d7f03527b5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637241983407627042&sdata=SPecWRNRcuHBVPxctBBJzWs%2B6Xf8pI6%2FASql8q9HL6E%3D&reserved=0>

--

Eric
--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteas-ns-dt&data=02%7C01%7Ckiranm%40futurewei.com%7C81f46a40b0bb4be2533708d7f03527b5%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637241983407636999&sdata=CTx3PVI4shiyOBT3JM5JsAlqPTJuxzZD0hk6No6QBL8%3D&reserved=0>