Subject: [Teas-ns-dt] Suggestion for "fixing" the tables shared between our DT drafts.

From: Eric Gray <[email-masked]>
Date: Wed, 8 Jul 2020 16:00:18 +0000

Currently, Figure 4 in the definitions draft and Figure 1 in the Framework draft include (at least as a subset) the following ASCII art figure or at least something very like it).

       +---------------------------------------+
       |              Customer                 |
       +---------------------------------------+
                         ^
                         |
                         v
       +---------------------------------------+
       |   A higher level operation system     |
       | (e.g. e2e network slice orchestrator) |
       +---------------------------------------+
                         ^
                         | TSC NBI
                         v
       +---------------------------------------+
       |       Transport Slice Controller      |
       +---------------------------------------+
                         ^
                         | TSC SBI
                         v
       +---------------------------------------+
       |    Transport Network Controller(s)    |
       +---------------------------------------+

As discussed during the last meeting, there is some ambiguity related to exactly what we mean by "Customer" and whether or not it even makes sense to have this as a block in those figures.

I suggest - as a "fix" - that we consider replacing the above part of both Figures with something along the lines of:

       +---------------------------------------+
       |        Network Slice Consumer         |
       | (e.g. e2e network slice orchestrator) |
       +---------------------------------------+
                         ^
                         | TSC NBI
                         v
       +---------------------------------------+
       |       Transport Slice Controller      |
       +---------------------------------------+
                         ^
                         | TSC SBI
                         v
       +---------------------------------------+
       |    Transport Network Controller(s)    |
       +---------------------------------------+

We do not need to make this change prior to the submission deadline, unless some folks feel that we would have more trouble getting the two drafts adopted in IETF 108.

I would also like to point out that - based on the issues raised with respect to "TSC SBI" and TNC (which are actually out of scope in this effort) - we could possibly/eventually change this figure further to look like this:

       +---------------------------------------+
       |   A higher level operation system     |
       | (e.g. e2e network slice orchestrator) |
       +---------------------------------------+
                         ^
                         | TSC NBI
                         v
       +---------------------------------------+
     +-|       Transport Slice Controller      |-+
     | +---------------------------------------+ |
     |                   ^                       |
     |                   | TSC SBI               |
     |                   v                       |
     | +---------------------------------------+ |
     | |    Transport Network Controller(s)    | |
     | +---------------------------------------+ |
     |                                           |
     +-------------------------------------------+

The big block that includes everything in this figure from the TSC down (i.e. - TSC SBI and TNCs) would be described as logical components that would not be visible to a network slice consumer and are therefore out of scope.

--
Eric

---

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 9 Jul 2020 10:09:04 +0000

Hi all,

I also support the “customer” figure modification.

In IETF 107, Susan Hares had many concerns about whether the TS NBI is a customer service model or a network resource model.
It seems quite reasonable for her to think that the interface between the higher level operation system and customer is a kind of customer service model, either from text below the figure or from the figure itself.

In the current TS NSDT drafts, the customer interface of the figure is no direct relationship with TSC NBI, and the TSC NBI is actually a customer intent interface.

This figure is used in both the draft definitions and the framework. As suggested by Eric, I also support that both the documents can be modified.

Thanks,
Bo

发件人: Teas-ns-dt [mailto:[email-masked]] 代表 Eric Gray
发送时间: 2020年7月9日 0:00
收件人: teas-ns-dt <[email-masked]>; teas-wg/teas-ns-dt <[email-masked]>
主题: [Teas-ns-dt] Suggestion for "fixing" the tables shared between our DT drafts.

As discussed during the last meeting, there is some ambiguity related to exactly what we mean by “Customer” and whether or not it even makes sense to have this as a block in those figures.

I suggest – as a “fix” – that we consider replacing the above part of both Figures with something along the lines of:

I would also like to point out that – based on the issues raised with respect to “TSC SBI” and TNC (which are actually out of scope in this effort) – we could possibly/eventually change this figure further to look like this:

The big block that includes everything in this figure from the TSC down (i.e. – TSC SBI and TNCs) would be described as logical components that would not be visible to a network slice consumer and are therefore out of scope.

--
Eric