Subject: Re: [Teas-ns-dt] Suggestion for "fixing" the tables shared between our DT drafts.

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 9 Jul 2020 11:58:01 +0000

All,

I also agree with Eric’s comment. Using “Customer” alone does not add any value and might be also confusing.

Reza

From: Teas-ns-dt <[email-masked]> on behalf of Eric Gray <eric.gray=[email-masked]>
Date: Wednesday, July 8, 2020 at 12:00 PM
To: teas-ns-dt <[email-masked]>, teas-wg/teas-ns-dt <[email-masked]>
Subject: [Teas-ns-dt] Suggestion for "fixing" the tables shared between our DT drafts.

Currently, Figure 4 in the definitions draft and Figure 1 in the Framework draft include (at least as a subset) the following ASCII art figure or at least something very like it).

       +---------------------------------------+
       |              Customer                 |
       +---------------------------------------+
                         ^
                         |
                         v
       +---------------------------------------+
       |   A higher level operation system     |
       | (e.g. e2e network slice orchestrator) |
       +---------------------------------------+
                         ^
                         | TSC NBI
                         v
       +---------------------------------------+
       |       Transport Slice Controller      |
       +---------------------------------------+
                         ^
                         | TSC SBI
                         v
       +---------------------------------------+
       |    Transport Network Controller(s)    |
       +---------------------------------------+

As discussed during the last meeting, there is some ambiguity related to exactly what we mean by “Customer” and whether or not it even makes sense to have this as a block in those figures.

I suggest – as a “fix” – that we consider replacing the above part of both Figures with something along the lines of:

       +---------------------------------------+
       |        Network Slice Consumer         |
       | (e.g. e2e network slice orchestrator) |
       +---------------------------------------+
                         ^
                         | TSC NBI
                         v
       +---------------------------------------+
       |       Transport Slice Controller      |
       +---------------------------------------+
                         ^
                         | TSC SBI
                         v
       +---------------------------------------+
       |    Transport Network Controller(s)    |
       +---------------------------------------+

We do not need to make this change prior to the submission deadline, unless some folks feel that we would have more trouble getting the two drafts adopted in IETF 108.

I would also like to point out that – based on the issues raised with respect to “TSC SBI” and TNC (which are actually out of scope in this effort) – we could possibly/eventually change this figure further to look like this:

       +---------------------------------------+
       |   A higher level operation system     |
       | (e.g. e2e network slice orchestrator) |
       +---------------------------------------+
                         ^
                         | TSC NBI
                         v
       +---------------------------------------+
     +-|       Transport Slice Controller      |-+
     | +---------------------------------------+ |
     |                   ^                       |
     |                   | TSC SBI               |
     |                   v                       |
     | +---------------------------------------+ |
     | |    Transport Network Controller(s)    | |
     | +---------------------------------------+ |
     |                                           |
     +-------------------------------------------+

The big block that includes everything in this figure from the TSC down (i.e. – TSC SBI and TNCs) would be described as logical components that would not be visible to a network slice consumer and are therefore out of scope.

--
Eric

---

From: Xufeng Liu <[email-masked]>
Date: Thu, 9 Jul 2020 10:53:45 -0400

+1. Agree.

On Thu, Jul 9, 2020 at 7:58 AM Rokui, Reza (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> *From: *Teas-ns-dt <[email-masked]> on behalf of Eric Gray
> <eric.gray=[email-masked]>
> *Date: *Wednesday, July 8, 2020 at 12:00 PM
> *To: *teas-ns-dt <[email-masked]>, teas-wg/teas-ns-dt <
> [email-masked]>
> *Subject: *[Teas-ns-dt] Suggestion for "fixing" the tables shared between
> our DT drafts.
>
>
>
> Currently, Figure 4 in the definitions draft and Figure 1 in the Framework
> draft include (at least as a subset) the following ASCII art figure or at
> least something very like it).
>
>
>
>
>
> As discussed during the last meeting, there is some ambiguity related to
> exactly what we mean by “Customer” and whether or not it even makes sense
> to have this as a block in those figures.
>
>
>
> I suggest – as a “fix” – that we consider replacing the above part of both
> Figures with something along the lines of:
>
>
>
> We do not need to make this change prior to the submission deadline,
> unless some folks feel that we would have more trouble getting the two
> drafts adopted in IETF 108.
>
>
>
> I would also like to point out that – based on the issues raised with
> respect to “TSC SBI” and TNC (which are actually out of scope in this
> effort) – we could possibly/eventually change this figure further to look
> like this:
>
>
>
> The big block that includes everything in this figure from the TSC down
> (i.e. – TSC SBI and TNCs) would be described as logical components that
> would not be visible to a network slice consumer and are therefore out of
> scope.
>
>
>
> --
>
> Eric
>
>
>
>
>
>
>
>
> --
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt
>