Subject: [Teas-ns-dt] definitions draft uploaded

From: Kiran Makhijani <[email-masked]>
Date: Wed, 8 Jul 2020 18:09:28 +0000

Hello,
I just uploaded definitions draft with editorial clean up. I think its good for submission to IETF data tracker - unless you have comments that I missed to address.

https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/draft-nsdt-teas-transport-slice-definition-03.txt

Regards
Kiran

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Fri, 10 Jul 2020 07:54:35 +0000

Hi Kiran, Reza, authors,
Maybe I'm late for comment, but I realized yesterday evening reading again the document one point in the mapping between TSE and TSRE.

In 4.2 it is said :

"There is another type of the endpoints called "Transport Slice
   Realization endpoints (TSRE)".  These endpoints are allocated and
   assigned by the network controller during the realization of a
   transport slice...."

This is absolutely correct. But just below it is said about the mapping between TSE and TSRE on TSC : " When TSC receives a request via its NBI to create a transport slice between multiple TSEs, it will then find the
appropriate TSREs and sends the request via its SBI to realize the transport slice."

This is contradicts what said above : how TSC can find TSREs that should be "allocated by the network controller during the realization of a transport slice.." if network controller has not even received yet the request form TSC?

The TSRE should be notified to TSC after realization of TS.
Maybe a suggested text could be:

"Note that there will be a mapping between TSE and TSRE on Transport Slice Controller (TSC).  When TSC receives a request via its NBI to create a transport slice between multiple TSEs,it will send the request via its SBI to realize the transport slice, and the TSRE will be notified by Network Controller during TS realization, to permit TSC the correct mapping with TSEs."

Thanks
SErgio

From: Teas-ns-dt <[email-masked]> On Behalf Of Kiran Makhijani
Sent: Wednesday, July 8, 2020 8:09 PM
To: [email-masked]
Subject: [Teas-ns-dt] definitions draft uploaded

Hello,

Regards
Kiran

---

From: Eric Gray <[email-masked]>
Date: Mon, 13 Jul 2020 13:00:43 +0000

Sergio,

              The objection I have to the proposed text is that you're assuming the existence of a real SBI.

              We don't need to include "send the request via its SBI to" as it is in your proposed text.

--
Eric

From: Teas-ns-dt <[email-masked]> On Behalf Of Belotti, Sergio (Nokia - IT/Vimercate)
Sent: Friday, July 10, 2020 3:55 AM
To: Kiran Makhijani <[email-masked]>; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas-ns-dt] definitions draft uploaded

Hi Kiran, Reza, authors,

In 4.2 it is said :

Thanks
SErgio

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Kiran Makhijani
Sent: Wednesday, July 8, 2020 8:09 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Teas-ns-dt] definitions draft uploaded

Hello,

https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/draft-nsdt-teas-transport-slice-definition-03.txt<https://protect2.fireeye.com/v1/url?k=c7780934-99d8a7f9-c77849af-866132fe445e-b9c07af68b2cddf5&q=1&e=bc92aace-5efb-497e-b580-c072408f82b6&u=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fdefinitions%2Fdraft-nsdt-teas-transport-slice-definition-03.txt>

Regards
Kiran