Subject: [Teas-ns-dt] Brief meeting notes

From: Jari Arkko <[email-masked]>
Date: Thu, 24 Sep 2020 16:33:38 +0000

Situation:
- Documents not adopted as is

Process:
- we need to revise based on feedback and ask again
- wait on framework until definitions agreed
- interim on Oct 19

Main changes:
1/ need to use a different term
- Perhaps more about the name itself than its definition – but also have to worry about the latter. Maybe easier to discuss once the name is not objectionable?
- We all recognize the feedback, and agree not to use transport network slice term
- IETF network slice one contender, some resistance
2/ isolation
- Need acceptable content, not just a placeholder
- Need to understand which approach to use, though (Jari recommended explaining how the term relates to this work, perhaps some breakdown of the term as well)

Next steps:
- For each issue/change, a small team to look at it, provide some options, and analysis of the implications and tradeoffs in those options
- Post early to main TEAS WG list, keep discussion ongoing
- Jari can arrange a weekly call starting next week (again, posted to main list) for those who want to discuss in real-time. But useful only after the above two steps are done first.
- Responsible people: on the name issue, the author team; on isolation Luis, Jie, and Jeff will work on it
- Everyone else to stay active on list + comment and make counter proposals and additional analysis

---

From: John E Drake <[email-masked]>
Date: Thu, 24 Sep 2020 19:41:37 +0000

Hi,

I just wanted to comment on some of the statements that were made during the conference call today.  I think it's important that we have a written record rather than trying to respond during the conference call.

  1.  Reza said that we couldn't use the term 'network slice' because 3GPP uses the term 'E2E network slice'.  Obviously, 'network slice' is a different term than 'E2E network slice' so this is nonsense.  Further, the definition of the term 'E2E network slice' would appear to be the concatenation of two or more 'network slices'.
  2.  Kiran said that the network slicing was introducing an entirely new concept to the IETF.  The last time I checked, there were roughly 20-30 drafts or RFCs on the topic of network slicing, all of which pre-date anything the NSDT has published and all of which use the term 'network slicing'
  3.  Kiran said that 'transport network' was a common term in the IETF.  This is incorrect.  'Transport Network' is an ITU term and the only time it is used in the IETF is in support of the ITU's use of MPLS.  This is MPLS-TP (transport profile).
  4.  Kiran said that term 'IETF network slice' is not generic.  Why is it important that the term we use be generic and why is this term not generic?
  5.  Kiran said that the NBI was not a service definition.  I think this is nonsense - otherwise, why do we have 'service level objectives'?

Further, any discussion of isolation should be in terms of the variation of an SLO parameter's value, since this is the only thing a customer can measure as the instantiation of its 'service'.  E.g., absolute isolation would mean that a given SLO parameter's value is invariant.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas-ns-dt <[email-masked]> On Behalf Of Jari Arkko
Sent: Thursday, September 24, 2020 12:34 PM
To: [email-masked]
Subject: [Teas-ns-dt] Brief meeting notes

[External Email. Be cautious of content]

Situation:

Process:

Main changes:
- Perhaps more about the name itself than its definition - but also have to worry about the latter. Maybe easier to discuss once the name is not objectionable?

Next steps:

---

From: John E Drake <[email-masked]>
Date: Thu, 24 Sep 2020 19:55:54 +0000

Hi,

And one thing further, the primary purpose of the definitions draft is to define a network slice.  I would assert that our current definition is woefully inadequate:

"A transport slice is a logical network topology connecting a number of endpoints with a set of shared or dedicated network resources, that are used to satisfy specific Service Level Objectives (SLOs)".

And would propose an alternative definition:

"A set of endpoints and a set of one or more dataplane constructs (MP2MP, P2MP, P2P uni-directional, and P2P bi-directional) each of which connects a subset of these endpoints.  For each dataplane construct there is an SLO for each endpoint that can transmit using that dataplane construct.  (This allows us to self-identify the type of a given data plane construct.)"

Yours Irrespectively,

John

Juniper Business Use Only
From: John E Drake
Sent: Thursday, September 24, 2020 3:42 PM
To: Jari Arkko <jari.arkko=[email-masked]>; [email-masked]
Cc: Vishnu Pavan Beeram <vbeeram=[email-masked]>; Lou Berger <[email-masked]>; 'BRUNGARD, DEBORAH A' <[email-masked]>; [email-masked]
Subject: RE: Brief meeting notes

Hi,

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Jari Arkko
Sent: Thursday, September 24, 2020 12:34 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Teas-ns-dt] Brief meeting notes

Situation:

Process:

Main changes:

Next steps:

---

From: Eric Gray <[email-masked]>
Date: Fri, 25 Sep 2020 14:25:41 +0000

I’ve added further to the points John made in his mail, below…

--
Eric

From: Teas-ns-dt <[email-masked]> On Behalf Of John E Drake
Sent: Thursday, September 24, 2020 3:42 PM
To: Jari Arkko <jari.arkko=[email-masked]>; [email-masked]
Cc: [email-masked]; Lou Berger <[email-masked]>; 'BRUNGARD, DEBORAH A' <[email-masked]>; Vishnu Pavan Beeram <vbeeram=[email-masked]>
Subject: Re: [Teas-ns-dt] Brief meeting notes

Hi,

I just wanted to comment on some of the statements that were made during the conference call today.  I think it’s important that we have a written record rather than trying to respond during the conference call.

  1.  Reza said that we couldn’t use the term ‘network slice’ because 3GPP uses the term ‘E2E network slice’.  Obviously, ‘network slice’ is a different term than ‘E2E network slice’ so this is nonsense.  Further, the definition of the term ‘E2E network slice’ would appear to be the concatenation of two or more ‘network slices’.

There is some confusion in this part of the discussion.  The concern (from the perspective of folks who deal with more than one other SDO, besides the IETF) is that a reader may be confused by the use of the term/phrase also used in another context, being used in a different way in an IETF context.  Nobody can reasonably argue that the IETF – generally – cannot use the phrase “network slice” because there is ample evidence to support the conclusion that we do use it and have been using it for a considerable period of time.

One thing we have learned repeatedly in the IETF – and, in my personal experience at least, in other SDOs – is that the phrase “end to end” is a fundamentally useless qualifier without significant context information.  Since we do not need this concept in order to describe support requirements for IETF Network Slices (or Slice Services) in a single domain, we can (and should) avoid spending much time in discussing it.

In order to avoid the concerns about potential confusion, however, we need only provide a brief explanation of how an “IETF Network Slice” would be used (or what it might be known as) in other groups or organizations.  The hardest part about doing this is deciding where to do it – which is a key reason for sticking to providing a few relevant term/phrase definitions in the current definition draft and delegating the task of explaining the applicability of IETF Network Slices to other contexts to a section added explicitly for that purpose to the Framework draft, or a separate “Applicability Draft.”

  1.  Kiran said that the network slicing was introducing an entirely new concept to the IETF.  The last time I checked, there were roughly 20-30 drafts or RFCs on the topic of network slicing, all of which pre-date anything the NSDT has published and all of which use the term ‘network slicing’

I’m not sure if Kiran actually said this, but it is a common enough belief.  I doubt anyone can claim certain knowledge of who used the phrase first, but it is fairly obvious that a number of distinct standards organizations have been using “network slice/slices/slicing” for quite a while.

  1.  Kiran said that ‘transport network’ was a common term in the IETF.  This is incorrect.  ‘Transport Network’ is an ITU term and the only time it is used in the IETF is in support of the ITU’s use of MPLS.  This is MPLS-TP (transport profile).

If you look a little into the structure and history of the IETF, you will see quite quickly why it is that the term “Transport” is used with considerable reluctance in the IETF to mean anything other than the “Transport” layer originally included in the (now more than a little archaic) OSI seven-layer model.  The many ways that layering is done now can be confusing enough, without referring to any of the bottom three layers as “Transport” as well.

As an SDO, while we want to make an effort to avoid confusing the industry, our first responsibility is to avoid confusing ourselves.  😊

  1.  Kiran said that term ‘IETF network slice’ is not generic.  Why is it important that the term we use be generic and why is this term not generic?

Again, I am not sure I heard Kiran say this, precisely, but someone may have and many may have interpreted what was said as meaning this.  In fact, it may look like there are a number of possibly distinct network slice concepts in the IETF.  But this is mostly because of the work in different drafts having a focus on how to use some specific subset of one or more technologies to support what has become an increasingly stable concept of a network slice in an IETF context (hence, an “IETF Network Slice”).

In order to make an IETF Network Slice generic, we have to abstract the means for creating an IETF Network Slice from what the result looks like to a consumer.

This is what the industry as a whole typically refers to as a service model – i.e. – how we define a service in terms of things that a consumer can actually determine as service objectives that the service is meeting.

  1.  Kiran said that the NBI was not a service definition.  I think this is nonsense – otherwise, why do we have ‘service level objectives’?

And this is the clincher.  If we are modeling whatever it is that we are providing using “service (level) objectives,” then what we are defining is a service model.

Further, any discussion of isolation should be in terms of the variation of an SLO parameter’s value, since this is the only thing a customer can measure as the instantiation of its ‘service’.  E.g., absolute isolation would mean that a given SLO parameter’s value is invariant.

Personally, I think that “isolation” us a topic best discussed separately.

Yours Irrespectively,

John

- - - [SNIP] - - -

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Sep 2020 15:50:40 +0100

Eric,

I think this is a really helpful mail. Thanks.

It is, IMHO, really useful to separate the “what are we trying to deliver?” (i.e., what is the service?) from “how will it be delivered?” (which encompasses management framework/components and network behaviour). As engineers, we usually get ourselves stuck in the second question, but it seems to me that the description of the service (and the NBI) are fundamental to the understanding of network slicing.

Without trying to imply that a slice is a VPN, I think it is helpful to consider the VPN case. You can separate this into a discussion of what a VPN does for a consumer (connects together a set of sites for exchange of packets/frames of the same encapsulation), and how the VPN is delivered (adaptation, network encapsulation, network protocols, etc.). They are both important, but it is service definition that is capable of being generic and describing the concepts.

I particularly like Eric’s point about applicability statements. There will be a need to write “mappings” for how IETF technology is used to deliver the function wanted in different use cases, especially those described by other SDOs. It is a lot easier to make the IETF work internally consistent in the IETF and then write the necessary applicability statements.

Thanks,

Adrian

PS I also like the statement about isolating the work on isolation 😊  But I think it should be possible to split this along exactly the same lines. That is, what does a consumer want in their SLOs (at the NBI) and is any of that specific to isolation? And then, how do we deliver the SLOs inside the network, and does that require some concepts of isolation?

From: Teas-ns-dt <[email-masked]> On Behalf Of Eric Gray
Sent: 25 September 2020 15:26
To: John E Drake <jdrake=[email-masked]>; Jari Arkko <jari.arkko=[email-masked]>; [email-masked]
Cc: [email-masked]; Lou Berger <[email-masked]>; Vishnu Pavan Beeram <vbeeram=[email-masked]>; 'BRUNGARD, DEBORAH A' <[email-masked]>
Subject: Re: [Teas-ns-dt] Brief meeting notes

--

Eric

Hi,

2.	Kiran said that the network slicing was introducing an entirely new concept to the IETF.  The last time I checked, there were roughly 20-30 drafts or RFCs on the topic of network slicing, all of which pre-date anything the NSDT has published and all of which use the term ‘network slicing’

3.	Kiran said that ‘transport network’ was a common term in the IETF.  This is incorrect.  ‘Transport Network’ is an ITU term and the only time it is used in the IETF is in support of the ITU’s use of MPLS.  This is MPLS-TP (transport profile).

4.	Kiran said that term ‘IETF network slice’ is not generic.  Why is it important that the term we use be generic and why is this term not generic?

5.	Kiran said that the NBI was not a service definition.  I think this is nonsense – otherwise, why do we have ‘service level objectives’?

Yours Irrespectively,

John

- - - [SNIP] - - -

---

From: Eric Gray <[email-masked]>
Date: Fri, 25 Sep 2020 15:01:20 +0000

Hey, we’re making progress here.  😊

One minor point of potential disagreement (and I am pretty sure this is really more of a clarification), is that – while I agree that having some number of follow-on applicability statements makes a huge amount of sense – I do not see that there should be any show-stopping issues with including at least a seed for applicability of the work described in earlier documents in a few interesting use cases.

From: Adrian Farrel <[email-masked]>
Sent: Friday, September 25, 2020 10:51 AM
To: Eric Gray <[email-masked]>; 'John E Drake' <[email-masked]>; Jari Arkko <[email-masked]>; [email-masked]
Cc: 'Lou Berger' <[email-masked]>; 'Vishnu Pavan Beeram' <[email-masked]>; 'BRUNGARD, DEBORAH A' <[email-masked]>
Subject: RE: [Teas-ns-dt] Brief meeting notes
Importance: High

Eric,

Thanks,
Adrian

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Eric Gray
Sent: 25 September 2020 15:26
To: John E Drake <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>; Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Lou Berger <[email-masked]<mailto:[email-masked]>>; Vishnu Pavan Beeram <vbeeram=[email-masked]<mailto:vbeeram=[email-masked]>>; 'BRUNGARD, DEBORAH A' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas-ns-dt] Brief meeting notes

--
Eric

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of John E Drake
Sent: Thursday, September 24, 2020 3:42 PM
To: Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Lou Berger <[email-masked]<mailto:[email-masked]>>; 'BRUNGARD, DEBORAH A' <[email-masked]<mailto:[email-masked]>>; Vishnu Pavan Beeram <vbeeram=[email-masked]<mailto:vbeeram=[email-masked]>>
Subject: Re: [Teas-ns-dt] Brief meeting notes

Hi,

Yours Irrespectively,

John

- - - [SNIP] - - -

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Sep 2020 16:12:32 +0100

Sorry, I don’t disagree with this either.

If applicability to a use case can be covered in (say) 1.5 pages, I would roll it in. If it takes more effort it is a separate document.

A

From: Teas-ns-dt <[email-masked]> On Behalf Of Eric Gray
Sent: 25 September 2020 16:01
To: [email-masked]; 'John E Drake' <[email-masked]>; Jari Arkko <[email-masked]>; [email-masked]
Cc: 'Lou Berger' <[email-masked]>; 'BRUNGARD, DEBORAH A' <[email-masked]>; 'Vishnu Pavan Beeram' <[email-masked]>
Subject: Re: [Teas-ns-dt] Brief meeting notes

Eric,

Thanks,

Adrian

From: Teas-ns-dt <[email-masked] <mailto:[email-masked]> > On Behalf Of Eric Gray
Sent: 25 September 2020 15:26
To: John E Drake <jdrake=[email-masked] <mailto:jdrake=[email-masked]> >; Jari Arkko <jari.arkko=[email-masked] <mailto:jari.arkko=[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> ; Lou Berger <[email-masked] <mailto:[email-masked]> >; Vishnu Pavan Beeram <vbeeram=[email-masked] <mailto:vbeeram=[email-masked]> >; 'BRUNGARD, DEBORAH A' <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Teas-ns-dt] Brief meeting notes

--

Eric

From: Teas-ns-dt <[email-masked] <mailto:[email-masked]> > On Behalf Of John E Drake
Sent: Thursday, September 24, 2020 3:42 PM
To: Jari Arkko <jari.arkko=[email-masked] <mailto:jari.arkko=[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> ; Lou Berger <[email-masked] <mailto:[email-masked]> >; 'BRUNGARD, DEBORAH A' <[email-masked] <mailto:[email-masked]> >; Vishnu Pavan Beeram <vbeeram=[email-masked] <mailto:vbeeram=[email-masked]> >
Subject: Re: [Teas-ns-dt] Brief meeting notes

Hi,

Yours Irrespectively,

John

- - - [SNIP] - - -