Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

From: Lou Berger <[email-masked]>
Date: Mon, 13 Apr 2015 14:08:17 -0400

All,

This is start of a two week poll on making
draft-liu-teas-yang-te-topo-01 a TEAS working group document. Please
send email to the list indicating “yes/support” or “no/do not support”.
If indicating no, please state your technical reservations with the
document.  If yes, please also feel free to provide comments you'd like
to see addressed once the document is a WG document.

This document is the product of the TE Topology YANG Model Design Team
and the intent is for this work to serve as the foundation for the WG's
normal activities in this area, i.e., the document is the starting point
for the WG -- not a finished product.  The DT will be closed once we
have a WG document on this topic.

The poll ends Monday April 27th
Thanks,
Lou (and Pavan, who is a co-author)

---

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Mon, 13 Apr 2015 19:18:37 +0000

Support

Cheers

Matt

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: Monday, April 13, 2015 2:08 PM
> To: TEAS WG
> Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG
> document
> 
> All,
> 
> draft-liu-teas-yang-te-topo-01 a TEAS working group document. Please send
> email to the list indicating "yes/support" or "no/do not support".
> document.  If yes, please also feel free to provide comments you'd like to
> see addressed once the document is a WG document.
> 
> This document is the product of the TE Topology YANG Model Design Team and
> the intent is for this work to serve as the foundation for the WG's normal
> activities in this area, i.e., the document is the starting point for the
> WG -- not a finished product.  The DT will be closed once we have a WG
> document on this topic.
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 13 Apr 2015 20:36:42 +0100

Oh, yes please.

We keenly need to adopt a draft to provide a focus so that we don't proliferate
"competing" drafts. This one would be a good starting point and, once adopted,
the WG can work on making it say what they want.

Adrian

> > Sent: 13 April 2015 19:08
> > To: TEAS WG
> > Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document
> >
> > All,
> >
> > send email to the list indicating "yes/support" or "no/do not support".

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 13 Apr 2015 19:42:48 +0000

Yes, support

	Regards,
		Greg

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Monday, April 13, 2015 11:08 AM
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

This is start of a two week poll on making
draft-liu-teas-yang-te-topo-01 a TEAS working group document. Please send email to the list indicating "yes/support" or "no/do not support".
If indicating no, please state your technical reservations with the document.  If yes, please also feel free to provide comments you'd like to see addressed once the document is a WG document.

This document is the product of the TE Topology YANG Model Design Team and the intent is for this work to serve as the foundation for the WG's normal activities in this area, i.e., the document is the starting point for the WG -- not a finished product.  The DT will be closed once we have a WG document on this topic.

---

From: Santosh Esale <[email-masked]>
Date: Mon, 13 Apr 2015 23:52:49 +0000

Yes/Support.

-Santosh

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Tue, 14 Apr 2015 00:02:35 +0000

Hi Lou,

yes/support.

Regards,
Rakesh

On 2015-04-13 2:08 PM, "Lou Berger" <[email-masked]> wrote:

>send email to the list indicating ³yes/support² or ³no/do not support².

---

From: "Doolan, Paul (Coriant - US/Irving)" <[email-masked]>
Date: Tue, 14 Apr 2015 00:54:12 +0000

Hi Lou, 

> Please

yes/support

> If yes, please also feel free to provide comments you'd like

TEAS is "Traffic Engineering Architecture and Signaling". This is a draft for a YANG (and therefore) data model for 'TE topologies' which is but one part of the puzzle; it's necessary but not sufficient. Somewhere the TEAS WG needs to document a bunch of other things and,  until we dismiss the need or find another home for them, I suggest we address them in this document.

Amongst the things I think need covering are:  architectural background/framework; definition of terms; use cases; examples; performance considerations and relationship to/alignment  with work in other WG's/organizations (see Adrian's comment). I think we should also try hard to separate fundamental topology matters  from things like scheduling.

All that said this draft is a good place to start from.

pd

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 14 Apr 2015 01:12:06 +0000

Yes/support.

I would like see the changes mentioned and comments raised during IETF92 to be reflected either within this document or in another form. Paul already provides a good summary, besides the minutes, I see no need to repeat. :-)

Regards,
Xian

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 2015年4月14日 2:08
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 14 Apr 2015 01:43:09 +0000

Support.

Best Regards,
Huaimo

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Mach Chen <[email-masked]>
Date: Tue, 14 Apr 2015 02:27:50 +0000

Yes/support.

Best regards,
Mach

> Sent: Tuesday, April 14, 2015 2:08 AM
> To: TEAS WG
> If indicating no, please state your technical reservations with the document.
> If yes, please also feel free to provide comments you'd like to see addressed
> once the document is a WG document.
> 
> activities in this area, i.e., the document is the starting point for the WG -- not
> a finished product.  The DT will be closed once we have a WG document on
> this topic.
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 14 Apr 2015 06:06:45 +0000

Yes/support

BR
Daniele

> Sent: lunedì 13 aprile 2015 20:08
> To: TEAS WG
> and the intent is for this work to serve as the foundation for the WG's normal
> activities in this area, i.e., the document is the starting point for the WG --
> not a finished product.  The DT will be closed once we have a WG document
> on this topic.
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 14 Apr 2015 06:57:40 +0000

Hi Lou, 

Yes/support. Agree with what Adrian said: this document can be a good starting point.

Best regards,
Jie

> If indicating no, please state your technical reservations with the document.  If
> yes, please also feel free to provide comments you'd like to see addressed once
> the document is a WG document.
> 
> activities in this area, i.e., the document is the starting point for the WG -- not a
> finished product.  The DT will be closed once we have a WG document on this
> topic.
>

---

From: Paweł Brzozowski <[email-masked]>
Date: Tue, 14 Apr 2015 13:14:09 +0000

Yes/support. 

Regards,
Pawel

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Monday, April 13, 2015 2:08 PM
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Gert Grammel <[email-masked]>
Date: Tue, 14 Apr 2015 13:24:36 +0000

Support

Gert

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 13 April 2015 20:08
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Aihua Guo <[email-masked]>
Date: Tue, 14 Apr 2015 13:44:20 +0000

Yes, support.

Aihua

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Monday, April 13, 2015 2:08 PM
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 14 Apr 2015 14:00:59 +0000

Yes/support

Cheers,
Jeff

>>send
>>document.
>>normal

---

From: Leeyoung <[email-masked]>
Date: Tue, 14 Apr 2015 15:49:06 +0000

Yes/support.

My comment is that there should be a clear scope of this model to be applied to in the introduction section. Specifically, if this is a device model or a controller-controller model or both. It will be also good to describe what information element is being captured by the YANG model before jumping into the YANG model.  

Young

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Monday, April 13, 2015 1:08 PM
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Cyril Margaria <[email-masked]>
Date: Wed, 15 Apr 2015 14:02:59 -0400

Yes/Support

BR
Cyril

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 16 Apr 2015 04:20:41 +0000

Support! 

+1 to comments from Paul, Young and Xian

Regards,
Dhruv

> Sent: 13 April 2015 23:38
> To: TEAS WG
> activities in this area, i.e., the document is the starting point for the WG
> -- not a finished product.  The DT will be closed once we have a WG document
> on this topic.
>

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Thu, 16 Apr 2015 06:27:15 +0000

yes/support

~G

> On 13 Apr 2015, at 20:08, Lou Berger <[email-masked]> wrote:
> 
> All,
>

---

From: Dieter Beller <[email-masked]>
Date: Fri, 17 Apr 2015 20:59:44 +0200

Hi Lou, all,

yes/support - however, other than +1 to comments from Paul, Young,
and Xian, I would like to emphasize again what I commented

during the discussion in Dallas:

An introduction and a description of the information model (similar
to that in draft-ietf-i2rs-yang-network-topo-00) is needed in the

beginning of the document that explains the YANG data model. This
section would describe the relationships of the managed entities

(objects) and their attributes with references to the YANG model
tree structure and the model definition.

Moreover, for example in the context of ACTN, the model also needs
to describe how it can support an arbitrary number of TE

topology hierarchies.  I have seen that the
current model already provides some means for that, but this should
be described in

more detail and some examples should be provided.

Thanks,

Dieter

On 13.04.2015 20:08, Lou Berger wrote:

All,

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 20 Apr 2015 01:47:28 -0400

Dieter: 

Do you think the arbitrary number of TE topologies are arbitrary in a
hierarchy (1-N levels) or a wide topologies (1-N topologies). 

Sue 

From: Teas [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Friday, April 17, 2015 3:00 PM
To: Lou Berger; TEAS WG
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG
document

Hi Lou, all,

yes/support - however, other than +1 to comments from Paul, Young, and Xian,
I would like to emphasize again what I commented
during the discussion in Dallas:

An introduction and a description of the information model (similar to that
in draft-ietf-i2rs-yang-network-topo-00) is needed in the
beginning of the document that explains the YANG data model. This section
would describe the relationships of the managed entities
(objects) and their attributes with references to the YANG model tree
structure and the model definition.

Moreover, for example in the context of ACTN, the model also needs to
describe how it can support an arbitrary number of TE
topology hierarchies.  I have seen that the current model already provides
some means for that, but this should be described in
more detail and some examples should be provided.

Thanks,
Dieter

All,

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Mon, 20 Apr 2015 07:44:31 +0000

Hi Lou, all,

yes/support - however, I completely share comments from from Paul, Young, Xian, and Dieter.

Thanks

Sergio

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: lunedì 13 aprile 2015 20:08
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Loa Andersson <[email-masked]>
Date: Mon, 20 Apr 2015 15:23:57 +0200

Lou, et.al.,

I'm on the same page as Xian, support the adoption but there are
comments that need addressed.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Dieter Beller <[email-masked]>
Date: Tue, 21 Apr 2015 14:55:04 +0200

Hi Sue, all,

On 20.04.2015 07:47, Susan Hares wrote:

Dieter:

Do
you think the arbitrary number of TE topologies are
arbitrary in a hierarchy (1-N levels) or a wide topologies
(1-N topologies).

I am having some difficulties to really understand your question.
Let me try to clarify what I meant with my comment:

An abstract topology is according to my understanding composed of
links and vertices (nodes) and a vertex could be an abstract

node that represents an underlying abstract topology. This
underlying abstract topology can be decomposed again into links and

vertices (nodes) when you zoom into an abstract node.

Based on this principle of recursion, you can create a hierarchy
that can have arbitrary levels and a further decomposition is
possible

until you have not reached the physical node level (bottom of the
hierarchy).

I hope this helps.

Thanks,

Dieter

Sue

From:
Teas [mailto:[email-masked]] On Behalf Of Dieter
Beller

To: Lou Berger; TEAS WG

Subject: Re: [Teas] Poll on making
draft-liu-teas-yang-te-topo-01 a WG document

Hi Lou, all,

yes/support - however, other than +1 to comments from Paul,
Young, and Xian, I would like to emphasize again what I
commented

An introduction and a description of the information model
(similar to that in draft-ietf-i2rs-yang-network-topo-00) is
needed in the

beginning of the document that explains the YANG data model.
This section would describe the relationships of the managed
entities

(objects) and their attributes with references to the YANG
model tree structure and the model definition.

Moreover, for example in the context of ACTN, the model also
needs to describe how it can support an arbitrary number of
TE

topology hierarchies.  I have seen that the current
model already provides some means for that, but this should be
described in

Thanks,

Dieter

All,

Thanks,

Teas mailing list

[email-masked]

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 21 Apr 2015 13:38:38 +0000

Agree Dieter, and I think this maps to "hierarchy" in Susan' commets.

Actually, if my understanding of "wide topology" is correct (I guess it refers to the split of a big topology in smaller "domains") I think that we should consider both.

BR
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: martedì 21 aprile 2015 14:55
To: Susan Hares; 'Lou Berger'; 'TEAS WG'
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

Hi Sue, all,

Do you think the arbitrary number of TE topologies are arbitrary in a hierarchy (1-N levels) or a wide topologies (1-N topologies).
I am having some difficulties to really understand your question. Let me try to clarify what I meant with my comment:

An abstract topology is according to my understanding composed of links and vertices (nodes) and a vertex could be an abstract
node that represents an underlying abstract topology. This underlying abstract topology can be decomposed again into links and
vertices (nodes) when you zoom into an abstract node.

Based on this principle of recursion, you can create a hierarchy that can have arbitrary levels and a further decomposition is possible
until you have not reached the physical node level (bottom of the hierarchy).

I hope this helps.

Thanks,
Dieter

Sue

From: Teas [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Friday, April 17, 2015 3:00 PM
To: Lou Berger; TEAS WG
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

Hi Lou, all,

yes/support - however, other than +1 to comments from Paul, Young, and Xian, I would like to emphasize again what I commented
during the discussion in Dallas:

An introduction and a description of the information model (similar to that in draft-ietf-i2rs-yang-network-topo-00) is needed in the
beginning of the document that explains the YANG data model. This section would describe the relationships of the managed entities
(objects) and their attributes with references to the YANG model tree structure and the model definition.

Moreover, for example in the context of ACTN, the model also needs to describe how it can support an arbitrary number of TE
topology hierarchies.  I have seen that the current model already provides some means for that, but this should be described in
more detail and some examples should be provided.

Thanks,
Dieter

All,

Thanks,

Teas mailing list

[email-masked]<mailto:[email-masked]>

Teas mailing list

[email-masked]<mailto:[email-masked]>

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Tue, 21 Apr 2015 17:19:00 +0000

Hi Daniele, but I think Dieter's comment is in fact linked particularly to  requirement coming e.g. from ACTN, that surely, fall into the first case (hierarchy) not explicitly into the second, that, if understand your statement is more related to horizontal segmentation e.g. for scalability reason than to the possibility to present different level of topologies accordingly  to abstraction required policy.

Thanks
Sergio

From: Teas [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: martedì 21 aprile 2015 15:39
To: Beller, Dieter (Dieter); Susan Hares; 'Lou Berger'; 'TEAS WG'
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

BR
Daniele

Hi Sue, all,

I hope this helps.

Thanks,
Dieter

Sue

Hi Lou, all,

Thanks,
Dieter

All,

Thanks,

Teas mailing list

Teas mailing list

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 21 Apr 2015 17:32:12 +0000

Hi Sergio,

Exactly, correct! They are 2 orthogonal issues.
BR
Daniele

From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: martedì 21 aprile 2015 19:19
To: Daniele Ceccarelli; Beller, Dieter (Dieter); Susan Hares; 'Lou Berger'; 'TEAS WG'
Subject: RE: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

Thanks
Sergio

BR
Daniele

Hi Sue, all,

I hope this helps.

Thanks,
Dieter

Sue

Hi Lou, all,

Thanks,
Dieter

All,

Thanks,

Teas mailing list

Teas mailing list

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Apr 2015 22:12:26 -0400

Dieter: 

Thank you for answer the hierarchy question.   Your abstract topologies
reates arbitrary number of levels in a hierarchy. 

The question for the wide-topologies can be restated at Layer 3 as multiple
VPNS.   In IP, You can create 1-N number of VPNs.  This is n-wide
topologies. Does this fit into your abstract topologies? 

Sue 

From: Dieter Beller [mailto:[email-masked]] 
Sent: Tuesday, April 21, 2015 8:55 AM
To: Susan Hares; 'Lou Berger'; 'TEAS WG'
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG
document

Hi Sue, all,

Dieter: 

I am having some difficulties to really understand your question. Let me try
to clarify what I meant with my comment:

An abstract topology is according to my understanding composed of links and
vertices (nodes) and a vertex could be an abstract
node that represents an underlying abstract topology. This underlying
abstract topology can be decomposed again into links and
vertices (nodes) when you zoom into an abstract node.

Based on this principle of recursion, you can create a hierarchy that can
have arbitrary levels and a further decomposition is possible
until you have not reached the physical node level (bottom of the
hierarchy).

I hope this helps.

Thanks,
Dieter

Sue 

Hi Lou, all,

Thanks,
Dieter

All,

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Apr 2015 22:13:54 -0400

Daniele: 

You are correct.  Dieter has given the hierarchy.    The wide topologies is
the split of the bigger topology into smaller domains (in layer 3 VPNs).  

I also think we should consider both. 

Sue 

From: Daniele Ceccarelli [mailto:[email-masked]] 
Sent: Tuesday, April 21, 2015 9:39 AM
To: Dieter Beller; Susan Hares; 'Lou Berger'; 'TEAS WG'
Subject: RE: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG
document

Agree Dieter, and I think this maps to “hierarchy” in Susan’ commets.

Actually, if my understanding of “wide topology” is correct (I guess it
refers to the split of a big topology in smaller “domains”) I think that we
should consider both.

BR
Daniele

Hi Sue, all,

Dieter: 

I hope this helps.

Thanks,
Dieter

Sue 

Hi Lou, all,

Thanks,
Dieter

All,

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Apr 2015 22:52:51 -0400

+1 to Loa and Xian's comments.

Sue

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Monday, April 20, 2015 9:24 AM
To: [email-masked]
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG
document

Lou, et.al.,

I'm on the same page as Xian, support the adoption but there are comments
that need addressed.

/Loa

On 2015-04-14 03:12, Zhangxian (Xian) wrote:
> Yes/support.
>
> I would like see the changes mentioned and comments raised during
> IETF92 to be reflected either within this document or in another form.
> Paul already provides a good summary, besides the minutes, I see no
> need to repeat. :-)
>
> Regards,
> Xian
>
> document.  If yes, please also feel free to provide comments you'd
> like to see addressed once the document is a WG document.
>
> and the intent is for this work to serve as the foundation for the
> WG's normal activities in this area, i.e., the document is the
> starting point for the WG -- not a finished product.  The DT will be
> closed once we have a WG document on this topic.
>

--

---

From: Dieter Beller <[email-masked]>
Date: Wed, 22 Apr 2015 11:33:02 +0200

+1 that we should consider both

Thanks,

Dieter

On 22.04.2015 04:13, Susan Hares wrote:

Daniele:

You
are correct.  Dieter has given the hierarchy.    The wide
topologies is the split of the bigger topology into smaller
domains (in layer 3 VPNs).

I
also think we should consider both.

Sue

From:
Daniele Ceccarelli
[mailto:[email-masked]]

To: Dieter Beller; Susan Hares; 'Lou Berger';
'TEAS WG'

Subject: RE: [Teas] Poll on making
draft-liu-teas-yang-te-topo-01 a WG document

Agree
Dieter, and I think this maps to “hierarchy” in Susan’
commets.

Actually,
if my understanding of “wide topology” is correct (I guess
it refers to the split of a big topology in smaller
“domains”) I think that we should consider both.

BR

Daniele

From:
Teas [mailto:[email-masked]]
On Behalf Of Dieter Beller

Hi
Sue, all,

Dieter:

Do
you think the arbitrary number of TE topologies are
arbitrary in a hierarchy (1-N levels) or a wide
topologies (1-N topologies).

I am having some difficulties to really
understand your question. Let me try to clarify what I meant
with my comment:

An abstract topology is according to my understanding
composed of links and vertices (nodes) and a vertex could be
an abstract

node that represents an underlying abstract topology. This
underlying abstract topology can be decomposed again into
links and

Based on this principle of recursion, you can create a
hierarchy that can have arbitrary levels and a further
decomposition is possible

until you have not reached the physical node level (bottom
of the hierarchy).

I hope this helps.

Thanks,

Dieter

Sue

From:
Teas [mailto:[email-masked]]
On Behalf Of Dieter Beller

To: Lou Berger; TEAS WG

Hi Lou, all,

Moreover, for example in the context of ACTN, the model also
needs to describe how it can support an arbitrary number
of TE

topology hierarchies.  I have seen that the current
model already provides some means for that, but this should
be described in

Thanks,

Dieter

All,

Thanks,

Teas mailing list

[email-masked]

Teas mailing list

[email-masked]

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 22 Apr 2015 13:08:31 +0000

Sue,

I think you are exactly right. The model supports arbitrary number of TE topologies. Some of them are bound  in hierarchies. There could be multiple independent hierarchies.
For example, topologies cooked by provider on per- client or VPN is an example of independent topologies. Topology overlay/underlay relationships form topology hierarchies. For example, a topology cooked for a particular client (overlay) is supported by provider native topology (underlay), and this is an example of a hierarchy.

Cheers,
Igor

From: Teas [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, April 21, 2015 10:12 PM
To: 'Dieter Beller'; 'Lou Berger'; 'TEAS WG'
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

Dieter:

Thank you for answer the hierarchy question.   Your abstract topologies reates arbitrary number of levels in a hierarchy.

The question for the wide-topologies can be restated at Layer 3 as multiple VPNS.   In IP, You can create 1-N number of VPNs.  This is n-wide topologies. Does this fit into your abstract topologies?

Sue

Hi Sue, all,

I hope this helps.

Thanks,
Dieter

Sue

Hi Lou, all,

Thanks,
Dieter

All,

Thanks,

Teas mailing list

Teas mailing list

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Wed, 22 Apr 2015 13:51:35 +0000

Hi Igor,
while we all agree in the needs of both type of topology requirements , I would just clarify that the Dieter's comment, that I have shared during my positive vote for "support" of the draft, is addressing "recursion" , and I do not see recursion is linked to "independent topologies" but only to hierarchies (overlay/underlay relationship in the draft).

Thanks
Cheers

Sergio

From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: mercoledì 22 aprile 2015 15:09
To: Susan Hares; Beller, Dieter (Dieter); 'Lou Berger'; 'TEAS WG'
Subject: Re: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

Sue,

Cheers,
Igor

Dieter:

Sue

Hi Sue, all,

I hope this helps.

Thanks,
Dieter

Sue

Hi Lou, all,

Thanks,
Dieter

All,

Thanks,

Teas mailing list

Teas mailing list

---

From: Fatai Zhang <[email-masked]>
Date: Sat, 25 Apr 2015 09:05:46 +0000

Yes/Support.

Best Regards

Fatai

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Tuesday, April 14, 2015 2:08 AM
To: TEAS WG
Subject: [Teas] Poll on making draft-liu-teas-yang-te-topo-01 a WG document

All,

---

From: Lou Berger <[email-masked]>
Date: Mon, 27 Apr 2015 09:51:06 -0400

All,
    This draft is adopted.

Authors,
    Please republish draft-liu-teas-yang-te-topo-01 as
draft-ietf-teas-yang-te-topo-00 with the ONLY change being the name and
date.  Please publish any changes resulting from points raised during
adoption, and other changes per normal WG process, starting with
revision -01.

Thank you,
Lou