Subject: [Teas] "admin-group" in draft-ietf-teas-yang-te-04

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Mon, 26 Sep 2016 14:45:36 +0000

Hi all,

I try to understand this definition of draft-ietf-teas-yang-te-04:

     typedef admin-group {
       type binary {
         length 32;
       }
       description
         "Administrative group/Resource class/Color.";
     }

Is this definition correct? Or would this be "length 4"?

Both RFC 6020 and RFC 7950 define the length parameter of binary as follows: "The length of a binary value is the number of octets it contains."

As a result, this definition seems to imply a 32 octet value. Is this the intention?

Until draft-saad-teas-yang-te-01, the value apparently was uint32. What was the motivation for changing this in draft-saad-teas-yang-te-02?

Thanks a lot!

Michael

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Tue, 27 Sep 2016 04:04:08 +0000

Hi Michael,

Thanks for reporting this. You are right, since length is in octets, the correct one is 4. We will fix this in our next update.
BTW, the type admin-groups is a union for the classic 32-bits and extended admin groups (variable length multiple of 4-octets).

  typedef admin-groups {
    type union {
      type admin-group;
      type extended-admin-group;
    }
    description "TE administrative group derived type";
  }

Regards,
Tarek

On 2016-09-26, 10:45 AM, "Teas on behalf of Scharf, Michael (Nokia - DE)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,

         typedef admin-group {
           type binary {
             length 32;
           }
           description

    

    Thanks a lot!
    
    Michael
    
    _______________________________________________
    Teas mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/teas