Subject: [Teas] Basic question on YANG Data Model for TE Topologies

From: Glen Kent <[email-masked]>
Date: Tue, 1 Nov 2016 08:42:59 +0530

Hi WG members,

I am new to TEAS and am trying to understand the need to standardise the
YANG model for the TE topologies?

Isn't how I model a TE network an internal issue to a system? Why do all
vendors need a standardised way to model the TE networks. Its not something
thats exchanged between two different vendors. Can somebody help me here?

Glen

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 1 Nov 2016 03:42:24 +0000

Hi, Glen,

       Welcome, ☺.

       The traffic engineering database maintained by a controller is indeed an internal matter, so I agree with you it is probably not subject to standardization. However,  a customer definitely wants a common way to extract/view and even maybe impose certain topology information down to the network, irrespective of which vendor it picks, this is one of the motivations.  What is more,  there may be a hierarchical structure of controllers/orchestrators in many cases such as multi-domain, IP+optical scenario,  (see draft-ietf-teas-actn-framework<https://tools.ietf.org/wg/teas/draft-ietf-teas-actn-framework/> for more details), which controllers need to talk with each other.  A standard interface is preferred for some obvious reasons, for example: avoiding vendor/controller provider lock-in, easiness for adding value-added features on top of the standard capabilities etc..

My 2cents,
Xian

发件人: Teas [mailto:[email-masked]] 代表 Glen Kent
发送时间: 2016年11月1日 11:13
收件人: [email-masked]
主题: [Teas] Basic question on YANG Data Model for TE Topologies

Hi WG members,

I am new to TEAS and am trying to understand the need to standardise the YANG model for the TE topologies?

Isn't how I model a TE network an internal issue to a system? Why do all vendors need a standardised way to model the TE networks. Its not something thats exchanged between two different vendors. Can somebody help me here?

Glen