Subject: Re: [Teas] <draft-ietf-teas-p2mp-loose-path-reopt-05>: Review

From: Vishnu Pavan Beeram <[email-masked]>
Date: Sun, 2 Oct 2016 08:03:10 -0400

Rakesh, Hi!

Thanks for accommodating and addressing all suggestions/comments. I'm
satisfied with the latest version and I agree that it is ready to be taken
to the next step.

Couple of questions on the following change:

> Comment: What happens if all fragments don’t show up (lost messages) at a
> given recipient node? Can you add some text discussing what needs to be
> done in that case.
>
>
> *<end>*
> <RG> Added following text:
>
>    If a mid-point LSR does not receive all fragments of the
>    Path message (for example, when fragments are lost), it SHOULD
>    trigger re-evaluation of all S2L sub-LSPs of the P2MP-TE LSP
>    transiting on the node.
>
>
>    If an ingress node does not receive all
>    fragments of the PathErr message (for example, when fragments are
>    lost), it SHOULD trigger re-optimization of all S2L sub-LSPs of the
>    P2MP-TE LSP transiting on the mid-point node that had sent the
>    PathErr message.
>
>
When should a recipient node give up on waiting for more fragments? Use a
configurable timer? A statement or two clarifying this in the draft would
be useful.

If I understood the above text correctly, what the draft is saying is the
following:
"If all the fragments are not received within a stipulated amount of time,
the recipient node SHOULD behave the same way as it would when there are no
fragments". Is this interpretation correct?

Regards,
-Pavan

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Mon, 3 Oct 2016 12:45:22 +0000

Hi Pavan,

Thank you for the review comments. Please see inline..<RG> ..

From: Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>
Date: Sunday, October 2, 2016 at 8:03 AM
To: RAKESH GANDHI <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: <draft-ietf-teas-p2mp-loose-path-reopt-05>: Review

Rakesh, Hi!

Thanks for accommodating and addressing all suggestions/comments. I'm satisfied with the latest version and I agree that it is ready to be taken to the next step.

<RG> Great, thanks.

Comment: What happens if all fragments don’t show up (lost messages) at a given recipient node? Can you add some text discussing what needs to be done in that case.

*<end>*

When should a recipient node give up on waiting for more fragments? Use a configurable timer? A statement or two clarifying this in the draft would be useful.

<RG> Yes, using a configurable timer.  Sure, we can add text it in the next update.

If I understood the above text correctly, what the draft is saying is the following:
"If all the fragments are not received within a stipulated amount of time, the recipient node SHOULD behave the same way as it would when there are no fragments". Is this interpretation correct?

<RG> A node should receive at least one fragmented packet to trigger the above logic and should behave as if there were no fragmented message received for building the S2L list.

Thanks,
Rakesh

Regards,
-Pavan

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Thu, 6 Oct 2016 15:34:19 -0400

Rakesh, Hi!

Please see below.

Regards,
-Pavan

> <RG> Yes, using a configurable timer.  Sure, we can add text it in the

[VPB] You can add it in the next update along with other WG LC comments (if
any).

> <RG> A node should receive at least one fragmented packet to trigger the
> above logic and should behave as if there were no fragmented message
> received for building the S2L list.
>

[VPB] Please do add the above statement to the draft in the next update
(after the LC).

---

From: Rakesh Gandhi <[email-masked]>
Date: Fri, 7 Oct 2016 08:59:50 -0400

Hi Pavan,

Yes, Acking.

Thanks,
Rakesh

On Thu, Oct 6, 2016 at 3:34 PM, Vishnu Pavan Beeram <[email-masked]>
wrote:

> Rakesh, Hi!
>
> Please see below.
>
> Regards,
> -Pavan
>
> On Mon, Oct 3, 2016 at 8:45 AM, Rakesh Gandhi (rgandhi) <[email-masked]
> > wrote:
>
>>
>>
> [VPB] You can add it in the next update along with other WG LC comments
> (if any).
>
>>
>> "If all the fragments are not received within a stipulated amount of
>> time, the recipient node SHOULD behave the same way as it would when there
>> are no fragments". Is this interpretation correct?
>>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
>

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Mon, 24 Oct 2016 12:57:30 +0000

Hi Pavan,

Thank you for the review comments. Following revision should address these comments.

URL:            https://www.ietf.org/internet-drafts/draft-ietf-teas-p2mp-loose-path-reopt-07.txt
Htmlized:   https://tools.ietf.org/html/draft-ietf-teas-p2mp-loose-path-reopt-07
Diff:             https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-p2mp-loose-path-reopt-07

Thanks,
Rakesh

From: Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 6, 2016 at 3:34 PM
To: RAKESH GANDHI <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: <draft-ietf-teas-p2mp-loose-path-reopt-05>: Review
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, RAKESH GANDHI <[email-masked]<mailto:[email-masked]>>, Zafar Ali <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Resent-Date: Thursday, October 6, 2016 at 3:34 PM

Rakesh, Hi!

Please see below.

Regards,
-Pavan

On Mon, Oct 3, 2016 at 8:45 AM, Rakesh Gandhi (rgandhi) <[email-masked]<mailto:[email-masked]>> wrote:

[VPB] You can add it in the next update along with other WG LC comments (if any).

[VPB] Please do add the above statement to the draft in the next update (after the LC).

Thanks,
Rakesh

Regards,
-Pavan