Subject: [Teas] [email-masked] YANG module

From: Benoit Claise <[email-masked]>
Date: Mon, 5 Mar 2018 08:36:43 +0100

Dear authors,

Please correct the YANG module validation warnings.
See http://www.claise.be/IETFYANGPageCompilation.html
Many YANG modules depend on yours and face the same issue.

Regards, Benoit

---

From: Xufeng Liu <[email-masked]>
Date: Mon, 5 Mar 2018 18:06:00 +0000

Hi Tarek,

Wondering if you will have the time to check. For the two yangdum warnings, I have the fixes as attached. 

I think that the confd-c warnings are benign.

Thanks,
- Xufeng

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Monday, March 5, 2018 2:37 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [email-masked] YANG module
> 
> Dear authors,
> 
56c56
<   revision "2018-03-03" {
---
>   revision "2018-03-05" {
2099,2100c2099,2104
<     uses path-route-exclude-objects {
<       when "metric-type = 'te-types:path-metric-optimize-excludes'";
---
>     container explicit-route-exclude-objects {
>       when "../metric-type = "
>         + "'te-types:path-metric-optimize-excludes'";
>       description
>         "Container for the exclude route object list";
>       uses path-route-exclude-objects;
2102,2103c2106,2111
<     uses path-route-include-objects {
<       when "metric-type = 'te-types:path-metric-optimize-includes'";
---
>     container explicit-route-include-objects {
>       when "../metric-type = "
>         + "'te-types:path-metric-optimize-includes'";
>       description
>         "Container for the include route object list";
>       uses path-route-include-objects;
2211c2219,2220
<     container explicit-route-include-objects {
---
>     list route-object-include-object {
>       key index;
2213,2220c2222,2224
<         "Container for the include route object list";
<       list route-object-include-object {
<         key index;
<         description
<           "List of explicit route objects to be included
<            in path computation";
<         uses te-types:explicit-route-hop;
<       }
---
>         "List of explicit route objects to be included
>          in path computation";
>       uses te-types:explicit-route-hop;
2228c2232,2233
<     container explicit-route-exclude-objects {
---
>     list route-object-exclude-object {
>       key index;
2230,2237c2235,2237
<         "Container for the exclude route object list";
<       list route-object-exclude-object {
<         key index;
<         description
<           "List of explicit route objects to be excluded
<            in path computation";
<         uses te-types:explicit-route-hop;
<       }
---
>         "List of explicit route objects to be excluded
>          in path computation";
>       uses te-types:explicit-route-hop;

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Mon, 5 Mar 2018 20:22:51 +0000

Thanks Xufeng for reporting this. We've uploaded version 14 which addresses this warning.
For the confd-c warnings below, I'll try to followup with Benoit if thise could be addressed.

/[email-masked]:69: warning: the type leafref (defined at ./[email-masked]:69) is converted to 'string' when part of a union
./[email-masked]:73: warning: the type leafref (defined at ./[email-masked]:73) is converted to 'string' when part of a union

Regards,
Tarek

On 2018-03-05, 1:06 PM, "Xufeng Liu" <[email-masked]> wrote:

    Hi Tarek,

    
    Thanks,
    - Xufeng