Subject: [Teas] draft-lee-teas-te-service-mapping-yang-09

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 19 Jul 2018 19:08:49 +0000

Hi,

trying to continue the discussion on the service mapping yang model.
There are a couple of items that need further discussion.

  1.  Terminology - mapping vs binding

The scope of the draft is to MAP the service models and the TE models and one of the goals is to BIND a service against a TE tunnel to provide the service with the guaranteed KPIs/SLA/TE metric bound that only a TE tunnel can provide. Which term is more appropriate here? Mapping? Binding ? we are open to suggestions.

I'm borrowing the image below from a new draft under development that might be useful to better understand what is the mapping function, where it is and what are its inputs. Probably having the figure in this draft would improve readability?

  1.  Scope

The drafts implicitly states that this model only applies to the CMI interface. Such implication could be made explicit with an improvement of the text.

THanks

Daniele + authors

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 20 Jul 2018 12:34:03 +0000

Some questions inline [ms]...

Thanks

Michael

From: Teas [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, July 19, 2018 9:09 PM
To: TEAS WG ([email-masked]) <[email-masked]>
Subject: [Teas] draft-lee-teas-te-service-mapping-yang-09

Hi,

[ms] This figure is probably better than the ones currently used on the I-D. Yet, it is not clear to me how this figure relates to Section 5.5 and Figure 10 in draft-ietf-teas-actn-framework-15. For instance, operators could use network resources also from other operators, e.g., optical connectivity from another operator. Due to recursion, the CMI could play a role in the lower parts of the figure, no? Would the model then apply to all CMI in different layers inside the figure?

  1.  Scope

[ms] The I-D explicitly refers to L3SM, L2SM, etc., which are service models between customers and network operators. Indeed, a model that refers e.g. to L3SM and L2SM may be limited to customer-network operator communication.

[ms] But isn't the mapping (or binding) of service to tunnels is a generic concept that can apply basically on any technology or layer, and even recursively? So how would the mapping problem be modeled outside the CMI? Would there be a different YANG model for that?

Thanks

Michael

THanks

Daniele + authors