Subject: Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Tue, 8 Jan 2019 09:46:29 +0000

Hi Pavan, Lou, all,

Happy New Year!

Here's my reply to the poll: no/do not support

I have doubts whether interoperable SMP implementations are existing today in the data plane that justify the definition of GMPLS signaling extensions to support SMP.

Thanks,
Dieter

On 18.12.2018 15:07, Vishnu Pavan Beeram wrote:
All,

This is start of a *three* week poll on making
draft-he-teas-gmpls-signaling-smp a TEAS working group document.
Please send email to the list indicating "yes/support" or "no/do not
support". If indicating no, please state your reservations with the
document. If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.

The poll ends Jan 8th 2019 (extra week to account for the holidays).

Thanks,
Pavan and Lou

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Loa Andersson <[email-masked]>
Date: Tue, 8 Jan 2019 18:05:30 +0800

Pavan,

Yes/support!

/Loa

On 2018-12-18 22:07, Vishnu Pavan Beeram wrote:
> [email-masked]

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 8 Jan 2019 10:20:55 +0000

Hi Pavan, Lou, all,
Happy New Year to all !

"no/do not support".
About the document, I share Dieter’s perplexity on real interoperable deployment of SMP justifying the usage and extension of GMPLS signaling. (SMP already support APS data plane signaling for protection switching).
Thanks
Sergio

From: Teas <[email-masked]> On Behalf Of Beller, Dieter (Nokia - DE/Stuttgart)
Sent: Tuesday, January 8, 2019 10:46 AM
To: Vishnu Pavan Beeram <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Hi Pavan, Lou, all,

Happy New Year!

Thanks,
Dieter

Thanks,
Pavan and Lou

Teas mailing list

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 8 Jan 2019 14:03:17 +0000

Yes/Support

Yuji

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Tuesday, December 18, 2018 11:07 PM
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

All,

Thanks,
Pavan and Lou

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 8 Jan 2019 09:21:58 -0500

Sergio et all,

I support WG adoption. The draft talks about the advantages of SMP and the
relationship with APS.

Cheers,
Andy

On Tue, Jan 8, 2019 at 5:21 AM Belotti, Sergio (Nokia - IT/Vimercate) <
[email-masked]> wrote:

> Hi Pavan, Lou, all,
>
> Happy New Year to all !
>
>
>
> "no/do not support".
>
> About the document, I share Dieter’s perplexity on real interoperable
> deployment of SMP justifying the usage and extension of GMPLS signaling.
> (SMP already support APS data plane signaling for protection switching).
>
> Thanks
>
> Sergio
>
>
>
> *From:* Teas <[email-masked]> *On Behalf Of *Beller, Dieter (Nokia
> - DE/Stuttgart)
> *Sent:* Tuesday, January 8, 2019 10:46 AM
> *To:* Vishnu Pavan Beeram <[email-masked]>; TEAS WG <[email-masked]>
> *Cc:* TEAS WG Chairs <[email-masked]>
> *Subject:* Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp
>
>
>
> Hi Pavan, Lou, all,
>
> Happy New Year!
>
> I have doubts whether interoperable SMP implementations are existing today
> in the data plane that justify the definition of GMPLS signaling extensions
> to support SMP.
>
>
> Thanks,
> Dieter
>

---

From: Italo Busi <[email-masked]>
Date: Tue, 8 Jan 2019 16:54:18 +0000

yes/support

I take the opportunity to wish you  all an Happy New Year

Italo (as co-author)

From: Vishnu Pavan Beeram [mailto:[email-masked]]
Sent: martedì 18 dicembre 2018 15:07
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

All,

Thanks,
Pavan and Lou

---

From: "Hejia (Jia)" <[email-masked]>
Date: Wed, 9 Jan 2019 01:47:48 +0000

Hi Sergio,

The signaling extension in this draft is not used for APS purpose(data plane protocol for protection switching). It is used for provisioning of primary and secondary LSPs.

B.R.
Jia
发件人：Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>
收件人：Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>;Vishnu Pavan Beeram <[email-masked]>;TEAS WG <[email-masked]>
抄 送：TEAS WG Chairs <[email-masked]>
时间：2019-01-08 18:21:23
主 题：Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Hi Pavan, Lou, all,
Happy New Year to all !

"no/do not support".

Hi Pavan, Lou, all,

Happy New Year!

Thanks,
Dieter

Thanks,
Pavan and Lou

Teas mailing list

---

From: "Hejia (Jia)" <[email-masked]>
Date: Wed, 9 Jan 2019 02:38:44 +0000

Hi Dieter,

SMP standard is published as G.808.3 by ITU-T SG15. As far as I know, there are implementations in the industry. Besides, the draft is not to addess interoperability issue, but rather to define a new protection type that is used in the provisioning of primary and secondary LSPs in the SMP case.

B.R.
Jia
发件人：Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>
收件人：Vishnu Pavan Beeram <[email-masked]>;TEAS WG <[email-masked]>
抄 送：TEAS WG Chairs <[email-masked]>
时间：2019-01-08 17:46:54
主 题：Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Hi Pavan, Lou, all,

Happy New Year!

Thanks,
Dieter

Thanks,
Pavan and Lou

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 9 Jan 2019 08:27:21 +0000

Hi,

I agree with Jia and support the adoption of the draft. SMP is a standard, I don’t see any reason why we shouldn’t support it’s signaling.

BR

Daniele  

From: Teas <[email-masked]> On Behalf Of Hejia (Jia)
Sent: den 9 januari 2019 03:39
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Hi Dieter,

B.R.
Jia

发件人：Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked] <mailto:[email-masked]> >

收件人：Vishnu Pavan Beeram <[email-masked] <mailto:[email-masked]> >;TEAS WG <[email-masked] <mailto:[email-masked]> >

抄 送：TEAS WG Chairs <[email-masked] <mailto:[email-masked]> >

时间：2019-01-08 17:46:54

Hi Pavan, Lou, all,

Happy New Year!

Thanks,
Dieter

All,

Thanks,
Pavan and Lou

_______________________________________________
Teas mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/teas

---

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 9 Jan 2019 14:46:30 +0000

Hi Daniele, Jia, all,

the existence of an ITU-T standard (I was aware of that) does not mean that there are implementations. ITU-T defined many different protection schemes and some were
implemented and are supported by many equipment vendors (like 1+1 SNCP) while other protection schemes do not have the same support (those with extra traffic for example).
Re SMP, I have doubts and therefore I decided to vote no/do not support.

Thanks,
Dieter

On 09.01.2019 09:27, Daniele Ceccarelli wrote:
Hi,

BR

Daniele

From: Teas <[email-masked]><mailto:[email-masked]> On Behalf Of Hejia (Jia)
Sent: den 9 januari 2019 03:39
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]><mailto:[email-masked]>; Vishnu Pavan Beeram <[email-masked]><mailto:[email-masked]>; TEAS WG <[email-masked]><mailto:[email-masked]>
Cc: TEAS WG Chairs <[email-masked]><mailto:[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Hi Dieter,

B.R.
Jia
发件人：Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>
收件人：Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>;TEAS WG <[email-masked]<mailto:[email-masked]>>
抄 送：TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>
时间：2019-01-08 17:46:54
主 题：Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Hi Pavan, Lou, all,

Happy New Year!

Thanks,
Dieter

Thanks,
Pavan and Lou

Teas mailing list

---

From: Leeyoung <[email-masked]>
Date: Wed, 9 Jan 2019 15:56:30 +0000

Hi,

Yes/support.

Thanks.
Young

Sent: Tuesday, December 18, 2018 8:07 AM

All,

Thanks,
Pavan and Lou

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 8 Jan 2019 01:16:20 +0000

Yes/support

Regards,
Yuji

All,

Thanks,
Pavan and Lou

---

From: <[email-masked]>
Date: Mon, 14 Jan 2019 09:58:06 -0000

Hi All, 

Happy New Year!
	
Whoops, I know the poll closed but I have now read the document and thought I would add my 10 pence. 

Yes, I support. 

Having read through the I-D it seems to be defining a GMPLS-based SMP protection type for primary and secondary LSPs, considering the nature of  deployments and single vendor GMPLS environments, I can see the reluctance by some to not support the work. Personally, I think operators would use this type of mechanism and having an agreed well-defined IETF document that defines generic procedure would be helpful. 

BR, Dan.  

From: Teas <[email-masked]> On Behalf Of [email-masked]
Sent: 08 January 2019 01:16
To: TEAS WG <[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

Yes/support

Regards,
Yuji

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Tuesday, December 18, 2018 11:07 PM
To: TEAS WG <mailto:[email-masked]>
Cc: TEAS WG Chairs <mailto:[email-masked]>
Subject: [Teas] WG adoption poll - draft-he-teas-gmpls-signaling-smp

All,

Thanks,
Pavan and Lou

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Mon, 14 Jan 2019 05:58:02 -0500

All,
    The WG poll is closed. The concerns raised about the utility of this
extension are duly noted and are expected to get debated further as the
document progresses through the WG process. Based on the discussion so far,
the chairs don't see a good reason to not support this signaling extension.

Authors,
    Please republish draft-he-teas-gmpls-signaling-smp-00 as
draft-ietf-teas-gmpls-signaling-smp-00 with only the date and file name
changed.

- Pavan and Lou