Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 7 Jan 2019 03:41:17 +0000

Hi John,

Thanks for your comments.

We totally agree that scalability is an important thing to be considered in this work. In this aspect the description in current draft may be further polished to clarify the question you raised.

Once this document is adopted, we will develop some text (with the help of the WG) to scope enhanced VPN and its targeted services/tenants, so that it will help to explain the scaling of the work.

Best regards,
Jie

From: John E Drake [mailto:[email-masked]]
Sent: Monday, December 24, 2018 8:49 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: Igor Bryskin <[email-masked]>; Andrew G. Malis <[email-masked]>; [email-masked] <[email-masked]>; TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Comments inline
Sent from my iPhone

On Dec 24, 2018, at 5:46 AM, Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>> wrote:
Hi John,

Please see inline.

Best regards,
Jie

From: John E Drake [mailto:[email-masked]]
Sent: Friday, December 21, 2018 9:15 PM
To: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi,

Comment inline

Yours Irrespectively,

John

From: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, December 20, 2018 9:47 PM
To: John E Drake <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi John,

This draft does not suggest to allocate network resources to each individual VPN, only the VPNs which require particular level of SLA need to be integrated with underlay network resources, thus the number of enhanced VPN would be much less than the number of traditional overlay VPNs. Also it is possible that several VPNs with similar characteristics could be assigned with a set of aggregated resources,  and would share the same logical network.

[JD]  I don’t recall any such discussion in the draft.  Further, what is the maximum # of VPN+ instances supported in a given network such that that network does not implode?

[Jie] Such discussion happened during the presentation on previous IETF meetings, the current draft doesn't mandate the mapping of each individual VPN to dedicated logical network with resources allocated.

JD. I am going to compile a list of statements
that the draft makes that would lead one to a
different conclusion

That said, we could add some clarification in future version. The number of enhanced VPNs would depend on the number of services and customers which have such level of SLA requirement.

JD  So, you have no guidance to offer?

Best regards,
Jie

From: Teas [mailto:[email-masked]] On Behalf Of John E Drake
Sent: Thursday, December 20, 2018 11:14 PM
To: Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Igor,

I am not convinced that network slicing is a good idea because it assumes that logical networks w/ vastly different characteristics can be built out of a set of common network resources.  I am convinced that allocating network resources on a per-VPN basis is a bad idea because of the scaling issues.

Yours Irrespectively,

John

From: Igor Bryskin <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, December 20, 2018 9:55 AM
To: John E Drake <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi John,

Do you see any differences between a logical network and a network topology? Specifically, would you define network slices as produced by the same physical network sufficiently separated network topologies, each of which designed for specific class(es) of clients/overlays, with network resources available for the overlays limited by the resource pools allocated to the corresponding topologies? Another question: could network slices in your opinion be built hierarchically, i.e. higher level slices comprised of lower level ones?

Thanks,
Igor

From: Teas [mailto:[email-masked]] On Behalf Of John E Drake
Sent: Wednesday, December 19, 2018 11:46 AM
To: Andrew G. Malis; [email-masked]<mailto:[email-masked]>
Cc: TEAS WG Chairs; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Andy,

Network slicing is very different from what is described in this draft.  Network slicing envisions a small number of logical networks built using the same physical network, each of which is designed for a specific type of overlay network and a given VPN, depending upon its requirements, would be assigned to one or more of these network slices.  This draft, in contrast, is describing assignment of resources from the physical network to individual VPNs.

This is clearly absurd, and its characterization as a ‘scalable approach’ seems ill-considered.

This draft is also not a framework draft in any of the normally used definitions of that word (https://www.merriam-webster.com/dictionary/framework<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_framework&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=n9sCWh1x8RH083BAlFMqUZfK0blyu7AEqTYj5kopZ1I&s=o2aQfkCcHYaq6v8_OptqlhDqzYAgs1OiHS3JnOcuXtY&e=>).  Rather, I would characterize it as a set of semi-random musings.

Yours Irrespectively,

John

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of Andrew G. Malis
Sent: Tuesday, December 18, 2018 9:38 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Yes/support. This is a scalable approach for network slicing and enhanced VPNs that builds on a body of existing work.

Cheers,
Andy

On Mon, Dec 17, 2018 at 2:27 AM Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>> wrote:
All,

This is start of a *three* week poll on making
draft-dong-teas-enhanced-vpn a TEAS working group document.
Please send email to the list indicating "yes/support" or "no/do not
support". If indicating no, please state your reservations with the
document. If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.

The poll ends Jan 7th 2019 (extra week to account for the holidays).

Thanks,
Pavan and Lou
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=jfPzAk6KYMTzEcjux7ADyZR5qPrxoPYBDdzWSlkedyw&s=uXdPvThk8MvzKASbv-H0_ekBtni_GK-xqPKnIbJ6ek4&e=>

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Mon, 14 Jan 2019 05:44:02 -0500

All,
    The WG poll is closed. The scalability concerns raised during the poll
are duly noted and are expected to get discussed and debated thoroughly as
the document progresses through the WG process. Please note that the WG
adoption is just the beginning step in the process and that everyone in the
WG is welcome to weigh in with relevant contributions.

Authors,
    Please republish draft-dong-teas-enhanced-vpn-03 as
draft-ietf-teas-enhanced-vpn-00 with only the date and file name changed.

Thanks,
- Pavan and Lou