Subject: [Teas] RtgDir review: draft-ietf-teas-native-ip-scenarios-06

From: Loa Andersson <[email-masked]>
Date: Wed, 21 Aug 2019 21:04:43 +0200

Hello,

I have been selected as the Routing Directorate reviewer for this draft. 
The Routing Directorate seeks to review all routing or routing-related 
drafts as they pass through IETF last call and IESG review, and 
sometimes on special request. The purpose of the review is to provide 
assistance to the Routing ADs. For more information about the Routing 
Directorate, please see 
​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it 
would be helpful if you could consider them along with any other IETF 
Last Call comments that you receive, and strive to resolve them through 
discussion or by updating the draft.

Document: draft-ietf-teas-native-ip-scenarios-06
Reviewer: Loa Andersson
Review Date: date
IETF LC End Date: -
Intended Status: Informational

I have some minor concerns about this document that I think should be 
resolved before publication.
The concerns might in some cases be considered to be nits.

Comments:

The document describes scenarios in which CCDR, a technology that
combines the advantages or distributed and centralized control, could be
deployed.
The document also report on testing that has been performed with this
technology.

Major Issues:
No major issues found.

This a very interesting and valuable document that should be progressed 
to RFC.
It is refreshing to see an attempt to take advantage of distributed and 
centralized
control technologies and merge them together to a single whole.

Minor Issues:

I found the document well worth reading and think about, I also found
it somewhat hard to read, most of this probably depends on my
lack of expertise in the area.

However:

- I would consider doing a English language review, I don't think there
   is anything wrong, but the language is sometimes a bit heavy.
   Sometimes the choice of word could be discussed, in a specification
   I would rather expect "advantage" rather than "merit".

- I'd like to see exactly which specification that has been tested early
   in the document, preferably in the Introduction.

- I would expand the Abstract with one or two paragraphs.
   When I worked for larger companies, I used to say that the abstract
   should be written such that my immediate manager could read it and
   understand what it is all about.

   Since the abstract is supposed to self-contained and separable from
   the RFC (see RFC 7997) abbreviations in the abstract is to be avoided
   (or expanded).

- Abbreviations
   The RFC Editor Abbreviations list
   (https://www.rfc-editor.org/materials/abbrev.expansion.txt)
   gives a good idea on the rules that applies to abbreviations in RFCs.
   The basic rule is that an abbreviation is expanded the first time
   it is used.
   In this document there are abbreviations, for example in figures, that
   is not expanded, e.g. CR, SR, BRAS and IDC

  - I also have a small concern about listing "alternative" technologies
    (MPLS-TE, SR and DETNET) in the introduction, it is hard to come away
    without the impression that these technologies are seen as
    insufficient.
    Admittedly they do not solve the problem that CCDR solves, but they
    are well suited to solve the problem they were designed for.

Nits:

I'm unclear about nits vs. minor concerns for this document, and listed
everything as minor concerns.

/Loa

PS
I'm sorry that this review has been delayed.
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 26 Aug 2019 11:28:11 +0800

Hi, Loa:

Thanks for your review. We have updated the draft according to your comments.
The detail responses for your comments are inline below.

Best Regards.

Aijun Wang
China Telecom

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Loa Andersson
发送时间: 2019年8月22日 3:05
收件人: <[email-masked]>
抄送: [email-masked]; [email-masked]; TEAS WG
主题: [Teas] RtgDir review: draft-ietf-teas-native-ip-scenarios-06

Hello,

I have been selected as the Routing Directorate reviewer for this draft. 
The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

I have some minor concerns about this document that I think should be resolved before publication.
The concerns might in some cases be considered to be nits.

Comments:

The document describes scenarios in which CCDR, a technology that combines the advantages or distributed and centralized control, could be deployed.
The document also report on testing that has been performed with this technology.

Major Issues:
No major issues found.

This a very interesting and valuable document that should be progressed to RFC.
It is refreshing to see an attempt to take advantage of distributed and centralized control technologies and merge them together to a single whole.

Minor Issues:

I found the document well worth reading and think about, I also found it somewhat hard to read, most of this probably depends on my lack of expertise in the area.

However:

【Aijun Wang】: Have done some changes. We are also seeking one Native English speaker to polish it again.  

- I'd like to see exactly which specification that has been tested early
   in the document, preferably in the Introduction.
【Aijun Wang】: Add some sentences for the application of existing technologies.

【Aijun Wang】: Done

- Abbreviations

【Aijun Wang】: Have done some changes. Point out mainly that the alternative technologies are not suitable for the Native IP scenarios that described in this draft. This is the main motivation for us to introduce the solution that described in https://datatracker.ietf.org/doc/draft-ietf-teas-pce-native-ip/ and https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-extension-native-ip/

Nits:

I'm unclear about nits vs. minor concerns for this document, and listed everything as minor concerns.

/Loa

PS

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas