Subject: [Teas] I-D Action: draft-ietf-teas-yang-path-computation-08.txt

From: [email-masked]
Date: Tue, 10 Dec 2019 08:51:32 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Traffic Engineering Architecture and Signaling WG of the IETF.

        Title           : Yang model for requesting Path Computation
        Authors         : Italo Busi
                          Sergio Belotti
                          Victor Lopez
                          Anurag Sharma
                          Yan Shi
	Filename        : draft-ietf-teas-yang-path-computation-08.txt
	Pages           : 78
	Date            : 2019-12-10

Abstract:
   There are scenarios, typically in a hierarchical SDN context, where
   the topology information provided by a TE network provider may not
   be sufficient for its client to perform end-to-end path computation.
   In these cases the client would need to request the provider to
   calculate some (partial) feasible paths.

   This document defines a YANG data model for a stateless RPC to
   request path computation. This model complements the stateful
   solution defined in [TE-TUNNEL].

   Moreover this document describes some use cases where a path
   computation request, via YANG-based protocols (e.g., NETCONF or
   RESTCONF), can be needed.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teas-yang-path-computation/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teas-yang-path-computation-08
https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-path-computation-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-yang-path-computation-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Italo Busi <[email-masked]>
Date: Wed, 11 Dec 2019 08:28:07 +0000

We have just uploaded an updated version of the I-D addressing the comments received during the discussions @ IETF 106

The updated description of the proposed mechanism is provided in section 5.3 and the overview of the YANG Tree that would results from these proposed changes is provide in Appendix B

These are the changes to the YANG tree with respect to the previous proposal:

OLD
           +---- path-request* [request-id]
           |  +--- request-id                       uint32
           |  +---- (tunnel-information)?
           |  |  +----:(tunnel-association)
           |  |  |  +---- (tunnel-exist)?
           |  |  |  |  +----:(tunnel-ref)
           |  |  |  |  |  +---- tunnel-ref                 leafref
           |  |  |  |  +----:(tunnel-association-id)
           |  |  |  |    +---- tunnel-association-id      uint32
           |  |  +----:(tunnel-attributes)
           |  |  |  +---- tunnel-name?                    string
           |  |  |  +--- encoding?                        identityref
           |  |  |  +--- switching-type?                  identityref
           +---- tunnel-associations* [tunnel-association-id]
           |  +---- tunnel-association-id?           uint32
           |  +---- tunnel-name?                     string
           |  +---- encoding?                        identityref
           |  +---- switching-type?                  identityref

NEW

           +---- path-request* [request-id]
           |  +--- request-id                       uint32
           |  +---- (tunnel-attributes)?
           |  |  +----:(reference)
           |  |  |  +---- (tunnel-exist)?
           |  |  |  |  +----:(tunnel-ref)
           |  |  |  |  |  +---- tunnel-ref                 leafref
           |  |  |  |  +----:(tunnel-attributes-ref)
           |  |  |  |    +---- tunnel-attributes-ref       leafref
           |  |  |  +---- path-name?                       string
           |  |  +----:(values)
           |  |  |  +---- tunnel-name?                     string
           |  |  |  +--- encoding?                         identityref
           |  |  |  +--- switching-type?                   identityref
           +---- tunnel-attributes* [tunnel-name]
           |  +---- tunnel-name                      string
           |  +---- encoding?                        identityref
           |  +---- switching-type?                  identityref

Note that:
•       tunnel-ref is a leafref to the tunnel-name in the te-tunnel model
•       tunnel-attributes-ref is a leafref to the tunnel-name in the tunnel-attributes* list within the path-computation rpc request

Please review section 5.3 and Appendix B and let us know if you have any comments with this proposal.

Thanks

Sergio and Italo (on behalf of co-authors)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: martedì 10 dicembre 2019 17:52
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Teas] I-D Action: draft-ietf-teas-yang-path-computation-08.txt
>
>
> https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-path-computation-<https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-path-computation-08>
> 08
>