Subject: [Teas] teas-yang-te-types

From: tom petch <[email-masked]>
Date: Wed, 6 May 2020 09:04:21 +0000

Lou

I am looking at teas-yang-te-types-13 which is in the RFC-Editor queue and I do not want to believe what I am seeing.

The I-D contains two YANG modules and s.1.2 lists the modules and their prefixes and these module names and prefixes appear in s.4; but when I get to IANA Considerations, the prefix names are different.  The formatting is such that the prefix names are well hidden but I cannot make them match the modules.

I can see this causing every TEAS YANG module to fail.

Whoops.

Tom Petch
(who now ducks)

---

From: Lou Berger <[email-masked]>
Date: Wed, 06 May 2020 05:58:46 -0400

Tom

Nice catch - and thankfully there's still an opportunity to correct it!

Given the tooling infrastructure extracts the modules from the document's 
code sections, I'm not sure anything would actually fail due to this error, 
but the potential failures are certainly not a good thing - sounds like 
there's a new idnits feature here.

Authors,

Can you send the needed editorial changes  to IANA and the RFC Editor as 
well as to the list?

Thank you!

Lou

----------
On May 6, 2020 5:30:55 AM tom petch <[email-masked]> wrote:

> Lou
>
> I am looking at teas-yang-te-types-13 which is in the RFC-Editor queue and 
> I do not want to believe what I am seeing.
>
> The I-D contains two YANG modules and s.1.2 lists the modules and their 
> prefixes and these module names and prefixes appear in s.4; but when I get 
> to IANA Considerations, the prefix names are different.  The formatting is 
> such that the prefix names are well hidden but I cannot make them match the 
> modules.
>

---

From: tom petch <[email-masked]>
Date: Wed, 6 May 2020 10:17:45 +0000

From: Lou Berger <[email-masked]>
Sent: 06 May 2020 10:58
To: tom petch; TEAS WG Chairs

Tom

<tp>
Are you saying that no one uses IANA?  I thought that it was the foundation stone of YANG:-)

You may have seen some other comments of mine on the TEAS list and it seems that almost every TEAS YANG I-D gets IANA Considerations wrong putting in  a spurious ietf- or two.

Tom Petch

Authors,

Thank you!

Lou

----------

---

From: Tarek Saad <[email-masked]>
Date: Wed, 6 May 2020 14:23:03 +0000

Hi Tom,

Thanks for reporting this. In fact, this has already been corrected in the version that is in the RFC-Editor queue:
https://www.rfc-editor.org/authors/rfc8776.txt

Regards,
Tarek

On 5/6/20, 5:59 AM, "Teas on behalf of Lou Berger" <[email-masked] on behalf of [email-masked]> wrote:

    Tom

    Authors,

    Thank you!

    Lou

    ----------

    > I can see this causing every TEAS YANG module to fail.

    _______________________________________________
    Teas mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/teas

---

From: tom petch <[email-masked]>
Date: Thu, 7 May 2020 09:23:43 +0000

Lou

A change of topic and in your capacity as Chair, I note that a number of TEAS YANG I-D have six authors.  Is the AD ok with that?

Tom Petch
________________________________________
From: Lou Berger <[email-masked]>
Sent: 06 May 2020 10:58
To: tom petch; TEAS WG Chairs
Cc: TEAS WG ([email-masked]); [email-masked]
Subject: Re: teas-yang-te-types

Tom

Authors,

Thank you!

Lou

----------

---

From: Lou Berger <[email-masked]>
Date: Fri, 8 May 2020 07:04:25 -0400

This is an approved document.  For AD approval details you can see 
https://datatracker.ietf.org/doc/draft-ietf-teas-yang-te-types/ballot/

Lou