Subject: Re: [Teas] Status update on draft-ietf-teas-yang-l3-te-topo

From: tom petch <[email-masked]>
Date: Fri, 1 May 2020 10:56:40 +0000

From: Teas <[email-masked]> on behalf of Xufeng Liu <[email-masked]>
Sent: 21 April 2020 21:09

Status update on draft-ietf-teas-yang-l3-te-topo

Current Status:

  *  The updated revision -06 was posted on March 8, 2020:
     - Editorial changes.
  *  Corordinated with ietf-eth-te-topology and ietf-te-mpls-tp-topo
     for the augmentation of ietf-te-topology
     - ietf-te-topology does not need to be changed.
  *  Answered YANG doctor's review comments.

Open Issues:

  *   None.

<tp>

I started  to review this and have given up,  I cannot make sense of section 2, which I see as fundamental to understanding the I-D.
 Thus 
The YANG modulues  ietf-l3-te-topology ...
These two modules augment ietf-l3-te topology
No they don't!  This augments 
ietf-l3-unicast-topology
which is quite different and I find this confusion elsewhere in section two. Thus
Relationship  between Layer 3 Topology and TE Topology
Is that Layer 3 TE Topology or ietf-network-topology?  I think that many if not most  references to TE Topology are ambiguous and need clarifying - is the reference to Layer 3 TE Topology to  ietf-network-topology?

Some of the words are quirky and this website is determined not to let me put them into an e-mail but here goes.

modulues
topoology
moducment
Local ink

Tom Petch
Next Steps:

  *  Update the model to sync with the referenced models like draft-ietf-teas-yang-te-types if there are any changes.
  *  Welcome further reviews and suggestions.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 6 May 2020 19:22:31 -0400

Hi Tom,

Thanks for reviewing and sorry about the errors. We have posted an updated
version https://tools.ietf.org/html/draft-ietf-teas-yang-l3-te-topo-07, to
fix the errors about the augmentation description and to rephrase a couple
of sections to explain the relations between the related models and their
objects. Please let us know for anything that is not clear enough.

Thanks,
- Xufeng

On Fri, May 1, 2020 at 6:56 AM tom petch <[email-masked]> wrote:

> I started  to review this and have given up,  I cannot make sense of
> section 2, which I see as fundamental to understanding the I-D.
>  Thus
> Is that Layer 3 TE Topology or ietf-network-topology?  I think that many
> if not most  references to TE Topology are ambiguous and need clarifying -
> is the reference to Layer 3 TE Topology to  ietf-network-topology?
>
>   *  Update the model to sync with the referenced models like
> draft-ietf-teas-yang-te-types if there are any changes.

---

From: tom petch <[email-masked]>
Date: Fri, 8 May 2020 10:06:50 +0000

From: Xufeng Liu <[email-masked]>
Sent: 07 May 2020 00:22

Hi Tom,

Thanks for reviewing and sorry about the errors. We have posted an updated version https://tools.ietf.org/html/draft-ietf-teas-yang-l3-te-topo-07, to fix the errors about the augmentation description and to rephrase a couple of sections to explain the relations between the related models and their objects. Please let us know for anything that is not clear enough.

<tp>
Thanks for the update.  I now find s.2 s.2.1 clear but still struggle thereafter.  When you use layer 3 topology I find it ambiguous.  Is it layer 3 unicast topology or layer 3 te topology?  Thus in s.2.2.1
"When TE is enabled on a layer 3 topology .. " implies unicast
"congruent to the layer 3 topology .."
implies unicast
" the layer 3 topology will have a reference.."
 ah, no, must be layer 3 te topology
and this is the case throughout the rest of s.2.  I would like to see those references to layer 3 topology clarified, unicast or te.  You may want to say that layer 3 topology means ... while layer 3 ... topology will be spelt out in full or some such, I am easy, but do think that you need to use two distinct terms.  

As you may infer, I like to work top down, start with Abstract, then Introduction, then s.2 s.3 making sense of them before seeing if the module does what these sections say, so when I get stuck in s.2, I do not make it to details of the YANG module.

Tom Petch

Thanks,
- Xufeng

On Fri, May 1, 2020 at 6:56 AM tom petch <[email-masked]<mailto:[email-masked]>> wrote:
From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Sent: 21 April 2020 21:09

Current Status:

Open Issues:

  *   None.

<tp>

modulues
topoology
moducment
Local ink

Tom Petch
Next Steps:

Thanks,
- Xufeng