Subject: Re: [Teas] Status update on draft-ietf-teas-yang-sr-te-topo

From: tom petch <[email-masked]>
Date: Sat, 2 May 2020 11:16:26 +0000

Xufeng

I suggest you respin this I-D lest it expires in four days time.

Tom Petch

________________________________________
From: Teas <[email-masked]> on behalf of Xufeng Liu <[email-masked]>
Sent: 21 April 2020 21:10

Current Status:

  *  No update since IETF106 with last post on November 3, 2019.
  *  Answered YANG doctor's review comments.

Open Issues:

  *   None.

Next Steps:

  *  Update the model to sync with the referenced models like draft-ietf-spring-sr-yang if there are any changes.
  *  Welcome further reviews and suggestions.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng

---

From: tom petch <[email-masked]>
Date: Sun, 3 May 2020 15:45:59 +0000

And while you are at it ..

I don't understand quite a lot of this I-D.

In places it is explicit - MPLS data plane only.  Elsewhere it seems to claim to be for all SR as with the choice of prefix srt module name or with container SR or with the Abstract.  If this is MPLS data plane only. then I think that that needs spelling out in more places starting with the Abstract

2.1 references unicast-igp-topology - I know of no such module

2.7 Both IGP and BGP are supported ...is this BGP or BGP-LS?

feature msd
what if one IGP supports msd and another does not, say OSPFv2 does and OSPFv3 does not?  I don't know if that will happen or if it should be supported but, for once, YANG does have good support for such an approach

grouping sr topology type
a presence container for SR-MPLS - good
But how about 
sr node prefix attributes
a presence container which indicates SR is enabled and
sr link attributes
a presence container which indicates SR is enabled.
That is eight possible combinations of presence containers with eight different interpretations - I do not understand what they mean.  I do realise that the groupings have different roles.

RFC 7752 is the reference for BGP-LS but
needs to be in the I-D references.  And how about references for OSPFv2 etc?  Currently BGP-LS may be new and different and people want to know where to find it but in a year or two they may be wondering what OSPFv2 is or was.

Since you import sr-routing-cmn I cannot see how that can fail to be a Normative Reference - I cannot understand the I-D without it!

Tom Petch
________________________________________
From: Teas <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 02 May 2020 12:16
To: Xufeng Liu; TEAS WG
Subject: Re: [Teas] Status update on draft-ietf-teas-yang-sr-te-topo

Xufeng

Tom Petch

Current Status:

Open Issues:

  *   None.

Next Steps:

Thanks,
- Xufeng

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas