Subject: Re: [Teas] Status update on draft-ietf-teas-yang-l3-te-topo

From: Xufeng Liu <[email-masked]>
Date: Mon, 13 Jul 2020 10:29:25 -0400

Hi Tom,

Thanks for further reviewing. We have posted an updated version
https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-l3-te-topo-08.
Some rewording has been made, with the hope of making the document more
comprehensible. Please let us know for anything that is still confusing
(for such an unconventional modeling approach).

Best regards,
- Xufeng

On Fri, May 8, 2020 at 6:06 AM tom petch <[email-masked]> wrote:

> From: Xufeng Liu <[email-masked]>
> Sent: 07 May 2020 00:22
>
> Hi Tom,
>
> Thanks for reviewing and sorry about the errors. We have posted an updated
> version https://tools.ietf.org/html/draft-ietf-teas-yang-l3-te-topo-07,
> to fix the errors about the augmentation description and to rephrase a
> couple of sections to explain the relations between the related models and
> their objects. Please let us know for anything that is not clear enough.
>
> <tp>
> Thanks for the update.  I now find s.2 s.2.1 clear but still struggle
> thereafter.  When you use layer 3 topology I find it ambiguous.  Is it
> layer 3 unicast topology or layer 3 te topology?  Thus in s.2.2.1
> "When TE is enabled on a layer 3 topology .. " implies unicast
> "congruent to the layer 3 topology .."
> implies unicast
> " the layer 3 topology will have a reference.."
>  ah, no, must be layer 3 te topology
> and this is the case throughout the rest of s.2.  I would like to see
> those references to layer 3 topology clarified, unicast or te.  You may
> want to say that layer 3 topology means ... while layer 3 ... topology will
> be spelt out in full or some such, I am easy, but do think that you need to
> use two distinct terms.
>
[Xufeng]: Reworded. Please let us know if anything is confusing.

>
> As you may infer, I like to work top down, start with Abstract, then
> Introduction, then s.2 s.3 making sense of them before seeing if the module
> does what these sections say, so when I get stuck in s.2, I do not make it
> to details of the YANG module.
>
[Xufeng]: Thank you much for looking at it. We are striving to get your
review unstuck.

>
> Tom Petch
>
> Thanks,
> - Xufeng
>
> On Fri, May 1, 2020 at 6:56 AM tom petch <[email-masked]<mailto:
> [email-masked]>> wrote:
> From: Teas <[email-masked]<mailto:[email-masked]>> on
> behalf of Xufeng Liu <[email-masked]<mailto:
> [email-masked]>>
> Sent: 21 April 2020 21:09
>
>
> Status update on draft-ietf-teas-yang-l3-te-topo
>
> Current Status:
>
>   *  The updated revision -06 was posted on March 8, 2020:
>      - Editorial changes.
>   *  Corordinated with ietf-eth-te-topology and ietf-te-mpls-tp-topo
>      for the augmentation of ietf-te-topology
>      - ietf-te-topology does not need to be changed.
>   *  Answered YANG doctor's review comments.
>
> Open Issues:
>
>   *   None.
>
> <tp>
>
> I started  to review this and have given up,  I cannot make sense of
> section 2, which I see as fundamental to understanding the I-D.
>  Thus
> The YANG modulues  ietf-l3-te-topology ...
> These two modules augment ietf-l3-te topology
> No they don't!  This augments
> ietf-l3-unicast-topology
> which is quite different and I find this confusion elsewhere in section
> two. Thus
> Relationship  between Layer 3 Topology and TE Topology
> Is that Layer 3 TE Topology or ietf-network-topology?  I think that many
> if not most  references to TE Topology are ambiguous and need clarifying -
> is the reference to Layer 3 TE Topology to  ietf-network-topology?
>
> Some of the words are quirky and this website is determined not to let me
> put them into an e-mail but here goes.
>
> modulues
> topoology
> moducment
> Local ink
>
> Tom Petch
> Next Steps:
>
>
>   *  Update the model to sync with the referenced models like
> draft-ietf-teas-yang-te-types if there are any changes.
>   *  Welcome further reviews and suggestions.
>   *  Working Group Last Call after completing the above.
>
> Thanks,
> - Xufeng
>

---

From: tom petch <[email-masked]>
Date: Tue, 14 Jul 2020 11:34:51 +0000

Sent: 13 July 2020 15:29

Hi Tom,

Thanks for further reviewing. We have posted an updated version https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-l3-te-topo-08. Some rewording has been made, with the hope of making the document more comprehensible. Please let us know for anything that is still confusing (for such an unconventional modeling approach).

<tp>
I still find some of the terminology in this a challenge.

2.1   o  The multiplicity of such an association is: 0..1 to 0..1.
the following sentence suggests it is '1 to 0..1'

'associated to the objects in a coresponding TE topology'
'a' suggests there can be more than one which the YANG does not seem to
and 2.2.1 has 'the' not 'a'

in passing 'associated with' and 'corresponding'

'   Since ietf-te-topology augments ietf-network-topology defined in
[RFC8345] [I-D.ietf-teas-yang-te-topo], the referenced leaf
   /nw:networks/network/network-id identifies an instance of TE topology
   by inheritance. '
No and no!  ietf-network-topology is in one document so there should be
only one reference or else the module name is wrong or ....
And the referenced leaf does not identify an instance of TE Topology -
it identifies a network of any type.  As the next sentence makes clear,
this module has to ensure it is of the correct type and does so.

'   If the TE topology is congruent to the layer 3 unicast topology, the
   above reference can still be used to specified TE parameters defined
   in the TE topology model.
I do not understand.  What parameters? I do not see any and if they were
to be defined in TE Topology then they should not be specified here or
anywhere else.

s.2.2.2
'a node in the layer 3 TE topology may have a reference to the
corresponding TE node.'
perhaps clearer as
'a node in the layer  3 TE topology may have a reference to the
corresponding node in the TE Topology.'

s.2.2.3 s.2.2.4 ditto mutatis mutandi

More technically this I-D seems confused about prefix and inconsistent
elsewhere
.
module
     namespace "urn:ietf:params:xml:ns:yang:ietf-l3-te-topology";
     prefix "l3tet";
IANA
   name:         ietf-l3-te-topology
   namespace:    urn:ietf:params:xml:ns:yang:ietf-l3-te-topology
   prefix:       l3te

YANG
       container l3-te {
         presence "Indicates L3 TE Topology";

   augment /nw:networks/nw:network/nw:network-types
             /l3t:l3-unicast-topology:
     +--rw l3-te!

In passing, 'congruent with' in many places (at least in English
English)

s.3
The YANG data  model defined in this document ...
This document specifies two YANG modules ..
actually three!

Tom Petch

Best regards,
- Xufeng

On Fri, May 8, 2020 at 6:06 AM tom petch <[email-masked]<mailto:[email-masked]>> wrote:
From: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Sent: 07 May 2020 00:22

Hi Tom,

Thanks for reviewing and sorry about the errors. We have posted an updated version https://tools.ietf.org/html/draft-ietf-teas-yang-l3-te-topo-07, to fix the errors about the augmentation description and to rephrase a couple of sections to explain the relations between the related models and their objects. Please let us know for anything that is not clear enough.

<tp>
Thanks for the update.  I now find s.2 s.2.1 clear but still struggle thereafter.  When you use layer 3 topology I find it ambiguous.  Is it layer 3 unicast topology or layer 3 te topology?  Thus in s.2.2.1
"When TE is enabled on a layer 3 topology .. " implies unicast
"congruent to the layer 3 topology .."
implies unicast
" the layer 3 topology will have a reference.."
 ah, no, must be layer 3 te topology
and this is the case throughout the rest of s.2.  I would like to see those references to layer 3 topology clarified, unicast or te.  You may want to say that layer 3 topology means ... while layer 3 ... topology will be spelt out in full or some such, I am easy, but do think that you need to use two distinct terms.
[Xufeng]: Reworded. Please let us know if anything is confusing.

As you may infer, I like to work top down, start with Abstract, then Introduction, then s.2 s.3 making sense of them before seeing if the module does what these sections say, so when I get stuck in s.2, I do not make it to details of the YANG module.
[Xufeng]: Thank you much for looking at it. We are striving to get your review unstuck.

Tom Petch

Thanks,
- Xufeng

On Fri, May 1, 2020 at 6:56 AM tom petch <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>> wrote:
From: Teas <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>> on behalf of Xufeng Liu <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
Sent: 21 April 2020 21:09

Current Status:

Open Issues:

  *   None.

<tp>

I started  to review this and have given up,  I cannot make sense of section 2, which I see as fundamental to understanding the I-D.
 Thus
The YANG modulues  ietf-l3-te-topology ...
These two modules augment ietf-l3-te topology
No they don't!  This augments
ietf-l3-unicast-topology
which is quite different and I find this confusion elsewhere in section two. Thus
Relationship  between Layer 3 Topology and TE Topology
Is that Layer 3 TE Topology or ietf-network-topology?  I think that many if not most  references to TE Topology are ambiguous and need clarifying - is the reference to Layer 3 TE Topology to  ietf-network-topology?

Some of the words are quirky and this website is determined not to let me put them into an e-mail but here goes.

modulues
topoology
moducment
Local ink

Tom Petch
Next Steps:

  *  Update the model to sync with the referenced models like draft-ietf-teas-yang-te-types if there are any changes.
  *  Welcome further reviews and suggestions.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng