Subject: [Teas] Status update on draft-ietf-teas-enhanced-vpn-06

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 15 Jul 2020 07:09:33 +0000

Hi all, 

We've uploaded a new revision of draft-ietf-teas-enhanced-vpn-06. The changes in this version are: 

1. Some further clarification about the terms used in this document. 

2. In section 4.1, the architecture figure is updated to better reflect the relationship between overlay VPN service and underlay VTN. 

3. In section 5.4, some further descriptions about SR control plane are added. 

4. In section 5.6, text about the applicability of service data models is simplified, as the details will be covered in NS-DT, draft-wd-teas-transport-slice-yang, draft-king-teas-applicability-actn-slicing, etc. 

5. Some editorial changes. 

As always, review comments and feedbacks are appreciated. 

Best regards,
Jie 

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, July 13, 2020 4:47 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Teas] I-D Action: draft-ietf-teas-enhanced-vpn-06.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Traffic Engineering Architecture and Signaling
> WG of the IETF.
> 
>         Title           : A Framework for Enhanced Virtual Private
> Networks (VPN+) Service
>         Authors         : Jie Dong
>                           Stewart Bryant
>                           Zhenqiang Li
>                           Takuya Miyasaka
>                           Young Lee
> 	Filename        : draft-ietf-teas-enhanced-vpn-06.txt
> 	Pages           : 35
> 	Date            : 2020-07-13
> 
> Abstract:
>    This document describes the framework for Enhanced Virtual Private
>    Network (VPN+) service.  The purpose is to support the needs of new
>    applications, particularly applications that are associated with 5G
>    services, by utilizing an approach that is based on existing VPN and
>    Traffic Engineering (TE) technologies and adds features that specific
>    services require over and above traditional VPNs.
> 
>    Typically, VPN+ will be used to form the underpinning of network
>    slicing, but could also be of use in its own right providing enhanced
>    connectivity services between customer sites.
> 
>    It is envisaged that enhanced VPNs will be delivered using a
>    combination of existing, modified, and new networking technologies.
>    This document provides an overview of relevant technologies and
>    identifies some areas for potential new work.
> 
>    Comparing to traditional VPNs, It is not envisaged that quite large
>    numbers of VPN+ services will be deployed in a network.  In other
>    word, it is not intended that all existing VPNs supported by a
>    network will use VPN+ related techniques.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-teas-enhanced-vpn/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-teas-enhanced-vpn-06
> https://datatracker.ietf.org/doc/html/draft-ietf-teas-enhanced-vpn-06
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-enhanced-vpn-06
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 15 Jul 2020 08:33:12 +0000

Hi Jie,

Just a minor clarification. In section 3.2 there is a statement saying: 

"The usage of such  (referring to TSN and FlexE) underlying technologies for VPN+ service needs to be considered."

This is not mandating the usage of TNS and FlexE as underlaying technologies right?

Thanks
Daniele  

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Dongjie (Jimmy)
Sent: den 15 juli 2020 09:10
To: [email-masked]
Subject: [Teas] Status update on draft-ietf-teas-enhanced-vpn-06

Hi all, 

Best regards,
Jie 

> This draft is a work item of the Traffic Engineering Architecture and 
> Signaling WG of the IETF.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 15 Jul 2020 09:32:13 +0000

Hi Daniele, 

Thanks for your comment. Please see my reply inline:

> From: Daniele Ceccarelli [mailto:[email-masked]]
> Sent: Wednesday, July 15, 2020 4:33 PM
> To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
> Subject: RE: Status update on draft-ietf-teas-enhanced-vpn-06
> 
> Hi Jie,
> 

No, they are just listed as candidate technologies which may help to provide the required performance. 

Best regards,
Jie

> 2. In section 4.1, the architecture figure is updated to better reflect the
> relationship between overlay VPN service and underlay VTN.
> 
> 4. In section 5.6, text about the applicability of service data models is
> simplified, as the details will be covered in NS-DT,
> draft-wd-teas-transport-slice-yang, draft-king-teas-applicability-actn-slicing,
> etc.
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 15 Jul 2020 09:15:05 -0400

Given what you say, is the sentence needed?  It leads the reader to 
think these two things are more important.  (I am not objecting to the 
discussion under L2 technologies, just to this one sentence earlier.)

Yours,
Joel

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 16 Jul 2020 12:08:01 +0000

Hi Joel, 

Thanks for your comment. 

Actually the word "such" in that sentence refers to a set of candidate technologies in the underlay, TSN and FlexE are just two examples. We could rephrase that sentence to make it clear. How about: 

"The usage of such type of underlying technologies... "?

Best regards,
Jie

> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Wednesday, July 15, 2020 9:15 PM
> Subject: Re: [Teas] Status update on draft-ietf-teas-enhanced-vpn-06
> 
> Given what you say, is the sentence needed?  It leads the reader to think
> these two things are more important.  (I am not objecting to the discussion
> under L2 technologies, just to this one sentence earlier.)
> 
> Yours,
> Joel
> 
> >> "The usage of such  (referring to TSN and FlexE) underlying
> >> technologies for
> >> VPN+ service needs to be considered."
> >>
> >> 2. In section 4.1, the architecture figure is updated to better
> >> reflect the relationship between overlay VPN service and underlay VTN.
> >>
> >> 4. In section 5.6, text about the applicability of service data
> >> models is simplified, as the details will be covered in NS-DT,
> >> draft-wd-teas-transport-slice-yang,
> >> draft-king-teas-applicability-actn-slicing,
> >> etc.
> >>
> >>> This draft is a work item of the Traffic Engineering Architecture
> >>> and Signaling WG of the IETF.
> >>>

---

From: Joel Halpern Direct <[email-masked]>
Date: Thu, 16 Jul 2020 09:53:24 -0400

That proposed sentence would be better.  Still, I do not see that the 
sentence adds much value.  While I can live with the replacement, I 
think we would be better off simply removing the sentence.

Yours,
Joel

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 20 Jul 2020 13:35:22 +0100

Well, are we really trying to say...

"The usage of underlying L2 technologies (such as TSN and FlexE) for VPN+
services needs to be considered"

?

Adrian
-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Joel Halpern Direct
Sent: 16 July 2020 14:53
To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
Subject: Re: [Teas] Status update on draft-ietf-teas-enhanced-vpn-06

Yours,
Joel

On 7/16/2020 8:08 AM, Dongjie (Jimmy) wrote:
> Hi Joel,
> 
> Thanks for your comment.
> 
> Actually the word "such" in that sentence refers to a set of candidate
technologies in the underlay, TSN and FlexE are just two examples. We could
rephrase that sentence to make it clear. How about:
>>> No, they are just listed as candidate technologies which may help to
provide
>> the required performance.
>>>
>>> Best regards,
>>> Jie
>>>
>>>>
>>>> Thanks
>>>> Daniele
>>>>
>>>>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 21 Jul 2020 02:27:16 +0000

Hi Adrian, 

Yes that was the intent of the sentence. Thanks for the rephrasing, it looks more clear to me. 

Best regards,
Jie

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Monday, July 20, 2020 8:35 PM
> To: 'Joel Halpern Direct' <[email-masked]>; Dongjie (Jimmy)
> <[email-masked]>; [email-masked]
> Subject: RE: [Teas] Status update on draft-ietf-teas-enhanced-vpn-06
> 
> That proposed sentence would be better.  Still, I do not see that the sentence
> adds much value.  While I can live with the replacement, I think we would be
> better off simply removing the sentence.
> 
> Yours,
> Joel
> 
> discussion
> >>>> 3. In section 5.4, some further descriptions about SR control plane
> >>>> are
> >> added.
> >>>>
> >>>>>      Network (VPN+) service.  The purpose is to support the needs
> >>>>> of
> >> new
> >>>>>      applications, particularly applications that are associated
> >>>>> with
> 5G
> >>>>>      services, by utilizing an approach that is based on existing
> >>>>> VPN
> and
> >>>>> https://datatracker.ietf.org/doc/html/draft-ietf-teas-enhanced-vpn
> >>>>> -0
> >>>>> 6
> >>>>>