Subject: [Teas] Status update on draft-ietf-teas-yang-l3-te-topo

From: Xufeng Liu <[email-masked]>
Date: Thu, 12 Nov 2020 20:06:45 -0500

Current Status:

  *  Received further valuable comments from Tom Petch.
  *  Plan to post an updated version next week to address some review
comments from Tom.

Open Issues:

  *  Authors working on addressing Tom’s comments.

Next Steps:

  *  Follow-up with Tom and resolve comments.
  *  Welcome further reviews and suggestions.
  *  Keep coordinating with ietf-eth-te-topology and ietf-te-mpls-tp-topo
to ensure aligned model relations.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng

---

From: tom petch <[email-masked]>
Date: Tue, 24 Nov 2020 12:37:28 +0000

From: Teas <[email-masked]> on behalf of Xufeng Liu <[email-masked]>
Sent: 13 November 2020 01:06

Current Status:

  *  Received further valuable comments from Tom Petch.
  *  Plan to post an updated version next week to address some review comments from Tom.

<tp>

Thanks for that; clearer but I will take a while to get my mind around it.

On prefix, I think that l3tet is absolutely right (there are those who think that anything remotely te should  be texyz - not me)
I would take it one stage further and use l3-tet for topology type since it is a l3 te topology!

The references to te-topo and te-types need updating to the RFC - I do not know if there are technical changes, those I-D did so many somersaults that I lost track.

Your e-mail addresses in this I-D do match!

Since the IETF has abolished pagination, a bugbear of mine, then it behoves us to try and keep sections short.  I wonder if s.4.2 would be better split so that each augment is a separate section with perhaps a line or two of text saying e.g.
This augments the te link attributes with statistics and configuration when the network type is packet 
I do not think that that subtracts from legibility and does ease references thereto

Appendix B is more of a challenge to divide into sections!

Tom Petch

Open Issues:

Next Steps:

  *  Follow-up with Tom and resolve comments.
  *  Welcome further reviews and suggestions.
  *  Keep coordinating with ietf-eth-te-topology and ietf-te-mpls-tp-topo to ensure aligned model relations.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng