Subject: [Teas] Drafts on slicing in SR networks

From: Lou Berger <[email-masked]>
Date: Mon, 16 Nov 2020 06:25:29 -0500

Authors,

     Apologies for the lack of time to discuss your drafts in today's 
TEAS WG meeting.  I note that both cover overlapping topics, i.e., 
slicing in SR networks.  Would it be possible/reasonable for the authors 
to try to work together to come up with a joint proposal for 
consideration by the WG?  I do note that one document is solely on SR 
with the other covers SR and non-SR usage.

Thank you,

Lou (as Chair)

---

From: <[email-masked]>
Date: Tue, 17 Nov 2020 10:19:17 +0800 (CST)

Hi Lou,

Thanks for your suggestion.  Let's take a look at draft-bestbar-teas-ns-packet and look for cooperation.

Best Regards

Ran 

原始邮件

发件人：LouBerger
收件人：[email-masked];[email-masked];
抄送人：TEAS WG;
日 期 ：2020年11月16日 19:25
主 题 ：[Teas] Drafts on slicing in SR networks

Authors,

Thank you,

Lou (as Chair)

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Tarek Saad <[email-masked]>
Date: Tue, 17 Nov 2020 02:27:51 +0000

Thank you Lou for reaching out. 

Indeed, the solution that draft-bestbar-teas-ns-packet proposes is path control agnostic and covers SR and non-SR.
For SR-MPLS, draft-bestbar proposes a slice selector that can be in the form of a forwarding label (SR prefix-SID) or a global slice label that is carried in the MPLS packet.
The global slice label as a slice selector offers some advantages with respect to scale that we have mentioned in the draft in section 5.2.1.

When the selector is derived from the forwarding label (SR prefix-SID), we do see some overlap between the two drafts. We would like to point out that there are also some key differences with respect to slice identification and slice per-hop QoS enforcement. We also notice that the slice identifier "AII" used in draft-peng-teas-network-slicing associates a dedicated topology for each slice. Since it is possible to slice the same topology into multiple slices, we think it is preferrable to decouple the AII as a slice identifier from the underlying topology identifier.

That said, we would like to reach out to the authors of draft-peng-teas-network-slicing and figure out a way to converge.
We will report back the results of this discussion to the WG on the mailing list.

Regards,
Tarek (for authors of draft-bestbar-teas-ns-packet)

On 11/16/20, 6:25 AM, "Teas on behalf of Lou Berger" <[email-masked] on behalf of [email-masked]> wrote:

    Authors,

    Thank you,

    Lou (as Chair)

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 17 Nov 2020 09:12:22 +0000

[adding SPRING chairs]

Hi,

Regarding the overlap between these two drafts: slicing in SR networks, should this also be discussed in SPRING WG? 

Also note that in SPRING there are in progress documents related to network slicing, e.g. draft-ietf-spring-resource-aware-segments and draft-dong-spring-sr-for-enhanced-vpn. The authors are encouraged to review those SPRING documents and see if there is anything to be added to them. Thanks.

Best regards,
Jie

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of Tarek Saad
> Sent: Tuesday, November 17, 2020 10:28 AM
> To: Lou Berger <[email-masked]>; [email-masked];
> [email-masked]
> Cc: TEAS WG <[email-masked]>
> Subject: Re: [Teas] Drafts on slicing in SR networks
> 
> Indeed, the solution that draft-bestbar-teas-ns-packet proposes is path
> control agnostic and covers SR and non-SR.
> For SR-MPLS, draft-bestbar proposes a slice selector that can be in the form
> of a forwarding label (SR prefix-SID) or a global slice label that is carried in the
> MPLS packet.
> The global slice label as a slice selector offers some advantages with respect
> to scale that we have mentioned in the draft in section 5.2.1.
> 
> When the selector is derived from the forwarding label (SR prefix-SID), we do
> see some overlap between the two drafts. We would like to point out that
> there are also some key differences with respect to slice identification and
> slice per-hop QoS enforcement. We also notice that the slice identifier "AII"
> used in draft-peng-teas-network-slicing associates a dedicated topology for
> each slice. Since it is possible to slice the same topology into multiple slices,
> we think it is preferrable to decouple the AII as a slice identifier from the
> underlying topology identifier.
> 
> That said, we would like to reach out to the authors of
> draft-peng-teas-network-slicing and figure out a way to converge.
> On 11/16/20, 6:25 AM, "Teas on behalf of Lou Berger"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>     Authors,
>