Subject: [Teas] Fwd: [Lsr] WG Adoption Call for "IGP Flexible Algorithms (Flex-Algorithm) In IP Networks" - draft-bonica-lsr-ip-flexalgo-01

From: Dhruv Dhody <[email-masked]>
Date: Fri, 4 Dec 2020 11:57:32 +0530

Hi TEAS WG,

An interesting thread at LSR on 'what is TE' in the context of Flex Algo!

Two questions for us -
1. Should we include Flex Algo in RFC3272bis?
2. Should we expand on "partial TE" to accommodate these cases a little better?

Thoughts?

Thanks!
Dhruv

---------- Forwarded message ---------
From: Jeff Tantsura <[email-masked]>
Date: Fri, Dec 4, 2020 at 6:48 AM
Subject: Re: [Lsr] WG Adoption Call for "IGP Flexible Algorithms
(Flex-Algorithm) In IP Networks" - draft-bonica-lsr-ip-flexalgo-01
To: Tony Li <[email-masked]>, Robert Raszuk <[email-masked]>
Cc: lsr <[email-masked]>, Acee Lindem (acee) <acee=[email-masked]>

Anything else than IGP metric based SPT is considered TE. Looking
holistically - topology virtualization (or similar) could have been a
better name.

Cheers,
Jeff
On Dec 3, 2020, 4:25 PM -0800, Robert Raszuk <[email-masked]>, wrote:

Hi Tony,

The moment I hit "Send" I knew that this response may be coming as it
really depends what is one's definition of TE.

If indeed IGP TE is anything more then SPF - then sure we can call it
a TE feature.

However, while a very useful and really cool proposal, my point is to
make sure this is not oversold - that's all.

Best,
R.

On Fri, Dec 4, 2020 at 1:13 AM Tony Li <[email-masked]> wrote:
>
>
> Hi Robert,
>
>
> > However I really do not think that what Flexible Algorithm offers can be compared or even called as Traffic Engineering (MPLS or SR).
> >
> > Sure Flex Algo can accomplish in a very elegant way with little cost multi topology routing but this is not full TE. It can also direct traffic based on static or dynamic network preferences (link colors, rtt drops etc ... ),  but again it is not taking into account load of the entire network and IMHO has no way of accomplish TE level traffic distribution.
> >
> > Just to make sure the message here is proper.
>
>
> It’s absolutely true that FlexAlgo (IP or SR) has limitations. There’s no bandwidth reservation. There’s no dynamic load balancing. No, it’s not a drop in replacement for RSVP. No, it does not supplant SR-TE and a good controller. Etc., etc., etc….
>
> However I don’t feel that it’s fair to say that FlexAlgo can’t be called Traffic Engineering.  After all TE is a very broad topic. Everything that we’ve done that’s more sophisticated than simple SPF falls in the area of Traffic Engineering.  Link coloring and SRLG alone clearly fall into that bucket.
>
> I’ll grant you that it may not have the right TE features for your application, but that doesn’t mean that it’s not sufficient for some.  Please don’t mislead people by saying that it’s not Traffic Engineering.
>
> Regards,
> Tony
>
>
_______________________________________________
Lsr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsr

_______________________________________________
Lsr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsr

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 4 Dec 2020 11:41:02 -0000

Thanks Dhruv,

I'm certainly open to text suggestions in both cases. (I should post -09 because it has some text on SR policy that might help.)

AFAICS SR Flex Algo is actually two things:
- It is a recognition that you don't necessarily use SPF to determine the next hop when deriving a path.
- It is a way to indicate which algorithm should be used to determine the path for a given packet.
I would imagine that this could be described in, say, four lines of text.

The "partial TE" discussion is "interesting". My opinion (and it's only me, so please disagree) is that talk of "partial TE" is actually not helpful. That is because it gives the flavour of TE without actually being TE. It seems to me that it is better to name the components of TE (Policy, Path steering, Resource management) and, if a system does not use all of these components, the system should be called by the component names. Thus, vanilla SR is a Path Steering solution, etc.

Side note: you can construct a full TE system using SR provided you do:
- central management of resources
- traffic policing at the edges
- policy for traffic classification
- no non-SR traffic
- full explicit paths (or a lot of maths on how packets will flow between segment end points)

The problem with the SR discussion (as I see it) is that SR is a tool not a system. A tool is not TE, but a tool can be used to build a TE system. For example, RSVP-TE is not TE, but it is a tool that can be used to build an MPLS TE system.

Best,
Adrian

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: 04 December 2020 06:28
To: TEAS WG ([email-masked]) <[email-masked]>; [email-masked]
Subject: Fwd: [Lsr] WG Adoption Call for "IGP Flexible Algorithms (Flex-Algorithm) In IP Networks" - draft-bonica-lsr-ip-flexalgo-01

Hi TEAS WG,

Two questions for us -

Thoughts?

Thanks!
Dhruv

---------- Forwarded message ---------
From: Jeff Tantsura <[email-masked]>
Date: Fri, Dec 4, 2020 at 6:48 AM
Subject: Re: [Lsr] WG Adoption Call for "IGP Flexible Algorithms

Cheers,
Jeff

Hi Tony,

Best,
R.

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 4 Dec 2020 20:04:24 +0530

Hi Adrian,

On Fri, Dec 4, 2020 at 5:11 PM Adrian Farrel <[email-masked]> wrote:

> Thanks Dhruv,
>
> I'm certainly open to text suggestions in both cases. (I should post -09
> because it has some text on SR policy that might help.)
>
>
Thanks, -09 looks good.

> I would imagine that this could be described in, say, four lines of text.
Agreed.

> The "partial TE" discussion is "interesting". My opinion (and it's only
> me, so please disagree) is that talk of "partial TE" is actually not
> helpful. That is because it gives the flavour of TE without actually being
> TE. It seems to me that it is better to name the components of TE (Policy,
> Path steering, Resource management) and, if a system does not use all of
> these components, the system should be called by the component names. Thus,
> vanilla SR is a Path Steering solution, etc.
>
>
I agree with you regarding your description but I believe that we need to
talk about it in the bis document so that we have something concrete to
point to when discussing TE or not-TE.

We have two ways to provide some guidance in the document -

- Your suggestion to use TE component names, and not to call it TE when not
all components exist. My worry is this could become confusing to describe
when all but one component is not supported! SR Policy is not just policy
for instance.
- Give this a name: partial-TE, limited-TE, imperfect-TE, something under
the umbrella of TE...( I was hoping the WG would come up with a better term
:).
- Some other approach

It would be good to hear from the WG on this.

> The problem with the SR discussion (as I see it) is that SR is a tool not
> a system. A tool is not TE, but a tool can be used to build a TE system.
> For example, RSVP-TE is not TE, but it is a tool that can be used to build
> an MPLS TE system.
>

Again, +1 to all this!

BTW the discussion in LSR is about IP flex algo :)

Thanks!
Dhruv

> Subject: Fwd: [Lsr] WG Adoption Call for "IGP Flexible Algorithms
> > > However I really do not think that what Flexible Algorithm offers can
> be compared or even called as Traffic Engineering (MPLS or SR).
> > >
> > > Sure Flex Algo can accomplish in a very elegant way with little cost
> multi topology routing but this is not full TE. It can also direct traffic
> based on static or dynamic network preferences (link colors, rtt drops etc
> ... ),  but again it is not taking into account load of the entire network
> and IMHO has no way of accomplish TE level traffic distribution.
> > >
> > It’s absolutely true that FlexAlgo (IP or SR) has limitations. There’s
> no bandwidth reservation. There’s no dynamic load balancing. No, it’s not a
> drop in replacement for RSVP. No, it does not supplant SR-TE and a good
> controller. Etc., etc., etc….
> >
> > However I don’t feel that it’s fair to say that FlexAlgo can’t be called
> Traffic Engineering.  After all TE is a very broad topic. Everything that
> we’ve done that’s more sophisticated than simple SPF falls in the area of
> Traffic Engineering.  Link coloring and SRLG alone clearly fall into that
> bucket.
> >
> > I’ll grant you that it may not have the right TE features for your
> application, but that doesn’t mean that it’s not sufficient for some.
> Please don’t mislead people by saying that it’s not Traffic Engineering.
> >
> > Regards,
> > Tony
> >
> >

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 4 Dec 2020 15:48:18 -0000

Thanks Dhruv,

Yes, the place to work on “components of TE” and “partial TE” is section 1.2

A

From: Dhruv Dhody <[email-masked]> 
Sent: 04 December 2020 14:34
To: Farrel Adrian <[email-masked]>
Cc: TEAS WG <[email-masked]>; [email-masked]
Subject: Re: [Lsr] WG Adoption Call for "IGP Flexible Algorithms (Flex-Algorithm) In IP Networks" - draft-bonica-lsr-ip-flexalgo-01

Hi Adrian,

On Fri, Dec 4, 2020 at 5:11 PM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Thanks Dhruv,

Thanks, -09 looks good. 

Agreed. 

I agree with you regarding your description but I believe that we need to talk about it in the bis document so that we have something concrete to point to when discussing TE or not-TE. 

- Your suggestion to use TE component names, and not to call it TE when not all components exist. My worry is this could become confusing to describe when all but one component is not supported! SR Policy is not just policy for instance.  

- Give this a name: partial-TE, limited-TE, imperfect-TE, something under the umbrella of TE...( I was hoping the WG would come up with a better term :). 

- Some other approach

Again, +1 to all this! 

Thanks! 

Dhruv

Best,
Adrian

-----Original Message-----
From: Dhruv Dhody <[email-masked] <mailto:[email-masked]> > 
Sent: 04 December 2020 06:28
To: TEAS WG ([email-masked] <mailto:[email-masked]> ) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Fwd: [Lsr] WG Adoption Call for "IGP Flexible Algorithms (Flex-Algorithm) In IP Networks" - draft-bonica-lsr-ip-flexalgo-01

Hi TEAS WG,

Two questions for us -

Thoughts?

Thanks!
Dhruv

---------- Forwarded message ---------
From: Jeff Tantsura <[email-masked] <mailto:[email-masked]> >
Date: Fri, Dec 4, 2020 at 6:48 AM
Subject: Re: [Lsr] WG Adoption Call for "IGP Flexible Algorithms
(Flex-Algorithm) In IP Networks" - draft-bonica-lsr-ip-flexalgo-01
To: Tony Li <[email-masked] <mailto:[email-masked]> >, Robert Raszuk <[email-masked] <mailto:[email-masked]> >
Cc: lsr <[email-masked] <mailto:[email-masked]> >, Acee Lindem (acee) <acee=[email-masked] <mailto:[email-masked]> >

Cheers,
Jeff
On Dec 3, 2020, 4:25 PM -0800, Robert Raszuk <[email-masked] <mailto:[email-masked]> >, wrote:

Hi Tony,

Best,
R.

_______________________________________________
Lsr mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/lsr

_______________________________________________
Lsr mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/lsr

---

From: Tony Li <[email-masked]>
Date: Fri, 4 Dec 2020 08:00:29 -0800

> On Dec 3, 2020, at 10:27 PM, Dhruv Dhody <[email-masked]> wrote:
> 
> Two questions for us -

1. Yes, absolutely. You would be doing everyone a grave disservice to the industry to exclude options from what is attempting to be a comprehensive survey.

2. Is this constructive? No solution is going to provide everything to everyone. Not every network requires every possible feature. We should strive for clarity and let others judge their own needs.

Tony