Subject: [Teas] Éric Vyncke's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Wed, 20 Jan 2021 02:56:38 -0800

Éric Vyncke has entered the following ballot position for
draft-ietf-teas-pce-native-ip-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-teas-pce-native-ip/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document. I love the oxymoron approach
with "The solution combines the use of distributed routing protocols and a
centralized controller" ;-)

Please find below some non-blocking COMMENT points (but replies would be
appreciated), and some nits.

I hope that this helps to improve the document,

Regards,

-éric

== COMMENTS ==

Am I right when inferring that for each TE path there is a need to add one
loopback interface/address on every edge router + 1 BGP session ? How will it
scale ? Should there be a mention somewhere of this limitation (if confirmed) ?
I saw nothing in section 7.1 (scalability).

-- Abstract --
"it ... identifies needed extensions for the Path Computation Element
Communication Protocol (PCEP)", at first sight, it seems that it is an
incomplete document or a problem statement until reading the last sentence of
the introduction. May I suggest to change the sentence in the abstract in a
more assertive way ?

-- Section 3 --
Suggest to define the lo11 & others as the loopback interfaces in the first
bullet in the list.

I am far from being an expert in BGP and routing but isn't the link selection
still done *only* on the destination prefix ? I fail to see how the source
prefix is used in the forwarding decision (except for the return traffic).
I.e., there is no traffic isolation as PF11 can sent traffic to PF22 using the
link 'reserved' for PF12 to PF22.

-- Section 4 --
Suggest to add 'RR' in the R3 box.

== NITS ==

several s/large scale/large-scale/ ?

The usual way for acronyms is "Path Computation Client (PCC)" rather than "PCC
(Path Computation Client)"

---

From: "Aijun Wang" <[email-masked]>
Date: Thu, 21 Jan 2021 17:20:51 +0800

Hi, Eric:

Thanks for your review and comments.
Would you like to provide some suggestions for the abstract in a more assertive way?
Other response are inline below.[WAJ]

Thanks for your efforts.

Best Regards

Aijun Wang
China Telecom

-----Original Message-----
From: [email-masked] <[email-masked]> On Behalf Of éric Vyncke via Datatracker
Sent: Wednesday, January 20, 2021 6:57 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [Teas] Éric Vyncke's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thank you for the work put into this document. I love the oxymoron approach with "The solution combines the use of distributed routing protocols and a centralized controller" ;-)

Please find below some non-blocking COMMENT points (but replies would be appreciated), and some nits.

Regards,

-éric

== COMMENTS ==

Am I right when inferring that for each TE path there is a need to add one loopback interface/address on every edge router + 1 BGP session ? How will it scale ? Should there be a mention somewhere of this limitation (if confirmed) ?
I saw nothing in section 7.1 (scalability).
[WAJ] The TE number of path is proportional to the service types between one BGP pairs, not proportional to the prefixes/address pairs. Section 5 gives some clues for such considerations. 
Actually, in operator's network, we think there is not many different disjoint paths to be selected. Do you think so? 

-- Abstract --
"it ... identifies needed extensions for the Path Computation Element Communication Protocol (PCEP)", at first sight, it seems that it is an incomplete document or a problem statement until reading the last sentence of the introduction. May I suggest to change the sentence in the abstract in a more assertive way ?
[WAJ] OK. Would you like to provide the suggestions to let the reader to get the key points of this draft more quickly? 

-- Section 3 --
Suggest to define the lo11 & others as the loopback interfaces in the first bullet in the list.
[WAJ] OK, Done. Will update the first bullet as " Build two BGP sessions between R1 and R2, via the different loopback addresses on these routers (lo11 and lo12 are the loopback address of R1, lo21 and lo22 are the loopback address of R2). "  is this acceptable?

I am far from being an expert in BGP and routing but isn't the link selection still done *only* on the destination prefix ? I fail to see how the source prefix is used in the forwarding decision (except for the return traffic).
I.e., there is no traffic isolation as PF11 can sent traffic to PF22 using the link 'reserved' for PF12 to PF22.
[WAJ] Yes. For such isolation and traffic diverse, we should consider other mechanisms.  

-- Section 4 --
[WAJ] Done.

== NITS ==

[WAJ] Done

The usual way for acronyms is "Path Computation Client (PCC)" rather than "PCC (Path Computation Client)"
[WAJ] Has fixed.

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas