Subject: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

From: Vishnu Pavan Beeram <[email-masked]>
Date: Mon, 4 Jan 2021 08:02:28 -0600

All,

This is start of a two week poll on making
draft-nsdt-teas-ietf-network-slice-definition-02 a TEAS working group
document.
Please send email to the list indicating "yes/support" or "no/do not
support". If indicating no, please state your reservations with the
document. If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.

The poll ends January 18th.

Thanks,
Pavan and Lou

---

From: John E Drake <[email-masked]>
Date: Tue, 5 Jan 2021 14:48:49 +0000

Support.  It's a start.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas <[email-masked]> On Behalf Of Vishnu Pavan Beeram
Sent: Monday, January 4, 2021 9:02 AM
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

[External Email. Be cautious of content]

All,

draft-nsdt-teas-ietf-network-slice-definition-02 a TEAS working group document.

Thanks,
Pavan and Lou

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 5 Jan 2021 15:07:01 +0000

Yes/support.

There is still some work to be done, but this version is a good place for the WG to start.

Best regards,
Jie

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Monday, January 4, 2021 10:02 PM
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

All,

Thanks,
Pavan and Lou

---

From: Kiran Makhijani <[email-masked]>
Date: Tue, 5 Jan 2021 15:37:43 +0000

Support as co-author.
Thanks
Kiran

Sent: Monday, January 4, 2021 6:02 AM

All,

Thanks,
Pavan and Lou

---

From: Eric Gray <[email-masked]>
Date: Tue, 5 Jan 2021 10:40:31 -0500

Support.

> On Jan 5, 2021, at 9:48 AM, John E Drake <jdrake=[email-masked]> wrote:
> 
> Support.  It’s a start.
>  
> Yours Irrespectively,
>  
> John
>  
>  
> From: Teas <[email-masked] <mailto:[email-masked]>> On Behalf Of Vishnu Pavan Beeram
> To: TEAS WG <[email-masked] <mailto:[email-masked]>>
> Cc: TEAS WG Chairs <[email-masked] <mailto:[email-masked]>>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 5 Jan 2021 16:06:17 +0000

Support as co-author.

Cheers,
Reza

From: Teas <[email-masked]> on behalf of Vishnu Pavan Beeram <[email-masked]>
Date: Monday, January 4, 2021 at 9:02 AM
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

All,

Thanks,
Pavan and Lou

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 5 Jan 2021 09:54:54 -0800

Support as co-author

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 5 Jan 2021 12:27:07 -0800

Hi,
support adoption.

Regards,
Greg

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 5 Jan 2021 20:51:08 -0000

Like I said before Christmas, I think we should adopt this so that we can continue to polish it. It’s come a long way, and the author team are to be thanked for the progress made.

Thanks,

Adrian

Sent: 04 January 2021 14:02

All,

Thanks,
Pavan and Lou

---

From: Shunsuke Homma <[email-masked]>
Date: Wed, 6 Jan 2021 22:34:44 +0900

Support as co-author.

Best regards,

Shunsuke

---

From: Dieter Beller <[email-masked]>
Date: Wed, 6 Jan 2021 14:55:47 +0100

yes/support

Thanks,
Dieter

---

From: <[email-masked]>
Date: Wed, 6 Jan 2021 15:30:03 +0000

Hi all,

I support adoption.

Looking forward to resolve the issues that were reported on the list.

Cheers,
Med

De : Teas [mailto:[email-masked]] De la part de Vishnu Pavan Beeram
Envoyé : lundi 4 janvier 2021 15:02
À : TEAS WG <[email-masked]>
Cc : TEAS WG Chairs <[email-masked]>
Objet : [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

All,

Thanks,
Pavan and Lou

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 7 Jan 2021 00:36:46 +0000

Support

Regards,
Yuji

Sent: Monday, January 4, 2021 11:02 PM

All,

Thanks,
Pavan and Lou

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Thu, 7 Jan 2021 08:24:47 +0000

Hi Pavan, all,

Yes/support.

I think it is a good starting point for WG activity in the slicing topic.

Thanks
Sergio
Sent: Monday, January 4, 2021 3:02 PM

All,

Thanks,
Pavan and Lou

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 7 Jan 2021 08:41:14 +0000

Hi all,

As co-author, I support the adoption of the draft.

Best regards

Luis

De: Teas <[email-masked]> En nombre de Belotti, Sergio (Nokia - IT/Vimercate)
Enviado el: jueves, 7 de enero de 2021 9:25
Para: Vishnu Pavan Beeram <[email-masked]>; TEAS WG <[email-masked]>
CC: TEAS WG Chairs <[email-masked]>
Asunto: Re: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

Hi Pavan, all,

Yes/support.

Thanks
Sergio

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of Vishnu Pavan Beeram
Sent: Monday, January 4, 2021 3:02 PM
To: TEAS WG <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

All,

Thanks,
Pavan and Lou

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 7 Jan 2021 10:19:36 +0000

Hi all,

Yes/support.
The draft still needs work to be done but it provides the good foundation for the WG to work on.

BR
Daniele

Sent: den 4 januari 2021 15:02

All,

Thanks,
Pavan and Lou

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 11 Jan 2021 10:13:10 +0800

Hi All,

yes/support.
Please consider the following comments and questions:
1. Figure 3, does the NSC SBI only interact with network controllers? Can it talk with network entities directly?
2. Isolation is very important for IETF network slice. So the whole chapter 9 of this doc is about isolation. Do we need some SLIs and SLOs to describe the isolation requirements? are the isolation requirements indirect, whose SLOs can be derived from other SLOs such as latency or latency variation?

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Vishnu Pavan Beeram
Date: 2021-01-04 22:02
To: TEAS WG
CC: TEAS WG Chairs
Subject: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition
All,

Thanks,
Pavan and Lou

---

From: "Boris Khasanov" <[email-masked]>
Date: Mon, 11 Jan 2021 14:46:14 +0300

Hi all,

Yes, I support. Agree that it is a good foundation and needs to be proceed further.

SY,

Boris

Sent: Monday, January 4, 2021 5:02 PM

All,

Thanks,
Pavan and Lou

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Tue, 12 Jan 2021 03:21:24 +0000

Yes, support.
I think this topic has been discussed thoroughly and the document reflects most of the conclusion. This version could be the base of further work.

Best
Xuesong

发件人: Teas [mailto:[email-masked]] 代表 Vishnu Pavan Beeram
发送时间: 2021年1月4日 22:02
收件人: TEAS WG <[email-masked]>
抄送: TEAS WG Chairs <[email-masked]>
主题: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

All,

Thanks,
Pavan and Lou

---

From: <[email-masked]>
Date: Fri, 15 Jan 2021 10:08:29 +0800 (CST)

A little comment:

It seems that the definition document only support that the realization of IETF network slice is triggered by the consumer through the interface to NSC with specific SLO. I think it is not enough. Please see if it is needed to support the case for a network device (the headend) to explicitly request a slice on demand, and request a connection path within the specific slice on demand.

Regards,

PSF

原始邮件

发件人：VishnuPavanBeeram
收件人：TEAS WG;
抄送人：TEAS WG Chairs;
日 期 ：2021年01月04日 22:02
主 题 ：[Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

All,

 
 Thanks,
 Pavan and Lou

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 14 Jan 2021 21:18:21 -0500

Given that station in the case below is making a request, isn't it 
reasonable to assume that the request makes its way to the control 
systems, which then handle the itneraction with the underlay network 
through the mechanisms proposed in the definitions and framework drafts?

Yours,
Joel

On 1/14/2021 9:08 PM, [email-masked] wrote:
> 
> A little comment:
> 
> 
> It seems that the definition document only support that the realization 
> of IETF network slice is triggered by the consumer through the interface 
> to NSC with specific SLO. I think it is not enough. Please see if it is 
> needed to support the case for a network device (the headend) to 
> explicitly request a slice on demand, and request a connection path 
> within the specific slice on demand.
> 
> 
> Regards,
> 
> PSF
> 
> 
> 原始邮件
> *发件人：*VishnuPavanBeeram
> *收件人：*TEAS WG;
> *抄送人：*TEAS WG Chairs;
> *日 期 ：*2021年01月04日 22:02
> *主 题 ：**[Teas] WG adoption - 
> draft-nsdt-teas-ietf-network-slice-definition*

---

From: <[email-masked]>
Date: Fri, 15 Jan 2021 11:06:16 +0800 (CST)

Hi Joel,

Thanks for your attention.

Here, as the direction of the request is from south to north, do you think whether the definition document need to describe this case ?

If so, the request would be very different with that is discribed in the current document. In detailed, it is sent through technology-specific interface between headend and network controller, then the network contoller may continue to request a slice from NSC, or report the created slice to NSC through technology-specific interface.

Regards,

PSF

原始邮件

发件人：JoelM.Halpern
收件人：彭少富10053815;
抄送人：[email-masked];
日 期 ：2021年01月15日 10:18
主 题 ：Re: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

Yours,
Joel

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 15 Jan 2021 03:25:48 +0000

PSF,

If such a use-cases exist (I am not aware of any use-cases), the current draft address them. As Joel mentioned, if (for some use-cases) the network decides to create a new “IETF network slice” between various endpoints, this request will be find its way to the NBI of “IETF Network Slice Controller” (NSC) and whatever mentioned in draft is still valid. How this request gets to the NSC NBI is out-of-scope of the draft. Any method can be use.

IMO, such a request from network should not go from NSC SBI to NBI. It is not correct. The only information travel from SBI to NBI should be related to “IETF network slice” assurance (i.e. monitoring data from the network).

Cheers,

Reza

From: Teas <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Thursday, January 14, 2021 at 10:06 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

Hi Joel,

Regards,

PSF

原始邮件
发件人：JoelM.Halpern
收件人：彭少富10053815;
抄送人：[email-masked];
日 期 ：2021年01月15日 10:18

Yours,
Joel

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 15 Jan 2021 00:03:45 -0500

I support WG adoption.

This draft can be worked further to fine tune and as it stands I believe
it’s mature for adoption.

Thanks

Gyan

On Thu, Jan 14, 2021 at 10:26 PM Rokui, Reza (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> PSF,
>
>
>
> If such a use-cases exist (I am not aware of any use-cases), the current
> draft address them. As Joel mentioned, if (for some use-cases) the network
> decides to create a new “IETF network slice” between various endpoints,
> this request will be find its way to the NBI of “IETF Network Slice
> Controller” (NSC) and whatever mentioned in draft is still valid. How this
> request gets to the NSC NBI is out-of-scope of the draft. Any method can be
> use.
>
>
>
> IMO, such a request from network should not go from NSC SBI to NBI. It is
> not correct. The only information travel from SBI to NBI should be related
> to “IETF network slice” assurance (i.e. monitoring data from the network).
>
>
>
> Cheers,
>
>
>
> Reza
>
>
>
>
>
>
>
> *From: *Teas <[email-masked]> on behalf of "[email-masked]"
> <[email-masked]>
> *Date: *Thursday, January 14, 2021 at 10:06 PM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Teas] WG adoption -
> draft-nsdt-teas-ietf-network-slice-definition
>
>
>
>
>
> Hi Joel,
>
>
>
> Here, as the direction of the request is from south to north, do you think
> whether the definition document need to describe this case ?
>
> If so, the request would be very different with that is discribed in the
> current document. In detailed, it is sent through technology-specific
> interface between headend and network controller, then the network
> contoller may continue to request a slice from NSC, or report the created
> slice to NSC through technology-specific interface.
>
>
>
> Regards,
>
> PSF
>
>
>
> 原始邮件
>
> *发**件人：*JoelM.Halpern
>
> *收件人：*彭少富10053815;
>
> *抄送人：[email-masked];
>
> *日* *期* *：*2021年01月15日 10:18
>
> *主* *题* *：**Re: [Teas] WG adoption -
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 15 Jan 2021 12:41:53 -0800

+1 Joel

In distributed systems - the communication lines  have to follow the abstraction layers. Peer to peer commination between systems in different layers doesn’t scale and results in broken/ inconsistent end-state.

Cheers,
Jeff

---

From: Xufeng Liu <[email-masked]>
Date: Sat, 16 Jan 2021 12:12:15 -0500

yes/support.

Thanks,
- Xufeng

---

From: <[email-masked]>
Date: Mon, 18 Jan 2021 10:55:46 +0800 (CST)

Hi Reza,

Thank you for your reply.

One scenario may be that the network controller received the path computation request from the headend, and because the constraints are too strict, the network controller may create the corresponding slice independently, and then report the created slice to the NSC. Or, the network controller can also request NSC for a slice. Isn't that possible?

Regards,

PSF

原始邮件

发件人：Rokui,Reza(Nokia-CA/Ottawa)
收件人：彭少富10053815;[email-masked];[email-masked];
抄送人：Rokui, Reza (Nokia - CA/Ottawa);
日 期 ：2021年01月15日 11:26
主 题 ：Re: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

PSF,

 

 

Cheers,

Reza

 

 

Hi Joel,

Regards,

PSF

原始邮件

发件人：JoelM.Halpern

收件人：彭少富10053815;

抄送人：[email-masked];

日 期 ：2021年01月15日 10:18

 
 Yours,
 Joel

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 18 Jan 2021 11:43:54 +0530

Hi,

I support the adoption of this I-D. This I-D should now be in control of
the WG and we follow the normal WG process to further refine it as we work
on the framework, NBI, etc.  Thanks to the author team and DT for all the
work they put in.

Thanks!
Dhruv

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 18 Jan 2021 14:26:06 +0000

Hi PSF,

I do not think the scenario is a valid case. We need to distinguish between the “IETF Network Slice” define and its realization in the network. Your example is related to realization of an “IETF Network slice”.
The creation of IETF network slice is not triggered by path computation in the network. As described in the draft, the IETF network slice is technology agnostic and describes the connectivity between various endpoints.
Path computation is technology specific.

Reza

From: Teas <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Sunday, January 17, 2021 at 9:55 PM
To: Reza Rokui <[email-masked]>
Cc: Reza Rokui <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teas] WG adoption - draft-nsdt-teas-ietf-network-slice-definition

Hi Reza,

Regards,

PSF

原始邮件

Cheers,

Reza

Hi Joel,

Regards,

PSF

原始邮件
发件人：JoelM.Halpern
收件人：彭少富10053815;
抄送人：[email-masked];
日 期 ：2021年01月15日 10:18

Yours,
Joel

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 18 Jan 2021 11:58:40 -0800

Dear All,

The definitions and scope defined in this draft can be applicable to many
networks in a generic fashion, where IETF technologies are used  in various
network segments. I see tremendous work done by the Design Team with folks
who participated in multi-domain slicing BoFs prior to that  to get to this
point.

However, though the name "IETF Network slice" certainly distinguishes the
slicing work being done in many global organizations (viz., ITU-T GSTR
TN5G, ONF SDN, 3GPP 5G, ETSI ISGs NGP & NFV, GSMA, MEF LSO to name a few) ,
it creates bit complexity  when this is being applied and being referred in
E2E scenarios specific to a domain. I can give examples a bit later.

I also still see a lot of other documents in this group still refer to
Transport Network/Transport Network Slice. I presume the name will be
changed across all these documents in future.
I personally feel we (as IETF) can distinguish this important work and
applicability of this work being explicitly prepending 'IETF'. I shall
respond to the other thread here with my suggestion.

Last but not least, I support this work and help further to make this
better.

Cheers!
--
Uma C.

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 18 Jan 2021 12:15:48 -0800

>I personally feel we (as IETF) can distinguish this important work and
applicability of this work *without* being explicitly prepending 'IETF'.

--
Uma C.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 18 Jan 2021 15:26:40 -0500

I have observed multiple conversations where the absence of a qualifier 
on "slice" or "network slice" leaves folk participating with different 
understandings.

I don't care if the modifier is "IETF" as agreed.  or if we agree on 
another term.  folks objected to using "Transport" as the qualifier, for 
understandable reasons.

Yours,
Joel

On 1/18/2021 3:15 PM, Uma Chunduri wrote:
> On Mon, Jan 18, 2021 at 11:58 AM Uma Chunduri <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Dear All,
> 
>     The definitions and scope defined in this draft can be applicable to
>     many networks in a generic fashion, where IETF technologies are
>     used  in various network segments. I see tremendous work done by the
>     Design Team with folks who participated in multi-domain slicing BoFs
>     prior to that  to get to this point.
> 
>     However, though the name "IETF Network slice" certainly
>     distinguishes the slicing work being done in many global
>     organizations (viz., ITU-T GSTR TN5G, ONF SDN, 3GPP 5G, ETSI ISGs
>     NGP & NFV, GSMA, MEF LSO to name a few) , it creates bit complexity 
>     when this is being applied and being referred in E2E scenarios
>     specific to a domain. I can give examples a bit later.
> 
>     I also still see a lot of other documents in this group still refer
>     to Transport Network/Transport Network Slice. I presume the name
>     will be changed across all these documents in future.
>     I personally feel we (as IETF) can distinguish this important work
>     and applicability of this work being explicitly prepending 'IETF'. I
>     shall respond to the other thread here with my suggestion.
> 
>     Last but not least, I support this work and help further to make
>     this better.
> 
>     Cheers!
>     --
>     Uma C.
> 
> 
>     On Mon, Jan 4, 2021 at 6:02 AM Vishnu Pavan Beeram
>     <[email-masked] <mailto:[email-masked]>> wrote:
> 
>         All,
> 
>         [email-masked] <mailto:[email-masked]>
>         <https://www.ietf.org/mailman/listinfo/teas>
> 
>

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 18 Jan 2021 17:12:47 -0800

We (TEAS community)have spent a number of weeks trying to reach consensus on the naming, IETF came out as the least controversial and most acceptable by far and most.
I’d rather us not reopening this discussion and spending our efforts on other, not less important topics.

Cheers,
Jeff

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Tue, 19 Jan 2021 06:28:10 -0600

All,
    The WG poll is closed.

Authors,
    Please republish draft-nsdt-teas-ietf-network-slice-definition-02 as
draft-ietf-teas-ietf-network-slice-definition-00 with only the date and
file name changed.

Please continue to discuss the open items on the list (post adoption) and
bring them to closure.

Much Thanks to the authors, the design team and everyone else involved in
getting this document to this stage.

Regards,
-Pavan and Lou

---

From: <[email-masked]>
Date: Wed, 20 Jan 2021 09:37:27 +0800 (CST)

Hi Reza,

Thank you for your clarification.

Regards,

PSF

原始邮件

日 期 ：2021年01月18日 22:26

Hi PSF,

 

Reza

 

 

Hi Reza,

Regards,

PSF

原始邮件

日 期 ：2021年01月15日 11:26

PSF,

 

 

Cheers,

Reza

 

 

Hi Joel,

Regards,

PSF

原始邮件

发件人：JoelM.Halpern

收件人：彭少富10053815;

抄送人：[email-masked];

日 期 ：2021年01月15日 10:18

 
 Yours,
 Joel