Subject: [Teas] Magnus Westerlund's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

From: Magnus Westerlund via Datatracker <[email-masked]>
Date: Thu, 21 Jan 2021 06:24:46 -0800

Magnus Westerlund has entered the following ballot position for
draft-ietf-teas-pce-native-ip-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-teas-pce-native-ip/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I think this whole idea is based on the fact that you can actually have
multiple different prefix the traffic based on the network treatment it should
have. I think that has very limited applicability unless we are talking a
deployment where one target tunnels between in ingress and egress that does
traffic classification based on other aspects. Can this assumption about that
the IP traffic needs to use different IP addresses with different prefix to get
any differential treatment be expanded in the discussion?

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 22 Jan 2021 09:58:25 +0800

Hi, Magnus:

Please see the detail response inline [WAJ].
Wish it can address your concern.

Best Regards

Aijun Wang
China Telecom

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Thursday, January 21, 2021 10:25 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>; [email-masked]
Subject: Magnus Westerlund's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I think this whole idea is based on the fact that you can actually have multiple different prefix the traffic based on the network treatment it should have. I think that has very limited applicability unless we are talking a deployment where one target tunnels between in ingress and egress that does traffic classification based on other aspects. Can this assumption about that the IP traffic needs to use different IP addresses with different prefix to get any differential treatment be expanded in the discussion?
[WAJ] The logic of this document is the followings:
1. Different applications have different QoS requirement.
2. Different applications have different IP Prefix.
3. These different IP Prefix needs to find different path to pass within the network.
4. we use the different BGP sessions to advertise these different prefixes, manage the route the nexthop these BGP sessions, then influence the path of these application traffic.
5. Usage scenarios can be found in https://tools.ietf.org/html/rfc8735
6. Using tunnel between the ingress and egress are also possible accomplished under the procedures described in current documents.

Are the above short description address your concerns?