Subject: [Teas] Martin Duke's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Wed, 20 Jan 2021 14:49:11 -0800

Martin Duke has entered the following ballot position for
draft-ietf-teas-pce-native-ip-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-teas-pce-native-ip/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I am a bit confused that a design objective (sec 1) is “ No changes in a
router's forwarding behavior”. Isn’t that what this whole draft is about?

---

From: "Aijun Wang" <[email-masked]>
Date: Thu, 21 Jan 2021 14:31:56 +0800

Hi, Martin:

Thanks for your review.

“No changes in a router's forwarding behavior” is one of main objective of the solution that described in this draft, not the whole of this document.
The main reason is that we want to utilize the deployed/existing devices in large extent, thus focus mainly on the design/update of the control plane.

Is there any concern from you for such considerations?

Best Regards

Aijun Wang
China Telecom

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Thursday, January 21, 2021 6:49 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>; [email-masked]
Subject: Martin Duke's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I am a bit confused that a design objective (sec 1) is “ No changes in a router's forwarding behavior”. Isn’t that what this whole draft is about?

---

From: Martin Duke <[email-masked]>
Date: Thu, 21 Jan 2021 06:51:12 -0800

A new standard must involve some change in forwarding behavior; I guess you
mean that this draft simply combines existing pathways rather than
introducing an algorithm that it is entirely new?

I might ask this to be a bit clearer, but I certainly won't insist on
holding up the document over it, if it's clear to people knowledgable in
the field.

On Wed, Jan 20, 2021 at 10:33 PM Aijun Wang <[email-masked]> wrote:

> Hi, Martin:
>
> Thanks for your review.
>
> “No changes in a router's forwarding behavior” is one of main objective of
> the solution that described in this draft, not the whole of this document.
> The main reason is that we want to utilize the deployed/existing devices
> in large extent, thus focus mainly on the design/update of the control
> plane.
>
> Cc: [email-masked]; [email-masked];
> [email-masked]; Lou Berger <[email-masked]>; [email-masked]

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 22 Jan 2021 10:02:59 +0800

Hi, Martin:

From: [email-masked] <[email-masked]> 
Sent: Thursday, January 21, 2021 10:51 PM
To: Aijun Wang <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>
Subject: Re: Martin Duke's No Objection on draft-ietf-teas-pce-native-ip-15: (with COMMENT)

A new standard must involve some change in forwarding behavior; I guess you mean that this draft simply combines existing pathways rather than introducing an algorithm that it is entirely new?

[WAJ] The control plane of the router should be updated, but the data plane, specially the forwarding line card should be kept as its way. 

I might ask this to be a bit clearer, but I certainly won't insist on holding up the document over it, if it's clear to people knowledgable in the field.

[WAJ] Thanks a lot.

On Wed, Jan 20, 2021 at 10:33 PM Aijun Wang <[email-masked] <mailto:[email-masked]> > wrote:

Hi, Martin:

Thanks for your review.

Best Regards

Aijun Wang
China Telecom