Subject: Re: [Teas] New Version Notification for draft-wd-teas-ietf-network-slice-nbi-yang-03.txt

From: "Wubo (lana)" <[email-masked]>
Date: Mon, 12 Jul 2021 10:05:17 +0000

Hi Med,

Many thanks for your valuable review and comments. It is not the intention to ignore your suggestion. We will address the comments in the next revision.
Please see inline for the detailed answer with [Bo].

Best regards,
Bo

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2021年7月9日 20:06
收件人: Wubo (lana) <[email-masked]>; [email-masked]
抄送: [email-masked]
主题: RE: New Version Notification for draft-wd-teas-ietf-network-slice-nbi-yang-03.txt

Hi Bo, all,

Thank you for sharing this updated version. 

I'm supportive of this work, but I think we have a fundamental point to clarify: the document is currently missing data nodes that makes a slice, a slice! 

If we don't have such data nodes, the current module can be used to provision any form of connectivity. If we omit the "ns-" prefix, the module can be used for provisioning the connectivity of VoIP, multicast, etc. services. That’s actually good (as the applicability scope is wider) but we need also to think about network slice specifics.  

I have touched on some of these points in a review I shared with you back in 02/21, but unless I'm mistaken I don't think it was addressed:
https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-wd-teas-ietf-network-slice-nbi-yang-02-rev%20Med.doc 

Below an extract of my main comments: 

(1) A proposal to rationalize the discussion and ease progressing the spec is to clearly call that a network slice can be defined as a collection of at least three components: (1) connectivity component, (2) storage component, and (3) compute component. Having a provision for this since early stages of the model will ease grafting other components of an IETF slice easily, but also allows to avoid having a linear model.
[Bo]: I think this comment relates with the thread discussion of SFC and slicing. If my understanding is correct, we will add this when WG decides the SF aware network slice is within the scope of draft-ietf-teas-ietf-network-slices. But based on the discussion, I am afraid that someone would suggest a separate YANG model for this.

(2) For the connectivity part, the following items are important to cover as well:
* Traffic steering and advanced services: a slice may require the invocation of service functions (firewall, for example) in a given order. These policies have to be captured in the slice request. This is also useful when the customer request that its slice should not cross some networks or not span some regions. 
[Bo] Thanks. If I understand correctly, we will add SLE(Service Level Expectation)-specific steering policies applied per slice or per slice connection. Are there any other modelling suggestion?

* What to do for out of profile traffic: See the traffic conformance discussion in RFC7297. 
[Bo] I'm not sure I understand this. Do you mean that MTU attributes should be included?

* Activation means: may need to be included in a slice definition. Think about a slice that can be implemented as a VPN service. Such service may require the activation of a given routing protocol between a CE and a PE, otherwise the service won’t be offered. 
[Bo] I do agree. Current YANG model has a container of "ep-protocol" under "ns-endpoint", and also previous revision of the model had nodes of "BGP" and "static routing". But there is some arguments that some scenarios, for example, optical networks don't need these nodes. 

* Invocation means: Think about a multicast service that requires IGMP/MLD and so on.
[Bo] Is this similar with the previous one that you suggest to add IGMP/MLD nodes under "ns-endpoint"?

* Notification means: these are important for service assurance and fulfillment purposes.
[Bo] Yes. The current model includes network slice, endpoint, and connection status. Do you think there are other nodes that are necessary?

(3) The model seems to be inspired from the opsawg vpn I-Ds (network-access structure, for example). That's great and appreciated, but I would formalize that by using I-D.ietf-opsawg-vpn-common for data nodes such as connectivity-type, endpoint-role, status-params, etc. 
Bo: Yes. VPN is one of important technologies of realizing network slice. But there are some discussions that VPN is not mandatory to realize network slice, e.g. optical mechanism could be used.
Therefore we don't reuse the YANG nodes defined in I-D.ietf-opsawg-vpn-common.

(4) One last comment, I still don't get what is an "underlay IETF network".
Bo: Thanks for pointing this out. Will remove 'underlay'.
	
Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : Teas [mailto:[email-masked]] De la part de Wubo (lana) 
> Envoyé : vendredi 9 juillet 2021 12:18 À : [email-masked] Cc : 
> [email-masked] Objet : Re: [Teas] New Version Notification for 
> draft-wd-teas-ietf- network-slice-nbi-yang-03.txt
> 
> Dear WG and chairs,
> 
> The draft has been aligned with changes in the IETF Network Slice 
> framework WG I-D.
> 
> The Authors believe that it has been maturing with the inputs from the 
> WG, and can be evaluated as a candidate for WG adoption.
> Diff: https://www.ietf.org/rfcdiff?url2=draft-wd-teas-ietf-network-
> slice-nbi-yang-03
> 
> Best regards,
> Bo (on behalf of the co-authors)
> 
> 
> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]]
> 发送时间: 2021年7月9日 17:32
> 收件人: Wubo (lana) <[email-masked]>; Dhruv Dhody 
> <[email-masked]>; Liuyan Han <[email-masked]>; Reza 
> Rokui <[email-masked]>; Tarek Saad <[email-masked]>
> 主题: New Version Notification for draft-wd-teas-ietf-network-slice- 
> nbi-yang-03.txt
> 
> 
> A new version of I-D, draft-wd-teas-ietf-network-slice-nbi-yang-
> 03.txt
> has been successfully submitted by Bo Wu and posted to the IETF 
> repository.
> 
> Name:		draft-wd-teas-ietf-network-slice-nbi-yang
> Revision:	03
> Title:		A Yang Data Model for IETF Network Slice NBI
> Document date:	2021-07-09
> Group:		Individual Submission
> Pages:		45
> URL:            https://www.ietf.org/archive/id/draft-wd-teas-ietf-
> network-slice-nbi-yang-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-wd-teas-ietf-
> network-slice-nbi-yang/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-wd-teas-
> ietf-network-slice-nbi-yang
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-wd-teas-
> ietf-network-slice-nbi-yang-03
> 
> Abstract:
>    This document provides a YANG data model for the IETF Network Slice
>    Controller (NSC) Northbound Interface (NBI).  The model can be used
>    by a IETF Network Slice customer to request configuration, and
>    management IETF Network Slice services from the IETF NSC.
> 
> 
> 
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 13 Jul 2021 07:08:02 +0000

Hi Bo, 

Please see inline.

Cheers,
Med

> Envoyé : lundi 12 juillet 2021 12:05
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>;
> [email-masked]
> Objet : Re: [Teas] New Version Notification for draft-wd-teas-ietf-
> Many thanks for your valuable review and comments. It is not the
> intention to ignore your suggestion. We will address the comments in
> the next revision.
> I'm supportive of this work, but I think we have a fundamental point
> to clarify: the document is currently missing data nodes that makes
> a slice, a slice!
> 
> If we don't have such data nodes, the current module can be used to
> provision any form of connectivity. If we omit the "ns-" prefix, the
> module can be used for provisioning the connectivity of VoIP,
> multicast, etc. services. That’s actually good (as the applicability
> scope is wider) but we need also to think about network slice
> specifics.
> 
> I have touched on some of these points in a review I shared with you
> back in 02/21, but unless I'm mistaken I don't think it was
> addressed:
> https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-
> wd-teas-ietf-network-slice-nbi-yang-02-rev%20Med.doc
> 
> (1) A proposal to rationalize the discussion and ease progressing
> the spec is to clearly call that a network slice can be defined as a
> collection of at least three components: (1) connectivity component,
> (2) storage component, and (3) compute component. Having a provision
> for this since early stages of the model will ease grafting other
> components of an IETF slice easily, but also allows to avoid having
> a linear model.
> [Bo]: I think this comment relates with the thread discussion of SFC

[Med] Not only. This is important as we are modelling a slice not any connectivity service. We need to make sure slice specifics are covered and that the structure can evolve to cover all future slice components.  

If there are no slice specifics, we just need to cast the module as a general connectivity service module. Slicing will be one use case. 

> and slicing. If my understanding is correct, we will add this when
> WG decides the SF aware network slice is within the scope of draft-
> ietf-teas-ietf-network-slices. But based on the discussion, I am
> afraid that someone would suggest a separate YANG model for this.
> 
> * Traffic steering and advanced services: a slice may require the
> invocation of service functions (firewall, for example) in a given
> order. These policies have to be captured in the slice request. This
> is also useful when the customer request that its slice should not
> cross some networks or not span some regions.
> [Bo] Thanks. If I understand correctly, we will add SLE(Service
> Level Expectation)-specific steering policies applied per slice or
> per slice connection. Are there any other modelling suggestion?

[Med] That would be a first approach, but what is important is have a provision for this in the module. A kind if information model can be seen at rfc7297.html#section-4.

One aside note: I don't think we need to overload our design with SLO/SLEs subtleties. We just need to call these service requirements or something similar. I'm still waiting for a follow-up from Adrian on this as this point is related to the framework draft. 

> [Bo] I'm not sure I understand this. Do you mean that MTU attributes

[Med] MTU is related to the conformance traffic. It should be included because a slice may be tweak for specific data lengths.

Some shaping/policing may be agreed for the conforming traffic, however the slice request can include the agreed behavior for out-of-profile. Such traffic can be redirected to another slice, discarded, etc. 

> 
> * Activation means: may need to be included in a slice definition.
> Think about a slice that can be implemented as a VPN service. Such
> service may require the activation of a given routing protocol
> between a CE and a PE, otherwise the service won’t be offered.
> [Bo] I do agree. Current YANG model has a container of "ep-protocol"
> under "ns-endpoint", and also previous revision of the model had
> nodes of "BGP" and "static routing". But there is some arguments
> that some scenarios, for example, optical networks don't need these
> nodes.

[Med] BGP or static routing are good example of activation means. Other attachment circuit specific technologies can be included.  

> IGMP/MLD nodes under "ns-endpoint"?

[Med] Invocation means are distinct from the activation: You may have a multicast slice that is in place, but in order to access some specific channels or (S,G), the CE will need to send specific queries within the slice itself (MLD, for example). 

> [Bo] Yes. The current model includes network slice, endpoint, and
> connection status. Do you think there are other nodes that are
> necessary?
> 

[Med] What I had in mind is more notifications to the slice customer. 

> 
> (3) The model seems to be inspired from the opsawg vpn I-Ds
> (network-access structure, for example). That's great and
> appreciated, but I would formalize that by using I-D.ietf-opsawg-
> vpn-common for data nodes such as connectivity-type, endpoint-role,
> status-params, etc.
> Bo: Yes. VPN is one of important technologies of realizing network
> slice. But there are some discussions that VPN is not mandatory to
> realize network slice, e.g. optical mechanism could be used.

[Med] The types in the common I-D are more generic than the te-types as they can be applied for service requests :-) You may at least cite it in the text and explain that you prefer to copy some data nodes rather than importing them. That would be fair.  

> Bo: Thanks for pointing this out. Will remove 'underlay'.

[Med] I actually have an issue with "IETF network" :-)

> ____________________________________________________________________
> _____________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre
> diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler a l'expediteur et le
> detruire ainsi que les pieces jointes. Les messages electroniques
> etant susceptibles d'alteration, Orange decline toute responsabilite
> si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or
> privileged information that may be protected by law; they should not
> be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender
> and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that
> have been modified, changed or falsified.
> Thank you.
> 

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.