Subject: Re: [Teas] Status of draft-king-teas-applicability-actn-slicing?

From: Vishnu Pavan Beeram <[email-masked]>
Date: Fri, 2 Jul 2021 20:48:52 -0500

Adrian, Hi!

Thanks for summarizing the status of this draft!

Yes, it is time to reconsider adoption for this document. We look forward
to discussing this draft at the upcoming meeting and then taking it through
the adoption process.

Regards,
-Pavan and Lou

On Wed, Jun 30, 2021 at 6:42 AM Adrian Farrel <[email-masked]> wrote:

> Hi,
>
>
>
> I think there were three questions about
> draft-king-teas-applicability-actn-slicing that needed to be answered:
>
>
>
> 1. How to resolve overlap with draft-ietf-teas-enhanced-vpn?
>
> My understanding is that there has been some rebalancing of material
> between the drafts based on two factors:
>
>    1. VPN+ is not just about slicing
>    2. There is more material needed to describe the ACTN applicability
>    than conveniently fits in a subsection of the VPN+ document
>
> I think this issue is resolved. The question was opened on the list last
> year, and there were no objections to how the text is now balanced.
>
>
>
> 2. How to resolve terminology issues with the network slicing work?
>
> We have come a long way with network slicing.
> draft-ietf-teas-ietf-network-slices now represents the work-in-progress.
>
> Although there is still work to be done with network slices (and that is
> queued with me – sorry), I think we have all the core terminology and
> concepts resolved.
>
> draft-king-teas-applicability-actn-slicing has “recently” been updated to
> use align the terminology, so I think this issues is resolved.
>
>
>
> 3. Do we even need an applicability statement?
>
> I think this resolves to “Is it useful? Does the WG want it?”
>
> Of course, the material could be published as a white paper or a blog, but
> it does seem to link together a number IETF (particularly TEAS)
> technologies and that seems to be valuable.
>
> Perhaps this question is a question for the WG during an adoption poll?
>
>
>
> So that leads me to ask whether the chairs are now ready to reconsider an
> adoption poll for this document?
>
>
>
> Thanks,
>
> Adrian
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Mon, 5 Jul 2021 00:26:41 +0000

Hi draft-king-teas-applicability-actn-slicing authors and All,

I just looked through the draft and the following question rose.

-3.4.3.  ACTN Used to Deliver a Virtual Consumer Network
The network slice may include nodes with specific capabilities. These can be delivered as Physical Network Functions (PNFs) or Virtual Network Functions (VNFs).

If this section deals with ACTN virtual network as the same entity as IETF network slice, this description seems misleading. 
In my understanding, the current ACTN solutions don’t have any method handling SFC.
As "SFC and slicing" thread discusses, I don't mind if IETF network slicing should cover/incorporate an SFC capability, but there is no applicable solution and even architecture in ACTN for now.

Typo
-Abstract
Network Function Virtualization -> Network Functions Virtualization

-3.  Abstraction and Control of Traffic Engineered (TE) Networks (ACTN)
Physical forwarding plane sources -> Physical forwarding plane resources?

All the best,
Kenichi

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Vishnu Pavan Beeram
Sent: Saturday, July 3, 2021 10:49 AM
To: Adrian Farrel <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] Status of draft-king-teas-applicability-actn-slicing?

Adrian, Hi!

Yes, it is time to reconsider adoption for this document. We look forward to discussing this draft at the upcoming meeting and then taking it through the adoption process.

Regards,
-Pavan and Lou

On Wed, Jun 30, 2021 at 6:42 AM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

	Hi,

	I think there were three questions about draft-king-teas-applicability-actn-slicing that needed to be answered:

	My understanding is that there has been some rebalancing of material between the drafts based on two factors:

	a.	VPN+ is not just about slicing
	b.	There is more material needed to describe the ACTN applicability than conveniently fits in a subsection of the VPN+ document

	I think this issue is resolved. The question was opened on the list last year, and there were no objections to how the text is now balanced.

	We have come a long way with network slicing. draft-ietf-teas-ietf-network-slices now represents the work-in-progress.

	Although there is still work to be done with network slices (and that is queued with me – sorry), I think we have all the core terminology and concepts resolved.

	draft-king-teas-applicability-actn-slicing has “recently” been updated to use align the terminology, so I think this issues is resolved.

	Of course, the material could be published as a white paper or a blog, but it does seem to link together a number IETF (particularly TEAS) technologies and that seems to be valuable.

	So that leads me to ask whether the chairs are now ready to reconsider an adoption poll for this document?

	Thanks,

	Adrian

	_______________________________________________
	Teas mailing list
	[email-masked] <mailto:[email-masked]> 
	https://www.ietf.org/mailman/listinfo/teas