Subject: [Teas] Network slicing framework : Issue #7: Workflow

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 27 Sep 2021 19:25:26 +0100

Dependent slightly on the resolution of issue #6 (architecture and
terminology), we could document a workflow.

For example,:
- customer requests a slice
- NSC maps slice to a slice group
- NSC maps slice group to a resource partition
- NSC allocates resources to the resource partition

But it seems to me that these steps could happen in pretty much any order
depending to operational preferences and possibly the technology of the
network. 

For that reason, I think it would be wrong to document a workflow. (This is
a change to my original opinion!)

Maybe add a sentence to explain that the order that the architectural
networks are constructed is open for operational choice.

Cheers,
Adrian

---

From: <[email-masked]>
Date: Wed, 29 Sep 2021 15:44:31 +0000

Hi Adrian, 

> For that reason, I think it would be wrong to document a workflow. (This
> is a change to my original opinion!)
> 

Seems reasonable. Internals to the NSC should be kep as such (especially, the second and third bullets of your list). 

Another approach would be to focus only on the visible external behavior, e.g.,: 

- The network exposes its (slice) capabilities
- The customer requests a slice
- The NSC maps the requests to the capabilities while applies provider policies (if any) and then creates the resource partition
- The NSC reports back to the customer as a function of the previous step

Cheers,
Med

> -----Message d'origine-----
> De : Teas <[email-masked]> De la part de Adrian Farrel
> Envoyé : lundi 27 septembre 2021 20:25
> À : [email-masked]
> Objet : [Teas] Network slicing framework : Issue #7: Workflow
> 
> For that reason, I think it would be wrong to document a workflow. (This
> is a change to my original opinion!)
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 30 Sep 2021 08:39:17 +0000

Hi Adrian and Med,

As I wrote below before, a feasibility check request step may be introduced before the creation request.
A feasibility check has a broad sense, but we can limit the scope to the available resource check to create a slice.
This may be not used by an end user(consumer), but a Customer higher level operations system* may require to avoid the creation failure or suspended state.
It corresponds to VN compute of Sec. 4.3.1 of actn-vn-yang model.

https://mailarchive.ietf.org/arch/msg/teas/WZKp2PHrPqH5J5_km8Mz8P2pSVU/

*Figure 1 in draft-ietf-teas-ietf-network-slices-04

Thanks,
Kenichi

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, September 30, 2021 12:45 AM
To: [email-masked]; [email-masked]
Subject: Re: [Teas] Network slicing framework : Issue #7: Workflow

Hi Adrian, 

> For that reason, I think it would be wrong to document a workflow. 
> (This is a change to my original opinion!)
> 

Cheers,
Med

> De : Teas <[email-masked]> De la part de Adrian Farrel Envoyé : 
> lundi 27 septembre 2021 20:25 À : [email-masked] Objet : [Teas] Network 
> slicing framework : Issue #7: Workflow
> 
> But it seems to me that these steps could happen in pretty much any 
> order depending to operational preferences and possibly the technology 
> of the network.
> 
> For that reason, I think it would be wrong to document a workflow. 
> (This is a change to my original opinion!)
> 

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 30 Sep 2021 09:10:49 +0000

Hi Kenichi, 

I agree this makes sense even if I think that this can be handled by the protocol used to place a request (confirmed commit in netconf, for example). 

A successful feasibility check does not guarantee that a subsequent request will be accepted unless some resource preservations are made, though. 

Cheers, 
Med

> De : Teas <[email-masked]> De la part de Ogaki, Kenichi
> Envoyé : jeudi 30 septembre 2021 10:39
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>;
> [email-masked]; [email-masked]
> Objet : Re: [Teas] Network slicing framework : Issue #7: Workflow
> 
> Hi Adrian and Med,
> 
> A feasibility check has a broad sense, but we can limit the scope to the
> available resource check to create a slice.
> This may be not used by an end user(consumer), but a Customer higher level
> operations system* may require to avoid the creation failure or suspended
> state.
> Seems reasonable. Internals to the NSC should be kep as such (especially,
> the second and third bullets of your list).
> 
> - The NSC maps the requests to the capabilities while applies provider
> policies (if any) and then creates the resource partition
> __________________________________________________________________________
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message par
> erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 30 Sep 2021 10:22:48 +0000

Hi Med,

In the other SDOs, the reservation step may be introduced after a successful feasibility check.
Clause 7.3.3. of ETSI NFV IFA 013 V4.2.1 is easy to understand.
https://www.etsi.org/deliver/etsi_gs/nfv-ifa/001_099/013/04.02.01_60/gs_nfv-ifa013v040201p.pdf

When we assume TE technology, the reservation, LSP setup, is almost same as the creation, but the reservation may be necessary for SFC case.

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Thursday, September 30, 2021 6:11 PM
To: 大垣 健一 <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [Teas] Network slicing framework : Issue #7: Workflow

Hi Kenichi, 

Cheers,
Med

> De : Teas <[email-masked]> De la part de Ogaki, Kenichi Envoyé 
> : jeudi 30 septembre 2021 10:39 À : BOUCADAIR Mohamed INNOV/NET 
> <[email-masked]>; [email-masked]; [email-masked] 
> A feasibility check has a broad sense, but we can limit the scope to 
> the available resource check to create a slice.
> This may be not used by an end user(consumer), but a Customer higher 
> level operations system* may require to avoid the creation failure or 
> suspended state.
> > Maybe add a sentence to explain that the order that the 
> > architectural networks are constructed is open for operational choice.
> 
> Seems reasonable. Internals to the NSC should be kep as such 
> (especially, the second and third bullets of your list).
> 
> Another approach would be to focus only on the visible external 
> behavior,
> e.g.,:
> 
> > lundi 27 septembre 2021 20:25 À : [email-masked] Objet : [Teas] 
> > Network slicing framework : Issue #7: Workflow
> >
> > order depending to operational preferences and possibly the 
> > technology of the network.
> >
> > Maybe add a sentence to explain that the order that the 
> > architectural networks are constructed is open for operational choice.
> >
> > Cheers,
> > Adrian
> >
> ______________________________________________________________________
> ____ _______________________________________________
> 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.

---

From: Xufeng Liu <[email-masked]>
Date: Thu, 30 Sep 2021 17:10:53 -0400

As Med mentioned, a state report would be an expected step:

Also, should this report include all allocated resources and maps? Or
partial allocations with follow-up updates?

Thanks,
- Xufeng

On Thu, Sep 30, 2021 at 6:33 AM Ogaki, Kenichi <[email-masked]> wrote:

> When we assume TE technology, the reservation, LSP setup, is almost same
> as the creation, but the reservation may be necessary for SFC case.
>
> Thanks,
> Kenichi
>
> I agree this makes sense even if I think that this can be handled by the
> protocol used to place a request (confirmed commit in netconf, for
> example).
>
> A successful feasibility check does not guarantee that a subsequent
> request will be accepted unless some resource preservations are made,
> though.
>
> Cheers,
> Med
>
> pieces jointes. Les messages electroniques etant susceptibles d'alteration,

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 30 Sep 2021 23:26:35 +0000

Hi Med,

In terms reservation, more explanatory reference is here.
Clause 6.2.2.1 of ETSI ZSM 003.
https://www.etsi.org/deliver/etsi_gs/ZSM/001_099/003/01.01.01_60/gs_ZSM003v010101p.pdf

Let me complement, please.
A reservation also has a broad sense which may include calendaring and scheduling below, but my intention here is the pre-allocation of the resource to create a slice without the instantiation after a successful feasibility check.
#ZSM's focus includes calendaring and scheduling.
https://mailarchive.ietf.org/arch/msg/teas/I5UIEOPl_IU_agrtdKMBgY42oTI/

Thanks,
Kenichi

-----Original Message-----
From: Xufeng Liu <[email-masked]> 
Sent: Friday, October 1, 2021 6:11 AM
To: 大垣 健一 <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: ***フリーメール*** Re: [Teas] Network slicing framework : Issue #7: Workflow

Also, should this report include all allocated resources and maps? Or partial allocations with follow-up updates?

Thanks,
- Xufeng

On Thu, Sep 30, 2021 at 6:33 AM Ogaki, Kenichi <[email-masked] <mailto:[email-masked]> > wrote:

	Hi Med,

	
	Thanks,
	Kenichi
	
	-----Original Message-----
	From: [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> > 
	Sent: Thursday, September 30, 2021 6:11 PM
	To: 大垣 健一 <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
	Subject: RE: [Teas] Network slicing framework : Issue #7: Workflow
	
	Hi Kenichi, 

	
	Cheers,
	Med
	
	> De : Teas <[email-masked] <mailto:[email-masked]> > De la part de Ogaki, Kenichi Envoyé 
	> <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]>  
	> From: Teas <[email-masked] <mailto:[email-masked]> > On Behalf Of 
	> [email-masked] <mailto:[email-masked]> 
	> To: [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
	> > De : Teas <[email-masked] <mailto:[email-masked]> > De la part de Adrian Farrel Envoyé :
	> > lundi 27 septembre 2021 20:25 À : [email-masked] <mailto:[email-masked]>  Objet : [Teas] 
	> > [email-masked] <mailto:[email-masked]> 
	> [email-masked] <mailto:[email-masked]> 
	> [email-masked] <mailto:[email-masked]> 

	
	
	_______________________________________________
	Teas mailing list
	[email-masked] <mailto:[email-masked]> 
	https://www.ietf.org/mailman/listinfo/teas