Subject: [Teas] Issue in draft-ietf-teas-te-service-mapping-yang

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 1 Sep 2021 21:20:36 +0100

Hi,

Looking at Appendix B, I see that there is an open discussion issue:

   *  Support for Calendaring and scheduling TE resources.

I think we had a similar discussion as we went through the work on PCE and
RSVP-TE. The way we approached it then was to acknowledge that calendaring
and scheduling is an important function for network operators, but to leave
it out of the core work. We concentrated on ensuring that the core work
would be extensible so that calendaring could be added at a later stage.

I suggest that we take the same approach here. That is, we add some text to
say that "Scheduling is currently out of scope, although an operator could
use their own scheduling mechanism on top of this YANG model. In future
augmentations to this model might be designed to integrate scheduling."

Cheers,
Adrian

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 2 Sep 2021 07:14:13 +0000

Hi Adrian, 

That is a good suggestion. Unless I hear objections I will update the I-D accordingly. 

Thanks! 
Dhruv 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 02 September 2021 01:51
To: [email-masked]
Cc: 'TEAS WG' <[email-masked]>
Subject: [Teas] Issue in draft-ietf-teas-te-service-mapping-yang

Hi,

I think we had a similar discussion as we went through the work on PCE and RSVP-TE. The way we approached it then was to acknowledge that calendaring and scheduling is an important function for network operators, but to leave it out of the core work. We concentrated on ensuring that the core work would be extensible so that calendaring could be added at a later stage.

I suggest that we take the same approach here. That is, we add some text to say that "Scheduling is currently out of scope, although an operator could use their own scheduling mechanism on top of this YANG model. In future augmentations to this model might be designed to integrate scheduling."

Cheers,
Adrian

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 2 Sep 2021 11:42:51 -0700

+1

Cheers,
Jeff

> On Sep 2, 2021, at 00:14, Dhruv Dhody <[email-masked]> wrote:
> 
> Hi Adrian, 
>