Subject: [Teas] LLDP snooping references for ACTN POI

From: Italo Busi <[email-masked]>
Date: Thu, 16 Sep 2021 09:28:23 +0000

Dear TEAS WG,

In draft-ietf-teas-actn-poi-applicability, LLDP snooping is mentioned as the preferred method to discover the adjacency between an IP router port and an ROAD edge port

The issue we are facing is that LLDP snooping is not described in any standard document but only in vendors' documentations so we are not sure which informative reference we should provide in the draft for LLDP snooping

For more information see: https://github.com/FabioPeruzzini/actn-poi/issues/39

Do you know if a similar issue been faced before and, if so, how it has been addressed?

Would be ok to add informative references to vendors' documentation?

Thanks, Italo (on behalf of co-authors and contributors)

---

From: "Scharf, Michael" <[email-masked]>
Date: Sun, 19 Sep 2021 09:44:53 +0000

For what it is worth: Three years ago, when I was responsible for LLDP snooping running code, I would have argued that a mechanism that apparently most vendors implement could nicely be described in a short informational RFC. LLDP snooping may not require new standardization, but there could e.g. be operational aspects for which a description could be useful.

If an informational RFC is not a realistic option, and no other vendor-neutral reference elsewhere exists, I'd be perfectly fine with references to the documentation of running code.

My 2 cents

Michael

From: Teas <[email-masked]> On Behalf Of Italo Busi
Sent: Thursday, September 16, 2021 11:28 AM
To: TEAS WG <[email-masked]>
Subject: [Teas] LLDP snooping references for ACTN POI

Dear TEAS WG,

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 23 Sep 2021 17:04:05 +0100

Hi all,

>From where I look at this, protocol snooping is just snooping on a protocol  ;-)

That is, the protocol is specified and we know what is in various fields. Snooping is just looking at the packets (praying that there is no encryption) and extracting useful information.

I think that documenting that an implementation can snoop on a protocol and can draw specific information from what it sees, is OK for an Informational RFC or for some advisory text in a Standards Track RFC, but I would think it odd to mandate it in any RFC.

Looking at the links that people have conveniently posted in the github Italo pointed to, it seems that there are two differences between the various vendors:

*	Different ways to configure LLDP snooping
*	Some variation in what information is gathered

But so what?

I think what your work needs to do is:

*	Work out what information *could* be gathered by LLDP snooping (that is useful for this document)
*	List this information in the document and say that an implementation MAY gather the information through LLDP snooping, but also say that it MAY be gathered through other means such as configuration.

I wouldn’t include references to vendor implementations because:

*	It is hard to keep them up-to-date once the RFC is published
*	It creates the impression of favouring certain vendors
*	It’s not particularly interesting :-)

Best,

Adrian

From: Teas <[email-masked]> On Behalf Of Scharf, Michael
Sent: 19 September 2021 10:45
To: Italo Busi <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] LLDP snooping references for ACTN POI

If an informational RFC is not a realistic option, and no other vendor-neutral reference elsewhere exists, I’d be perfectly fine with references to the documentation of running code.

My 2 cents

Michael

From: Teas <[email-masked] <mailto:[email-masked]> > On Behalf Of Italo Busi
Sent: Thursday, September 16, 2021 11:28 AM
To: TEAS WG <[email-masked] <mailto:[email-masked]> >
Subject: [Teas] LLDP snooping references for ACTN POI

Dear TEAS WG,

The issue we are facing is that LLDP snooping is not described in any standard document but only in vendors’ documentations so we are not sure which informative reference we should provide in the draft for LLDP snooping

Would be ok to add informative references to vendors’ documentation?