Subject: [Teas] Network slicing : Issue #7 (workflow) resolution

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 24 Oct 2021 19:55:21 +0100

Hi all,

Looking back through the emails, I think this item is easily resolved.

- Don't include a workflow
- Do include the "externally visible behaviours" of the NSC
- Do include a note about the "feasibility check" stage
- Do include a note about "feedback about what alternatives are available"

I will note (having been there and implemented stuff) that:

- The feasibility check is very much a moment in time, and what is tested at
one
   moment may be impossible later owing to changes in network availability.
- The feedback about alternatives may be hard to implement (although it
sounds
   easy) because it is not possible to know which parameters the customer
may
   be willing to relax. We saw this, for example, with PCE where it is hard
to say
   why a particular path computation has failed beyond "there is no path
available
   that matches your request."

But nothing stops an implementation offering both of these, so we can
mention them.

Cheers,
Adrian

---

From: Igor Bryskin <[email-masked]>
Date: Mon, 25 Oct 2021 14:05:18 +0000 (UTC)

Hi Adrian,
You wrote:
"...The feedback about alternatives may be hard to implement (although itsounds
  easy) because it is not possible to know which parameters the customer
may
  be willing to relax. We saw this, for example, with PCE where it is hard
to say
  why a particular path computation has failed beyond "there is no path
available
  that matches your request."
I am aware of at least one path computation algorithm/strategy that could do better than that. For example, it may generate a path computation response looking something like this:Path computation has failed, but it would be successfully resulted in path P if constraints C1, C2, etc. are relaxed.
Or
Path computation is successful. The result is path P, but the result could be a better path P', if constraints C1, C2, etc. are relaxed.
So, it is not unreasonable IMHO to give server a means to convey  alternatives along with constraint relaxation suggestions.
Best,Igor
Sent from Yahoo Mail on Android 
 
  On Sun, Oct 24, 2021 at 2:55 PM, Adrian Farrel<[email-masked]> wrote:   Hi all,

Cheers,
Adrian

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 25 Oct 2021 15:20:03 +0100

Well, I will include the option to return “advice” although I remain unconvinced of its utility.

“You asked for a pair of brown shoes. We found you a pair at $37. However, if you would like a blue tie instead, that would only cost you £33.”

“Other customers who asked for a P2P connection with low latency, also shopped for an MP2MP service with low cost.”

Cheers,

Adrian

From: Igor Bryskin <[email-masked]> 
Sent: 25 October 2021 15:05
To: [email-masked]; Adrian Farrel <[email-masked]>; 'TEAS WG' <[email-masked]>
Subject: Re: [Teas] Network slicing : Issue #7 (workflow) resolution

Hi Adrian,

You wrote:

"...

The feedback about alternatives may be hard to implement (although it

sounds

may

to say

available

I am aware of at least one path computation algorithm/strategy that could do better than that. For example, it may generate a path computation response looking something like this:

Path computation has failed, but it would be successfully resulted in path P if constraints C1, C2, etc. are relaxed.

Or

Best,

Igor

Sent from Yahoo Mail on Android <https://go.onelink.me/107872968?pid=InProduct&c=Global_Internal_YGrowth_AndroidEmailSig__AndroidUsers&af_wl=ym&af_sub1=Internal&af_sub2=Global_YGrowth&af_sub3=EmailSignature> 

On Sun, Oct 24, 2021 at 2:55 PM, Adrian Farrel

<[email-masked] <mailto:[email-masked]> > wrote:

Hi all,

one

sounds

may

to say

available

mention them.

Cheers,

Adrian

Teas mailing list

[email-masked] <mailto:[email-masked]>

---

From: Igor Bryskin <[email-masked]>
Date: Mon, 25 Oct 2021 14:30:51 +0000 (UTC)

I mean path computation may reply:Cannot give you a path with under 5 ms delay, but path P1 would give you 7ms delay or path P2 would give you  your 5 ms delay if only I am allowed to use link L you requested me to exclude, ...

  On Mon, Oct 25, 2021 at 10:20 AM, Adrian Farrel<[email-masked]> wrote:   _______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas