Subject: [Teas] Send again using PDF: A slide on VPN+ and IETF network slices

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Nov 2021 17:18:02 -0000

Sorry. PDF would be more polite

(Should also say - slide courtesy of Jie Dong).

A

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: 09 November 2021 17:16
To: [email-masked]' <[email-masked]>
Subject: A slide on VPN+ and IETF network slices

Hi,

I think this is relatively uncontentious. (But what do I know? You guys are
more than capable of finding issues where I see calm water ;-)

The point of the slide is:
You can use enhanced VPNs to deliver network slicing, but it is not the only
way.
You can request an enhanced VPN as a separate concept (i.e., not
specifically as a slice).

Comments?

Adrian

---

From: "Jalil, Luay" <[email-masked]>
Date: Tue, 9 Nov 2021 11:21:00 -0600

Thanks Adrian. That was my question that I didn't get to ask. Does the
draft assume that every slice requires an enhanced VPN?

Regards,
*Luay*

On Tue, Nov 9, 2021 at 11:18 AM Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> Teas mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=CPylyIoPBihGEF3H0LPkbAqew_TgySysBaG6tdjWmIM&s=43hgEi4avQAc2E83pqEDDC8_jW6SshvVOnh9A0PP5B8&e=
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Nov 2021 17:40:26 -0000

No, the framework makes no assumption on how you realise/deliver the slice service. It *does* point at a couple of options based on established TEAS technology, while acknowledging “other solutions are available”.

I think that work is ongoing to show the applicability of VPN+ to slicing (to help you work out how to do it) just as there is a draft on ACTN applicability.

A

From: Jalil, Luay <[email-masked]> 
Sent: 09 November 2021 17:21
To: [email-masked]
Cc: [email-masked]
Subject: Re: [E] [Teas] Send again using PDF: A slide on VPN+ and IETF network slices

Thanks Adrian. That was my question that I didn't get to ask. Does the draft assume that every slice requires an enhanced VPN?

Regards,

Luay

On Tue, Nov 9, 2021 at 11:18 AM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

A

-----Original Message-----
From: Adrian Farrel <[email-masked] <mailto:[email-masked]> > 
Sent: 09 November 2021 17:16
To: [email-masked] <mailto:[email-masked]> ' <[email-masked] <mailto:[email-masked]> >
Subject: A slide on VPN+ and IETF network slices

Hi,

Comments?

Adrian
_______________________________________________
Teas mailing list
[email-masked] <mailto:[email-masked]> 
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=CPylyIoPBihGEF3H0LPkbAqew_TgySysBaG6tdjWmIM&s=43hgEi4avQAc2E83pqEDDC8_jW6SshvVOnh9A0PP5B8&e=> &d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=CPylyIoPBihGEF3H0LPkbAqew_TgySysBaG6tdjWmIM&s=43hgEi4avQAc2E83pqEDDC8_jW6SshvVOnh9A0PP5B8&e=

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 10 Nov 2021 15:19:10 +0000

Hi Adrian and all,

Thanks for raising this topic on the list. I thought you would use "A slice on VPN+ and IETF network slice":)

I totally agree that enhanced VPN (VPN+) can be used to deliver network slicing. VPN+ provides an architecture and a set of technologies which can be used for realizing network slices. There can be different solutions (the combination of technologies in forwarding plane, data plane and control plane) which align with the VPN+ architecture, and there may be solutions which is based on another architecture. 

As for the other VPN+ use cases in addition to IETF network slices, I would like to hear more from the WG especially the operators. The VPN+ framework document used to say that VPN+ could be used to provide transport network slices for 5G end-to-end network slicing, and it could also be used in general cases providing enhanced connectivity services. Since the scope of IETF network slice is not limited to "slicing of the transport network" in the 5G network slicing context, it may also cover some of non-5G VPN+ use cases. 

Then a question is: how to define the boundary between the IETF network slices services and other VPN+ use cases? Or it would be helpful to identify some VPN+ use cases which are not considered as IETF network slices.

Best regards,
Jie

> From: Teas [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Wednesday, November 10, 2021 1:18 AM
> To: [email-masked]
> Subject: [Teas] Send again using PDF: A slide on VPN+ and IETF network slices
> 
> I think this is relatively uncontentious. (But what do I know? You guys are more
> than capable of finding issues where I see calm water ;-)
> 
> You can request an enhanced VPN as a separate concept (i.e., not specifically
> as a slice).
> 
> Comments?
> 
> Adrian