Subject: [Teas] A2A definition

From: John Scudder <[email-masked]>
Date: Tue, 9 Nov 2021 16:41:28 +0000

Hi Adrian and all,

My eyebrows went up when I saw today, and confirmed in the draft, that you’ve defined A2A as (emphasis added),

   o  With an A2A matrix, any sending CE may send to any one receiving
      CE *or any set of receiving CEs*.

I can’t find a way to read what’s written that doesn’t imply that any arbitrary CE can multicast any given packet to any other arbitrary group of CEs (“any set”).

Is it really your intention that A2A includes arbitrary ad-hoc multicast? Because I would otherwise have guessed A2A to just be the special all-CEs case of P2P. 

Thanks,

—John

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Nov 2021 17:10:15 -0000

Well, the intention is model the service level available in a general VPN.
That is, (with appropriate agreement by the service provider) a site may send traffic to one or more other sites in the VPN. That is a "routed service" so that the sending side sends traffic to a destination address. In the P2P case, the service provider maps this to a destination site (and hence a destination PE/AC). In the P2MP case (if supported) the destination address is a multicast address and the service provider maps it to multiple destination sites using source replication or P2MP connectivity to deliver the traffic to the destination PEs/ACs.

VERY happy to receive suggestions of clarification or better terminology.

A

-----Original Message-----
From: John Scudder <[email-masked]> 
Sent: 09 November 2021 16:41
To: [email-masked]; Adrian Farrel <[email-masked]>
Cc: [email-masked]
Subject: A2A definition

Hi Adrian and all,

Thanks,

—John