Subject: [Teas] Hierarchical IETF Network Slicing

From: Lizhenbin <[email-masked]>
Date: Fri, 5 Nov 2021 00:55:05 +0000

Hi Folks,

Recently we submitted a new draft on hierarchical IETF network slicing. 

In IETF we have been working on the network slicing topic for a while, and have produced a series of drafts covering the terminologies, the general framework, the service models, the realization framework and technologies (e.g. VPN+). For the realization of IETF network slices, different solutions are proposed to meet the requirement of different slicing use cases in terms of the functionality and scalability. In the process to research, implementation and deployment, we communicates with the service providers and learn more about the requirements on the IETF network slicing. Based on the existing IETF network slicing work, the introduction of end-to-end network slicing and hierarchical network slicing aims to extend the scope and applicability of IETF network slices, so as to facilitate the deployment of IETF network slices in real networks.

The hierarchical IETF network slicing was briefly mentioned in draft-ietf-teas-ietf-network-slice. Following that, the following new draft describes the typical scenarios of hierarchical IETF network slices. In addition, the considerations and requirements on the realization of hierarchical network slices in different network planes are also provided. 

Review and comments are always welcome.

Best regards,
Robin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 25, 2021 7:29 PM
To: Dongjie (Jimmy) <[email-masked]>; Lizhenbin <[email-masked]>
Subject: New Version Notification for draft-dong-teas-hierarchical-ietf-network-slice-00.txt

A new version of I-D, draft-dong-teas-hierarchical-ietf-network-slice-00.txt
has been successfully submitted by Jie Dong and posted to the IETF repository.

Name:		draft-dong-teas-hierarchical-ietf-network-slice
Revision:	00
Title:		Considerations about Hierarchical IETF Network Slices
Document date:	2021-10-25
Group:		Individual Submission
Pages:		11
URL:            https://www.ietf.org/archive/id/draft-dong-teas-hierarchical-ietf-network-slice-00.txt
Status:         https://datatracker.ietf.org/doc/draft-dong-teas-hierarchical-ietf-network-slice/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dong-teas-hierarchical-ietf-network-slice

Abstract:
   Network slicing is targeted at existing or emerging customers or
   services which may request for network connectivity services with a
   specific set of Service Level Objectives (SLOs) and Service Level
   Expectations (SLEs).  The framework of IETF network slice can support
   hierarchical network slicing.  And in some network scenarios, there
   may be requirements for the deployment of hierarchical network
   slices.

   This document describes the typical scenarios of hierarchical IETF
   network slices, and provides the considerations and requirements on
   the technologies in different network planes to support hierarchical
   network slicing.

The IETF Secretariat

---

From: <[email-masked]>
Date: Fri, 5 Nov 2021 14:37:12 +0000

Hi Robin, al,

Thank you for the work put into this document.

I may be missing some details, but I'm not sure that all the cases discussed in the I-D fall under hierarchical slices. For example, how scenario 2 can be requested following the teas framework? In reference to what is depicted as low-level slices, are those visible to the network provider? Shouldn't this be specified as district connectivity matrices + service objectives? If this is to be visible as a slice for the provider, then this should be requested as a separate top-level slice. 

The same comments apply for the wholesale case.  

The industry case is different as a provide can create a slice aggregate (not visible to the requesting customers) and then bind per-customer slices to that aggregate. 

Cheers,
Med 

> -----Message d'origine-----
> De : Teas <[email-masked]> De la part de Lizhenbin
> Envoyé : vendredi 5 novembre 2021 01:55
> À : [email-masked]
> Objet : [Teas] Hierarchical IETF Network Slicing
> 
> Hi Folks,
> 
> In IETF we have been working on the network slicing topic for a while, and
> have produced a series of drafts covering the terminologies, the general
> framework, the service models, the realization framework and technologies
> (e.g. VPN+). For the realization of IETF network slices, different
> solutions are proposed to meet the requirement of different slicing use
> cases in terms of the functionality and scalability. In the process to
> research, implementation and deployment, we communicates with the service
> providers and learn more about the requirements on the IETF network
> slicing. Based on the existing IETF network slicing work, the introduction
> of end-to-end network slicing and hierarchical network slicing aims to
> extend the scope and applicability of IETF network slices, so as to
> facilitate the deployment of IETF network slices in real networks.
> 
> The hierarchical IETF network slicing was briefly mentioned in draft-ietf-
> teas-ietf-network-slice. Following that, the following new draft describes
> the typical scenarios of hierarchical IETF network slices. In addition,
> the considerations and requirements on the realization of hierarchical
> network slices in different network planes are also provided.
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.