Subject: Re: [Teas] New Version Notification for draft-bestbar-teas-ns-packet-05.txt

From: Tarek Saad <[email-masked]>
Date: Tue, 16 Nov 2021 19:21:56 +0000

Hi WG,

During IETF112, we have received some feedback about further terminology alignment that we made in rev-04.
The revision -05 updates include:

  *   several nits edit
  *   Replacement of following terms for better readability:
s/Slice Aggregate/Slice-Flow Aggregate
s/Slice Selector (SS)/Slice-Flow Aggregate Selector (SS)
s/Slice Policy/Network Resource Partition Policy

With this change, we think the terminology concerns are all addressed.
We would like to re-iterate to WG chairs that the authors think the document is ready to progress to be adopted.

Regards,
Tarek (for the co-authors)

From: [email-masked] <[email-masked]>
Date: Tuesday, November 16, 2021 at 2:12 PM
To: Luis M. Contreras <[email-masked]>, EXT - [email-masked] <[email-masked]>, Daniele Ceccarelli <[email-masked]>, Joel Halpern <[email-masked]>, Luis Contreras <[email-masked]>, Ran Chen <[email-masked]>, Reza Rokui <[email-masked]>, Shaofu Peng <[email-masked]>, Tarek Saad <[email-masked]>, Vishnu Pavan Beeram <[email-masked]>, Vishnu Pavan Beeram <[email-masked]>, Xufeng Liu <[email-masked]>
Subject: New Version Notification for draft-bestbar-teas-ns-packet-05.txt
[External Email. Be cautious of content]

A new version of I-D, draft-bestbar-teas-ns-packet-05.txt
has been successfully submitted by Tarek Saad and posted to the
IETF repository.

Name:           draft-bestbar-teas-ns-packet
Revision:       05
Title:          Realizing Network Slices in IP/MPLS Networks
Document date:  2021-11-16
Group:          Individual Submission
Pages:          32
URL:            https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-bestbar-teas-ns-packet-05.txt__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvTERVHWQ$<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-bestbar-teas-ns-packet-05.txt__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvTERVHWQ$>
Status:         https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-bestbar-teas-ns-packet/__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvIH3GpSg$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-bestbar-teas-ns-packet/__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvIH3GpSg$>
Htmlized:       https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-bestbar-teas-ns-packet__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvNqwjOag$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-bestbar-teas-ns-packet__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvNqwjOag$>
Diff:           https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-bestbar-teas-ns-packet-05__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvl-kDxXw$<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-bestbar-teas-ns-packet-05__;!!NEt6yMaO-gk!UZYcmU7Nk_K-yNamcid6nEM5ePeSHFP8V1721RB5S4baK_u9DQD2JVvl-kDxXw$>

Abstract:
   Network slicing provides the ability to partition a physical network
   into multiple logical networks of varying sizes, structures, and
   functions so that each slice can be dedicated to specific services or
   customers.  Network slices need to operate in parallel while
   providing slice elasticity in terms of network resource allocation.
   The Differentiated Service (Diffserv) model allows for carrying
   multiple services on top of a single physical network by relying on
   compliant nodes to apply specific forwarding treatment (scheduling
   and drop policy) on to packets that carry the respective Diffserv
   code point.  This document adopts the Diffserv principles and
   proposes a scalable approach to realize network slicing in IP/MPLS
   networks.  The solution does not mandate Diffserv to be enabled in
   the network to provide a specific forwarding treatment, but can co-
   exist with and complement it when enabled.

The IETF Secretariat

Juniper Business Use Only

---

From: <[email-masked]>
Date: Wed, 17 Nov 2021 11:52:02 +0000

Hi Tarek,

Thank you for the effort put into this document.

I fully agree that slice aggregate (traffic aggregate, in general) is a useful concept even if I tend to see the aggregation mainly happening when mapping the slice services themselves or when stitching slices. For example, more slice instances can be supported in the access but only few ones will be provided in the core network. The binding of access slices to fewer core slices is likely. This approach is similar to how class of service are designed and mapped.

I may be wrong, but an underly network device does not need to know whether a flow belongs to an individual slice or a slice aggregate. You may find some more comments at:

  *   pdf: https://raw.githubusercontent.com/boucadair/IETF-Drafts-Reviews/master/draft-bestbar-teas-ns-packet-05-rev%20Med.pdf
  *   doc: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-bestbar-teas-ns-packet-05-rev%20Med.docx

Most of the points discussed in the draft are generic ones (but also deployment-specific). It would be useful to extract specifics when manipulating aggregates. Thank you.

Cheers,
Med

De : Teas <[email-masked]> De la part de Tarek Saad
Envoyé : mardi 16 novembre 2021 20:22
À : [email-masked]
Cc : [email-masked]
Objet : Re: [Teas] New Version Notification for draft-bestbar-teas-ns-packet-05.txt

Hi WG,

  *   several nits edit

Regards,

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 16, 2021 at 2:12 PM
To: Luis M. Contreras <[email-masked]<mailto:[email-masked]>>, EXT - [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>, Joel Halpern <[email-masked]<mailto:[email-masked]>>, Luis Contreras <[email-masked]<mailto:[email-masked]>>, Ran Chen <[email-masked]<mailto:[email-masked]>>, Reza Rokui <[email-masked]<mailto:[email-masked]>>, Shaofu Peng <[email-masked]<mailto:[email-masked]>>, Tarek Saad <[email-masked]<mailto:[email-masked]>>, Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>, Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>, Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bestbar-teas-ns-packet-05.txt
[External Email. Be cautious of content]

Abstract:

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Tarek Saad <[email-masked]>
Date: Fri, 26 Nov 2021 15:04:20 +0000

Hi Med,

Thanks for reviewing the draft and providing very useful comments.
We have addressed them and prepared some responses inline (in the word doc in repo below).
https://github.com/tsaad-dev/reviews/raw/main/draft-bestbar-teas-ns-packet-05-rev%20Med.docx

Please let us know if you have any further comments.

Regards,
Tarek (for co-authors)

From: Teas <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Wednesday, November 17, 2021 at 6:52 AM
To: Tarek Saad <tsaad=[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Teas] New Version Notification for draft-bestbar-teas-ns-packet-05.txt

Hi Tarek,

Cheers,
Med

Hi WG,

  *   several nits edit

Regards,

Abstract:

The IETF Secretariat

Thank you.