Subject: [Teas] Slicing Framework Open issue #1 : Service != Realization

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Mar 2022 09:17:13 -0000

Hi,

First in a series of emails to resolve the open issues mentioned during the
TEAS meeting.

We have, for the longest time, suffered from a blurring between the service
provided to the customer, and how that service is engineered in the network.
This leads us to talk about VPNs in a way where sometimes a VPN is what the
customer gets and sometimes it is what the operator engineers. A good
example is the term "MPLS VPN" as though the customer cares whether the VPN
is provided using MPLS technology.

We have, to some extent, clarifies this with recent YANG "Customer Service
Models" that describe the service offered to the customer, but do not
constrain the provider's choice of implementation technology or options.

As the discussion of IETF Network Slices continues, I have repeatedly seen
some blurring between the topics of the "IETF Network Slice Service" and the
"IETF Network Slice." It seems to me that this mixing of concepts will
continue as future readers pick up the document.

Although I have tried to use the two terms clearly and distinctly, the
document is missing a clear statement to disambiguate the two.

Section 3 provides the definitions of the two terms at some length using
subsections. The clarification would get lost if it was placed at the bottom
of the section after the subsections, so I propose to include some text near
the top of section as follows.

OLD
   IETF Network Slices are created to meet specific requirements,
   typically expressed as bandwidth, latency, latency variation, and
   other desired or required characteristics.  Creation of an IETF
   Network Slice is initiated by a management system or other
   application used to specify network-related conditions for particular
   traffic flows in response to an actual or logical IETF Network Slice
   service request.

   Once created, these slices can be monitored, modified, deleted, and
   otherwise managed.

   Applications and components will be able to use these IETF Network
   Slices to move packets between the specified end-points of the
   service in accordance with specified characteristics.
NEW
   IETF Network Slices are created to meet specific requirements,
   typically expressed as bandwidth, latency, latency variation, and
   other desired or required characteristics.  Creation of an IETF
   Network Slice is initiated by a management system or other
   application used to specify network-related conditions for particular
   traffic flows in response to an actual or logical IETF Network Slice
   service request.

   Once created, these slices can be monitored, modified, deleted, and
   otherwise managed.

   Applications and components will be able to use these IETF Network
   Slices to move packets between the specified end-points of the
   service in accordance with specified characteristics.

   A clear distinction should be made between the "IETF Network
   Slice service" which is the function delivered to the customer
   (see Section 3.2) and which is agnostic to the technologies and
   Mechanisms used by the service provider, and the "IETF Network
   Slice" which is the realization of the service in the provider's 
   network achieved by partitioning network resources and by
   applying certain tools and techniques within the network (see
   Section 3.1).
END

Any objections?

Thanks,
Adrian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 25 Mar 2022 05:30:25 -0400

Works for me.
Yours,
Joel

On 3/25/2022 5:17 AM, Adrian Farrel wrote:
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: <[email-masked]>
Date: Fri, 25 Mar 2022 09:42:59 +0000

Hi Adrian, all, 

Looks good to me as well. Thanks.

You may consider these very minor changes: 
* s/Mechanisms/mechanisms
* s/Section 3.1/Section 6

Cheers,
Med

> -----Message d'origine-----
> De : Teas <[email-masked]> De la part de Adrian Farrel
> Envoyé : vendredi 25 mars 2022 10:17
> À : [email-masked]
> Objet : [Teas] Slicing Framework Open issue #1 : Service != Realization
> 
> Hi,
> 
> First in a series of emails to resolve the open issues mentioned during
> the TEAS meeting.
> 
> We have, for the longest time, suffered from a blurring between the
> service provided to the customer, and how that service is engineered in
> the network.
> This leads us to talk about VPNs in a way where sometimes a VPN is what
> the customer gets and sometimes it is what the operator engineers. A
> good example is the term "MPLS VPN" as though the customer cares whether
> the VPN is provided using MPLS technology.
> 
> We have, to some extent, clarifies this with recent YANG "Customer
> Service Models" that describe the service offered to the customer, but
> do not constrain the provider's choice of implementation technology or
> options.
> 
> As the discussion of IETF Network Slices continues, I have repeatedly
> seen some blurring between the topics of the "IETF Network Slice
> Service" and the "IETF Network Slice." It seems to me that this mixing
> of concepts will continue as future readers pick up the document.
> 
> subsections. The clarification would get lost if it was placed at the
> bottom of the section after the subsections, so I propose to include
> some text near the top of section as follows.
> 
> OLD

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Fri, 25 Mar 2022 09:47:02 +0000

Hi all,

Agree, the proposed change is ok.

Best regards

Luis

-----Mensaje original-----
De: Teas <[email-masked]> En nombre de Joel M. Halpern
Enviado el: viernes, 25 de marzo de 2022 10:30
Para: [email-masked]
Asunto: Re: [Teas] Slicing Framework Open issue #1 : Service != Realization

Works for me.
Yours,
Joel

On 3/25/2022 5:17 AM, Adrian Farrel wrote:
> Hi,
>
> First in a series of emails to resolve the open issues mentioned
> during the TEAS meeting.
>
> service provided to the customer, and how that service is engineered in the network.
> This leads us to talk about VPNs in a way where sometimes a VPN is
> what the customer gets and sometimes it is what the operator
> engineers. A good example is the term "MPLS VPN" as though the
> customer cares whether the VPN is provided using MPLS technology.
>
> do not constrain the provider's choice of implementation technology or options.
>
> Section 3 provides the definitions of the two terms at some length
> using subsections. The clarification would get lost if it was placed
> at the bottom of the section after the subsections, so I propose to
> include some text near the top of section as follows.
>
> OLD

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is confidential and privileged information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Jalil, Luay" <[email-masked]>
Date: Fri, 25 Mar 2022 12:48:52 +0100

+1

Regards,
*Luay*

On Fri, Mar 25, 2022 at 10:49 AM LUIS MIGUEL CONTRERAS MURILLO <
[email-masked]> wrote:

> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is confidential and
> privileged information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=
>

---

From: Kiran M <[email-masked]>
Date: Fri, 25 Mar 2022 06:08:55 -0700

yes, looks good. I hope that documents that refer to this one use them 
properly.
------------------------------------------------------------------------
*From:* Jalil, Luay [mailto:luay.jalil=[email-masked]]
*Sent:* Friday, March 25, 2022, 4:48 AM
*To:* LUIS MIGUEL CONTRERAS MURILLO
*Cc:* [email-masked]
*Subject:* [Teas] [E] Re: Slicing Framework Open issue #1 : Service != 
Realization

> +1
>
> Regards,
> *Luay*
>
>
> On Fri, Mar 25, 2022 at 10:49 AM LUIS MIGUEL CONTRERAS MURILLO 
> <[email-masked]> wrote:
>
>     Hi all,
>
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=>
>
>
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=>
>
>
>     Este mensaje y sus adjuntos se dirigen exclusivamente a su
>     destinatario, puede contener información privilegiada o
>     confidencial y es para uso exclusivo de la persona o entidad de
>     destino. Si no es usted. el destinatario indicado, queda
>     notificado de que la lectura, utilización, divulgación y/o copia
>     sin autorización puede estar prohibida en virtud de la legislación
>     vigente. Si ha recibido este mensaje por error, le rogamos que nos
>     lo comunique inmediatamente por esta misma vía y proceda a su
>     destrucción.
>
>     privileged information intended only for the use of the individual
>     or entity named above. If the reader of this message is not the
>     intended recipient, you are hereby notified that any
>     dissemination, distribution or copying of this communication is
>     strictly prohibited. If you have received this transmission in
>     error, do not read it. Please immediately reply to the sender that
>     you have received this communication in error and then delete it.
>
>     Esta mensagem e seus anexos se dirigem exclusivamente ao seu
>     destinatário, pode conter informação privilegiada ou confidencial
>     e é para uso exclusivo da pessoa ou entidade de destino. Se não é
>     vossa senhoria o destinatário indicado, fica notificado de que a
>     leitura, utilização, divulgação e/ou cópia sem autorização pode
>     estar proibida em virtude da legislação vigente. Se recebeu esta
>     mensagem por erro, rogamos-lhe que nos o comunique imediatamente
>     por esta mesma via e proceda a sua destruição
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=>
>
>
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 25 Mar 2022 13:19:52 +0000

Hi Adrian, 

Thanks for raising this issue to the list. 

The description about the network slice service and the network slice realization in the last paragraph looks good to me, except the typos pointed out by Med. 

Best regards,
Jie

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Friday, March 25, 2022 5:17 PM
> To: [email-masked]
> Subject: [Teas] Slicing Framework Open issue #1 : Service != Realization
> 
> Hi,
> 
> First in a series of emails to resolve the open issues mentioned during the TEAS
> meeting.
> 
> customer gets and sometimes it is what the operator engineers. A good example
> is the term "MPLS VPN" as though the customer cares whether the VPN is
> provided using MPLS technology.
> 
> Models" that describe the service offered to the customer, but do not constrain
> the provider's choice of implementation technology or options.
> 
> As the discussion of IETF Network Slices continues, I have repeatedly seen some
> blurring between the topics of the "IETF Network Slice Service" and the "IETF
> Network Slice." It seems to me that this mixing of concepts will continue as future
> readers pick up the document.
> 
> Although I have tried to use the two terms clearly and distinctly, the document is
> missing a clear statement to disambiguate the two.
> 
> subsections. The clarification would get lost if it was placed at the bottom of the
> section after the subsections, so I propose to include some text near the top of
> section as follows.
> 
> OLD

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Fri, 25 Mar 2022 18:56:36 +0100

Hi,

I have only one comment, regarding below:

  the "IETF Network

‘Achieved by partitioning network resources’ is some specific relation option, which might (or might not) be used in particular realization (depending how the slice is realized, might be entire network is single partition). Hence, it should rather be omitted here, as it should be agnostic to to the actual realization. Thus, I would change it to:

  the "IETF Network
  network achieved by

Regards,
Krzysztof

> On 2022 -Mar-25, at 12:48, Jalil, Luay <luay.jalil=[email-masked] <mailto:luay.jalil=[email-masked]>> wrote:
> 
> +1
> 
> Regards,
> Luay
> 
> 
> On Fri, Mar 25, 2022 at 10:49 AM LUIS MIGUEL CONTRERAS MURILLO <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> De: Teas <[email-masked] <mailto:[email-masked]>> En nombre de Joel M. Halpern
> Para: [email-masked] <mailto:[email-masked]>
> > [email-masked] <mailto:[email-masked]>
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=> 
> 
> [email-masked] <mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=> 
> 
> [email-masked] <mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=> 
> [email-masked] <mailto:[email-masked]>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Mar 2022 21:21:41 -0000

Hi Krzysztof,

I think you might have something here, but it is confused by a side point.

“might be entire network is single partition” is not a contradiction with “partitioning the network resources.” True, it is at the extreme end of the spectrum, but one is a special case of many.

Now, the BIG question for network slicing is whether the network resources are partitioned at all. If they are counted in any way (including in a central controller) in order to ensure that the traffic can meet the SLOs, then the resources *are* partitioned. It is only if the service delivery is best effort, allowing for congestion and drops, that we can say that the resources are not partitioned.

Or, in another view, if traffic for a particular service is steered onto particular links in order to meet SLOs (for example, latency), then the resources have been partitioned.

So, while I agree that partitioning is strongly tied to realization, I wonder whether it is possible to have a network slice (note “slice”, not “slice service”) without it.

My concern is that we end up with a definition of network slice that is so far removed from realization that it becomes “a slice is what an operator does to their network to deliver a slice service” which, I think, doesn’t tell us what a slice is.

Cheers,

Adrian

From: Krzysztof Szarkowicz <[email-masked]> 
Sent: 25 March 2022 17:57
To: Adrian Farrel <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas] [E] Re: Slicing Framework Open issue #1 : Service != Realization

Hi,

  the "IETF Network

  the "IETF Network

Regards,

Krzysztof

On 2022 -Mar-25, at 12:48, Jalil, Luay <luay.jalil=[email-masked] <mailto:luay.jalil=[email-masked]> > wrote:

+1

Regards,

Luay

On Fri, Mar 25, 2022 at 10:49 AM LUIS MIGUEL CONTRERAS MURILLO <[email-masked] <mailto:[email-masked]> > wrote:

Hi all,

Best regards

Luis

-----Mensaje original-----
De: Teas <[email-masked] <mailto:[email-masked]> > En nombre de Joel M. Halpern
Enviado el: viernes, 25 de marzo de 2022 10:30
Para: [email-masked] <mailto:[email-masked]> 
Asunto: Re: [Teas] Slicing Framework Open issue #1 : Service != Realization

Works for me.
Yours,
Joel

On 3/25/2022 5:17 AM, Adrian Farrel wrote:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=> &d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e= 

_______________________________________________
Teas mailing list
[email-masked] <mailto:[email-masked]> 
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=> &d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e= 

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
_______________________________________________
Teas mailing list
[email-masked] <mailto:[email-masked]> 
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=> &d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=

---

From: <[email-masked]>
Date: Mon, 28 Mar 2022 06:20:35 +0000

Hi Adrian, al,

I think that it is safe to say that partitioning is always needed to realize a slice service. In reference to -10, I even tend to suggest this change:

==
OLD:
An IETF Network Slice is a slice of a network that uses
   IETF technology.

NEW:

An IETF Network Slice is a partition of a network that is provided using

   IETF technologies.

==

However, that partition does not need to involve only node resources that are partitioned (e.g., some nodes of a partition may exclusively belong to one single slice) or that partition resources are fully isolated. For example, it is completely fine that some form for resource preemption is allowed between slices that belong to the same customer or those engineered for internal use of an operator. I suggest to clarify this in the text by making this change:

====
OLD:

   Network slicing provides the ability to partition a physical network

   into multiple isolated logical networks of varying sizes, structures,

                 ^^^^^^^^

   and functions so that each slice can be dedicated to specific

   services or customers.

NEW:

   Network slicing provides the ability to partition a physical network

   into multiple logical networks of varying sizes, structures,

   and functions so that each slice can be dedicated to specific

   services or customers. The support of resource preemption between

                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   IETF network slices is deployment specific.
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
=====

Please note that this proposed change is consistent with the definition of “isolation” in the draft:

==

   Isolation:  As described in Section 7<https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices-10.txt#section-7>, a customer may request that

      its traffic within its IETF Network Slice service is isolated from

      the effects of other network services supported by the same

      provider.

===

and also this text:

==

   An IETF Network Slice could span multiple technologies and multiple

   administrative domains.  Depending on the IETF Network Slice

   customer's requirements, an IETF Network Slice could be isolated from

   other, often concurrent IETF Network Slices in terms of data, control

   and management planes.

==

Thank you.

Cheers,
Med

De : Teas <[email-masked]> De la part de Adrian Farrel
Envoyé : vendredi 25 mars 2022 22:22
À : 'Krzysztof Szarkowicz' <[email-masked]>
Cc : [email-masked]
Objet : Re: [Teas] [E] Re: Slicing Framework Open issue #1 : Service != Realization

Hi Krzysztof,

Cheers,
Adrian

From: Krzysztof Szarkowicz <[email-masked]<mailto:[email-masked]>>
Sent: 25 March 2022 17:57
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] [E] Re: Slicing Framework Open issue #1 : Service != Realization

Hi,

  the "IETF Network

  the "IETF Network

Regards,
Krzysztof

On 2022 -Mar-25, at 12:48, Jalil, Luay <luay.jalil=[email-masked]<mailto:luay.jalil=[email-masked]>> wrote:

+1

Regards,
Luay

On Fri, Mar 25, 2022 at 10:49 AM LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Best regards

Luis

-----Mensaje original-----
De: Teas <[email-masked]<mailto:[email-masked]>> En nombre de Joel M. Halpern
Enviado el: viernes, 25 de marzo de 2022 10:30
Para: [email-masked]<mailto:[email-masked]>
Asunto: Re: [Teas] Slicing Framework Open issue #1 : Service != Realization

Works for me.
Yours,
Joel

On 3/25/2022 5:17 AM, Adrian Farrel wrote:
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=ZgpFwbYBRDMbGaCALx4Ex8KrMyZD-gVEhsHKWD9592QJ8dwgs8zvLN3YyhpE0lAq&s=PT9yEot5W1FaYvK-vS_Gc8_apuR_Azv2CkH7JBiNeUw&e=

[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Mon, 28 Mar 2022 11:31:29 +0200

Hi Med, Adrian,

I still see the partition as realization, thus should be left to the docs/drafts describing the realization, rather than be mandated in framework doc. 

Section 7.2. says:

For example, traffic separation between different IETF Network Slices may be achieved using VPN technologies, such as L3VPN, L2VPN, EVPN, etc. Interference avoidance may be achieved by network capacity planning, allocating dedicated network resources, traffic policing or shaping, prioritizing in using shared network resources, etc. 

‘Allocating dedicated network resources’, which is my understanding of network partition, is one (and not the only one) of many tools that can be used for realization. 

But, if you are saying, that from, realization perspective for example I can call I partitioned my network by creating two flex-algos, or two sets of TE tunnels (one optimized for latency, another optimized for high capacity links, as an example), then definition of partition is very open, indeed. 

Thanks,
Krzysztof

> On 2022 -Mar-28, at 08:20, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Adrian, al,
>  
>    Isolation:  As described in Section 7 <https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices-10.txt#section-7>, a customer may request that
> De : Teas <[email-masked] <mailto:[email-masked]>> De la part de Adrian Farrel
> À : 'Krzysztof Szarkowicz' <[email-masked] <mailto:[email-masked]>>
> Cc : [email-masked] <mailto:[email-masked]>
> From: Krzysztof Szarkowicz <[email-masked] <mailto:[email-masked]>> 
> To: Adrian Farrel <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/teas <https://www.ietf.org/mailman/listinfo/teas>
>

---

From: <[email-masked]>
Date: Mon, 28 Mar 2022 09:36:43 +0000

Re-,

Manipulating flavors of flex-algos (+ appropriate admission control) is indeed a way to partition a network.

Cheers,
Med

De : Krzysztof Szarkowicz <[email-masked]>
Envoyé : lundi 28 mars 2022 11:31
À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>; [email-masked]
Cc : [email-masked]
Objet : Re: [Teas] [E] Re: Slicing Framework Open issue #1 : Service != Realization

Hi Med, Adrian,

Section 7.2. says:

Thanks,
Krzysztof

On 2022 -Mar-28, at 08:20, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Hi Adrian, al,

==
OLD:

NEW:

   IETF technologies.

==

====
OLD:

                 ^^^^^^^^

   services or customers.

NEW:

==

      provider.

===

and also this text:

==

   and management planes.

==

Thank you.

Cheers,
Med

De : Teas <[email-masked]<mailto:[email-masked]>> De la part de Adrian Farrel
Envoyé : vendredi 25 mars 2022 22:22
À : 'Krzysztof Szarkowicz' <[email-masked]<mailto:[email-masked]>>
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Teas] [E] Re: Slicing Framework Open issue #1 : Service != Realization

Hi Krzysztof,

Cheers,
Adrian

Hi,

  the "IETF Network

  the "IETF Network

Regards,
Krzysztof

+1

Regards,
Luay

Best regards

Luis

-----Mensaje original-----
De: Teas <[email-masked]<mailto:[email-masked]>> En nombre de Joel M. Halpern
Enviado el: viernes, 25 de marzo de 2022 10:30
Para: [email-masked]<mailto:[email-masked]>
Asunto: Re: [Teas] Slicing Framework Open issue #1 : Service != Realization

Works for me.
Yours,
Joel

Thank you.

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Mon, 28 Mar 2022 12:26:36 +0200

OK,

If a realization example of network partition is flex-algo + admission control, then I am fine.

Thanks,
Krzysztof

> On 2022 -Mar-28, at 11:36, <[email-masked]> <[email-masked]> wrote:
> 
> Re-,
>  
> On 2022 -Mar-28, at 08:20, <[email-masked] <mailto:[email-masked]>> <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi Adrian, al,
>