Subject: Re: [Teep] Charter Text

From: Lubna Dajani <[email-masked]>
Date: Tue, 12 Sep 2017 11:40:45 +0000

please allow me to echo Petr's responses.1. Yes2. Yes3. Yes4. Yes I am
personally very excited to see this WG form and I look forward to actively
contributing to the evolution of this protocol as I have since the ideation
stages of this protocol …
Thank you Nancy, Petr and everyone here…
Lubna__________________________________________________Lubna Dajani  I
 Allternet Ltd.@lubnadajani

@futuristasORG

+ 1 201 982 0934

Confidentiality Notice:The information contained in this email and any
attachments is intended only for the recipient[s] listed above and may be
privileged and confidential. Any dissemination, copying, or use of or reliance
upon such information by or to anyone other than the recipient[s] listed above
is prohibited. If you have received this message in error, please notify the
sender immediately at the email address above and destroy any and all copies of
this message.

Sent with Mixmax  

On Thu, Jul 20, 2017 2:48 AM, Petr Peterka [email-masked]  wrote:
Hi Nancy

I think we had a very productive meeting yesterday. Here are my answers to your
questions:

1) Do you understand what TEEP is trying to achieve? 

ANSWER: Yes, I do. I’d like to add that the charter may re-emphasize that the
proposed WG is not going to define the TEE or the TAM service themselves but
just the protocol between them. 

2) Is this work that should be done in general?

ANSWER: Yes, it should since there are going to be more and more trusted
execution environments (lower case) especially with the proliferation of IoT
devices which will need more security than what they have today.

3) Is this work that should be done in the IETF, or does it belong to somewhere
else?

ANSWER: Since we are trying to define a protocol that is independent of the
different TEE implementations, I believe that IETF is the right home for it.

4) Should we form a WG with given charter to work on this?

ANSWER: Yes, that is my recommendation.

Thanks

          Petr

From:  TEEP [mailto:[email-masked]] On Behalf Of Nancy Cam-Winget
(ncamwing)
Sent:  Thursday, July 20, 2017 11:13 AM
To:  [email-masked]
Subject:  Re: [Teep] Charter Text

All,

Please provide feedback on the results of yesterday’s side meeting.  In
particular, we’d like to get feedback on whether this the right scope and if we
have captured it appropriately. If it is not, also please comment and if
possible, provide suggestions for improvement.

We would like to continue discussion over email and get consensus around the 2nd 
 week of September so that we can have a path forward.  In particular we would
like to get answers for:

1) Do you understand what TEEP is trying to achieve? 

2) Is this work that should be done in general?

3) Is this work that should be done in the IETF, or does it belong to somewhere
else?

4) Should we form a WG with given charter to work on this?

Warm regards, 

    Nancy & Tero (TEEP BoF Chairs)

From: TEEP <[email-masked]> on behalf of Hannes Tschofenig <
[email-masked]>
Date: Wednesday, July 19, 2017 at 5:56 AM
To: "[email-masked]" <[email-masked]>
Subject: [Teep] Charter Text

Here is the charter text we came up in the side-meeting today. 

------

TEEP -- A Protocol for Dynamic Trusted Execution Environment Enablement Charter

The Trusted Execution Environment (TEE) is a secure area of a processor. The TEE
provides security features, such as isolated execution, integrity of Trusted
Applications along with confidentiality of their assets. In general terms, the
TEE offers an execution space that provides a higher level of security than a
"rich" operating system and more functionality than a secure element. For
example, implementations of the TEE concept have been developed by ARM, and
Intel using the TrustZone and the SGX technology, respectively.

To programmatically install, update, and delete applications running in the TEE,
this protocol runs between a service running within the TEE, a relay application
or service access point on the device's network stack and a server-side
infrastructure that interacts with and optionally maintains the applications.
Some tasks are security sensitive and the server side requires information about
the device characteristics in form of attestation and the device-side may
require information about the server.

Privacy considerations have to be taken into account with authentication
features and attestation.

This working group aims to develop an application layer protocol providing TEEs
with the following functionality,

* lifecycle management of trusted applications, and 

* security domain management.

A security domain allows a service provider's applications to be isolated so
that one security domain cannot be influenced by another, unless it exposes an
API to allow it.

The solution approach must take a wide range of TEE and relevant technologies
into account and will focus on the use of public key cryptography. 

The group will produce the following deliverables. First, an architecture
document describing the involved entities, their relationships, assumptions, the
keying framework and relevant use cases. Second, a solution document that
describes the above-described functionality. The choice of encoding format(s)
will be decided in the working group. The group may document several attestation
technologies considering the different hardware capabilities, performance,
privacy and operational properties.

The group will maintain a close relationship with the GlobalPlatform, Trusted
Computing Group,  and other relevant standards to ensure proper use of existing
TEE-relevant application layer interfaces. 

Milestones

Dec 2017     Submit "TEEP Architecture" document as WG item.

Feb 2018     Submit "TEEP Protocol" document as WG item.

July 2018     Submit "TEEP Architecture" to the IESG for publication as an
Informational RFC.

Feb 2019     Submit "TEEP Protocol" to the IESG for publication as a Proposed
Standard.

Additional calendar items: 

Nov 2017     IETF #100 Hackathon to work on TEEP protocol prototype
implementations. 

Mar 2018     1st interoperability event (at IETF #101).

Jul 2018       2nd interoperability event (at IETF #102).

IMPORTANT NOTICE: The contents of this email and any attachments are
confidential and may also be privileged. If you are not the intended recipient,
please notify the sender immediately and do not disclose the contents to any
other person, use it for any purpose, or store or copy the information in any
medium. Thank you.

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 12 Sep 2017 15:49:57 +0000

Thank you Lubna and Petr!

Would still like to hear from others and also solicit feedback on the proposed charter text.

Warm regards,
                Nancy

From: Lubna Dajani <[email-masked]>
Date: Tuesday, September 12, 2017 at 4:40 AM
To: Petr Peterka <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Charter Text

please allow me to echo Petr's responses.
1. Yes
2. Yes
3. Yes
4. Yes
 I am personally very excited to see this WG form and I look forward to actively contributing to the evolution of this protocol as I have since the ideation stages of this protocol …

Lubna
__________________________________________________
Lubna Dajani  I  Allternet Ltd.

@lubnadajani

@futuristasORG

+ 1 201 982 0934

Confidentiality Notice: The information contained in this email and any attachments is intended only for the recipient[s] listed above and may be privileged and confidential. Any dissemination, copying, or use of or reliance upon such information by or to anyone other than the recipient[s] listed above is prohibited. If you have received this message in error, please notify the sender immediately at the email address above and destroy any and all copies of this message.

Sent with Mixmax<https://mixmax.com/s/Sjmasx74wNoX3uu2B?utm_source=mixmax&utm_medium=email&utm_campaign=signature_link&utm_content=sent_with_mixmax>

On Thu, Jul 20, 2017 2:48 AM, Petr Peterka [email-masked]<mailto:[email-masked]> wrote:

Hi Nancy

I think we had a very productive meeting yesterday. Here are my answers to your questions:

ANSWER: Yes, I do. I’d like to add that the charter may re-emphasize that the proposed WG is not going to define the TEE or the TAM service themselves but just the protocol between them.

ANSWER: Yes, it should since there are going to be more and more trusted execution environments (lower case) especially with the proliferation of IoT devices which will need more security than what they have today.

3) Is this work that should be done in the IETF, or does it belong to somewhere else?

ANSWER: Since we are trying to define a protocol that is independent of the different TEE implementations, I believe that IETF is the right home for it.

Thanks

          Petr

From: TEEP [mailto:[email-masked]] On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, July 20, 2017 11:13 AM
To: [email-masked]
Subject: Re: [Teep] Charter Text

All,

Please provide feedback on the results of yesterday’s side meeting.  In particular, we’d like to get feedback on whether this the right scope and if we have captured it appropriately. If it is not, also please comment and if possible, provide suggestions for improvement.

We would like to continue discussion over email and get consensus around the 2nd week of September so that we can have a path forward.  In particular we would like to get answers for:

3) Is this work that should be done in the IETF, or does it belong to somewhere else?

Warm regards,

From: TEEP <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 19, 2017 at 5:56 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Teep] Charter Text

------

The Trusted Execution Environment (TEE) is a secure area of a processor. The TEE provides security features, such as isolated execution, integrity of Trusted Applications along with confidentiality of their assets. In general terms, the TEE offers an execution space that provides a higher level of security than a "rich" operating system and more functionality than a secure element. For example, implementations of the TEE concept have been developed by ARM, and Intel using the TrustZone and the SGX technology, respectively.

To programmatically install, update, and delete applications running in the TEE, this protocol runs between a service running within the TEE, a relay application or service access point on the device's network stack and a server-side infrastructure that interacts with and optionally maintains the applications. Some tasks are security sensitive and the server side requires information about the device characteristics in form of attestation and the device-side may require information about the server.

Privacy considerations have to be taken into account with authentication features and attestation.

This working group aims to develop an application layer protocol providing TEEs with the following functionality,

A security domain allows a service provider's applications to be isolated so that one security domain cannot be influenced by another, unless it exposes an API to allow it.

The solution approach must take a wide range of TEE and relevant technologies into account and will focus on the use of public key cryptography.

The group will produce the following deliverables. First, an architecture document describing the involved entities, their relationships, assumptions, the keying framework and relevant use cases. Second, a solution document that describes the above-described functionality. The choice of encoding format(s) will be decided in the working group. The group may document several attestation technologies considering the different hardware capabilities, performance, privacy and operational properties.

The group will maintain a close relationship with the GlobalPlatform, Trusted Computing Group,  and other relevant standards to ensure proper use of existing TEE-relevant application layer interfaces.

Milestones

July 2018     Submit "TEEP Architecture" to the IESG for publication as an Informational RFC.

Feb 2019     Submit "TEEP Protocol" to the IESG for publication as a Proposed Standard.

Nov 2017     IETF #100 Hackathon to work on TEEP protocol prototype implementations.

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: "刘大鹏(鹏成)" <[email-masked]>
Date: Wed, 13 Sep 2017 00:35:16 +0800

Hello Nancy,
Thanks!
Actually, there are lots of companies/experts are very interested in the proposed TEEP work. But they may not familiar with IETF process, I hope they would getting more active in the list after the long
summer vacation:)
Note: I have copied to all the experts that are interested in TEEP based on offline discussions. To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe: https://www.ietf.org/mailman/listinfo/teep
Thanks,Max------------------------------------------------------------------From:Nancy Cam-Winget (ncamwing) <[email-masked]>Send Time:2017年9月12日(星期二) 23:50To:Lubna Dajani <[email-masked]>; Petr Peterka <[email-masked]>Cc:[email-masked] <[email-masked]>Subject:Re: [Teep] Charter Text
Thank you Lubna and Petr! Would still like to hear from others and also solicit feedback on the proposed charter text. Warm regards,                Nancy From: Lubna Dajani <[email-masked]>
Date: Tuesday, September 12, 2017 at 4:40 AM
To: Petr Peterka <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Charter Text please allow me to echo Petr's responses. 1. Yes2. Yes3. Yes4. Yes  I am personally very excited to see this WG form and I look forward to actively contributing to the evolution of this protocol as I have since the ideation stages of this protocol …  Thank you Nancy, Petr and everyone here… Lubna__________________________________________________Lubna Dajani  I  Allternet Ltd.@lubnadajani@futuristasORG+ 1 201 982 0934  Confidentiality Notice: The information
 contained in this email and any attachments is intended only for the recipient[s] listed above and may be privileged and confidential. Any dissemination, copying, or use of or reliance upon such information by or to anyone other than the recipient[s] listed
 above is prohibited. If you have received this message in error, please notify the sender immediately at the email address above and destroy any and all copies of this message. Sent with 
Mixmax   On Thu, Jul 20, 2017 2:48 AM, Petr Peterka
[email-masked] wrote:Hi NancyI think we had a very productive meeting yesterday. Here are my answers to your questions: 1) Do you understand what TEEP is trying to achieve?
ANSWER: Yes, I do. I’d like to add that the charter may re-emphasize that the proposed WG is not going to define the TEE or the TAM service themselves but just the protocol between them.
 2) Is this work that should be done in general?ANSWER: Yes, it should since there are going to be more and more trusted execution environments (lower case) especially with the proliferation of IoT devices which will need more security
 than what they have today. 3) Is this work that should be done in the IETF, or does it belong to somewhere else?ANSWER: Since we are trying to define a protocol that is independent of the different TEE implementations, I believe that IETF is the right home for it. 4) Should we form a WG with given charter to work on this?ANSWER: Yes, that is my recommendation. Thanks          Petr From: TEEP [mailto:[email-masked]]
On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, July 20, 2017 11:13 AM
To: [email-masked]
Subject: Re: [Teep] Charter Text All,Please provide feedback on the results of yesterday’s side meeting.  In particular, we’d like to get feedback on whether this the right scope and if we have captured it appropriately. If it is not, also please comment and
 if possible, provide suggestions for improvement. We would like to continue discussion over email and get consensus around the 2nd week of September so that we can have a path forward.  In particular we would like to get answers for: 1) Do you understand what TEEP is trying to achieve?
2) Is this work that should be done in general?3) Is this work that should be done in the IETF, or does it belong to somewhere else?4) Should we form a WG with given charter to work on this? Warm regards,     Nancy & Tero (TEEP BoF Chairs) From: TEEP <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Wednesday, July 19, 2017 at 5:56 AM
To: "[email-masked]" <[email-masked]>
Subject: [Teep] Charter Text Here is the charter text we came up in the side-meeting today.
 ------

TEEP -- A Protocol for Dynamic Trusted Execution Environment Enablement Charter The Trusted Execution Environment (TEE) is a secure area of a processor. The TEE provides security features, such as isolated execution, integrity of Trusted Applications along with confidentiality of their assets.
 In general terms, the TEE offers an execution space that provides a higher level of security than a "rich" operating system and more functionality than a secure element. For example, implementations of the TEE concept have been developed by ARM, and Intel
 using the TrustZone and the SGX technology, respectively. To programmatically install, update, and delete applications running in the TEE, this protocol runs between a service running within the TEE, a relay application or service access point on the device's network
 stack and a server-side infrastructure that interacts with and optionally maintains the applications. Some tasks are security sensitive and the server side requires information about the device characteristics in form of attestation and the device-side may
 require information about the server. Privacy considerations have to be taken into account with authentication features and attestation. This working group aims to develop an application layer protocol providing TEEs with the following functionality,* lifecycle management of trusted applications, and
* security domain management. A security domain allows a service provider's applications to be isolated so that one security domain cannot be influenced by another, unless it exposes an API to allow it. The solution approach must take a wide range of TEE and relevant technologies into account and will focus on the use of public key cryptography.
 The group will produce the following deliverables. First, an architecture document describing the involved entities, their relationships, assumptions, the keying framework and relevant use cases. Second, a solution
 document that describes the above-described functionality. The choice of encoding format(s) will be decided in the working group. The group may document several attestation technologies considering the different hardware capabilities, performance, privacy
 and operational properties. The group will maintain a close relationship with the GlobalPlatform, Trusted Computing Group,  and other relevant standards to ensure proper use of existing TEE-relevant application layer interfaces.
 Milestones Dec 2017     Submit "TEEP Architecture" document as WG item. Feb 2018     Submit "TEEP Protocol" document as WG item. July 2018     Submit "TEEP Architecture" to the IESG for publication as an Informational RFC. Feb 2019     Submit "TEEP Protocol" to the IESG for publication as a Proposed Standard. Additional calendar items:  Nov 2017     IETF #100 Hackathon to work on TEEP protocol prototype implementations.
 Mar 2018     1st interoperability event (at IETF #101). Jul 2018       2nd interoperability event (at IETF #102). IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any
 purpose, or store or copy the information in any medium. Thank you.

---

From: Dapeng Liu <[email-masked]>
Date: Tue, 12 Sep 2017 16:49:02 +0000

Hello Nancy,

Thanks!

Actually, there are lots of companies/experts are very interested in the
proposed TEEP work. But they may not familiar with IETF process, I hope
they would getting more active in the list after the long
summer vacation:)

Note: I have copied to all the experts that are interested in TEEP based on
offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list
first if you want to reply.   Here is how to subscribe:
https://www.ietf.org/mailman/listinfo/teep

Thanks,
Max
------------------------------------------------------------------
From:Nancy Cam-Winget (ncamwing) <[email-masked]>
Send Time:2017年9月12日(星期二) 23:50
To:Lubna Dajani <[email-masked]>; Petr Peterka <
[email-masked]>
Cc:[email-masked] <[email-masked]>
Subject:Re: [Teep] Charter Text

Would still like to hear from others and also solicit feedback on the
proposed charter text.

Warm regards,

                Nancy

*From: *Lubna Dajani <[email-masked]>

*Date: *Tuesday, September 12, 2017 at 4:40 AM
*To: *Petr Peterka <[email-masked]>

*Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>

*Subject: *Re: [Teep] Charter Text

1. Yes

2. Yes

3. Yes

4. Yes

 I am personally very excited to see this WG form and I look forward to
actively contributing to the evolution of this protocol as I have since the
ideation stages of this protocol …

Lubna

@lubnadajani

@futuristasORG

+ 1 201 982 0934 <(201)%20982-0934>

*Confidentiality Notice:* The information contained in this email and any
attachments is intended only for the recipient[s] listed above and may be
privileged and confidential. Any dissemination, copying, or use of or
reliance upon such information by or to anyone other than the recipient[s]
listed above is prohibited. If you have received this message in error,
please notify the sender immediately at the email address above and destroy
any and all copies of this message.

Sent with Mixmax
<https://mixmax.com/s/Sjmasx74wNoX3uu2B?utm_source=mixmax&utm_medium=email&utm_campaign=signature_link&utm_content=sent_with_mixmax>

Hi Nancy

I think we had a very productive meeting yesterday. Here are my answers to
your questions:

ANSWER: Yes, I do. I’d like to add that the charter may re-emphasize that
the proposed WG is not going to define the TEE or the TAM service
themselves but just the protocol between them.

ANSWER: Yes, it should since there are going to be more and more trusted
execution environments (lower case) especially with the proliferation of
IoT devices which will need more security than what they have today.

3) Is this work that should be done in the IETF, or does it belong to
somewhere else?

Thanks

          Petr

  <#m_4019887533134155472_this>

*From:* TEEP [mailto:[email-masked]] *On Behalf Of *Nancy Cam-Winget
(ncamwing)
*Sent:* Thursday, July 20, 2017 11:13 AM
*To:* [email-masked]
*Subject:* Re: [Teep] Charter Text

All,

Please provide feedback on the results of yesterday’s side meeting.  In
particular, we’d like to get feedback on whether this the right scope and
if we have captured it appropriately. If it is not, also please comment and
if possible, provide suggestions for improvement.

We would like to continue discussion over email and get consensus around
the 2nd week of September so that we can have a path forward.  In
particular we would like to get answers for:

3) Is this work that should be done in the IETF, or does it belong to
somewhere else?

Warm regards,

*From: *TEEP <[email-masked]> on behalf of Hannes Tschofenig <
[email-masked]>
*Date: *Wednesday, July 19, 2017 at 5:56 AM
*To: *"[email-masked]" <[email-masked]>
*Subject: *[Teep] Charter Text

------

TEEP -- A Protocol for Dynamic Trusted Execution Environment Enablement
Charter

The Trusted Execution Environment (TEE) is a secure area of a processor.
The TEE provides security features, such as isolated execution, integrity
of Trusted Applications along with confidentiality of their assets. In
general terms, the TEE offers an execution space that provides a higher
level of security than a "rich" operating system and more functionality
than a secure element. For example, implementations of the TEE concept have
been developed by ARM, and Intel using the TrustZone and the SGX
technology, respectively.

To programmatically install, update, and delete applications running in the
TEE, this protocol runs between a service running within the TEE, a relay
application or service access point on the device's network stack and a
server-side infrastructure that interacts with and optionally maintains the
applications. Some tasks are security sensitive and the server side
requires information about the device characteristics in form of
attestation and the device-side may require information about the server.

This working group aims to develop an application layer protocol providing
TEEs with the following functionality,

A security domain allows a service provider's applications to be isolated
so that one security domain cannot be influenced by another, unless it
exposes an API to allow it.

The solution approach must take a wide range of TEE and relevant
technologies into account and will focus on the use of public key
cryptography.

The group will produce the following deliverables. First, an architecture
document describing the involved entities, their relationships,
assumptions, the keying framework and relevant use cases. Second, a
solution document that describes the above-described functionality. The
choice of encoding format(s) will be decided in the working group. The
group may document several attestation technologies considering the
different hardware capabilities, performance, privacy and operational
properties.

The group will maintain a close relationship with the GlobalPlatform,
Trusted Computing Group,  and other relevant standards to ensure proper use
of existing TEE-relevant application layer interfaces.

Milestones

Feb 2019     Submit "TEEP Protocol" to the IESG for publication as a
Proposed Standard.

IMPORTANT NOTICE: The contents of this email and any attachments are
confidential and may also be privileged. If you are not the intended
recipient, please notify the sender immediately and do not disclose the
contents to any other person, use it for any purpose, or store or copy the
information in any medium. Thank you.

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 12 Sep 2017 17:00:09 +0000

Thanks Max!

…..and I presume you are OK w/the charter text?   -Nancy

From: TEEP <[email-masked]> on behalf of Dapeng Liu <[email-masked]>
Date: Tuesday, September 12, 2017 at 9:49 AM
To: Lubna Dajani <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, teep <[email-masked]>, Mingliang Pei <[email-masked]>, Marc Canel <[email-masked]>, "[email-masked]" <[email-masked]>, Rob Coombs <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Nick Cook <[email-masked]>, "[email-masked]" <[email-masked]>, Hannes Tschofenig <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Pengcheng Zou <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, 成 鹏 <[email-masked]>
Subject: Re: [Teep] Charter Text

Hello Nancy,

Thanks!

Note: I have copied to all the experts that are interested in TEEP based on offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe: https://www.ietf.org/mailman/listinfo/teep

Thanks,
Max
------------------------------------------------------------------
From:Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>>
Send Time:2017年9月12日(星期二) 23:50
To:Lubna Dajani <[email-masked]<mailto:[email-masked]>>; Petr Peterka <[email-masked]<mailto:[email-masked]>>
Cc:[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject:Re: [Teep] Charter Text

Warm regards,
                Nancy

From: Lubna Dajani <[email-masked]<mailto:[email-masked]>>

Date: Tuesday, September 12, 2017 at 4:40 AM
To: Petr Peterka <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Lubna

@lubnadajani

@futuristasORG

+ 1 201 982 0934<tel:(201)%20982-0934>

Hi Nancy

Thanks

          Petr

From: TEEP [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, July 20, 2017 11:13 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teep] Charter Text

All,

Warm regards,

------

Milestones

---

From: Dapeng Liu <[email-masked]>
Date: Wed, 13 Sep 2017 08:14:20 +0000

Hi Nancy,

Yes, I support the proposed charter.

Thanks,
Max

On Wed, Sep 13, 2017 at 1:00 AM Nancy Cam-Winget (ncamwing) <
[email-masked]> wrote:

> *From: *TEEP <[email-masked]> on behalf of Dapeng Liu <
> [email-masked]>
> *Date: *Tuesday, September 12, 2017 at 9:49 AM
> *To: *Lubna Dajani <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>,
> teep <[email-masked]>, Mingliang Pei <[email-masked]>, Marc
> Canel <[email-masked]>, "[email-masked]" <
> [email-masked]>, Rob Coombs <[email-masked]>, "
> [email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, Nick Cook <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, Hannes Tschofenig <[email-masked]>,
> "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, Pengcheng Zou <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>,
> "[email-masked]" <[email-masked]>, 成 鹏 <
> [email-masked]>
>
>
> To all the experts copied in this mail: Please subscribe to TEEP email
> list first if you want to reply.   Here is how to subscribe:
> ANSWER: Since we are trying to define a protocol that is independent of
> the different TEE implementations, I believe that IETF is the right home
> for it.
>
>
>
>   <#m_8524250949379227207_m_4019887533134155472_this>
>
> *From:* TEEP [mailto:[email-masked]] *On Behalf Of *Nancy
> Cam-Winget (ncamwing)
> To programmatically install, update, and delete applications running in
> the TEE, this protocol runs between a service running within the TEE, a
> relay application or service access point on the device's network stack and
> a server-side infrastructure that interacts with and optionally maintains
> the applications. Some tasks are security sensitive and the server side

---

From: "Paczkowski, Lyle W [CTO]" <[email-masked]>
Date: Tue, 19 Sep 2017 13:45:13 +0000

Sprint supports

Lyle W. Paczkowski
Technology Strategy - CTO
M: 913-484-3490  O: 913-315-1579
[email-masked]

From: Pengcheng Zou [mailto:[email-masked]]
Sent: Monday, September 18, 2017 6:33 PM
To: 刘大鹏(鹏成) <[email-masked]>
Cc: Lubna Dajani <[email-masked]>; Petr Peterka <[email-masked]>; TEEP <[email-masked]>; [email-masked]; Mingliang_Pei <[email-masked]>; Marc.Canel <[email-masked]>; Richard.Parris <[email-masked]>; Rob.Coombs <[email-masked]>; qingyang.meng <[email-masked]>; brian_witten <[email-masked]>; henry.j.lee <[email-masked]>; Nick.Cook <[email-masked]>; Parsel, Mike M [CTO] <[email-masked]>; Hannes.Tschofenig <[email-masked]>; zhijian.zhang <[email-masked]>; zhoup <[email-masked]>; maojun.wei <[email-masked]>; dominique.bolignano <[email-masked]>; heekwan.lee <[email-masked]>; mike.hendrick <[email-masked]>; xiayubin <[email-masked]>; sangjin.park <[email-masked]>; Paczkowski, Lyle W [CTO] <[email-masked]>; fmw <[email-masked]>; philip.attfield <[email-masked]>; Andrew.Atyeo <[email-masked]>; paromix <[email-masked]>
Subject: Re: [Teep] Charter Text

Hi, Nancy, Max

Thundersoft supports the proposed charter.

best regards,
----
Pengcheng ZOU
SVP & CTO
Thunder Software Technology Co., Ltd.
Tel: +86-10-62662686
Mobile: +86-13911029732
Email: [email-masked]<mailto:[email-masked]>

On Wed, Sep 13, 2017 at 12:35 AM, 刘大鹏(鹏成) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Nancy,

Thanks!

Note: I have copied to all the experts that are interested in TEEP based on offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe: https://www.ietf.org/mailman/listinfo/teep<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep&data=02%7C01%7Clyle.w.paczkowski%40sprint.com%7Cd87096b67f97409b8ede08d4feedb42b%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C636413744268049922&sdata=5E9k7G76Ut6cz0mZJmYiI%2Bv17kv2CA9B4B6QhNbXuss%3D&reserved=0>

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Sent with Mixmax<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmixmax.com%2Fs%2FSjmasx74wNoX3uu2B%3Futm_source%3Dmixmax%26utm_medium%3Demail%26utm_campaign%3Dsignature_link%26utm_content%3Dsent_with_mixmax&data=02%7C01%7Clyle.w.paczkowski%40sprint.com%7Cd87096b67f97409b8ede08d4feedb42b%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C636413744268049922&sdata=ceDXgmqCauAQSHKnwp7U7hegH68WoNZYA%2F1rKcJ%2B8KM%3D&reserved=0>

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 22 Sep 2017 10:10:57 +0800

hi,

 Beijing Laser Tech. support it.thanks.

周鹏
CEO
北京雷森科技发展有限公司
Beijing Laser Technology Development CO.,LTD
地址：西直门北大街甲43号金运大厦7层  邮编100044
手机：18910750012/15601105750/13911779990
网址：www.bjleisen.com
 
From: Dapeng Liu
Date: 2017-09-13 00:49
To: Lubna Dajani; ppeterka; teep-bounces; teep; Mingliang Pei; Marc Canel; [email-masked]; Rob Coombs; qingyang.meng; brian_witten; [email-masked]; Nick Cook; [email-masked]; Hannes Tschofenig; zhijian.zhang; zhoup; maojun.wei; dominique.bolignano; [email-masked]; [email-masked]; xiayubin; sangjin.park; lyle.w.paczkowski; Pengcheng Zou; fmw; philip.attfield; Andrew.Atyeo; paromix; ppeterkaa; 成 鹏
Subject: re: [Teep] Charter Text
Hello Nancy,

Thanks!

Thanks,
Max
To:Lubna Dajani <[email-masked]>; Petr Peterka <[email-masked]>

 
Warm regards,
                Nancy

 

Lubna

Sent with Mixmax 

 

 
Thanks
          Petr

All,

 
Warm regards, 
 
From: TEEP <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Wednesday, July 19, 2017 at 5:56 AM
To: "[email-masked]" <[email-masked]>
Subject: [Teep] Charter Text

------

 

 

 
 
Milestones

---

From: Mingliang Pei <[email-masked]>
Date: Tue, 19 Sep 2017 19:19:34 +0000

Hi Nancy,

Symantec also supports the proposed charter text, and yes to all four questions asked, echoing Petr’s responses .

Thanks,

Ming

From: "Paczkowski, Lyle W [CTO]" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 19, 2017 at 6:45 AM
To: Pengcheng Zou <[email-masked]<mailto:[email-masked]>>, "Dapeng 刘大鹏(鹏成) Liu" <[email-masked]<mailto:[email-masked]>>
Cc: Lubna Dajani <[email-masked]<mailto:[email-masked]>>, Petr Peterka <[email-masked]<mailto:[email-masked]>>, TEEP <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Mingliang Pei <[email-masked]<mailto:[email-masked]>>, Marc Canel <[email-masked]<mailto:[email-masked]>>, Richard Parris <[email-masked]<mailto:[email-masked]>>, "Rob.Coombs" <[email-masked]<mailto:[email-masked]>>, "qingyang.meng" <[email-masked]<mailto:[email-masked]>>, Brian Witten <[email-masked]<mailto:[email-masked]>>, Henry Lee <[email-masked]<mailto:[email-masked]>>, Nick Cook <[email-masked]<mailto:[email-masked]>>, "Parsel, Mike M [CTO]" <[email-masked]<mailto:[email-masked]>>, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>, "zhijian.zhang" <[email-masked]<mailto:[email-masked]>>, zhoup <[email-masked]<mailto:[email-masked]>>, "maojun.wei" <[email-masked]<mailto:[email-masked]>>, "dominique.bolignano" <[email-masked]<mailto:[email-masked]>>, "heekwan.lee" <[email-masked]<mailto:[email-masked]>>, Mike Hendrick <[email-masked]<mailto:[email-masked]>>, xiayubin <[email-masked]<mailto:[email-masked]>>, "sangjin.park" <[email-masked]<mailto:[email-masked]>>, fmw <[email-masked]<mailto:[email-masked]>>, "philip.attfield" <[email-masked]<mailto:[email-masked]>>, Andrew Atyeo <[email-masked]<mailto:[email-masked]>>, Minho Yoo <[email-masked]<mailto:[email-masked]>>
Subject: [EXT] RE: [Teep] Charter Text

Sprint supports

Lyle W. Paczkowski
Technology Strategy - CTO
M: 913-484-3490  O: 913-315-1579
[email-masked]<mailto:[email-masked]>

From: Pengcheng Zou [mailto:[email-masked]]
Sent: Monday, September 18, 2017 6:33 PM
To: 刘大鹏(鹏成) <[email-masked]<mailto:[email-masked]>>
Cc: Lubna Dajani <[email-masked]<mailto:[email-masked]>>; Petr Peterka <[email-masked]<mailto:[email-masked]>>; TEEP <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mingliang_Pei <[email-masked]<mailto:[email-masked]>>; Marc.Canel <[email-masked]<mailto:[email-masked]>>; Richard.Parris <[email-masked]<mailto:[email-masked]>>; Rob.Coombs <[email-masked]<mailto:[email-masked]>>; qingyang.meng <[email-masked]<mailto:[email-masked]>>; brian_witten <[email-masked]<mailto:[email-masked]>>; henry.j.lee <[email-masked]<mailto:[email-masked]>>; Nick.Cook <[email-masked]<mailto:[email-masked]>>; Parsel, Mike M [CTO] <[email-masked]<mailto:[email-masked]>>; Hannes.Tschofenig <[email-masked]<mailto:[email-masked]>>; zhijian.zhang <[email-masked]<mailto:[email-masked]>>; zhoup <[email-masked]<mailto:[email-masked]>>; maojun.wei <[email-masked]<mailto:[email-masked]>>; dominique.bolignano <[email-masked]<mailto:[email-masked]>>; heekwan.lee <[email-masked]<mailto:[email-masked]>>; mike.hendrick <[email-masked]<mailto:[email-masked]>>; xiayubin <[email-masked]<mailto:[email-masked]>>; sangjin.park <[email-masked]<mailto:[email-masked]>>; Paczkowski, Lyle W [CTO] <[email-masked]<mailto:[email-masked]>>; fmw <[email-masked]<mailto:[email-masked]>>; philip.attfield <[email-masked]<mailto:[email-masked]>>; Andrew.Atyeo <[email-masked]<mailto:[email-masked]>>; paromix <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teep] Charter Text

Hi, Nancy, Max

best regards,
----
Pengcheng ZOU
SVP & CTO

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Fri, 22 Sep 2017 04:49:30 +0000

Thank you all for responding  and for demonstrating there is good support to move this work along.

It would be good to get discussions started on the current drafts and milestones as well.

                Nancy

From: TEEP <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Thursday, September 21, 2017 at 7:10 PM
To: Dapeng Liu <[email-masked]>, Lubna Dajani <[email-masked]>, "[email-masked]" <[email-masked]>, teep-bounces <[email-masked]>, teep <[email-masked]>, Mingliang Pei <[email-masked]>, "Marc.Canel" <[email-masked]>, Richard Parris <[email-masked]>, Rob Coombs <[email-masked]>, "qingyang.meng" <[email-masked]>, Brian Witten <[email-masked]>, "[email-masked]" <[email-masked]>, Nick Cook <[email-masked]>, "[email-masked]" <[email-masked]>, Hannes Tschofenig <[email-masked]>, "zhijian.zhang" <[email-masked]>, 魏茂军 <[email-masked]>, Dominique Bolignano <[email-masked]>, "[email-masked]" <[email-masked]>, Mike Hendrick <[email-masked]>, XiaYubin <[email-masked]>, "[email-masked]" <[email-masked]>, "Paczkowski, Lyle W [CTO]" <[email-masked]>, Pengcheng Zou <[email-masked]>, "[email-masked]" <[email-masked]>, "philip.attfield" <[email-masked]>, "Andrew.Atyeo" <[email-masked]>, paromix <[email-masked]>, ppeterkaa <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Charter Text

hi,

网址：www.bjleisen.c<http://www.opentsm.cn>om

From: Dapeng Liu<mailto:[email-masked]>
Date: 2017-09-13 00:49
To: Lubna Dajani<mailto:[email-masked]>; ppeterka<mailto:[email-masked]>; teep-bounces<mailto:[email-masked]>; teep<mailto:[email-masked]>; Mingliang Pei<mailto:[email-masked]>; Marc Canel<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Rob Coombs<mailto:[email-masked]>; qingyang.meng<mailto:[email-masked]>; brian_witten<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Nick Cook<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Hannes Tschofenig<mailto:[email-masked]>; zhijian.zhang<mailto:[email-masked]>; zhoup<mailto:[email-masked]>; maojun.wei<mailto:[email-masked]>; dominique.bolignano<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; xiayubin<mailto:[email-masked]>; sangjin.park<mailto:[email-masked]>; lyle.w.paczkowski<mailto:[email-masked]>; Pengcheng Zou<mailto:[email-masked]>; fmw<mailto:[email-masked]>; philip.attfield<mailto:[email-masked]>; Andrew.Atyeo<mailto:[email-masked]>; paromix<mailto:[email-masked]>; ppeterkaa<mailto:[email-masked]>; 成 鹏<mailto:[email-masked]>
Subject: re: [Teep] Charter Text
Hello Nancy,

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Fri, 22 Sep 2017 07:59:58 +0000

Qualcomm would like to ensure that the charter and proposed deliverables are properly differentiated from work occurring in GlobalPlatform based on the OTrP contribution which has been accepted as a GlobalPlatform work item.

Since the proposed charter for teep includes a close relationship with GlobalPlatform, Qualcomm suggests some alignment between the organisations to ensure that there is a single, definitive, set of standards defining OTrP as the best outcome for all participants.

---
Jeremy O’Donoghue                            email: [email-masked]<mailto:[email-masked]>
Engineer, Principal/Manager                  tel:   +44 1252 363189
NFC & Secure Software and Systems

On 22 Sep 2017, at 05:49, Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>> wrote:

                Nancy

From: TEEP <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 21, 2017 at 7:10 PM
To: Dapeng Liu <[email-masked]<mailto:[email-masked]>>, Lubna Dajani <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, teep-bounces <[email-masked]<mailto:[email-masked]>>, teep <[email-masked]<mailto:[email-masked]>>, Mingliang Pei <[email-masked]<mailto:[email-masked]>>, "Marc.Canel" <[email-masked]<mailto:[email-masked]>>, Richard Parris <[email-masked]<mailto:[email-masked]>>, Rob Coombs <[email-masked]<mailto:[email-masked]>>, "qingyang.meng" <[email-masked]<mailto:[email-masked]>>, Brian Witten <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Nick Cook <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>, "zhijian.zhang" <[email-masked]<mailto:[email-masked]>>, 魏茂军<[email-masked]<mailto:[email-masked]>>, Dominique Bolignano <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Mike Hendrick <[email-masked]<mailto:[email-masked]>>, XiaYubin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Paczkowski, Lyle W [CTO]" <[email-masked]<mailto:[email-masked]>>, Pengcheng Zou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "philip.attfield" <[email-masked]<mailto:[email-masked]>>, "Andrew.Atyeo" <[email-masked]<mailto:[email-masked]>>, paromix <[email-masked]<mailto:[email-masked]>>, ppeterkaa <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teep] Charter Text

hi,

网址：www.bjleisen.c<http://www.opentsm.cn/>om

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

Thanks
          Petr
 <x-msg://13/#m_4019887533134155472_this>

All,

Warm regards,

------

Milestones

_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teep

---

From: "Wheeler, David M" <[email-masked]>
Date: Fri, 22 Sep 2017 14:26:38 +0000

Jeremy,
I understand your perspective and concern (I think, but would like to hear more). From Intel’s side, we have some issues with “too close” relationship to GP, because GP’s definition of TEE security ties that security to trusted boot. I understand that TZ, and even some of Intel’s TEEs (Android Trusty implementation) require a trusted secure boot in order to themselves be secure, but Intel also has TEEs that are *completely separated* from secure boot, and therefore do not require a secure booted platform to retain security.

Too close a relationship to GP will create issues around this definition. We need greater discussion around this, otherwise, by definition it rejects certain Intel TEEs (SGX primarily) and then Intel would consider this an implementation specific definition aligned to TrustZone, and not a general TEE protocol.

I think we need to talk more about this. I agree there is a lot of good stuff in GP that we should leverage.

Are you open to changing some of these core definitions, and working through the implications of those changes with us? This will separate us somewhat form GP standards, I think.

Very interested in your thoughts and perspective.
Thanks,
Dave Wheeler

From: TEEP [mailto:[email-masked]] On Behalf Of Jeremy O'Donoghue
Sent: Friday, September 22, 2017 1:00 AM
To: Nancy Cam-Winget (ncamwing) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teep] Charter Text

---

                Nancy

hi,

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

Thanks
          Petr

All,

Warm regards,

------

Milestones

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Fri, 22 Sep 2017 15:01:01 +0000

Hi Dave,

On 22 Sep 2017, at 15:26, Wheeler, David M <[email-masked]<mailto:[email-masked]>> wrote:

You are correct on this point. However, the GP notion of “trusted boot” allows quite a lot of wiggle room - the essential requirement is that the mechanism whereby the TEE is instantiated is bound to a secure root of trust on the SoC or on off-SoC security processor. I don’t know enough about SGX to be able to say whether it could meet this definition.

Most actual implementations of GP TEEs are bound to the ARM TZ architecture, so there may well be some bias to that in some of the informative material around a GP TEE.

However, implementations of most of the specifications e.g. the GP Internal Core API, Management Framework, OTrP etc. are not bound to that security definition. Both TMF and the GP approach to OTrP are explicitly designed to support management of non-GP TEE.

I do recognise that being outside the GP Security definition might pose commercial difficulties in such an approach.

My suspicion is that it also rejects ARM Cortex-M Trustzone for similar reasons (which I think has some similarities to SGX in its approach)

I think there is a need to have standards supporting TEEs that are not rooted in a secure boot style root of trust, and (ideally) for these to behave similarly from a developer and management perspective to TEEs that have such a root.

I would have thought that the main effort in such a case would be to define a system architecture, security requirements and (eventually) a Protection Profile - this looks a long way from the charter as currently proposed.

I would need to discuss further internally as to whether that is an effort to which I would be able to contribute.

Best regards
Jeremy

From: TEEP [mailto:[email-masked]] On Behalf Of Jeremy O'Donoghue
Sent: Friday, September 22, 2017 1:00 AM
To: Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teep] Charter Text

---

                Nancy

hi,

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

Thanks
          Petr

All,

Warm regards,

------

Milestones

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Fri, 22 Sep 2017 16:00:29 +0000

Folks,

As a reminder, while it has been good to get recognition that this is an area of interest that perhaps the IETF should look at chartering, it is important to note that the consensus is not about “voting by corporation” but more about individuals who feel this is important and express support and incite discussion.

That said, moving forward please join  (those who have responded to this email and are in the “To”) or have your colleagues join the mail group to continue discussions.

Thanks,  Nancy

hi,

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

---

From: Brian Witten <[email-masked]>
Date: Fri, 22 Sep 2017 16:17:17 +0000

Hi Nancy,

Many Thanks!  In that spirit, please allow me to echo Lubna, Ming, Petr & so many others stating "yes, yes, yes, yes," and sharing my excitement for the formation of this Working Group.  Thank You Again!

Looking Forward,
Brian

Brian Witten
Sr. Director, Symantec Research Labs

+1-571-215-8224<tel:+1-571-215-8224>
[email-masked]<mailto:[email-masked]>

On Sep 22, 2017, at 9:01 AM, Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>> wrote:

Folks,

Thanks,  Nancy

From: TEEP <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 21, 2017 at 7:10 PM
To: Dapeng Liu <[email-masked]<mailto:[email-masked]>>, Lubna Dajani <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, teep-bounces <[email-masked]<mailto:[email-masked]>>, teep <[email-masked]<mailto:[email-masked]>>, Mingliang Pei <[email-masked]<mailto:[email-masked]>>, "Marc.Canel" <[email-masked]<mailto:[email-masked]>>, Richard Parris <[email-masked]<mailto:[email-masked]>>, Rob Coombs <[email-masked]<mailto:[email-masked]>>, "qingyang.meng" <[email-masked]<mailto:[email-masked]>>, Brian Witten <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Nick Cook <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>, "zhijian.zhang" <[email-masked]<mailto:[email-masked]>>, 魏茂军 <[email-masked]<mailto:[email-masked]>>, Dominique Bolignano <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Mike Hendrick <[email-masked]<mailto:[email-masked]>>, XiaYubin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Paczkowski, Lyle W [CTO]" <[email-masked]<mailto:[email-masked]>>, Pengcheng Zou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "philip.attfield" <[email-masked]<mailto:[email-masked]>>, "Andrew.Atyeo" <[email-masked]<mailto:[email-masked]>>, paromix <[email-masked]<mailto:[email-masked]>>, ppeterkaa <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teep] Charter Text

hi,

网址：www.bjleisen.c<https://clicktime.symantec.com/a/1/Z-UN1ts7UmRDFJ3ulEwM39nbYooGm1HQ0Z68-lFRihI=?d=QlxjVtNtDHe1XKIFOWIDxPuEebZVcwVy_T_aj1YTYjR40EZg0g8shiChsmF0TlhcqPmvkfoWyJ2hhRbY7K6Iv_wTK46Tf1zMrIdnYACASVQ5ZG6G36aoflVGckndhI2EgA-dpcHgV1XfxCDE7OcOdZB5WsaSXPfqNWq0PaFhoilj9gupBWn30KZr5kUJufTrXdHIXV-crEjKyF0rftCU1aY7EM9SunbAO-yxSiKZl0myDTa_-OA9FkZrkJgJ883aufhMbhW3KihStmtFp-aOXNS2R-VEhQnjZVBJE-4rPkGmaxYaMBRtAl2AguseKmS8AG6pERUx8chp2Y4XUMEPI2NX7x6xRgDM8NE9JOwGFw%3D%3D&u=http%3A%2F%2Fwww.opentsm.cn>om

Thanks!

Note: I have copied to all the experts that are interested in TEEP based on offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe: https://www.ietf.org/mailman/listinfo/teep<https://clicktime.symantec.com/a/1/a688UaKqHQcDXj1137PVi_ZNjAbe_LjbKNg0yQTHnnc=?d=QlxjVtNtDHe1XKIFOWIDxPuEebZVcwVy_T_aj1YTYjR40EZg0g8shiChsmF0TlhcqPmvkfoWyJ2hhRbY7K6Iv_wTK46Tf1zMrIdnYACASVQ5ZG6G36aoflVGckndhI2EgA-dpcHgV1XfxCDE7OcOdZB5WsaSXPfqNWq0PaFhoilj9gupBWn30KZr5kUJufTrXdHIXV-crEjKyF0rftCU1aY7EM9SunbAO-yxSiKZl0myDTa_-OA9FkZrkJgJ883aufhMbhW3KihStmtFp-aOXNS2R-VEhQnjZVBJE-4rPkGmaxYaMBRtAl2AguseKmS8AG6pERUx8chp2Y4XUMEPI2NX7x6xRgDM8NE9JOwGFw%3D%3D&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep>

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Sent with Mixmax<https://clicktime.symantec.com/a/1/2U4FM9O1y9tVhg8IDBvwcrRZlBUW-frWDE4BJKJvx2A=?d=QlxjVtNtDHe1XKIFOWIDxPuEebZVcwVy_T_aj1YTYjR40EZg0g8shiChsmF0TlhcqPmvkfoWyJ2hhRbY7K6Iv_wTK46Tf1zMrIdnYACASVQ5ZG6G36aoflVGckndhI2EgA-dpcHgV1XfxCDE7OcOdZB5WsaSXPfqNWq0PaFhoilj9gupBWn30KZr5kUJufTrXdHIXV-crEjKyF0rftCU1aY7EM9SunbAO-yxSiKZl0myDTa_-OA9FkZrkJgJ883aufhMbhW3KihStmtFp-aOXNS2R-VEhQnjZVBJE-4rPkGmaxYaMBRtAl2AguseKmS8AG6pERUx8chp2Y4XUMEPI2NX7x6xRgDM8NE9JOwGFw%3D%3D&u=https%3A%2F%2Fmixmax.com%2Fs%2FSjmasx74wNoX3uu2B%3Futm_source%3Dmixmax%26amp%3Butm_medium%3Demail%26amp%3Butm_campaign%3Dsignature_link%26amp%3Butm_content%3Dsent_with_mixmax>

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://clicktime.symantec.com/a/1/sHtnECS9Wu1mQdgDIGbrebTnYImDEvc_bE2-G7ne1os=?d=krF61bpPTLAqvMf14r8w_50Ailj_JZDXYJgqineuwBtoCT6P_3BNom4ll1KlHhJZu7O1hYfbGBdFai8q8Lqu3ztreuNcuN0BZmZJksFxrIO0cqt-GH787jd01ElrAqT63HOz_UKX9vTSJhjyn5OLWj2HpF391CSqqbyn31BW71GLc9X7ZXXhyMu6vNX_1IXT1zZI96Zn7qNxk1oIjTTrkvMF1lhpST_AyiEoLMqNH7GPuALAhtl7z3Ax_OcLczEr_q3ir3X63f9e0RFTfzvZIn8B2YblxwK53y5cLIueB6u76fzn6NF8TDYq4mDb5zLXjfowXlJ-t4CELJcjzAwwC5x5d54MOLC3vekuzhh45w%3D%3D&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep

---

From: Dave Thaler <[email-masked]>
Date: Sat, 23 Sep 2017 19:33:05 +0000

Typically at a WG-forming BOF the questions are:

  1.  Do people understand the problem?
  2.  Do people think the problem is tractable?   This includes discussion of the correct scoping of “the problem” (too broad, too narrow, whatever).
  3.  Are there people willing to author specs?
  4.  Are there people willing to review specs?

In the first BoF the issue was that at the end of first bof only about 40% said yes if I remember correctly.
So in my view, the key goals of the next BoF are that we ensure that 90% of the people say yes to #1,
we get agreement on #2 as scoped in the proposed charter text, and there are enough meeting attendees who volunteer in answer to 3 and 4.
Dave

From: TEEP [mailto:[email-masked]] On Behalf Of Brian Witten
Sent: Friday, September 22, 2017 9:17 AM
To: Nancy Cam-Winget (ncamwing) <[email-masked]>
Cc: Marc Canel <[email-masked]>; Yubin Xia <[email-masked]>; Daniel Zhang <[email-masked]>; 이희관 <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Paczkowski, Lyle W [CTO] <[email-masked]>; 魏茂军 <[email-masked]>
Subject: Re: [Teep] [EXT] Re: Charter Text

Hi Nancy,

Looking Forward,
Brian

Brian Witten

Thanks,  Nancy

hi,

网址：www.bjleisen.c<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fclicktime.symantec.com%2Fa%2F1%2FZ-UN1ts7UmRDFJ3ulEwM39nbYooGm1HQ0Z68-lFRihI%3D%3Fd%3DQlxjVtNtDHe1XKIFOWIDxPuEebZVcwVy_T_aj1YTYjR40EZg0g8shiChsmF0TlhcqPmvkfoWyJ2hhRbY7K6Iv_wTK46Tf1zMrIdnYACASVQ5ZG6G36aoflVGckndhI2EgA-dpcHgV1XfxCDE7OcOdZB5WsaSXPfqNWq0PaFhoilj9gupBWn30KZr5kUJufTrXdHIXV-crEjKyF0rftCU1aY7EM9SunbAO-yxSiKZl0myDTa_-OA9FkZrkJgJ883aufhMbhW3KihStmtFp-aOXNS2R-VEhQnjZVBJE-4rPkGmaxYaMBRtAl2AguseKmS8AG6pERUx8chp2Y4XUMEPI2NX7x6xRgDM8NE9JOwGFw%253D%253D%26u%3Dhttp%253A%252F%252Fwww.opentsm.cn&data=02%7C01%7Cdthaler%40microsoft.com%7Ce6649a8fc93c4bf26b3108d501d98f60%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636416956293012990&sdata=UCB1fsI%2F7BZjok5MDqwKICXI2%2FlDhCSY4OdyKNGie04%3D&reserved=0>om

Thanks!

Note: I have copied to all the experts that are interested in TEEP based on offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe: https://www.ietf.org/mailman/listinfo/teep<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fclicktime.symantec.com%2Fa%2F1%2Fa688UaKqHQcDXj1137PVi_ZNjAbe_LjbKNg0yQTHnnc%3D%3Fd%3DQlxjVtNtDHe1XKIFOWIDxPuEebZVcwVy_T_aj1YTYjR40EZg0g8shiChsmF0TlhcqPmvkfoWyJ2hhRbY7K6Iv_wTK46Tf1zMrIdnYACASVQ5ZG6G36aoflVGckndhI2EgA-dpcHgV1XfxCDE7OcOdZB5WsaSXPfqNWq0PaFhoilj9gupBWn30KZr5kUJufTrXdHIXV-crEjKyF0rftCU1aY7EM9SunbAO-yxSiKZl0myDTa_-OA9FkZrkJgJ883aufhMbhW3KihStmtFp-aOXNS2R-VEhQnjZVBJE-4rPkGmaxYaMBRtAl2AguseKmS8AG6pERUx8chp2Y4XUMEPI2NX7x6xRgDM8NE9JOwGFw%253D%253D%26u%3Dhttps%253A%252F%252Fwww.ietf.org%252Fmailman%252Flistinfo%252Fteep&data=02%7C01%7Cdthaler%40microsoft.com%7Ce6649a8fc93c4bf26b3108d501d98f60%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636416956293012990&sdata=pqH%2Fe%2FTBM8jHvLdd4vjlVO9b8Eo8MyO7fGZ7ak2FaT0%3D&reserved=0>

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Sent with Mixmax<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fclicktime.symantec.com%2Fa%2F1%2F2U4FM9O1y9tVhg8IDBvwcrRZlBUW-frWDE4BJKJvx2A%3D%3Fd%3DQlxjVtNtDHe1XKIFOWIDxPuEebZVcwVy_T_aj1YTYjR40EZg0g8shiChsmF0TlhcqPmvkfoWyJ2hhRbY7K6Iv_wTK46Tf1zMrIdnYACASVQ5ZG6G36aoflVGckndhI2EgA-dpcHgV1XfxCDE7OcOdZB5WsaSXPfqNWq0PaFhoilj9gupBWn30KZr5kUJufTrXdHIXV-crEjKyF0rftCU1aY7EM9SunbAO-yxSiKZl0myDTa_-OA9FkZrkJgJ883aufhMbhW3KihStmtFp-aOXNS2R-VEhQnjZVBJE-4rPkGmaxYaMBRtAl2AguseKmS8AG6pERUx8chp2Y4XUMEPI2NX7x6xRgDM8NE9JOwGFw%253D%253D%26u%3Dhttps%253A%252F%252Fmixmax.com%252Fs%252FSjmasx74wNoX3uu2B%253Futm_source%253Dmixmax%2526amp%253Butm_medium%253Demail%2526amp%253Butm_campaign%253Dsignature_link%2526amp%253Butm_content%253Dsent_with_mixmax&data=02%7C01%7Cdthaler%40microsoft.com%7Ce6649a8fc93c4bf26b3108d501d98f60%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636416956293012990&sdata=MK%2FxL97c4zGNQI%2FhCzUvH%2BRsDUi6kWkij0qZaz5lY5o%3D&reserved=0>

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://clicktime.symantec.com/a/1/sHtnECS9Wu1mQdgDIGbrebTnYImDEvc_bE2-G7ne1os=?d=krF61bpPTLAqvMf14r8w_50Ailj_JZDXYJgqineuwBtoCT6P_3BNom4ll1KlHhJZu7O1hYfbGBdFai8q8Lqu3ztreuNcuN0BZmZJksFxrIO0cqt-GH787jd01ElrAqT63HOz_UKX9vTSJhjyn5OLWj2HpF391CSqqbyn31BW71GLc9X7ZXXhyMu6vNX_1IXT1zZI96Zn7qNxk1oIjTTrkvMF1lhpST_AyiEoLMqNH7GPuALAhtl7z3Ax_OcLczEr_q3ir3X63f9e0RFTfzvZIn8B2YblxwK53y5cLIueB6u76fzn6NF8TDYq4mDb5zLXjfowXlJ-t4CELJcjzAwwC5x5d54MOLC3vekuzhh45w%3D%3D&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fclicktime.symantec.com%2Fa%2F1%2FsHtnECS9Wu1mQdgDIGbrebTnYImDEvc_bE2-G7ne1os%3D%3Fd%3DkrF61bpPTLAqvMf14r8w_50Ailj_JZDXYJgqineuwBtoCT6P_3BNom4ll1KlHhJZu7O1hYfbGBdFai8q8Lqu3ztreuNcuN0BZmZJksFxrIO0cqt-GH787jd01ElrAqT63HOz_UKX9vTSJhjyn5OLWj2HpF391CSqqbyn31BW71GLc9X7ZXXhyMu6vNX_1IXT1zZI96Zn7qNxk1oIjTTrkvMF1lhpST_AyiEoLMqNH7GPuALAhtl7z3Ax_OcLczEr_q3ir3X63f9e0RFTfzvZIn8B2YblxwK53y5cLIueB6u76fzn6NF8TDYq4mDb5zLXjfowXlJ-t4CELJcjzAwwC5x5d54MOLC3vekuzhh45w%253D%253D%26u%3Dhttps%253A%252F%252Fwww.ietf.org%252Fmailman%252Flistinfo%252Fteep&data=02%7C01%7Cdthaler%40microsoft.com%7Ce6649a8fc93c4bf26b3108d501d98f60%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636416956293012990&sdata=sujqVp9LXEJ36v38BNk5mcYo2tPNwT316tKHdql5JmE%3D&reserved=0>

---

From: "刘大鹏(鹏成)" <[email-masked]>
Date: Thu, 28 Sep 2017 21:32:46 +0800

Hello all,
We get agreement on #2 and have enough meeting attendees who volunteer in answer to 3 and 4,   does that mean the answer of #1 is also positive? Since #1 is the prerequisite of the answer to #2, #3, #4.Maybe we can have a virtual BoF to confirm this before Nov meeting?
Regards,Dapeng(Max) Liu------------------------------------------------------------------From:Dave Thaler <[email-masked]>Send Time:2017年9月24日(星期日) 03:33To:[email-masked] <[email-masked]>Subject:Re: [Teep] [EXT] Re:  Charter Text
Typically at a WG-forming BOF the questions are: Do people understand the problem?   Do people think the problem is tractable?   This includes discussion of the correct scoping of “the problem” (too broad,
 too narrow, whatever).Are there people willing to author specs?Are there people willing to review specs? In the first BoF the issue was that at the end of first bof only about 40% said yes if I remember correctly.

we get agreement on #2 as scoped in the proposed charter text, and there are enough meeting attendees who volunteer in answer to 3 and 4.Dave From: TEEP [mailto:[email-masked]]
On Behalf Of Brian Witten
Sent: Friday, September 22, 2017 9:17 AM
To: Nancy Cam-Winget (ncamwing) <[email-masked]>
Cc: Marc Canel <[email-masked]>; Yubin Xia <[email-masked]>; Daniel Zhang <[email-masked]>;
이희관 <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Paczkowski, Lyle W [CTO] <[email-masked]>;
魏茂军 <[email-masked]>
Subject: Re: [Teep] [EXT] Re: Charter Text Hi Nancy,

Looking Forward,

Brian

Brian Witten

+1-571-215-8224
[email-masked] 

On Sep 22, 2017, at 9:01 AM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:Folks, As a reminder, while it has been good to get recognition that this is an area of interest that perhaps the IETF should look at chartering, it is important to note that the
 consensus is not about “voting by corporation” but more about individuals who feel this is important and express support and incite discussion. 
 That said, moving forward please join  (those who have responded to this email and are in the “To”) or have your colleagues join the mail group to continue discussions. Thanks,  Nancy From:
TEEP <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Thursday, September 21, 2017 at 7:10 PM
To: Dapeng Liu <[email-masked]>, Lubna Dajani <[email-masked]>, "[email-masked]" <[email-masked]>,
 teep-bounces <[email-masked]>, teep <[email-masked]>, Mingliang Pei <[email-masked]>, "Marc.Canel" <[email-masked]>,
 Richard Parris <[email-masked]>, Rob Coombs <[email-masked]>, "qingyang.meng" <[email-masked]>,
 Brian Witten <[email-masked]>, "[email-masked]" <[email-masked]>, Nick Cook <[email-masked]>,
 "[email-masked]" <[email-masked]>, Hannes Tschofenig <[email-masked]>, "zhijian.zhang"
 <[email-masked]>,
魏茂军 <[email-masked]>, Dominique
 Bolignano <[email-masked]>, "[email-masked]" <[email-masked]>, Mike Hendrick
 <[email-masked]>, XiaYubin <[email-masked]>, "[email-masked]" <[email-masked]>,
 "Paczkowski, Lyle W [CTO]" <[email-masked]>, Pengcheng Zou <[email-masked]>, "[email-masked]" <[email-masked]>,
 "philip.attfield" <[email-masked]>, "Andrew.Atyeo" <[email-masked]>, paromix <[email-masked]>,
 ppeterkaa <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Charter Text hi,  Beijing Laser Tech. support it.thanks. 周鹏CEO北京雷森科技发展有限公司Beijing Laser Technology Development CO.,LTD地址：西直门北大街甲43号金运大厦7层 
邮编100044手机：18910750012/15601105750/13911779990网址：www.bjleisen.com From: Dapeng
 LiuDate: 2017-09-13 00:49To: Lubna
 Dajani; ppeterka; 
teep-bounces; teep; 
Mingliang Pei; Marc Canel; 
[email-masked]; Rob Coombs;
qingyang.meng; 
brian_witten; [email-masked];
Nick Cook; 
[email-masked]; Hannes Tschofenig;
zhijian.zhang; 
zhoup; maojun.wei; 
dominique.bolignano; [email-masked];
[email-masked]; 
xiayubin; sangjin.park; 
lyle.w.paczkowski; Pengcheng Zou; 
fmw; philip.attfield; 
Andrew.Atyeo; paromix; 
ppeterkaa; 成鹏Subject: re: [Teep] Charter TextHello Nancy, Thanks! Actually, there are lots of companies/experts are very interested in the proposed TEEP work. But they may not familiar with IETF process, I hope they would getting more active in the list after the longsummer vacation:) Note: I have copied to all the experts that are interested in TEEP based on offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe:

https://www.ietf.org/mailman/listinfo/teep Thanks,Max------------------------------------------------------------------From:Nancy Cam-Winget (ncamwing) <[email-masked]>Send Time:2017年9月12日(星期二)
 23:50To:Lubna Dajani <[email-masked]>; Petr Peterka <[email-masked]>Cc:[email-masked] <[email-masked]>Subject:Re: [Teep] Charter Text Thank you Lubna and Petr! Would still like to hear from others and also solicit feedback on the proposed charter text. Warm regards,                Nancy From:
Lubna Dajani <[email-masked]>
Date: Tuesday, September 12, 2017 at 4:40 AM
To: Petr Peterka <[email-masked]>Cc:
"[email-masked]" <[email-masked]>, "[email-masked]"
 <[email-masked]>
Subject: Re: [Teep] Charter Text please allow me to echo Petr's responses. 1. Yes2. Yes3. Yes4. Yes  I am personally very excited to see this WG form and I look forward to actively contributing to the evolution of this
 protocol as I have since the ideation stages of this protocol …  Thank you Nancy, Petr and everyone here… Lubna__________________________________________________Lubna Dajani  I  Allternet Ltd.@lubnadajani@futuristasORG+ 1 201 982 0934  Confidentiality Notice: The
 information contained in this email and any attachments is intended only for the recipient[s] listed above and may be privileged and confidential. Any dissemination, copying, or use of or reliance upon such information by or to anyone other than the recipient[s]
 listed above is prohibited. If you have received this message in error, please notify the sender immediately at the email address above and destroy any and all copies of this message. Sent with

Mixmax   On Thu, Jul 20, 2017 2:48 AM, Petr Peterka
[email-masked] wrote:Hi NancyI think we had a very productive meeting yesterday. Here are my answers to your questions: 1) Do you understand what TEEP is trying to achieve?
ANSWER: Yes, I do. I’d like to add that the charter may re-emphasize that the proposed WG is not going to define the TEE or the TAM service themselves but
 just the protocol between them.  2) Is this work that should be done in general?ANSWER: Yes, it should since there are going to be more and more trusted execution environments (lower case) especially with the proliferation of IoT devices
 which will need more security than what they have today. 3) Is this work that should be done in the IETF, or does it belong to somewhere else?ANSWER: Since we are trying to define a protocol that is independent of the different TEE implementations, I believe that IETF is the right home for it. 4) Should we form a WG with given charter to work on this?ANSWER: Yes, that is my recommendation. Thanks          Petr From: TEEP [mailto:[email-masked]]
On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, July 20, 2017 11:13 AM
To: [email-masked]
Subject: Re: [Teep] Charter Text All,Please provide feedback on the results of yesterday’s side meeting.  In particular, we’d like to get feedback on whether this the right scope and if we have captured it appropriately.
 If it is not, also please comment and if possible, provide suggestions for improvement. We would like to continue discussion over email and get consensus around the 2nd week of September so that we can have a path forward.  In particular we would like to
 get answers for: 1) Do you understand what TEEP is trying to achieve?
2) Is this work that should be done in general?3) Is this work that should be done in the IETF, or does it belong to somewhere else?4) Should we form a WG with given charter to work on this? Warm regards,
    Nancy & Tero (TEEP BoF Chairs) From:
TEEP <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Wednesday, July 19, 2017 at 5:56 AM
To: "[email-masked]" <[email-masked]>
Subject: [Teep] Charter Text Here is the charter text we came up in the side-meeting today.
 ------

TEEP -- A Protocol for Dynamic Trusted Execution Environment Enablement Charter The Trusted Execution Environment (TEE) is a secure area of a processor. The TEE provides security features, such as isolated execution, integrity of Trusted Applications along with
 confidentiality of their assets. In general terms, the TEE offers an execution space that provides a higher level of security than a "rich" operating system and more functionality than a secure element. For example, implementations of the TEE concept have
 been developed by ARM, and Intel using the TrustZone and the SGX technology, respectively. To programmatically install, update, and delete applications running in the TEE, this protocol runs between a service running within the TEE, a relay application or service access
 point on the device's network stack and a server-side infrastructure that interacts with and optionally maintains the applications. Some tasks are security sensitive and the server side requires information about the device characteristics in form of attestation
 and the device-side may require information about the server. Privacy considerations have to be taken into account with authentication features and attestation. This working group aims to develop an application layer protocol providing TEEs with the following functionality,* lifecycle management of trusted applications, and
* security domain management. A security domain allows a service provider's applications to be isolated so that one security domain cannot be influenced by another, unless it exposes an API to allow it. The solution approach must take a wide range of TEE and relevant technologies into account and will focus on the use of public key cryptography.
 The group will produce the following deliverables. First, an architecture document describing the involved entities, their relationships, assumptions, the keying framework and relevant
 use cases. Second, a solution document that describes the above-described functionality. The choice of encoding format(s) will be decided in the working group. The group may document several attestation technologies considering the different hardware capabilities,
 performance, privacy and operational properties. The group will maintain a close relationship with the GlobalPlatform, Trusted Computing Group,  and other relevant standards to ensure proper use of existing TEE-relevant application
 layer interfaces.  Milestones Dec 2017     Submit "TEEP Architecture" document as WG item. Feb 2018     Submit "TEEP Protocol" document as WG item. July 2018     Submit "TEEP Architecture" to the IESG for publication as an Informational RFC. Feb 2019     Submit "TEEP Protocol" to the IESG for publication as a Proposed Standard. Additional calendar items:
 Nov 2017     IETF #100 Hackathon to work on TEEP protocol prototype implementations.
 Mar 2018     1st interoperability event (at IETF #101). Jul 2018       2nd interoperability event (at IETF #102). IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender
 immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
 _______________________________________________

TEEP mailing list
[email-masked]

---

From: Dave Thaler <[email-masked]>
Date: Thu, 28 Sep 2017 15:38:48 +0000

You can’t have agreement on #2 without a positive answer to #1.
You can only have partial agreement on the small subset of people who think yes to #1, but not necessarily across the full BoF participants, which is what matters.
So #1 is the most important to a successful BoF, and a virtual BoF won’t draw the same large set of participants.

I would encourage all proponents of this or any other BoF to look over RFC 5434: https://tools.ietf.org/html/rfc5434
(“Considerations for Having a Successful Birds-of-a-Feather (BOF) Session”).

Dave

From: TEEP [mailto:[email-masked]] On Behalf Of ???(??)
Sent: Thursday, September 28, 2017 6:33 AM
To: [email-masked]; TEEP <[email-masked]>
Subject: Re: [Teep] [EXT] Re: Charter Text

Hello all,

We get agreement on #2 and have enough meeting attendees who volunteer in answer to 3 and 4,   does that mean the answer of #1 is also positive?
Since #1 is the prerequisite of the answer to #2, #3, #4.
Maybe we can have a virtual BoF to confirm this before Nov meeting?

Regards,
Dapeng(Max) Liu
------------------------------------------------------------------
From:Dave Thaler <[email-masked]<mailto:[email-masked]>>
Send Time:2017年9月24日(星期日) 03:33
To:[email-masked] <[email-masked]<mailto:[email-masked]>>
Subject:Re: [Teep] [EXT] Re: Charter Text

Cc: Marc Canel <[email-masked]<mailto:[email-masked]>>; Yubin Xia <[email-masked]<mailto:[email-masked]>>; Daniel Zhang <[email-masked]<mailto:[email-masked]>>; 이희관 <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Paczkowski, Lyle W [CTO] <[email-masked]<mailto:[email-masked]>>; 魏茂军 <[email-masked]<mailto:[email-masked]>>

Hi Nancy,

Looking Forward,
Brian

Brian Witten

Thanks,  Nancy

hi,

From: Dapeng Liu<mailto:[email-masked]>
Date: 2017-09-13 00:49
To: Lubna Dajani<mailto:[email-masked]>; ppeterka<mailto:[email-masked]>; teep-bounces<mailto:[email-masked]>; teep<mailto:[email-masked]>; Mingliang Pei<mailto:[email-masked]>; Marc Canel<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Rob Coombs<mailto:[email-masked]>; qingyang.meng<mailto:[email-masked]>; brian_witten<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Nick Cook<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Hannes Tschofenig<mailto:[email-masked]>; zhijian.zhang<mailto:[email-masked]>; zhoup<mailto:[email-masked]>; maojun.wei<mailto:[email-masked]>; dominique.bolignano<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; xiayubin<mailto:[email-masked]>; sangjin.park<mailto:[email-masked]>; lyle.w.paczkowski<mailto:[email-masked]>; Pengcheng Zou<mailto:[email-masked]>; fmw<mailto:[email-masked]>; philip.attfield<mailto:[email-masked]>; Andrew.Atyeo<mailto:[email-masked]>; paromix<mailto:[email-masked]>; ppeterkaa<mailto:[email-masked]>; 成鹏<mailto:[email-masked]>
Subject: re: [Teep] Charter Text
Hello Nancy,

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones

---

From: "刘大鹏(鹏成)" <[email-masked]>
Date: Fri, 29 Sep 2017 15:50:46 +0800

Hi Dave,
I may misunderstand what you mean. Since in your fist email, it says:I thought you mean that according to the last bof/barbof and email confirmation on the list we already have the agreement of the #2 #3 #4.
------------------------------------------------------------------From:Dave Thaler <[email-masked]>Send Time:2017年9月28日(星期四) 23:38To:刘大鹏(鹏成) <[email-masked]>; [email-masked] <[email-masked]>; TEEP <[email-masked]>Subject:RE: [Teep] [EXT] Re:  Charter Text
You can’t have agreement on #2 without a positive answer to #1.You can only have partial agreement on the small subset of people who think yes to #1, but not necessarily across the full BoF participants, which is what matters.So #1 is the most important to a successful BoF, and a virtual BoF won’t draw the same large set of participants. I would encourage all proponents of this or any other BoF to look over RFC 5434:
https://tools.ietf.org/html/rfc5434(“Considerations for Having a Successful Birds-of-a-Feather (BOF) Session”). Dave From: TEEP [mailto:[email-masked]]
On Behalf Of ???(??)
Sent: Thursday, September 28, 2017 6:33 AM
To: [email-masked]; TEEP <[email-masked]>
Subject: Re: [Teep] [EXT] Re: Charter Text Hello all, We get agreement on #2 and have enough meeting attendees who volunteer in answer to 3 and 4,   does that mean the answer of #1 is also positive?
Since #1 is the prerequisite of the answer to #2, #3, #4.Maybe we can have a virtual BoF to confirm this before Nov meeting? Regards,Dapeng(Max) Liu------------------------------------------------------------------From:Dave Thaler <[email-masked]>Send Time:2017年9月24日(星期日)
 03:33To:[email-masked] <[email-masked]>Subject:Re: [Teep] [EXT] Re: Charter Text Typically at a WG-forming BOF the questions are: Do people understand the problem?   Do people think the problem is tractable?   This includes discussion of the correct scoping of “the problem” (too broad, too
 narrow, whatever).Are there people willing to author specs?Are there people willing to review specs? In the first BoF the issue was that at the end of first bof only about 40% said yes if I remember correctly.

we get agreement on #2 as scoped in the proposed charter text, and there are enough meeting attendees who volunteer in answer to 3 and 4.Dave From: TEEP [mailto:[email-masked]]
On Behalf Of Brian Witten
Sent: Friday, September 22, 2017 9:17 AM
To: Nancy Cam-Winget (ncamwing) <[email-masked]>
Cc: Marc Canel <[email-masked]>; Yubin Xia <[email-masked]>; Daniel Zhang <[email-masked]>;
이희관 <[email-masked]>;
[email-masked]; 
[email-masked]; [email-masked]; Paczkowski, Lyle W [CTO] <[email-masked]>;
魏茂军 <[email-masked]>
Subject: Re: [Teep] [EXT] Re: Charter Text Hi Nancy, Many Thanks!  In that spirit, please allow me to echo Lubna, Ming, Petr & so many others stating "yes, yes, yes, yes," and sharing my excitement for the formation of this Working Group.  Thank You Again!

Looking Forward,

Brian

Brian Witten

+1-571-215-8224
[email-masked] 

On Sep 22, 2017, at 9:01 AM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:Folks, As a reminder, while it has been good to get recognition that this is an area of interest that perhaps the IETF should look at chartering, it is important to note that the
 consensus is not about “voting by corporation” but more about individuals who feel this is important and express support and incite discussion. 
 That said, moving forward please join  (those who have responded to this email and are in the “To”) or have your colleagues join the mail group to continue discussions. Thanks,  Nancy From:
TEEP <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Thursday, September 21, 2017 at 7:10 PM
To: Dapeng Liu <[email-masked]>, Lubna Dajani <[email-masked]>, "[email-masked]"
 <[email-masked]>, teep-bounces <[email-masked]>, teep <[email-masked]>,
 Mingliang Pei <[email-masked]>, "Marc.Canel" <[email-masked]>, Richard Parris <[email-masked]>,
 Rob Coombs <[email-masked]>, "qingyang.meng" <[email-masked]>, Brian Witten <[email-masked]>,
 "[email-masked]" <[email-masked]>, Nick Cook <[email-masked]>,
 "[email-masked]" <[email-masked]>, Hannes Tschofenig <[email-masked]>,
 "zhijian.zhang" <[email-masked]>,
魏茂军 <[email-masked]>,
 Dominique Bolignano <[email-masked]>, "[email-masked]" <[email-masked]>,
 Mike Hendrick <[email-masked]>, XiaYubin <[email-masked]>, "[email-masked]"
 <[email-masked]>, "Paczkowski, Lyle W [CTO]" <[email-masked]>, Pengcheng Zou <[email-masked]>,
 "[email-masked]" <[email-masked]>, "philip.attfield" <[email-masked]>,
 "Andrew.Atyeo" <[email-masked]>, paromix <[email-masked]>, ppeterkaa <[email-masked]>,
 "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Charter Text hi,  Beijing Laser Tech. support it.thanks. 周鹏CEO北京雷森科技发展有限公司Beijing Laser Technology Development CO.,LTD地址：西直门北大街甲43号金运大厦7层 
邮编100044手机：18910750012/15601105750/13911779990网址：www.bjleisen.com From: Dapeng
 LiuDate: 2017-09-13 00:49To: Lubna
 Dajani; ppeterka;
teep-bounces; 
teep; Mingliang Pei;
Marc Canel; 
[email-masked]; 
Rob Coombs; qingyang.meng;
brian_witten; 
[email-masked]; 
Nick Cook; [email-masked];
Hannes Tschofenig;
zhijian.zhang;
zhoup; 
maojun.wei; 
dominique.bolignano; 
[email-masked]; 
[email-masked]; 
xiayubin; sangjin.park;
lyle.w.paczkowski;
Pengcheng Zou; 
fmw; philip.attfield;
Andrew.Atyeo; 
paromix; ppeterkaa;
成鹏Subject: re: [Teep] Charter TextHello Nancy, Thanks! Actually, there are lots of companies/experts are very interested in the proposed TEEP work. But they may not familiar with IETF process, I hope they would getting more active in the list after the longsummer vacation:) Note: I have copied to all the experts that are interested in TEEP based on offline discussions.
To all the experts copied in this mail: Please subscribe to TEEP email list first if you want to reply.   Here is how to subscribe:

Subject: Re: [Teep] Charter Text please allow me to echo Petr's responses. 1. Yes2. Yes3. Yes4. Yes  I am personally very excited to see this WG form and I look forward to actively contributing to the evolution of this protocol as I have since the ideation stages of this protocol
 …  Thank you Nancy, Petr and everyone here… Lubna__________________________________________________Lubna Dajani  I  Allternet Ltd.@lubnadajani@futuristasORG+ 1 201 982 0934  Confidentiality Notice: The

Subject: Re: [Teep] Charter Text All,Please provide feedback on the results of yesterday’s side meeting.  In particular, we’d like to get feedback on whether this the right scope and if we have captured it appropriately. If it is not, also please comment
 and if possible, provide suggestions for improvement. We would like to continue discussion over email and get consensus around the 2nd week of September so that we can have a path forward.  In particular we would like to get answers for: 1) Do you understand what TEEP is trying to achieve?

TEEP mailing list
[email-masked]

---

From: Dave Thaler <[email-masked]>
Date: Fri, 29 Sep 2017 13:10:50 +0000

A barbof is not an IETF meeting (and this was stated explicitly during the side meeting that it was not an IETF meeting).
So there was no “IETF consensus” per se.
The goal of the actual BoF is to get IETF consensus that the criteria are met.

From: 刘大鹏(鹏成) [mailto:[email-masked]]
Sent: Friday, September 29, 2017 12:51 AM
To: [email-masked]; TEEP <[email-masked]>; Dave Thaler <[email-masked]>
Subject: Re: [Teep] [EXT] Re: Charter Text

Hi Dave,

I may misunderstand what you mean. Since in your fist email, it says:
I thought you mean that according to the last bof/barbof and email confirmation on the list we already have the agreement of the #2 #3 #4.

------------------------------------------------------------------
From:Dave Thaler <[email-masked]>
Send Time:2017年9月28日(星期四) 23:38
To:刘大鹏(鹏成) <[email-masked]>; [email-masked] <[email-masked]>; TEEP <[email-masked]>
Subject:RE: [Teep] [EXT] Re: Charter Text

I would encourage all proponents of this or any other BoF to look over RFC 5434: https://tools.ietf.org/html/rfc5434<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc5434&data=02%7C01%7Cdthaler%40microsoft.com%7Cd6224eb357a845289a6008d5070ed0ff%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636422682600259232&sdata=wp8xT7Zo7hD8JMN4r3PFo1qZdw7ikrOgaLWZoAXzI5A%3D&reserved=0>
(“Considerations for Having a Successful Birds-of-a-Feather (BOF) Session”).

Dave

Hello all,

Regards,
Dapeng(Max) Liu

Hi Nancy,

Looking Forward,
Brian

Brian Witten

Thanks,  Nancy

hi,

Thanks!

Thanks,
Max

Warm regards,
                Nancy

Lubna

@lubnadajani

@futuristasORG

Hi Nancy

Thanks

          Petr

All,

Warm regards,

------

Milestones