Subject: [Teep] OTrP over HTTP

From: Dave Thaler <[email-masked]>
Date: Wed, 6 Feb 2019 02:18:01 +0000

Last IETF, I presented the hackathon report which included the slide discussion
of OTrP over HTTP (https://datatracker.ietf.org/meeting/103/materials/slides-103-teep-hackathon-report-01)

I've now written up in I-D form what we discussed, and submitted it as an individual
document for the WG to consider:
https://tools.ietf.org/html/draft-thaler-teep-otrp-over-http-00

The only substantive change from the slide was replacing the media type
application/json with a new media type application/otrp+json as recommended
in "Building Protocols with HTTP" (draft-ietf-httpbis-bcp56bis) section 4.8

Since I'm the document author, Nancy will have to act as chair for discussion of it.

Comments welcome.

Dave

---

From: Dave Thaler <[email-masked]>
Date: Wed, 6 Feb 2019 02:22:51 +0000

> https://tools.ietf.org/html/draft-thaler-teep-otrp-over-http-00<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-thaler-teep-otrp-over-http-00&data=02%7C01%7Cdthaler%40microsoft.com%7C40fb41b0073b4b42f33a08d68bd95769%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636850162927524953&sdata=OmzVt0UmzQYObpZEgvsOdFDLuh4EJgpeaq6MC%2BrGomU%3D&reserved=0>

I also asked Mark Nottingham (author of the "Building Protocols with HTTP" draft)
to review it.  His feedback, which I agree with, is quoted below with Mark's permission.

Dave

> -----Original Message-----

> From: Mark Nottingham <[email-masked]<mailto:[email-masked]>>

> Sent: Monday, February 4, 2019 9:42 PM

> To: Dave Thaler <[email-masked]<mailto:[email-masked]>>

> Subject: Re: OTrP over HTTP

> Hi Dave,

> Overall, I think this is reasonable. It was a bit difficult to read, but I suspect that's mostly because I'm not up to speed with TEEP. Defining terms like "TAM URI" at the beginning might help.

> The one technical question the I had was about using GET for session creation; I think that's probably better as a POST with a 0-length body, since GET returns the state of the TAM URI, and that's not what's happening here.

> Also:

>>  Redirects MAY be automatically followed, and no request headers need

>> be modified or removed upon a following such a redirect.

> That probably needs to say something like "...no additional request headers beyond those specified by HTTP need be modified..."

> It'd be great if you could pass this buy the HTTP WG mailing list, so that other folks can have a look.