Subject: Re: [Teep] local attestation

From: "Smith, Ned" <[email-masked]>
Date: Thu, 24 Mar 2022 09:44:54 +0000

I think this should be called ‘human-verifieable attestation’. Local is ambiguous as it requires context that distinguishes between what constitutes remove / local and neither designation requires the entities to be human.

From: TEEP <[email-masked]> on behalf of Brendan Moran <[email-masked]>
Date: Monday, March 21, 2022 at 12:19 PM
To: "[email-masked]" <[email-masked]>
Subject: [Teep] local attestation

I was asked to propose some text on local attestation.

While it may be the case that an asset must sometimes be secret from the user, it is not the case that the user should know nothing about the asset; the end user should be able to verify the authenticity and integrity of the asset. To enable this, local attestation can be used to prove integrity to the user. The user can then use that integrity check to verify authenticity, for example by checking against a signature or by verifying the expected integrity check using conventional web pki.

Thanks,
Brendan
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Brendan Moran <[email-masked]>
Date: Thu, 24 Mar 2022 11:07:22 +0000

Hi Ned,

That’s a fair point, but what I was really going for here is to distinguish it from “remote attestation.” There’s an additional point that there needs to be some OOB data transfer to obtain the “correct” values for the TA. For example, you could imagine a TA Transparency Log; something that is used to TATL on misbehaving TAMs.

Best Regards,
Brendan

On 24 Mar 2022, at 09:44, Smith, Ned <[email-masked]<mailto:[email-masked]>> wrote:

From: TEEP <[email-masked]<mailto:[email-masked]>> on behalf of Brendan Moran <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 21, 2022 at 12:19 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Teep] local attestation

Thanks,
Brendan