Subject: Comments on draft-lefaucher-te-metric-igp-01.txt

From: "Naidu, Venkata" <[email-masked]>
Date: Wed, 5 Dec 2001 18:06:06 -0500

All:
 
  I have few comments on draft-lefaucher-te-metric-igp-01.txt

  * Consider GMPLS (draft-ietf-ccamp-gmpls-routing-01.txt
    section 5) TE Links . That is, for some links there 
    may not be any IGP adjacency, so there won't be any 
    IGP metric.

    In that case how are we planning to solve CSPF for
    data/voice etc LSPs with a single TE metric. If not
    please add sufficient info to the section 2.3 Constraints.

  * I feel that this draft is a perfect subset of METRICS 
    draft (draft-fedyk-isis-ospf-te-metrics-01.txt). These 
    can be merged, but I don't understand why only this draft 
    is considered for TE-WG last call?

--Venkata Naidu

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 06 Dec 2001 10:45:28 +0100

Venkata,

>     may not be any IGP adjacency, so there won't be any

fair point.

>     please add sufficient info to the section 2.3 Constraints.

You're right that 2.3 should be updated to reflect this additional constraint.
We should add in 2.3 a 3rd item along the line of:
"(iii) It can only be used on links onto which support an IGP adjacency so 
that an IGP Metric is indeed advertised for the link. For example, this 
practise can not be used on Forwarding Adjacencies (see [LSP-HIER])."

>     is considered for TE-WG last call?

We did initially discuss with the METRICS authors about merging the two. 
But we thought it was not the right thing to do because of teh following:
It is true that functionally, this draft achieves a perfect subset of METRICS.
But protocol-wise, it is not a subset. It's more of a 
(not-so-rich-but-available-right-now) alternative to METRICS:
         - METRICS proposes protocol extensions
         - This draft proposes no protocol extensions

Because METRICS proposes protocol extensions it needs to go in the 
Standards Track.
Because this draft is simply documenting exsisting router implementation 
practises and SP practises, it should go in the BCP Track.
So, I think it is necessary to keep them separate.
Makes sense?

Thanks for your comments.

Francois

>--Venkata Naidu

My Mobile Phone number has changed to +33 (0)6 19 98 50 90
_________________________________________________________
Francois Le Faucheur
Development Engineer, IOS Layer 3 Services
Cisco Systems
Office Phone:          +33 4 97 23 26 19
Mobile :               +33 6 19 98 50 90
Fax:                   +33 4 97 23 26 26
Email:                 [email-masked]
_________________________________________________________
Cisco Systems
Domaine Green Side
400, Avenue de Roumanille
06 410  Biot - Sophia Antipolis
FRANCE
_________________________________________________________