Subject: RE: I-D ACTION:draft-ash-multi-area-te-reqmts-01.txt

From: Thomas Nadeau <[email-masked]>
Date: Tue, 04 Dec 2001 11:37:06 -0500

At 09:19 AM 12/4/2001 -0500, Ash, Gerald R (Jerry), ALCTA wrote:
>On Mon, 3 Dec 2001, Jim Boyle wrote:
>
> >> We would like to call for agreement that
> >> a) draft-ietf-tewg-restore-hierarchy-00.txt calls for multi-area TE
> >> requirements to be generated, but contains no such requirements (Section
>3
> >> says "requirements for multi-area traffic engineering need to be
>developed
> >> to provide guidance for any necessary protocol extensions"), and
> >> b) draft-ash-multi-area-te-reqmts-01.txt be adopted as a multi-area TE
> >> requirements draft.
>
> > I for one will disagree with your proposal of need for additional
> > (ancillary?) requirements documents at this time.
>
>I hope others are still going to comment/vote on the proposal, even though
>the WG chair perhaps 'called the election outcome' even before the first
>vote was cast...
>
> > In the interest of progress, I would suggest we just strike the sentences
> > which call for more requirements documents (from within the requirements
> > documents on the matter!)
>
>The TEWG was chartered to do requirements, and that's why CCAMP is doing the
>protocol work.  It's pretty unclear why we had a 9-month 'TEWG requirements
>design team' effort to just conclude that 'we're not going to do
>requirements'.  It's hard to see how this is 'progress'.
>
> > or leave them there and see what's on the
> > table of technical proposals.  The sentence "... may need to be extended."
> > captures the scope sufficiently,
>
>There are many proposed approaches to multi-area TE, and there is a need to
>sort out which of these should be advanced in CCAMP.  You seem to propose
>that the CCAMP protocol work *not* be driven by requirements?  I believe
>that many see the need for requirements, hopefully folks will comment yea or
>nay.
>
> > I'm not sure another 40 pages of
> > requirements discussion will be of any practical result.
>
>The proposed requirements take about 1/2 page, and perhaps could be added to
>the base requirements document.  Again I hope we hear other opinions on the
>list.

         I personally agree with Jim's comment regarding additional
requirements documents.

         --Tom

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.

---

From: [email-masked] (Gerald R Ash)
Date: Thu, 6 Dec 2001 12:50:23 -0500

Somehow did not get forwarded to the TEWG:

> From [email-masked] Thu Dec  6 09:46:45 2001
> To: [email-masked], [email-masked], [email-masked], [email-masked],
>        [email-masked]
> Cc: [email-masked]
> Subject: RE: I-D ACTION:draft-ash-multi-area-te-reqmts-01.txt
>
> Jim,
> Yakov,
> Tom,
> Randy,
> Kireeti,
> Any others who commented on this,
> Any others who want to comment now,
>
> I'm using my old-reliable UNIX email since goner zapped our Outlook (2 days now).
> Please respond also to [email-masked].
>
> Adrian was kind enough to forward me your posts re draft-ash-multi-area-te-reqmts.
> You all opposed having a separate multi-area-te requirements draft.  So, OK, that 
> leads to a couple of follow-up questions.  
>
> Given that:
>
> a. draft-ietf-tewg-restore-hierarchy-00.txt calls for multi-area-te requirements
> (but has none at present),
> b. George Swallow stated at IETF-49 (see the IETF-49/TEWG minutes) that "at least 
> 15 SPs have expressed interest in this.  Don't need it today but want it on the 
> roadmap."
> c. at least one of you has authored an I-D proposing multi-area-te solutions,
>
> here are the follow-up questions:
>
> a. do we need multi-area te?
> if yes, then
> b. do we need multi-area te requirements?
> if yes, then
> c. should we add these requrements to draft-ietf-restore-hierarchy-00.txt?
> if no, then
> d. what should we do about multi-area te requirements?
>
> Thanks,
> Jerry

---

From: "Naidu, Venkata" <[email-masked]>
Date: Thu, 6 Dec 2001 13:41:23 -0500

Jim:

-> I thought it was the consensus of the team, and the WG that 
-> there were not
-> immediate needs for vertical hierarchy, and indeed the needs for
-> horizontal were rather simple at this time (at least as 
-> viewed by people
-> who would intend to use any of this any time soon).

  Very sad to hear about this consensus. I see all the
  Transport Area protocols are developing full fledged 
  features (good protocols like SIP) and lower layers
  are capable of transporting gigs per second. We as a 
  group are not crossing *area* boundaries.

  When are we going to ensure end-to-end QoS then? 
  When can we expect a SIP/Megaco call traversing countries 
  in the Internet using muti-area/AS (DiffServ) TE 
  (with better QoS than we have today)? 

  This is all circular dependency - "need and/or solution".
  It doesn't matter whether a *separate draft* or not.
  But some set of requirements or a unified solution is
  needed (in the roadmap).

--Venkata Naidu

---

From: "Naidu, Venkata" <[email-masked]>
Date: Thu, 6 Dec 2001 15:40:01 -0500

Yakov:

-> > -> > b. do we need multi-area te requirements?
-> > 
-> >    Yes, for a unified solution.
-> 
-> if a unified solution can't be produced without multi-area te
-> requirements, then perhaps we could pursue a non-unified
-> solution...

  I prefer to avoid this situation. I am not asking for 
  *every one in the list/world should accept the
  multi-area TE proposal*. But at least the majority.

  If we are able to produce a unified solution even with 
  out multi-area TE requirements, that is fine. But as
  you know well, that is difficult.

-> > -> > if yes, then
-> > -> > c. should we add these requrements to 
-> > -> draft-ietf-restore-hierarchy-00.txt?
-> > -> > if no, then
-> > -> > d. what should we do about multi-area te requirements?
-> > 
-> >    Place doesn't matter - content matters!
-> 
-> Actually what really matters is working code and operational
-> experience. 
 
   I perfectly agree.

-> And it is far from obvious (at least to me) that a
-> requirements document is going to provide a useful contribution to
-> either the working code or the operational experience.
 
   I don't have as much experience as you do w.r.t above, 
   but I can see DS-TE is going fine after so many different 
   opinions. More over, there were 2 requirement docs, 
   TEWG DS-TE Requirements and MPLSWG DS-TE Requirements.

   Finally, I agree that we need working code but I don't
   agree to the consensus about *not* supporting hierarchy.

--Venkata Naidu

---

From: "Ash, Gerald R (Jerry), ALCTA" <[email-masked]>
Date: Fri, 7 Dec 2001 14:14:52 -0500

Yakov,

Comments below.

Thanks,
Jerry

> But I don't think that in order to produce a working code that
> addresses a real life problem it is necessary to have a requirements
> document produced by the IETF WG. In fact, I have an existence
> proof that plenty of working code that addresses real life problems
> have been produced with no requirements documents produced by the
> IETF WGs (just think of OSPF, BGP, etc...)

Yes, but I can also cite (many) examples where the requirements -> working-code model had glowing success.  Many SPs believe that this model has value because the requirements specify (oftentimes in detail) exactly what is needed and is going to be used.  This avoids a tendency (in the absence of requirements) to code a lot of bells and whistles which may sound good, but aren't needed or going to get used in the real world.

The TEWG is chartered to do requirements.  Are you suggesting requirements be dropped from the Charter?  I for one would like to see an even stronger effort toward requirements:  GMPLS (probably too late..), MPLS-OAM, etc.