Subject: Re: I-D ACTION:draft-ash-multi-area-te-reqmts-01.txt

From: Yakov Rekhter <[email-masked]>
Date: Fri, 07 Dec 2001 07:33:44 -0800

Osama,

> See my comments below

see inline...

> Venkata,
> 
> > Jerry:
> >
> >    my 2 cents...
> >
> > -> > here are the follow-up questions:
> > -> >
> > -> > a. do we need multi-area te?
> >
> >    Yes!
> >
> > -> > if yes, then
> > -> > b. do we need multi-area te requirements?
> >
> >    Yes, for a unified solution.
> *
> * if a unified solution can't be produced without multi-area te
> * requirements, then perhaps we could pursue a non-unified
> * solution...
> *
> > -> > if yes, then
> > -> > c. should we add these requrements to
> > -> draft-ietf-restore-hierarchy-00.txt?
> > -> > if no, then
> > -> > d. what should we do about multi-area te requirements?
> >
> >    Place doesn't matter - content matters!
> *
> * Actually what really matters is working code and operational
> * experience. And it is far from obvious (at least to me) that a
> * requirements document is going to provide a useful contribution to
> * either the working code or the operational experience.
> *
> * yakov.
> 
> 
> In My opinion, What really matters is the network ability to deliver
> deterministic QoS guarantee End-to-End to network subscribers; at the end of
> the day the subscriber will not benefit from TE engineering capabilities,
> unless its world is confined to a single area within an AD.
> 
> Working code that meets requirements is good; but if requirements are not
> addressing a real life problem; then the code and its requirements do not
> really matter that much.

Which suggest that we need working code that addresses a real life
problem.  I would certainly agree with that. 

But I don't think that in order to produce a working code that
addresses a real life problem it is necessary to have a requirements
document produced by the IETF WG. In fact, I have an existence
proof that plenty of working code that addresses real life problems
have been produced with no requirements documents produced by the
IETF WGs (just think of OSPF, BGP, etc...)

yakov.

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Fri, 07 Dec 2001 17:05:43 +0100

Hi Yakov,

At 07:33 07/12/2001 -0800, Yakov Rekhter wrote:
> > addressing a real life problem;

Ossama, code is usually done to address real life problems ....

>  then the code and its requirements do not
> > really matter that much.
>

I think the intention of Jerry was just to list the possible ways of 
performing inter-area TE with the hope of converging to a minimum subset of 
solutions. The draft title should have probably been different (Framework 
(?) instead of requirements).

>IETF WGs (just think of OSPF, BGP, etc...)

Related to this comment and your previous comments I fully agree with you.

JP.

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 7 Dec 2001 11:53:06 -0500

[BIG SNIP]
> > addressing a real life problem; then the code and its requirements do not

and Yakov says...
> IETF WGs (just think of OSPF, BGP, etc...)

Of course we don't _need_ requirements documents.
We don't even need any IETF drafts.
We can all go off into our little corners and produce working code that
addresses real life problems.

But let's assume that there is some value in the IETF and that lies in producing
and standardizing protocol definitions.

Given that, either:
- we allow all WGs to develop protocols and extensions as
  they see fit
or
- we charter a WG with setting the requirements for others
  to address
For better or worse we seem to be following the second model.

If requirements drafts are of no value then either allow people to waste their
time without trying to block them or scrap _all_ requirements documents.

Adrian (wondering why we are having this debate)