Subject: Question on DS-TE (solution) draft: How can I prevent preemption of a connection ?

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Wed, 12 Dec 2001 09:54:40 -0500

Hi! According to the latest DS-TE solution, the signaled (setup) 
	preemption priority is used to infer the bandwidth constraint
	associated with a LSP. 

	By doing this, are we losing the ability to prevent the preemption
	of a LSP (of a set of LSPs) , in a network using the DS-TE ?  
	
	[For example, an administrator may want to deploy DS-TE in his
  	 network, but may not want (automatic) preemption of existing 
	LSPs in response to the creation a new LSP.]

	Thanks,
	sanjay

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 12 Dec 2001 19:47:15 +0100

Sanjay,

>         LSPs in response to the creation a new LSP.]

I think you've raised a very valid point:
As currently specified, the solution would not allow LSPs in different CTs 
to use the same preemption level.

I believe this can be fixed by making the solution a little more flexible. 
In essence what we would do is :
         - consider that the 8 Bw values included in the IGP advertisments 
are no longer tied to preemption. The position of the Bw value in the IGP 
advertisement is considered purely as an index i,  0<=i<=7
         - a mapping is defined on all the LSRs: i ---> (preemption_level, CT)
         - this mapping must be consistent throughout the DSTE domain

For example, I could use the above to ensure each CT has a differnet 
preemption level (ie CT0 can preempt CT1, CT1 can preempt CT2) by 
configuring the following mapping:
         - BW value 0 is used for CT0/Preemption0
         - BW value 1 is used for CT1/Preemption1
         - BW value 2 is used for CT2/Preemption2

Alternatively, I could use the above to ensure all CTs have the same 
preemption level by configuring the following mapping:
         - BW value 0 is used for CT0/Preemption0
         - BW value 1 is used for CT1/Preemption0
         - BW value 2 is used for CT2/Preemption0

I had a chat with some of the co-authors about this and they were fine with it.

Does that work for you too?

Thanks

Francois

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 13 Dec 2001 08:55:19 +0100

Hi Francois

>          - BW value 2 is used for CT2/Preemption0

Sounds very reasonable to me. I'd prefer a DS TE routing protocol where preemption can be disabled too.

Regards, Rüdiger

Rüdiger Geib
Senior Project Manager
T-Systems Nova GmbH
Technologiezentrum
Am Kavalleriesand 3, 64295 Darmstadt
Germany
Fon: +49 6151 832138
Fax: +49 6151 838103
mailto:[email-masked]
http://www.t-nova.de