Subject: RE: Suggestion about Russian Dolls

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 21 Jan 2003 10:26:13 -0000

Victoria,

>> Below is my suggestion for the algorithm to be included
>> in Section 4.3 of "reqts-06" and Section 4 of "russian-00":
>> 
>> ---------------------------------
>> Formula:
>> ---------
>> Let M be MaxCT = MaxBC
>> 
>> for 0 <= b <= (M - 1)
>> BW of (sum of CTc) <= BCb
>> where
>> b <= c <= (M - 1)
>> 

If we want to go for a definition with formulas, then I'd suggest
something like this:
"
Let us define "Reserved(CTb)" as the sum of the bandwidth reserved by
all established LSPs which belong to CTb.
- MaxBC= MaxCT
- for 0 <= b <= (MaxCT - 1):
	* sum (Reserved (CTc)) <= BCb, where b <= c <= (MaxCT - 1)
"

But then we should probably also update the definition for MAM also for
consistency. It would read:
"
Let us define "Reserved(CTb)" as the sum of the bandwidth reserved by
all established LSPs which belong to CTb.
- MaxBC= MaxCT
- for 0 <= b <= (MaxCT - 1):
	* Reserved (CTb) <= BCb
"

Let's see if everyone is comfortable with these formula-based
definitions. If yes, we can include them in the updates of "-reqts" and
"russian" instead of the current text-based definitions.

Cheers

Francois

---

From: "Victoria Fineberg" <[email-masked]>
Date: Tue, 21 Jan 2003 08:23:48 -0500

Francois,

Thanks.  I provided some comments in-line.

Cheers

Victoria

----- Original Message ----- 
From: "Francois Le Faucheur (flefauch)" <[email-masked]>
To: "Victoria Fineberg" <[email-masked]>; <[email-masked]>
Cc: "Francois Le Faucheur (flefauch)" <[email-masked]>
Sent: Tuesday, January 21, 2003 5:26 AM
Subject: RE: Suggestion about Russian Dolls

> all established LSPs which belong to CTb.

Should not these be "Reserved(CTc)" and CTc ?

> * sum (Reserved (CTc)) <= BCb, where b <= c <= (MaxCT - 1)

May be it would be even more clear if we say:

- MaxBC= MaxCT
- for each 0 <= b <= (MaxCT - 1):
        SUM (Reserved (CTc)) <= BCb,
        for all "c" in the range  b <= c <= (MaxCT - 1)

?

> - for 0 <= b <= (MaxCT - 1):

I suggest to still use "Reserved(CTc)" and CTc and add a line
b = c.  Then it would read:

"
Let us define "Reserved(CTc)" as the sum of the bandwidth reserved by
all established LSPs which belong to CTc.
- MaxBC= MaxCT
- b = c
- for each 0 <= b <= (MaxCT - 1):
        Reserved (CTc) <= BCb
"

If we then provide examples that closely replicate formulas, that should
make it clear enough.