Subject: RE: WG Last Call : draft-ietf-tewg-measure-04.txt

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Fri, 24 Jan 2003 13:12:53 -0500

Jim,

The draft is on-target and satisfies this important TEM charter-milestone.  

I've reviewed it numerous times, and all my comments to the authors have been incorporated.  The latest update/comments from Merike further strengthen the draft.

I hope others read and comment, as many said they would at the TEWG meeting in Atlanta,

Thanks,
Jerry

-----Original Message-----
From: Jim Boyle [mailto:[email-masked]]
Sent: Saturday, January 18, 2003 10:40 PM
To: [email-masked]
Subject: WG Last Call : draft-ietf-tewg-measure-04.txt

This draft has definitely honed itself to its purpose from its earliest 
versions.  However it never appears to get wide comment or show of hands 
of folks that have reviewed it. 

So... Please do so.

I'll give us 3 weeks for folks to comment along these lines.

1) is this draft on-target for the TE measurements milestone we have in 
   our charter?  If you think it is off-target I would be interested 
   in hearing how we should deal with this portion of our charter.

2) minor / editorial comments to list and/or author

3) substantial comments to list

Last call will end February 7.

thanks!

Jim Boyle

On Fri, 10 Jan 2003 [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Internet Traffic Engineering Working Group of the IETF.
> 
> 	Title		: A Framework for Internet Traffic Engineering 
>                           Measurement
> 	Author(s)	: W. Lai, R. Tibbs, S. Van den Berghe
> 	Filename	: draft-ietf-tewg-measure-04.txt
> 	Pages		: 26
> 	Date		: 2003-1-10
> 	
> In this document, a measurement framework for supporting the traffic 
> engineering of IP-based networks is presented.  Uses of traffic 
> measurement in service provider environments are described, and 
> issues related to time scale and read-out period are discussed.  
> Different measurement types are classified, with each being 
> specified as a meaningful combination of a measurement entity and a 
> measurement basis. 
> For interoperable compatibility, uniform definitions across vendors 
> and operators must be ensured, e.g., in the distinction between 
> offered load and achieved throughput.  To aid network dimensioning, 
> mechanisms to collect node-pair-based traffic data should be 
> developed to facilitate the derivation of per-service-class traffic 
> matrix statistics.  For service assurance, there is a need for the 
> use of higher-order statistics.  To preserve representative traffic 
> detail at manageable sample volumes, there is a need for packet-
> sampled measurements.  To manage large volume of measured data, use 
> of bulk transfer and filtering/aggregation mechanisms may be 
> appropriate.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-tewg-measure-04.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-tewg-measure-04.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-tewg-measure-04.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: "Lai, Wai S (Waisum), ALABS" <[email-masked]>
Date: Tue, 28 Jan 2003 08:47:01 -0500

Dimitri,
  Many thanks for your comment on our draft.  Based on our
discusssion, to clarify the intent of the quoted paragraph (in
Section 5.3) below, we are going to add right after it the
following text:

(An example of such a feedback mechanism is described in [Ref].
As described therein, care should be exercised to ensure network
stability and consistency for any mechanism that makes direct
operational use of measurement (e.g., to use as feedback into path
computation).  However, such issues will not be dealt with here
as this framework document is mainly concerned with the definitions
and principles of measurements, rather than their usage to
subsequently ensure other network features such as accurate
bandwidth allocation.)
[Ref] P. Ashwood-Smith, B. Jamoussi, D. Fedyk, and D. Skalecki,
"Improving Topology Data Base Accuracy with Label Switched Path
Feedback in Constraint Based Label Distribution Protocol,"
Internet-Draft, Work in Progress, November 2002.

Thanks, Wai Sum

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Sunday, January 19, 2003 7:39 AM
To: Jim Boyle
Cc: [email-masked]
Subject: Re: WG Last Call : draft-ietf-tewg-measure-04.txt

jim, all,

in section 5.3, would it be possible to detail the
real scope behind the following paragraph:

"Providing a feedback mechanism in the reverse flow messaging of 
 RSVP-TE or CR-LDP signaling in MPLS to report on actual topology 
 state information such as link bandwidth availability."

more precisely, detail the relationship between "signalling
in mpls" and the report to "actual topology state information" 
since there are imho several ways to interpret the above 
sentence

thanks,
- dimitri.

-- 
Papadimitriou Dimitri 
E-mail : [email-masked] 
Private: http://www.rc.bel.alcatel.be/~papadimd/index.html
E-mail : [email-masked]
Public : http://psg.com/~dpapadimitriou/
Address: Fr. Wellesplein 1, B-2018 Antwerpen, Belgium
Phone  : Work: +32 3 2408491 - Home: +32 2 3434361