Subject: Request for comments: DSTE-MIB (draft-nadeau-mpls-dste-mib-00)

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Tue, 11 Feb 2003 14:56:48 -0500

Hi! Your comments on the following draft will be appreciated:
 <http://www.ietf.org/internet-drafts/draft-nadeau-mpls-dste-mib-00.txt>

Known TBDs:
	1. Update to reflect the latest DSTE-REQ and DSTE-PROTO
	2. Update to handle MAR BC Model
	3. reorg. the reference section.

Thanks,
sanjay

---

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Fri, 14 Feb 2003 18:13:00 -0500

Sanjay,

> http://www.ietf.org/internet-drafts/draft-nadeau-mpls-dste-mib-00.txt
> 
> Known TBDs:

I'm glad to see that you will include updates to handle the MAR (Maximum Allocation with Reservation) Model.  I presume you will also include updates to handle the Maximum Allocation Model (MAM).  The only model discussed in the MIB at present is the Russian Doll Model.

Just to be sure we're in sync, the MAR model is discussed in http://ietf.org/internet-drafts/draft-ash-mpls-dste-bcmodel-max-alloc-resv-00.txt, and the MAM model is discussed in http://ietf.org/internet-drafts/draft-wlai-tewg-bcmodel-00.txt.

Thanks,
Jerry

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 17 Feb 2003 14:18:18 -0000

Hello Sanjay, Jerry,

>> -----Original Message-----
>> From: Ash, Gerald R (Jerry), ALABS [mailto:[email-masked]] 
>> Sent: 15 February 2003 00:13
>> To: Choudhury, Sanjaya
>> Cc: Ash, Gerald R (Jerry), ALABS; [email-masked]
>> Subject: RE: Request for comments: DSTE-MIB 
>> (draft-nadeau-mpls-dste-mib-00)
>> 
>> 
>> Sanjay,
>> 
>> http://www.ietf.org/internet-drafts/draft->>
nadeau-mpls-dste-mib-00.txt
>> I'm glad to see that you will include updates to handle the 
>> MAR (Maximum Allocation with Reservation) Model.  I presume 
>> you will also include updates to handle the Maximum 
>> Allocation Model (MAM).  The only model discussed in the MIB 
>> at present is the Russian Doll Model.

I agree with Jerry that MAM should be covered in addition to RDM since
the WG agrees on their respective definition and has agreed to specify
these two BC models asap.

With respect to MAR, while I agree in principle that it will need to
have MIB support once it is specified, I would recommend that this piece
of work is progressed outside of the main DS-TE MIB work. This is
because while the WG agrees that we should investigate MAR further, I
think we are still some time away before we have converged on a final
MAR specification. So we should make sure we don't end up holding the
core DS-TE MIB because of discussion on a longer term model.

Does that make sense?

Cheers

Francois

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 18 Feb 2003 15:45:36 -0000

Sanjaya,

>>  Hi!
>>  The MIB as defined today is quite independent of individual BC
>>  Models(RD/MAM/MAR). The only reference to the BC models are 
>>  made in the following contexts:
>>  (i)  Examples of overall configurations (for sample scenarios)
>>  (ii) Examples of rules to be enforced to for different
>> 	BC models, based on the configured BC model.
>> 	[The draft requests user to refer to the BC Models 
>> 	drafts for details.]
>> 
>>  No structural changes will be need to support MAM. Just need
>>  to update the examples. I will incorporate these in rev-02
>>  of the draft.
>> 
>>  Supporting MAR BC Model, will need only incremental work (
>>  addition/extension of a table ). I can post the necessary 
>>  changes to the list (instead of directly adding them to
>>  the draft) for review. Once the WG finalizes the MAR BC
>>  model, we can update the MIB. 
>>  
>>  Does this sound like a plan? [Any other alternatives?]
>>  

This works me.
Thanks
Francois

---

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Tue, 18 Feb 2003 10:58:18 -0500

Sanjay,

>  Does this sound like a plan? [Any other alternatives?]

This sounds good to me.

Thanks,
Jerry

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 18 Feb 2003 13:37:24 -0500

>core DS-TE MIB because of discussion on a longer term model.

         Yes, it does to me.  We will put the core DS-TE functionality into
the DS-TE MIB and additional functions can be appended at a later time.
I believe that the MIB is constructed in such a way as to facilitate
this -- or at least we have tried to design it that way.

         --Tom

>Francois

"The difficult, we do immediately.  The impossible takes a little longer." 
-- Air Force Motto

http://www.mkp.com/books_catalog/catalog.asp?ISBN=1-55860-751-X