Subject: RE: draft-ash-mpls-dste-bcmodel-max-alloc-resv -> WG document?

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Wed, 2 Apr 2003 14:31:29 -0500

Hi! Few comments:

Technical (Scope):
(i) The aim here is to defined a BC Model and not a 
DSTE-Solution. i.e define the BC Model as per the 
DSTE requirement document: 
(a) the maximum number of Bandwidth Constraints
(b) which CTs each Bandwidth Constraint applies to and how

The draft in its present form, goes way beyond the scope.
For example: 
The proposed solution (a) expects modifications to the 
DSTE Solution (ii) introduces CT priority concept that
is not in DSTE-requirement 

I am not sure this is the right approach ...

Editorial: 
(i) Personally, I think this draft needs some editorial 
changes to state the solution more clearly [explicitly 
and succinctly state the rules/necessary configurations/
protocol extensions etc.] 

(ii) The draft also needs to define the term it uses 
precisely (and use them consistently]
Example: "bandwidth-in-progress","bandwidth-in-use", 
	   "reserved-bandwidth", "BWalloc" ... ...

(iii) Separate specification from the examples

Thanks,
sanjay

> -----Original Message-----
> From: Jim Boyle [mailto:[email-masked]]
> Sent: Tuesday, April 01, 2003 10:14 AM
> To: Ash, Gerald R (Jerry), ALABS
> Cc: [email-masked]
> Subject: draft-ash-mpls-dste-bcmodel-max-alloc-resv -> WG document?
> 
> 
> 
> When Jerry incorporates the discussed revisions, he would 
> like to resubmit 
> it as a WG document.  I think that makes sense, as it was the 
> course of 
> action on the other drafts (MAM, RDM).
> 
> Any comments?
> 
> thanks
> 
> Jim
> 
> On Tue, 1 Apr 2003, Ash, Gerald R (Jerry), ALABS wrote:
> 
> > > Hi, this is to allow the WG list to weigh in the 
> > > consensus from the meeting.  This email is on the 
> > > DS-TE drafts...
> > 
> > > 
> http://www.ietf.org/internet-drafts/draft-ash-mpls-dste-bcmode
> l-max-alloc-resv-01.txt
> > 
> > > This draft will be revised
> > 
> > Yes, as agreed, I'll add a section on 'assumptions & 
> applicability' to the I-D.
> > 
> > > it was not discussed if it should be re-updated as 
> > > a WG document.  If that is the Jerry's intention, 
> > > he can bring that question to the WG list.
> > 
> > The agreement was to "progress MAR" (my notes), which is 
> consistent with the proposal in my slides to "specify/progress MAR".
> > Also, the meeting minutes say "the way to go forward is to 
> make all of them [BC models] experimental"
> > 
> > Thanks,
> > 'the Jerry'
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> 
>

---

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Thu, 3 Apr 2003 16:54:32 -0600

Sanjay,

Thanks for your comments, please see responses below.

Thanks,
Jerry

> DSTE-Solution. 

There is no intent to change the DSTE solution.  MAR is an extension of MAM which fits completely within the existing DSTE solution, as does MAM (and RDM).

> i.e define the BC Model as per the DSTE requirement document: 

I think it already does that, e.g., in Section 2 it says "Up to 8 Bandwidth Constraints (MaxBC = 8) are supported and they are referred to as BCb, 0 <= b <= MaxBC-1 = 7."  

> (b) which CTs each Bandwidth Constraint applies to and how

OK, I'll clarify further along the lines of your suggestion.
 
> DSTE Solution 

As I said above, MAR fits completely within the existing DSTE solution, no extension is intended or proposed.

> (ii) introduces CT priority concept that

Priority, as discussed in the I-D, fits within the existing DSTE solution, and uses setup/holding priority capabilities as is.  This will be clarified in the next revision.

> protocol extensions etc.]

OK.  I'll clarify further along the lines of your suggestions.

> 	   "reserved-bandwidth", "BWalloc" ... ...

OK.  I'll include more definitions in Section 2.

> (iii) Separate specification from the examples

I think these are mostly separate already.  Section 3 contains the specification, Section 4 contains the examples (ANNEX A contains the analysis).