Subject: [TICTOC] TICTOC BOF Proposal

From: Stewart Bryant <[email-masked]>
Date: Wed, 17 Jan 2007 17:33:21 +0000

The the usual structure of a BOF is three phases:

1) Problem Statement
2) Possible solutions
3) Charter

Yaakov Stein and I are working an a draft that
puts forward the problem statement. We will post
a pointer to this to the list in the next few
days. We need to have this ready by the 25th
(next tuesday) so that the IESG can read it
before they discuss whether to hold the BOF.
That discussion takes place on 1st Feb.

I will also put together a draft charter and
share that with the list tomorrow.

Does anyone want to talk about possible
solutions at the BOF? For those not familiar
with the IETF such slots are typically
between 10 and 20 mins, and there may well
be several proposals, for example one or
more starting from an NTP perspective and
one or more starting from a 1588 perspective.
Note that NTP and 1588 are suggestions and
there may be other approaches.

Does anyone think that we need to cover
anything else at a BOF?

Stewart

_______________________________________________
TICTOC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tictoc

---

From: "Ron Cohen" <[email-masked]>
Date: Wed, 17 Jan 2007 20:05:35 +0200

Stewart,

I'll be happy to give IEEE1588 talk in the BOF.

What I believe should be clarified is what we want to achieve as WG:

1) Develop Requirements/Architecture

2) Develop a protocol to transfer timing 

3) Develop the timing distribution solution.

I think the WG should focus on 1 and 3, and NOT on 2. I suggest that
this would be clarified in the BOF as well.

The requirement and architecture (part 1) should provide a problem scope
and focus the WG work. We should decide whether we are solving a telecom
provider network timing distribution problem or not. Whether we can
assume MPLS transport or not, Whether we need time transfer or not, etc.

The timing distribution solution (part 3) would answer the questions of
such solution works, that is, how clocks are discovered, how is the
solution managed, is there interactions with routing/qos/signaling etc.
This would probably require developing extensions to various protocols
(BGP, LDP, etc) as well as (hopefully minor) extensions to the timing
protocol itself.

Best
Ron

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Wednesday, January 17, 2007 7:33 PM
To: [email-masked]
Subject: [TICTOC] TICTOC BOF Proposal

1) Problem Statement
2) Possible solutions
3) Charter

Stewart

-- 
This message has been scanned for viruses and
dangerous content by ESVA, and is
believed to be clean.

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 18 Jan 2007 13:01:50 +0000

Ron

> I'll be happy to give IEEE1588 talk in the BOF.

Thanks

> 1) Develop Requirements/Architecture

Yes

> 2) Develop a protocol to transfer timing 

See below

> 3) Develop the timing distribution solution.

Yes

> this would be clarified in the BOF as well.

Well it will be discussed as part of th charter section

> assume MPLS transport or not, Whether we need time transfer or not, etc.

Well I think that we (the IETF) have a much wider problem to solve
thna just timing (frequency) distribution, and just in the telco
environment. One way packet timing is a good example that exists
at all levels in the network, and for which the current generation
of NTP implementations are inadequate.

> (BGP, LDP, etc) as well as (hopefully minor) extensions to the timing

At to protocol. There are two approaches that have been discussed
in various circles - use 1588 in some mode, or enhance NTP, for
example by adding followup messages. It would be the job of the
WG to look at both approaches as descide.

- Stewart