Subject: RE: [TICTOC] Draft BOF description

From: "Sasha Vainshtein" <[email-masked]>
Date: Mon, 15 Jan 2007 16:37:38 +0200

Stewart,
Thanks again and please see a bit more below.

Regards,
                  Sasha

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Monday, January 15, 2007 4:27 PM
To: Sasha Vainshtein
Cc: [email-masked]
Subject: Re: [TICTOC] Draft BOF description

Sasha Vainshtein wrote:

> Stewart,
> Lots of thanks for a prompt response.
> 
> Please see a bit more inline below.
> 
> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, January 15, 2007 3:19 PM
> To: Sasha Vainshtein
> Cc: Alon Shtern; [email-masked]
> Subject: Re: [TICTOC] Draft BOF description
> 
> 
> 
>>2) Applications that require precision time with a greater accuracy 
>>than is currently available with NTP implementations. An example is 
>>the measurement of one-way packet delay in modern packet switched
> 
> networks.
> 
>>[Sasha] I am not sure that "the measurement of one-way packet delay in
> 
> 
>>modern packet switched networks" per se counts as an application. Can 
>>we possibly have another example?
>>
> 
> 
> Why not? There are plenty of folks that want to measure network delay 
> and jitter.
> The advantage of using it as the primary application is that everyone 
> at the IETF understands it.
> 
> [Sasha] What I've tried to say that while high-precision frequency 
> distribution is a mandatory precondition for deploying mobile 
> telephony cell sites using PSN technologies, I am not aware of a 
> similar case with the high-precision packet delay measurements (does 
> not mean that these cases do not exist).

Sasha - The previous section covered frequency, and you are correct that
it is needed for mobile cell site case. 
Packet delay measurements are needed to ensure that the edge and core
network are fit for purpose in many applications, 
including the support of circuit emulation.

[Sasha] I did not say that packet delay measurements are not useful.
But I am not sure that ability to measure packet delay with very high
accuracy is a precondition for deploying circuit emulation.

Not that CDMA cell sites do need time as well as frequency although at
the moment they get time from GPS. WiMAX also needs time.

[Sasha] Time or frequency? And anyway WiMAX gets whatever it needs from
GPS AFAIK.

> [Sasha] I even think that at least the printing industry example will 
> be understood by most people in the IETF.
> (Since I do not know what exactly a synchrophasor is, I reserve my 
> judgment on the universal understanding of the 2nd one:-)
> 

Well I don't think that there is space in the draft to discuss it, but
there is direct relationship between the inability to measure power
distribution in the electricity network the famous 17 August 2003
blackout of the eastern portion of the North American network.

[Sasha] This would be definitely understood by a substantial part of the
IETF people!

I will see if I can find a time to scan in the paragraph, it's quite an
interesting case.

  > No, there are also issues with path asymetry, and variations in
store
> and forward time.
> 
> [Sasha] Is not the issue of the path asymmetry also a discriminator 
> between the LAN environment and the IP/MPLS one?

Depends what path split value you set when you do the pathsplit
calculation :)

Seriously there are also more subtle issues about the path length and it
depends on the accuracy required.

> If yes, maybe it is worth mentioning as one of the arguments not to go

> with 1588v2 (which, IMHO, is about high quality time transfer).
> 

We can certainly call up the path split issue, but 1588 also has a
unicast mode that is notconstrained to a LAN.

- Stewart

_______________________________________________
TICTOC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tictoc

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 15 Jan 2007 14:47:28 +0000

> accuracy is a precondition for deploying circuit emulation.

I suspect that we are in violent agreement.

> [Sasha] Time or frequency? And anyway WiMAX gets whatever it needs from

CDMA needs time and frequency. WiMAX needs time and frequency. At the
moment WiMAX gets this from GPS, but that would be a problem outside
the US, and is certainly an issue that our developers have brought
to my attention.

> [Sasha] This would be definitely understood by a substantial part of the

Yes - it will definately go in the presentation. As I said I will
try to at least scan in the text from John's book, or find a
reference.

- Stewart