Subject: [TICTOC] Minutes for review

From: "Yaakov Stein" <[email-masked]>
Date: Sat, 24 Mar 2007 20:26:19 +0200

Hi all, 
 
Here are the minutes for the TICTOC session.
Please review.
 
Thanks to Laurent and Marshall for taking minutes and jabbering.
 
Y(J)S
 
========================================================================
=

TICTOC BoF Meeting Minutes
900-1130, Tuesday, March 20, 2007  
 
Yaakov Stein and Kurt Lindqvist, co-chairs of the TICTOC BoF, called the
meeting to order.
Laurent Montini volunteered to take minutes and Marshall Eubanks agreed
to act as jabber scribe.
 
Yaakov introduced TICTOC and bashed the agenda. 
http://www3.ietf.org/proceedings/07mar/agenda/tictoc.html
<http://www3.ietf.org/proceedings/07mar/agenda/tictoc.html> 
 
Yaakov explained the agenda had four parts:
1) problem statement, or "there is an interesting problem"
2) NTP and 1588 presentations, or "the problem IS solvable"
3) other SDOs, or "the problem is not being solved elsewhere"
4) open mike, or "do we want to solve this problem here?".
 
Yaakov warned audience that this BoF was not going to discuss which
if any existing protocol would be used.
 
No objections to the agenda.

* Presentation: TICTOC Problem statement (Stewart Bryant) 
Relevant Draft: draft-bryant-tictoc-probstat-00.txt
 
Stewart presented a large set of applications (cellular basestations, 
industrial applications, 
test and measurement, distributed systems) 
 
requiring precise timing (i.e. frequency),  or time (wallclock)
synchronization.
 
The requirements are 50 ppb for frequency and 1-10 microsec for time.
The tough applications are all "infrastructure" applications.

Several possible solutions were mentioned, and issues of security and
congestion raised.
Some techniques require hardware changes.
 
Question on other possible applications. 
Yaakov asked to keep such general questions for the open mike session.

* Presentation: Requirements for wallclock (Peter Lothberg)
 
Peter reviewed the expected features for generalized time (wallclock)
synchronization.
Because there are multiple UTC representations, client must be able to
handle many representations.
There is a need to solve the ambiguity NTP introduces today on time
format.
State must continue to be stored by client and not server.
Also there is a need for server to provide clock characteristics, (NTP
doesn't).
 
Joe Touch questioned about the 1ms objective when military requirement
and wireformat 
capability demand 1ps.
Peter's point was to ask wire format to support 1ps representation but
not how to achieve 1ps quality.
It was recalled wallclock time requirement is global not specific.
The 1ms value is coming from very few packet transmission, stability of
clock on host.
Kurt reminded to keep general questions for open mike session.

* Presentation: NTP improvements for wallclock  (Peter Lothberg)
 
NTP should be used as first option for short term issue and use the
capabilities of NTPv4 
to solve previously listed requirements for wallclock.
 
Support of linear timescale and better handling of leap seconds are key
requirements to support TAI 
(e.g. for Galileo GNSS).
 
In short, Peter proposed using NTP and consider changes for improved
wallclock.

* Presentation: NTP enhancements as a solution to TICTOC (Greg Dowd) 
 
Greg reviewed NTP and its history and proposed enhancements (eNTP) for
higher quality synchronization.
Greg presented results from initial tests.
Considering hardware timestamping, the use of different size packet to
compensate asymmetry 
Peter previously proposed would be an issue.
 
Joe Touch asked if studies have been made regarding impact of increased
variance and asymmetry of networks.
Greg answered that larger asymmetry would not change the results for a
constrained network.
 
Introducing next presentation, Yaakov reminded that NTP and IEEE1588 are
simply examples of possible solutions,
and that we are not yet considering basing tictoc on one or the other.

* Presentation: IEEE1588 as a solution to TICTOC (Ron Cohen) 
 
Ron presented PTP highlighting the key differences with NTP. 
In PTP, hardware timestamping is a basic requirement avoiding noise
insertion by the nodes, removing the PDV.
The different variables and extensions in IEEE1588v2 can be adapted to
suit specific requirements, 
assuming this protocol to be a good candidate for TICTOC.
 
Yaakov explained for those confused that PTP and IEEE1588v2 are the same
thing.

* Presentation: NTP and IEEE1588 Scaling Considerations (Karen
Odonoghue) 
 
Karen presented the different scalability parameters that need to be
taken into account.
Both protocols (NTP and PTP i.e. IEE1588) can be leveraged.
Karen suggested a detailed technical analysis.
 
Yaakov added that CTP (Classless Time Protocol) was another example.
(Network classless time protocol based on clock offset optimization 
 IEEE/ACM TRANSACTIONS ON NETWORKING, VOL. 14, NO. 4, AUGUST 2006)

* Presentation: Security of public NTP servers (Peter Lothberg) 
 
For a global time server, client needs to find a way to get signature of
the public, official server.
Internal server (e.g. enterprise) does not need official time.
What should be the the security model for timekeeping?

* Presentation: Related work in other SDOs (Silvana Rodrigues)
(SDO = Standards Development Organization
)

Silvana presented which other SDOs are working on with regard to
synchronization, 
ITU-T Q13/15, IEEE 1588 and 802.1AS, ATIS OPTXS-SYNC.
ITU-T Q13/15 G.paclock specifications for Synchronous Ethernet
(PHY-layer Ethernet frequency distribution) 
should be consented in June 07.
 
Question about IPR issues.
 
Silvana answered for IEEE1588 version 1, some IPR claims exist but with
very low fee and 
there are IPR statements from Cisco and Rockwell however not on
fundamental issues.
Greg and Silvana said none exists for NTP. 
Yaakov added an old patent exists concerning Synchronous Ethernet.

* Charter presentation (Kurt Lindqvist)
http://www.dspcsp.com/tictoc/ <http://www.dspcsp.com/tictoc/> 
 
Kurt introduced the draft charter and moved to the open mike session.
 
Al Morton asked to change first sentence in third paragraph  
"precision than can be achieved with the current version of NTP." 
Yaakov explained that the sentence refers to commonly available software
implementations.
 
Pekka commented on fourth paragraph that the goals were too open-ended.
What are the most critical issues? What is the focus?
Mark Townsley (AD) responded that this could decided after more thought
and discussion,
although he would prefer to avoid rechartering.
 
Peter remarked on first sentence it should be just about IP. 
Yaakov responded that at the IETF Packet Switched Networks could be IP
or MPLS.
Stewart added that the goal is to separate the payload encapsulation
from design work.
 
Tim Shepherd asked which requirements were the most important. 
There are indeed different requirements from different systems or even
in same system. 
As an example there are different UTC. 
We shall be able to transmit whatever timescale with one protocol: TAI,
UTC and other UT representations, 
that is multiple timescales at the same time on one same network.
Yaakov also underlined sometimes there is no time, only frequency.
 
Joe asked if TICTOC should become a WG. He believes that the IETF should
work 
on finalizing protocols, not developing solutions.
Yaakov stated that the whole idea was to work together form the
begining,
rather than getting multiple designs over few years and then fight here.
Joe said that the latter was the way the IETF works.
Mark Townsley remarked this is how IETF fails. 
Then he restated the discussion was about if this work should be handled
by IETF through a new WG.
 
Tim Shepherd highlighted that new upcoming applications like air traffic
navigation 
are not currently part of the discussion. The suggestion was to wait for
future requirements.
Yaakov answered the previous list was not exhaustive and more aggressive
requirements
could be added at a later date.
 
Sasha Vainshtein asked to separate the timing (frequency) and time
definition so that a specific protocol 
for timing could be worked out.
Yaakov said such distinction was not precluded and was specifically
mentioned in the problem statement.
Sasha said that the charter did not say how this will be handled and
should be specified before WG chartered. 
Also work shall distinguish the conditions where solutions are
deployable.
Mark recalled to keep the generality of IP in mind.
 
Silvana commented it was not clear if TICTOC was about "reuse" or
"invent".
Yaakov stated that the target was standard track solutions. 
Silvana said it was important to liaise with other SDOs.
Kurt (with IAB hat on) explained the issues with formal liaison
relationships.
Yaakov added there was a spectrum between what MEGACO did (single
document in 2 SDOs)
and what PWE3 did (informal liaisons and coparticipation).
 
Ron commented that he wanted a "telecom-grade" synchronization statement
in order to narrow the scope.
Kurt responded we do not know yet how different demands are and that we
do not want to limit the scope too much. 
This needs more analysis.
 
Joe Touch said that in his opinion the charter needed drastic rewriting,
again asked what the requirements were and and if we want to solve them.

In his opinion this seems more an IRTF than IETF problem.
Yaakov answered that the first step was to come up with a requirements
document,
afterwards an architecture document, and then we could see if there were
open
research issues.
 
Karen posed the question of how transition would be accomplished
from present NTP to new protocol. 
 
Luca asked about the need to integrate the solution with IETF transport
protocols.
Stewart responded that the majority of the current requirements come
from infrastructure carrier needs.
 
Greg commented that regardless of the name of the WG, there are multiple
needs around for frequency and time distribution with a framework for
modular environment with engineering, 
security etc... purposes.
 
Kurt noted that if primary customer are operators many other can benefit
on improvement of timekeeping.
He also asked if this should be a problem space (IRTF) or solution space
(IETF) but believes this is an engineering item, i.e. IETF.
Joe seconded in forwarding the problem space to IAB and solution space
to IESG for comment.
 
Benoit Claise noticed network management was missing. Point noted.
 
Joe stressed there was no evidence having enough input to make this a
new charter. 
He said that NTP could be good enough.
 
Kurt emphasized the need for writing a requirements draft before coming
up with solutions.
 
Stewart stressed the fact the eNTP results presented by Greg was for
frequency not time synchronization. 
 
Peter distinguished the cases of constrained network vs. public
Internet.
He did not see enough to say if we can't use what is already in IETF.
Kurt backed saying there are more to add.
 
Mark Townsley (AD) wrapped up listing the comments he had heard:
1) need to modularize (need modularization draft?)
2) focus - which problem do we want to solve ?
3) modes vs. protocols - multiple protocols are on the table
4) do we just want to update ntp? transition strategy - interoperability
5) clarify liaison relationships
6) management
7) security and threat analysis
 
Mark asked who would actively participate in a new WG.
Eight hands.
How many would be ready to review the documents?
Ten hands.
 
Mark stated that he was not convinced NTPv4 could solve the problem,
added other SDOs working on it. 
 
Mark then asked who thought there was NO need to form a WG.
Very few hands.
 
How many thought that a new WG was needed?
Many hands.
 
How many believe that more information is needed to make a decision?
Many hands.
 
Mark noted that the number of people ready to be involved for writing
and reviewing was 
relatively small for a WG.
However many were sufficiently interested to have already joined the
tictoc mailing list.
 
Mark concluded that the charter needed to be updated
before a conclusion could be drawn. 
This did not need to wait for another BOF
but could be done on the mailing list.

Mark and Yaakov closed the BoF at 11:35AM.

_______________________________________________
TICTOC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tictoc

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 29 Mar 2007 20:02:20 +0200

I have yet to receive ANY comments on these notes.
 
As I have found a few typos myself, I doubt that they are perfect.
 
I would appreciate comments as I want to upload them to the 
proceedings site next week.
 
Y(J)S

________________________________

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Saturday, March 24, 2007 20:26
To: [email-masked]
Subject: [TICTOC] Minutes for review

Hi all, 

 
Y(J)S

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 30 Mar 2007 17:02:34 +0100

Yaakov Stein wrote:
> ------------------------------------------------------------------------
> *From:* Yaakov Stein [mailto:[email-masked]]
> *Sent:* Saturday, March 24, 2007 20:26
> *To:* [email-masked]
> *Subject:* [TICTOC] Minutes for review
>
> Hi all,
>  
> =========================================================================
>
> Yaakov Stein and Kurt Lindqvist, co-chairs of the TICTOC BoF, called 
> the meeting to order.
> Laurent Montini volunteered to take minutes and Marshall Eubanks 
> agreed to act as jabber scribe.
>  
> The 1ms value is coming from very few packet transmission, stability 
> of clock on host.
> Support of linear timescale and better handling of leap seconds are 
> key requirements to support TAI
> (e.g. for Galileo GNSS).
>  
> Joe Touch asked if studies have been made regarding impact of 
> increased variance and asymmetry of networks.
> Introducing next presentation, Yaakov reminded that NTP and IEEE1588 
> are simply examples of possible solutions,
> Yaakov explained for those confused that PTP and IEEE1588v2 are the 
> same thing.
>  
>
> * Presentation: NTP and IEEE1588 Scaling Considerations (Karen Odonoghue)
>  
> For a global time server, client needs to find a way to get signature 
> of the public, official server.
> Silvana answered for IEEE1588 version 1, some IPR claims exist but 
> with very low fee and
> http://www.dspcsp.com/tictoc/
>  
> Yaakov explained that the sentence refers to commonly available 
> software implementations.
>  
> Mark Townsley (AD) responded that this could decided after more 
> thought and discussion,
> We shall be able to transmit whatever timescale with one protocol: 
> TAI, UTC and other UT representations,
> Joe asked if TICTOC should become a WG. He believes that the IETF 
> should work

I think that he said that it should not be a WG
> Yaakov stated that the whole idea was to work together form the begining,
Some needs to ask Mark what he actually said. I think that he
was countering Joes point by saying that the IETF needed to work
better rather than just giving up because things did not work
in the past.

> Then he restated the discussion was about if this work should be 
> handled by IETF through a new WG.
>  
> Tim Shepherd highlighted that new upcoming applications like air 
> traffic navigation
> are not currently part of the discussion. The suggestion was to wait 
> for future requirements.
> Yaakov answered the previous list was not exhaustive and more 
> aggressive requirements
> Also work shall distinguish the conditions where solutions are deployable.
> Ron commented that he wanted a "telecom-grade" synchronization 
> statement in order to narrow the scope.
> Kurt responded we do not know yet how different demands are and that 
> we do not want to limit the scope too much.
> afterwards an architecture document, and then we could see if there 
> were open
> research issues.
>  
> Luca asked about the need to integrate the solution with IETF 
> transport protocols.
> Kurt noted that if primary customer are operators many other can 
> benefit on improvement of timekeeping.
> Kurt emphasized the need for writing a requirements draft before 
> coming up with solutions.
>  
> Peter distinguished the cases of constrained network vs. public Internet.

Was that Peter or was it me (or both?)
> Mark and Yaakov closed the BoF at 11:35AM.

I new proposed charter was written after the mtg - I guess that this 
should be circulated.

- Stewart
> ------------------------------------------------------------------------
>