Subject: [TICTOC] Architecture document

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 21 Apr 2008 10:40:44 +0300

Hi all, 
 
Stewart and I are fleshing out the main documents.
 
As you saw last week, we believe that the problem statement should be
replaced
by a requirements document, and we have proposed section headings for
this doc.
 
We also believe that the modularization document should be replaced by
an architecure doc. However, here we are not sure about the scope and
contents.
Let's assuming that "architecture" in this context means both "network
architecture",
and "algorithm architecture".
 
Is the TICTOC layering model this simple ?
 
   APPLICATION LAYER  =  protocol payload including timestamps, etc.
                                          algorithms to stabilize
frequency and acquire time
 
   TRANSPORT LAYER   =  server network (IP, MPLS, Ethernet)
 
Or do we divide this up more finely, e.g. having a frequency recovery
layer underneath a time recovery one ?
Is the ranging protocol at the same architecture layer as the frequency
recovery ?
 
How are we going to handle the layer mixing introduced by TCs ?
 
Comments welcomed.
 
Y(J)S
 
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 23 Apr 2008 16:19:01 +0300

Danny

The way we see it, the requirements document will explain the background
too.

It seems a bit redundant to have both.

Y(J)S 

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]] 
Sent: Tuesday, April 22, 2008 2:40 PM
To: Yaakov Stein
Cc: [email-masked]
Subject: Re: [TICTOC] Architecture document

Yaakov Stein wrote:
> replaced by a requirements document, and we have proposed section 
> headings for this doc.
>  

I disagree. You need both. If you don't have a problem statement then
the requirements document has nothing to anchor itself to. Before you
can have requirements you need to know the problem you are trying to
solve.

Danny