Subject: Re: [TICTOC] TICTOC Digest, Vol 25, Issue 7

From: "Roger Sundman" <[email-masked]>
Date: Thu, 18 Sep 2008 11:23:06 +0200

Send TICTOC mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www.ietf.org/mailman/listinfo/tictoc
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of TICTOC digest..."

Today's Topics:

   1. Re:  TICTOC Digest, Vol 25, Issue 7 (Roger Sundman)

----------------------------------------------------------------------

Sasha,

No, I don't think 10 ms is enough for a stock exchanege at least not this
particular week given the turbulence on the stock market, but for a cash
register yes. 

Regards
Roger

-----------------------------------------------------------------------

Roger,

Just for the curiosity sake:

Do you imply that the 10 ms time accuracy (available today with NTP) is not
sufficient for
the financial market and/or cash registers?

Regards,
        Sasha

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Roger Sundman
> Sent: Thursday, September 18, 2008 9:18 AM
> To: [email-masked]
> Subject: Re: [TICTOC] TICTOC Digest, Vol 25, Issue 2
> Today's Topics:
>
>    1.  Requirements draft - call for assistance (Roger Sundman)
>
>
> ----------------------------------------------------------------------
>
> Hi all,
>
> There is a need for traceable time in the financial market
> and there is a (coming?) directive from the EC comission for traceable
time
> for use in cash registers. Seismic exploration, military and
transportation
> ar  some other applications.
>
> Best regards
> Roger
>
>
> Hi all,
>
> Yesterday the chairs and Silvana, who is co-editor of the requirements
> draft,
> discussed the progress of this draft.
>
> The requirements draft tries to cover quite a number of areas
> for which
> timing is relevant,
> and while there has been significant participation from the
> cellular and TDM
> PW communities,
> there has been inadequate input on most of the other areas.
>
> In particular, for the areas
>    * industrial applications
>    * test and measurement
>    * electric power and teleprotection
> we have no data other than that "pulled out of the air" at the Paris
> meeting,
> and no one has expressed interest in providing insights into their
> requirements.
>
> On the one hand TICTOC needs to consider all of the
> applications that will
> need to distribute timing,
> but on the other hand if groups with interest in particular
> applications do
> not join in the effort,
> we will not be able to produce a meaningful document.
>
> Please consider this email as a call for participation for the
> aforementioned areas.
> If you are working or interested in them, please send an
> email to the list.
> If you know people who are, please forward this email to them.
>
> If we do not receive input that we believe reliably reflects the
> requirements of these areas,
> we will have to drop them from the document, and thus remove them from
> consideration
> while working on solutions.
>
> Y(J)S
>
>
>
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
> http://www.ietf.org/pipermail/tictoc/attachments/20080918/24d9
7376/attachmen
t.htm

------------------------------

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

End of TICTOC Digest, Vol 25, Issue 2
*************************************

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

------------------------------

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

End of TICTOC Digest, Vol 25, Issue 6
*************************************

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 18 Sep 2008 06:17:42 -0400

>   1. Re:  TICTOC Digest, Vol 25, Issue 7 (Roger Sundman)

(I renamed the thread.)

Given that the financial people are concerned with millisecond delays,  
10 msec
is clearly not enough for some trading applications. See, e.g.,

http://www.usfst.com/currentissue/article.asp?art=275136&issue=281

“a millisecond advantage in trading applications can be worth $100  
million a year to a major brokerage firm.”

Much of their use of multicast is driven by such considerations.

  Whether they have thought this through or not
is another question.

Regards
Marshall

---

From: "Tony Li" <[email-masked]>
Date: Thu, 18 Sep 2008 10:40:48 -0700

Hi Marshall,

|Given that the financial people are concerned with millisecond 
|delays,  
|10 msec
|is clearly not enough for some trading applications. See, e.g.,
|
|http://www.usfst.com/currentissue/article.asp?art=275136&issue=281
|
|"a millisecond advantage in trading applications can be worth $100  
|million a year to a major brokerage firm."
|
|Much of their use of multicast is driven by such considerations.
|
|  Whether they have thought this through or not
|is another question.

Is there any bound to the amount of delay that they can exploit?  It would
seem that given a 1 ms offset, someone will work hard to exploit that.  This
simply becomes an arms race down to a femto-second.

Tony

---

From: <[email-masked]>
Date: Thu, 18 Sep 2008 21:20:58 +0100

I don't think timing for trading systems is delivered across the general
internet. I would expect these to be custom designed. But then again I
am open to be proved wrong.

Regards

Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Tony Li
Sent: 18 September 2008 18:41
To: 'Marshall Eubanks'; 'Roger Sundman'
Cc: [email-masked]
Subject: [TICTOC] Requirements: trading applications

Hi Marshall,

Is there any bound to the amount of delay that they can exploit?  It
would seem that given a 1 ms offset, someone will work hard to exploit
that.  This simply becomes an arms race down to a femto-second.

Tony

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 18 Sep 2008 20:42:07 -0400

On Sep 18, 2008, at 1:40 PM, Tony Li wrote:

> would

I would think that you're basically correct. Whenever there is a  
benefit to be had by being faster and /
or bigger, there will be a technological impetus to being faster and /  
or bigger.

I would expect diminishing returns as things improve, but who knows ?  
Maybe in  10 years financial crises will
take microseconds instead of days.

Regards
Marshall

---

From: Yaakov Stein <[email-masked]>
Date: Sun, 21 Sep 2008 13:52:20 +0300

Mike

I believe that it depends what kind of system we are talking about.

RFC 2801 (the Internet Open Trading protocol) has (optional) timestamps
for even small transfers of money.

Large electronic trading companies often place their servers as geographically close
to the market's computers as they can, in order to minimize the propagation latency.
They are assuming that the time that counts is the time a packet containing a transaction order
ARRIVES at the market's server.

I do not know of any case law (and perhaps others can help here)
where this has been definitively established.
If it turns out that the time that counts is the time the transaction is SENT,
then we will need a method of distributing highly accurate time to end users
along with tamper-proofing of the outgoing timestamp.

Of course, people close to e.g. NASDAQ's computer will still have the
advantage of getting up-to-date data faster,
but will lose the advantage of lower propagation latency of their orders.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, September 18, 2008 11:21 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [TICTOC] Requirements: trading applications

I don't think timing for trading systems is delivered across the general internet. I would expect these to be custom designed. But then again I am open to be proved wrong.

Regards

Mike