Subject: [TICTOC] Document with definitions discussed during the last TICTOC conference call

From: <[email-masked]>
Date: Sun, 10 May 2009 23:23:26 +0200

Hello,

Since I was late during the last TICTOC conference call, I was wondering what was the document that has been discussed during the call containing the definitions?
Is it the requirements document? A new document? Where does the need for new definitions come from?

Thanks in advance for the clarifications.

Just a personal opinion regarding possible new definitions in TICTOC: it would be good as far as possible to align and re-use terms that are already defined in other groups dealing with synchronization (e.g. NTP, IEEE1588, ITU-T...). It would avoid confusion in the timing community in general.

Thanks.

Best Regards,
 
 <<Picture (Metafile)>>   <<Picture (Metafile)>> 

Sébastien JOBERT
R&D engineer, network synchronization
Orange Labs / France Telecom R&D
FT/RD/CORE/MCN/WAN
Tel : +33 2 96 05 20 93 - Mob : +33 6 82 69 00 50 
[email-masked]

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 11 May 2009 07:00:10 +0300

Sebastien,

We discussed the definitions section of the requirements document.

I believe that we managed to pin down the concepts of

·         frequency

·         phase (1 / frequency – e.g. 1 pps, no connection between different systems)

·         aligned phase (phase with zero or known relationship at different systems)

·         labeled (previously called uncalibrated) time (aligned phase events are labeled, but no link to official time standard, e.g. TDMA systems)

·         calibrated time (locked to UTC or national time standard)

We also discussed stability and accuracy (which refer to one of the above)

We looked at the ITU and 1588 definitions where applicable.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 11, 2009 00:23
To: [email-masked]
Subject: [TICTOC] Document with definitions discussed during the last TICTOC conference call

Hello,

Just a personal opinion regarding possible new definitions in TICTOC: it would be good as far as possible to align and re-use terms that are already defined in other groups dealing with synchronization (e.g. NTP, IEEE1588, ITU-T…). It would avoid confusion in the timing community in general.

Thanks.

Best Regards,

Sébastien JOBERT
R&D engineer, network synchronization
Orange Labs / France Telecom R&D
FT/RD/CORE/MCN/WAN
Tel : +33 2 96 05 20 93 - Mob : +33 6 82 69 00 50
[email-masked]<mailto:[email-masked]>

---

From: "Stefano Ruffini" <[email-masked]>
Date: Mon, 11 May 2009 09:22:53 +0200

Hi Yaakov, 
 
unfortunately I was not able to attend the meeting.
 
  Comparing the definitions provisionally agreed in ITU-T and currently included in the G.pactiming-bis draft (the definitions are copied below) with the concepts you have discussed it seems that 

	Phase Synchonization (ITU-T)  = aligned phase (TICTOC)
	Time Synchronization (ITU-T) = labeled time + calibrated time (TICTOC)

Phase Synchronization - The term phase synchronization implies that all associated nodes have access to  reference timing signals whose significant events occur at the same instant (within the relevant phase accuracy requirement). In other words the term phase synchronization refers to the process of aligning clocks with respect to phase (phase alignment).

Note: phase synchronization includes compensation for delay between the (common) source and the associated nodes.

Note: this term might also include the notion of frame timing (that is, the point in time when the timeslot of an outgoing frame is to be generated). 

Note: the concept of phase synchronization (phase alignment) should not be confused with the concept of phase-locking where a fixed phase offset is allowed to be arbitrary and unknown. Phase alignment implies that this phase offset is nominally zero.  Two signals which are phase-locked are implicitly frequency synchronized. Phase-alignment and phase-lock both imply that the Time Error between any pair of associated nodes is bounded.

Figure 1/G.8266 - Phase Synchronization

Time synchronization - Time synchronization is the distribution of a time reference to the real-time clocks of a telecommunications network. All the associated nodes have access to information about time (in other words, each period of the reference timing signal is marked and dated) and share a common timescale and related epoch (within the relevant time accuracy requirement).

Examples of timescales are:

*	UTC
*	TAI
*	UTC + offset (e.g. local time)
*	GPS
*	PTP
*	Local arbitrary time

Note that distributing time synchronization is one way of achieving phase synchronization.

Figure 2/G.8266 - Time Synchronization

Best Regards
Stefano

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: lunedì 11 maggio 2009 6.00
To: [email-masked]; [email-masked]
Subject: Re: [TICTOC] Document with definitions discussed during the lastTICTOC conference call

Sebastien,

·         frequency

·         phase (1 / frequency - e.g. 1 pps, no connection between different systems)

Y(J)S

Hello, 

Thanks. 

Best Regards, 

Sébastien JOBERT 
R&D engineer, network synchronization
Orange Labs / France Telecom R&D 
FT/RD/CORE/MCN/WAN
Tel : +33 2 96 05 20 93 - Mob : +33 6 82 69 00 50
[email-masked] <mailto:[email-masked]>

---

From: <[email-masked]>
Date: Mon, 11 May 2009 23:16:21 +0200

Thank you Yaakov for the clarification.
 
BR,
 
Sébastien 

De : Yaakov Stein [mailto:[email-masked]] 
Envoyé : lundi 11 mai 2009 06:00
À : JOBERT Sebastien RD-CORE-LAN; [email-masked]
Objet : RE: Document with definitions discussed during the last TICTOCconference call

Sebastien,

·         frequency

Y(J)S

Hello, 

Thanks. 

Best Regards, 

Sébastien JOBERT