Subject: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

From: Yaakov Stein <[email-masked]>
Date: Wed, 14 Jul 2010 20:58:23 +0300

As I am sure you all know, TICTOC and NTP will be holding a joint meeting at the Maastricht IETF.

I have posted the preliminary agenda, based on slot requests received
http://www.ietf.org/proceedings/78/agenda/tictoc.txt .

I expect that Karen will add some more NTP items before we upload the final agenda.

If anyone else is interested in a slot, we still have a bit of spare time
(but not much if we want serious discussion over the 1588oMPLS issue).

Y(J)S

---

From: "Tim Frost" <[email-masked]>
Date: Wed, 14 Jul 2010 12:39:10 -0700

Thank you for the agenda, Yaakov.

For the information of people on the list, Yaakov has allocated a slot
for the discussion of management of packet-based timing, under which I
have submitted two internet drafts, draft-frost-tictoc-management-00,
and draft-frost-tictoc-ptp-slave-mib-00.  See the abstracts below.

Best regards,
Tim

A new version of I-D, draft-frost-tictoc-management-00.txt has been
successfully submitted by Tim Frost and posted to the IETF repository.

Filename:   draft-frost-tictoc-management

Revision:   00

Title:            Management Requirements for Packet-based Timing
Distribution

Creation_date:    2010-07-05

WG ID:            Independent Submission

Number_of_pages: 7

Abstract:

This Internet draft investigates the management aspects associated with
packet-based distribution of time and frequency using protocols such as
PTP (Precision Time Protocol, [1]).  It explores some of the issues that
need to be solved in connection with the management of synchronization
distribution.

A new version of I-D, draft-frost-tictoc-ptp-slave-mib-00.txt has been
successfully submitted by Tim Frost and posted to the IETF repository.

Filename:   draft-frost-tictoc-ptp-slave-mib

Revision:   00

Title:            Definitions of Managed Objects for Precision Time
Protocol Version 2 (PTPv2) Slave Clocks

Creation_date:    2010-07-05

WG ID:            Independent Submission

Number_of_pages: 35

Abstract:

This draft contains a preliminary MIB definition for a PTP Slave- Only
Ordinary clock.  This targeted at a slave clock compliant with the PTP
Telecom Profile described in [G.8265.1].

Tim Frost,

Symmetricom, Inc.

Tel: +44 7825 706952

Email: [email-masked]

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Yaakov Stein
Sent: 14 July 2010 18:58
To: [email-masked]
Subject: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

As I am sure you all know, TICTOC and NTP will be holding a joint
meeting at the Maastricht IETF.

I expect that Karen will add some more NTP items before we upload the
final agenda.

If anyone else is interested in a slot, we still have a bit of spare
time 

Y(J)S

---

From: Peter Roberts <[email-masked]>
Date: Tue, 20 Jul 2010 16:15:00 -0400

Tim,
I had a read through the two documents and I would like a quick 
clarification clarification on the MIB.

Is the MIB dealing with
     a G.8265.1 Telecom Slave or
     a G.8265.1 Slave-Only Ordinary Clock Instance or
     a IEEE1588 Slave Only Ordinary Clock?

I am guessing that the intent was a G.8265.1 Telecom Slave but the MIB 
is missing some of the aspects of this device (e.g. list of grandmasters).

Also every object is read-only.   Is this the intent or simply that this 
aspect has not yet been fully developed?

I have some additional comments but I want to understand the scope of 
this MIB first.

Peter R.

On 7/14/2010 3:39 PM, Tim Frost wrote:
> This Internet draft investigates the management aspects associated 
> with packet-based distribution of time and frequency using protocols 
> such as PTP (Precision Time Protocol, [1]).  It explores some of the 
> issues that need to be solved in connection with the management of 
> synchronization distribution.
>
> *Tim Frost,*
> *Symmetricom, Inc.***
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Yaakov Stein
> *Sent:* 14 July 2010 18:58
> *To:* [email-masked]
> *Subject:* [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda
>
> As I am sure you all know, TICTOC and NTP will be holding a /joint/

---

From: <[email-masked]>
Date: Tue, 20 Jul 2010 23:56:36 +0200

Tim,
 
In addition to the valid questions from Peter, I am also wondering why some additional objects which do not correspond to existing attributes in G.8265.1 are described in this draft (mainly at the end).
 
Among these new objects (which sounds to me like proprietary parameters), one can identify the following ones:
   ptpOperationalMinTDEVForward OBJECT-TYPE
   ptpOperationalMinTDEVReverse OBJECT-TYPE
   ptpOperationalMAFEForward OBJECT-TYPE
   ptpOperationalMAFEReverse OBJECT-TYPE
 
Are you proposing that a PTP slave compliant with this MIB would have to implement all those objects?
 
Thanks.

BR,
 
Sébastien 
________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Peter Roberts
Envoyé : mardi 20 juillet 2010 22:15
À : [email-masked]; Tim Frost
Objet : Re: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

Tim,
I had a read through the two documents and I would like a quick clarification clarification on the MIB. 

Is the MIB dealing with 

I am guessing that the intent was a G.8265.1 Telecom Slave but the MIB is missing some of the aspects of this device (e.g. list of grandmasters).  

Also every object is read-only.   Is this the intent or simply that this aspect has not yet been fully developed?

I have some additional comments but I want to understand the scope of this MIB first.

Peter R.

	For the information of people on the list, Yaakov has allocated a slot for the discussion of management of packet-based timing, under which I have submitted two internet drafts, draft-frost-tictoc-management-00, and draft-frost-tictoc-ptp-slave-mib-00.  See the abstracts below.

	Best regards,
	Tim

	A new version of I-D, draft-frost-tictoc-management-00.txt has been successfully submitted by Tim Frost and posted to the IETF repository.

	Revision:   00

	Title:            Management Requirements for Packet-based Timing Distribution

	Number_of_pages: 7

	Abstract:

	This Internet draft investigates the management aspects associated with packet-based distribution of time and frequency using protocols such as PTP (Precision Time Protocol, [1]).  It explores some of the issues that need to be solved in connection with the management of synchronization distribution.

	A new version of I-D, draft-frost-tictoc-ptp-slave-mib-00.txt has been successfully submitted by Tim Frost and posted to the IETF repository.

	Revision:   00

	Title:            Definitions of Managed Objects for Precision Time Protocol Version 2 (PTPv2) Slave Clocks

	Number_of_pages: 35

	Abstract:

	This draft contains a preliminary MIB definition for a PTP Slave- Only Ordinary clock.  This targeted at a slave clock compliant with the PTP Telecom Profile described in [G.8265.1].

	Tim Frost,

	Symmetricom, Inc.

	Tel: +44 7825 706952

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
	Sent: 14 July 2010 18:58
	To: [email-masked]
	Subject: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

	Y(J)S

---

From: "Tim Frost" <[email-masked]>
Date: Wed, 21 Jul 2010 05:03:38 -0700

Hi Peter, Sebastian, 

Thanks for the questions. As you can tell (and as the draft admits), this is not yet fully developed, and needs a thorough checking through before proceeding any further.  The intention was to give a flavor of the kind of MIB we envisaged, and to allow other people to comment on the work we have done and contribute to it.  

On Peter's point, I agree that it is unclear at present whether the MIB is for a G.8265.1 Telecom Slave, or a G.8265.1 Slave Only Ordinary Clock instance.  At some points I have stated a Slave-only Ordinary Clock instance, partly because I was unclear how to accommodate the multiple-instance concept in the MIB description.  However, the inclusion of parameters related to the control loop imply that the MIB is related to the whole Telecom Slave.  

We could look at using a separate MIB for each instance, plus a further one for the control loop side, or constructing one MIB for the whole telecom slave. This is the right point to have that kind of debate, before the work continues too far.

On Sebastien's point, there are a number of performance indicators on the packet flow that we can consider. We have extensively debated some of those parameters in ITU, such as MinTDEV, MAFE, MinTimeDispersion etc.  I would expect that when we can agree on some parameters there, these can be included in the MIB. For the time being, I have included some initial parameters as a placeholder until we can decide which are the most useful ones.

Best regards,

Tim

Tim Frost,

Symmetricom, Inc.

Tel: +44 7825 706952

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 20 July 2010 22:57
To: [email-masked]; [email-masked]; Tim Frost
Subject: Re: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

Tim,

Thanks.

BR,

Sébastien 

Tim,

Is the MIB dealing with 

Peter R.

Best regards,
Tim

Revision:   00

Number_of_pages: 7

Abstract:

Revision:   00

Number_of_pages: 35

Abstract:

Tim Frost,

Symmetricom, Inc.

Tel: +44 7825 706952

http://www.ietf.org/proceedings/78/agenda/tictoctxt <http://www.ietf.org/proceedings/78/agenda/tictoc.txt>  .

Y(J)S

---

From: <[email-masked]>
Date: Fri, 23 Jul 2010 12:55:26 +0200

Thanks Tim for the clarifications.
 
Regarding the "performance indicators", as you underlined, several proposals are still under discussion in ITU-T. This debate is not finished at the moment.
It might therefore be a bit premature to include any of these "performance indicators" at the moment, until ITU-T has agreed on them.
 
If the intention was to maintain a placeholder, it might be better not to mention any particular "performance indicator" in the draft, in order to avoid confusion for people that are not following closely the debates in ITU-T.
 
Apart from this comment, I personally believe that developing a MIB for the G.8265.1 telecom profile might be useful. We probably need however to discuss how to coordinate with some on-going discussions in ITU-T on management aspects (I remember some contributions from other operators with regards to this point).
 
Thanks.
 
BR,
 
Sébastien

De : Tim Frost [mailto:[email-masked]] 
Envoyé : mercredi 21 juillet 2010 14:04
À : JOBERT Sebastien RD-CORE-LAN; [email-masked]; [email-masked]
Objet : RE: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

Hi Peter, Sebastian, 

Best regards,

Tim

Tim Frost,

Symmetricom, Inc.

Tel: +44 7825 706952

Tim,

Thanks.

BR,

Sébastien 

Tim,

Is the MIB dealing with 

Peter R.

Best regards,
Tim

Revision:   00

Number_of_pages: 7

Abstract:

Revision:   00

Number_of_pages: 35

Abstract:

Tim Frost,

Symmetricom, Inc.

Tel: +44 7825 706952

Y(J)S

---

From: Yaakov Stein <[email-masked]>
Date: Sat, 24 Jul 2010 21:18:52 +0300

Just as a remark with WG chair hot on.

Our purview is to create timing solutions for the entire community.
One of our charter items is to create a 1588 MIB.

I would not be in favor of creating a MIB that is limited to a specific application,
even if that application is as interesting to some as the telecomm profile.

This course would get us into a bind later when other applications of 1588 would need MIBs.
In any case, before embarking on such a venture we would have to discuss with
the MIB doctors.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 23, 2010 13:55
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda

Thanks.

BR,

Sébastien

On Peter’s point, I agree that it is unclear at present whether the MIB is for a G.8265.1 Telecom Slave, or a G.8265.1 Slave Only Ordinary Clock instance.  At some points I have stated a Slave-only Ordinary Clock instance, partly because I was unclear how to accommodate the multiple-instance concept in the MIB description.  However, the inclusion of parameters related to the control loop imply that the MIB is related to the whole Telecom Slave.

On Sebastien’s point, there are a number of performance indicators on the packet flow that we can consider. We have extensively debated some of those parameters in ITU, such as MinTDEV, MAFE, MinTimeDispersion etc.  I would expect that when we can agree on some parameters there, these can be included in the MIB. For the time being, I have included some initial parameters as a placeholder until we can decide which are the most useful ones.

Best regards,
Tim

Tim Frost,
Symmetricom, Inc.
Tel: +44 7825 706952

Tim,

Thanks.

BR,

Sébastien

Is the MIB dealing with

Peter R.

Revision:   00

Number_of_pages: 7

Abstract:

Revision:   00

Number_of_pages: 35

Abstract:

Tim Frost,
Symmetricom, Inc.
Tel: +44 7825 706952
Email: [email-masked]<mailto:[email-masked]>
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: 14 July 2010 18:58
To: [email-masked]<mailto:[email-masked]>
Subject: [TICTOC] IETF78 (Maastricht) TICTOC + NTP agenda
As I am sure you all know, TICTOC and NTP will be holding a joint meeting at the Maastricht IETF.
I have posted the preliminary agenda, based on slot requests received
http://www.ietf.org/proceedings/78/agenda/tictoctxt<http://www.ietf.org/proceedings/78/agenda/tictoc.txt> .
I expect that Karen will add some more NTP items before we upload the final agenda.
If anyone else is interested in a slot, we still have a bit of spare time
(but not much if we want serious discussion over the 1588oMPLS issue).
Y(J)S