Subject: [TICTOC] 1588 over PW - MAC SA Modification

From: Tal Mizrahi <[email-masked]>
Date: Sun, 23 Jan 2011 09:07:37 +0200

Hi Manav et al,

When using 1588-over-Ethernet, each TC that modifies the CF also updates the Ethernet MAC SA to the address of the TC. This is because an 802.1 bridge that modifies a packet must update its source address to the bridge's address.

In draft-davari-tictoc-1588overmpls-01, when using 1588-over-PW, the LSR TCs update the CF in the passenger Ethernet packet. I am wondering whether the MAC SA of the passenger Ethernet packet must be updated in this case.
This issue applies also to 1588-over-IP-over-Ethernet-over-PW.

Regards,
Tal.

---

From: Ron Cohen <[email-masked]>
Date: Sun, 23 Jan 2011 17:46:35 +0200

Hi Tal,

In my opinion since the LSR is not an 802.1 bridge it doesn't need to change
source MAC addresses while performing TC functions.

Best,
Ron

On Sun, Jan 23, 2011 at 9:07 AM, Tal Mizrahi <[email-masked]> wrote:

>  Hi Manav et al,
>
>
>
> When using 1588-over-Ethernet, each TC that modifies the CF also updates
> the Ethernet MAC SA to the address of the TC. This is because an 802.1
> bridge that modifies a packet must update its source address to the bridge’s
> address.
>
>
>
> In draft-davari-tictoc-1588overmpls-01, when using 1588-over-PW, the LSR
> TCs update the CF in the passenger Ethernet packet. I am wondering whether
> the MAC SA of the passenger Ethernet packet must be updated in this case.
>
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc
>
>

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 26 Jan 2011 08:50:39 +0000

Yet another layer violation problem, and yet another reason for preferring a pure-MLPS encap.

If we are talking about an Ethernet PW, there is no NSP defined for intermediate LSRs,
(even if we think of a PW with TC as a sequence of S-PEs there is no NSP there)
and so technically no way to do any Ethernet level processing.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ron Cohen
Sent: Sunday, January 23, 2011 17:47
To: Tal Mizrahi
Cc: [email-masked]
Subject: Re: [TICTOC] 1588 over PW - MAC SA Modification

Hi Tal,

In my opinion since the LSR is not an 802.1 bridge it doesn't need to change source MAC addresses while performing TC functions.

Best,
Ron
On Sun, Jan 23, 2011 at 9:07 AM, Tal Mizrahi <[email-masked]<mailto:[email-masked]>> wrote:
Hi Manav et al,

Regards,
Tal.

_______________________________________________
TICTOC mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tictoc