Subject: [TICTOC] UDP checksum

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 21 Jan 2011 04:45:33 +0530

Hi,

Are the LSRs acting as TCs expected to verify the checksum before they update the correction field? If no, then there is no point in these LSRs in updating the UDP checksum as they will "correct" the checksum when its recomputed after modifying the CF field. In this case wouldn't it make more sense to just update the checksum at the MPLS terminating point?

I also think that updating the UDP checksum may be redundant as the LSRs are anyways verifying the outer ethernet checksum before accepting any packets. Any thoughts here?

Cheers, Manav

--
Manav Bhatia,
IP Division, Alcatel-Lucent,
Bangalore - India

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 20 Jan 2011 15:29:06 -0800

Hi Manav,

UDP checksum is usually not verified before updating the CF. After CF update it is incrementally recalculated. The end host will then verify the checksum for correctness.

Regards,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)
Sent: Thursday, January 20, 2011 3:16 PM
To: [email-masked]
Subject: [TICTOC] UDP checksum

Hi,

Cheers, Manav

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 21 Jan 2011 05:03:12 +0530

Hi Shahram,

It may be ok as long as the HWs are incrementally recalculating it. However, if its being done afresh then we have an issue. I don't see how the HW behavior can be mandated in a spec. 

Cheers, Manav

> From: Shahram Davari [mailto:[email-masked]] 
> Sent: Friday, January 21, 2011 4.59 AM
> To: Bhatia, Manav (Manav); [email-masked]
> Subject: RE: UDP checksum
> 
> Hi Manav,
> 
> UDP checksum is usually not verified before updating the CF. 
> After CF update it is incrementally recalculated. The end 
> host will then verify the checksum for correctness.
> 
> Regards,
> Shahram
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)
> Are the LSRs acting as TCs expected to verify the checksum 
> before they update the correction field? If no, then there is 
> no point in these LSRs in updating the UDP checksum as they 
> will "correct" the checksum when its recomputed after 
> modifying the CF field. In this case wouldn't it make more 
> sense to just update the checksum at the MPLS terminating point?
> 
> I also think that updating the UDP checksum may be redundant 
> as the LSRs are anyways verifying the outer ethernet checksum 
> before accepting any packets. Any thoughts here?
> 
> Cheers, Manav
> 
> --
> Manav Bhatia,

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 20 Jan 2011 15:52:14 -0800

Hi Manav,

The minimum requirement is to do UDP checksum incremental update on transmission. If full update is done then UDP checksum must be verified on reception as well.

Thx
Shahram

-----Original Message-----
From: Bhatia, Manav (Manav) [mailto:[email-masked]] 
Sent: Thursday, January 20, 2011 3:33 PM
To: Shahram Davari; [email-masked]
Subject: RE: UDP checksum

Hi Shahram,

Cheers, Manav

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 21 Jan 2011 20:27:29 +0000

Presumably this is a v6 discussion. I can't see any point in using the 
c/s in v4.

WRT v6 there is a movement to make this optional (the debate is 
happening in 6lowlan, and I think that we should be pushing to turn it 
off for PTP.

The worst that can happen is that we receive a corrupt pkt and either 
junk it, or put it in the timing servo whereupon it gets rejected as an 
outlier.

- Stewart

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 21 Jan 2011 15:39:08 -0500

On Jan 21, 2011, at 3:27 PM, Stewart Bryant wrote:

> Presumably this is a v6 discussion. I can't see any point in using the c/s in v4.
> 
> WRT v6 there is a movement to make this optional (the debate is happening in 6lowlan, and I think that we should be pushing to turn it off for PTP.
> 
> The worst that can happen is that we receive a corrupt pkt and either junk it, or put it in the timing servo whereupon it gets rejected as an outlier.
> 

I think you are referring to this 

which is (will be shortly) in 6man

http://tools.ietf.org/html/draft-eubanks-chimento-6man-01

This is for the case where there is an "inner" packet with a header and checksum, so that the "outer" packet doesn't need protection.

Regards
Marshall

---

From: michel ouellette <[email-masked]>
Date: Fri, 21 Jan 2011 21:34:09 +0000

PTP GM and OC are allowed to set the UDP checksum to 0 (according to the standard - UDP/IPv4 encap). In such case no action on the updating the UDP checksum would be required by the TCs.  The TC itself can also set the UDP checksum to 0 (according to the standard any intermediate node can do so).

This would also apply to the case where you have TCs interconnected by two BCs.

- Michel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: January 21, 2011 03:27 PM
To: [email-masked]
Subject: Re: [TICTOC] UDP checksum

- Stewart

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Sat, 22 Jan 2011 06:44:37 +0530

Michel,

The standard only allows the TCs to reset the checksum to 0 when transporting PTP over UDP/IPv4.

My original question was wrt IPv6 - I find correcting the checksum onerous when devices are adding the residence time in the correctionField in HW and I think we should do away with this because if a fresh checksum is being computed then it defeats the whole purpose of having a checksum in the first place. Assume an LSR receives a corrupted MPLS packet. We now change the CF and will end up updating the checksum based on the contents of the corrupted packet.

Cheers, Manav

> [mailto:[email-masked]] On Behalf Of michel ouellette
> Sent: Saturday, January 22, 2011 3.04 AM
> To: [email-masked]
> PTP GM and OC are allowed to set the UDP checksum to 0 
> (according to the standard - UDP/IPv4 encap). In such case no 
> action on the updating the UDP checksum would be required by 
> the TCs.  The TC itself can also set the UDP checksum to 0 
> (according to the standard any intermediate node can do so).
> 
> [mailto:[email-masked]] On Behalf Of Stewart Bryant
> > The minimum requirement is to do UDP checksum incremental 
> update on transmission. If full update is done then UDP 
> checksum must be verified on reception as well.
> >
> > Thx
> > Shahram
> >
> > It may be ok as long as the HWs are incrementally 
> recalculating it. However, if its being done afresh then we 
> have an issue. I don't see how the HW behavior can be 
> mandated in a spec.
> >
> > Cheers, Manav
> >

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 26 Jan 2011 17:46:50 +0000

Marshall

> This is for the case where there is an "inner" packet with a header and checksum, 
> so that the "outer" packet doesn't need protection.

Actually, I think Stewart was referring to http://tools.ietf.org/html/draft-ietf-6lowpan-hc-13 .

If there are several proposals on the table, albeit for special cases,
to make the UDP checksum optional, then we can propose that operation too.

Y(J)S

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 27 Jan 2011 06:24:15 +0530

Yakov, 

> Actually, I think Stewart was referring to 
> http://tools.ietf.org/html/draft-ietf-6lowpan-hc-13 .
> 

Alternatively, we could just keep this within our WG and add the following to the 1588oMPLS draft:

LSRs that adjust the CF field MAY not update the UDP checksum in case of IPv6. The node that terminates the tunnel MUST recompute the UDP checksum after MPLS decapsulation and before any further processing.

This way the 1588aware LSRs only need to update the CF field at the line rate in the HW and need not worry about the correcting/recomputing the UDP checksum. The tunnel terminating node after stripping off the MPLS labels can recompute the UDP checksum and pass it on to the PTP layer above where it will be processed.

Cheers, Manav

---

From: Jack Kohn <[email-masked]>
Date: Fri, 28 Jan 2011 07:58:56 +0530

> LSRs that adjust the CF field MAY not update the UDP checksum in case of IPv6. The node that terminates the tunnel MUST recompute the UDP checksum after MPLS decapsulation and before any further pr…

I would prefer this over a proposal for deprecating UDP checksum for IPv6.

Each 1588aware LSR that updates the CF is anyways updating the
ethernet FCS, which should be good enough to verify the basic
integrity of the packet.

My 0.02$

Jack

---

From: Ron Cohen <[email-masked]>
Date: Fri, 28 Jan 2011 11:25:02 +0200

Hi Jack,

I don't think it is a good idea. In my opinion we should not / can not
specify that packets with wrong UDP checksum will be sent on the wire.

Best,
Ron

On Fri, Jan 28, 2011 at 4:28 AM, Jack Kohn <[email-masked]> wrote:

> > LSRs that adjust the CF field MAY not update the UDP checksum in case of
> IPv6. The node that terminates the tunnel MUST recompute the UDP checksum
> after MPLS decapsulation and before any further processing.
>

---

From: Tal Mizrahi <[email-masked]>
Date: Fri, 28 Jan 2011 14:22:59 +0200

On Friday, January 28, 2011 11:25 AM, Ron Cohen [[email-masked]] wrote:
> I don't think it is a good idea. In my opinion we should not / can not specify that packets with wrong UDP
> checksum will be sent on the wire.

I agree with Ron.
Furthermore: one of the main goals of the current draft is "a generic method is defined in this document that does not require deep packet inspection at line rate".
The suggestion to have the tunnel termination point recompute the UDP checksum requires complex line rate processing at the egress LER, which may be a TC itslef.
I believe an incremental checksum update at every LSR is far simpler than recomputing the checksum at the LER.

A fair alternative is to update rfc2460, and to allow UDP checksum=0 (i.e., no checksum) for IPv6, very similar to UDP over IPv4.
Of course this goes beyond the scope of TICTOC, but is probably the best alternative.

Regards,
Tal.

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ron Cohen [[email-masked]]
Sent: Friday, January 28, 2011 11:25 AM
To: Jack Kohn
Cc: [email-masked]
Subject: Re: [TICTOC] UDP checksum

Hi Jack,

I don't think it is a good idea. In my opinion we should not / can not specify that packets with wrong UDP checksum will be sent on the wire.

Best,
Ron

On Fri, Jan 28, 2011 at 4:28 AM, Jack Kohn <[email-masked]<mailto:[email-masked]>> wrote:
On Thu, Jan 27, 2011 at 6:24 AM, Bhatia, Manav (Manav)

My 0.02$

Jack
_______________________________________________
TICTOC mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tictoc