Subject: [TICTOC] Updating draft-ietf-tictoc-1588overmpls

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Wed, 27 Apr 2011 05:04:32 +0530

Folks,

I am working on updating draft-ietf-tictoc-1588overmpls as per the WG feedback.

As part of this I will change the OSPF and IS-IS capabilities to be per link as against per node that its currently defined as.

Will also clarify that FCS retention for the payload Ethernet described in [RFC4720] MUST not be used.

Should I remove Sec 5.3 "1588 over pure MPLS mode" as I believe we had discussed that IETF cannot define new encapsulations in Prague?

I will also add some verbiage that P2MP LSPs may not work as they only provide unidirectional traffic flow and cannot guarantee a symmetrical path back to the head nodes. 

Anything else?

Cheers, Manav

--
Manav Bhatia,
Service Router Product Group (SRPG)
Alcatel-Lucent, India

---

From: "Shahram Davari" <[email-masked]>
Date: Tue, 26 Apr 2011 16:37:58 -0700

Manav,

In MPLS-TP the P2MP should work fine since it is all configured by management. May be just add some text that says using MPLS control plane the co-routing of the forward and reverse direction is not possible but using management plane this is possible such as in case of MPLS-TP. 

Thx
Shahram

-----Original Message-----
From: Bhatia, Manav (Manav) [mailto:[email-masked]] 
Sent: Tuesday, April 26, 2011 4:35 PM
To: [email-masked]
Cc: Shahram Davari
Subject: Updating draft-ietf-tictoc-1588overmpls

Folks,

Anything else?

Cheers, Manav

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Wed, 27 Apr 2011 05:10:35 +0530

Yup, will do that.

Cheers, Manav

> From: Shahram Davari [mailto:[email-masked]] 
> Sent: Wednesday, April 27, 2011 5.08 AM
> To: Bhatia, Manav (Manav); [email-masked]
> Subject: RE: Updating draft-ietf-tictoc-1588overmpls
> 
> Manav,
> 
> In MPLS-TP the P2MP should work fine since it is all 
> configured by management. May be just add some text that says 
> using MPLS control plane the co-routing of the forward and 
> reverse direction is not possible but using management plane 
> this is possible such as in case of MPLS-TP. 
> 
> Thx
> Shahram
> 
> As part of this I will change the OSPF and IS-IS capabilities 
> to be per link as against per node that its currently defined as.
> 
> Should I remove Sec 5.3 "1588 over pure MPLS mode" as I 
> believe we had discussed that IETF cannot define new 
> encapsulations in Prague?
> 
> I will also add some verbiage that P2MP LSPs may not work as 
> they only provide unidirectional traffic flow and cannot 
> guarantee a symmetrical path back to the head nodes. 
> 
> Anything else?
> 
> Cheers, Manav
> 
> --
> Manav Bhatia,

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 27 Apr 2011 12:34:10 +0000

Manav

I don't agree that IETF can not define new encaps - it certainly can.
It is just that we have not come to agreement that a new encap is needed.

I think we need language that states that for time delivery co-routed paths are needed,
but how to accomplish this for P2MP LSPs is for further study.

I agree with the other proposals.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)
Sent: Wednesday, April 27, 2011 02:35
To: [email-masked]
Subject: [TICTOC] Updating draft-ietf-tictoc-1588overmpls

Folks,

Anything else?

Cheers, Manav

--
Manav Bhatia,
Service Router Product Group (SRPG)
Alcatel-Lucent, India
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: "Roberts, Peter (Peter)" <[email-masked]>
Date: Wed, 27 Apr 2011 09:01:50 -0500

Manav,

Can you please provide a bit more background to the statement:

I believe we had discussed that IETF cannot define new encapsulations in Prague?

This is probably true that it would require a stamp of approval from IEEE but that needs to be verified.

Peter R>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)
Sent: Tuesday, April 26, 2011 7:41 PM
To: Shahram Davari; [email-masked]
Subject: Re: [TICTOC] Updating draft-ietf-tictoc-1588overmpls

Yup, will do that.

Cheers, Manav

> I am working on updating draft-ietf-tictoc-1588overmpls as

> per the WG feedback.

> Will also clarify that FCS retention for the payload Ethernet

> described in [RFC4720] MUST not be used.

TICTOC mailing list

[email-masked]

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Wed, 27 Apr 2011 19:55:34 +0530

Yup, thats what i had meant - that it would require getting IEEE involved and we should only tread down that path if its really really required.

Cheers, Manav

________________________________
From: Roberts, Peter (Peter)
Sent: Wednesday, April 27, 2011 7.32 PM
To: Bhatia, Manav (Manav); Shahram Davari; [email-masked]
Subject: RE: Updating draft-ietf-tictoc-1588overmpls

Manav,

Peter R>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)
Sent: Tuesday, April 26, 2011 7:41 PM
To: Shahram Davari; [email-masked]
Subject: Re: [TICTOC] Updating draft-ietf-tictoc-1588overmpls

Yup, will do that.

Cheers, Manav

TICTOC mailing list

[email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 27 Apr 2011 18:14:12 +0100

IEEE1588 worked with a number of organizations to map PTP over their 
protocols.

It seems unlikely that IEEE would object to the definition of a mapping 
to MPLS if the consensus was that this was the best way to carry PTP 
over an MPLS network.

Obviously we should ask before publishing a specification, but the most 
important starting point is to figure out the best technical solution to 
the problem in hand.

Stewart (speaking as an individual contributor.

On 27/04/2011 15:25, Bhatia, Manav (Manav) wrote:
> Yup, thats what i had meant - that it would require getting IEEE 
> involved and we should only tread down that path if its really really 
> required.
> Cheers, Manav
>
>     ------------------------------------------------------------------------
>     *From:* Roberts, Peter (Peter)
>     *Sent:* Wednesday, April 27, 2011 7.32 PM
>     *To:* Bhatia, Manav (Manav); Shahram Davari; [email-masked]
>     *Subject:* RE: Updating draft-ietf-tictoc-1588overmpls
>
>     Manav,
>
>     /I believe we had discussed that IETF cannot define new
>     encapsulations in Prague?/
>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Tony Li <[email-masked]>
Date: Wed, 27 Apr 2011 10:31:09 -0700

Unless something has changed radically, IEEE has no say in what happens after the Ethertype.

Tony

On Apr 27, 2011, at 10:14 AM, Stewart Bryant wrote:

> IEEE1588 worked with a number of organizations to map PTP over their protocols.
> 
> It seems unlikely that IEEE would object to the definition of a mapping to MPLS if the consensus was that this was the best way to carry PTP over an MPLS network.
> 
> Obviously we should ask before publishing a specification, but the most important starting point is to figure out the best technical solution to the problem in hand.
>

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 28 Apr 2011 06:32:55 +0530

Great. 

So the question now is that do we see a merit in including this encapsulation? If Yes, then this would entail some minor changes in the RSVP 1588_LSP object as well (or perhaps the existing offset in the PTP_LSP object can be used?).

Cheers, Manav

> From: Tony Li [mailto:[email-masked]] 
> Sent: Wednesday, April 27, 2011 11.01 PM
> To: [email-masked]
> Cc: Bhatia, Manav (Manav); [email-masked]
> > It seems unlikely that IEEE would object to the definition 
> of a mapping to MPLS if the consensus was that this was the 
> best way to carry PTP over an MPLS network.
> > 
> > Obviously we should ask before publishing a specification, 
> but the most important starting point is to figure out the 
> best technical solution to the problem in hand.
> > 
> >> Yup, thats what i had meant - that it would require 
> getting IEEE involved and we should only tread down that path 
> if its really really required.
> >>  
> >> Cheers, Manav
> >> 
> >> This is probably true that it would require a stamp of 
> approval from IEEE but that needs to be verified.  
> >> Peter R>
> >>  
> >>  
> >> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 28 Apr 2011 07:56:25 +0000

We are not talking about IEEE 802, we are talking about IEEE 1588.

They definitely DO have a say about what happens with 1588.
However, they encourage development of new transport layers for 1588,
so I do not see a problem were we to decide to develop one.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tony Li
Sent: Wednesday, April 27, 2011 20:31
To: [email-masked]
Cc: [email-masked]
Subject: Re: [TICTOC] Updating draft-ietf-tictoc-1588overmpls

Tony