Subject: Re: [TICTOC] I-D Action: draft-ietf-tictoc-ptp-mib-03.txt

From: Kevin Gross <[email-masked]>
Date: Fri, 11 Jan 2013 12:27:03 -0700

Some comments on this:

Abstract:

Add a bracketed reference to IEEE 1588-2008

Section 1

s/defined to monitor, measure the performance/defined to monitor and
measure the performance

It is claimed that monitoring is not a supported function of this MIB but I
have identified numerous versiables in the MIB which I would consider to be
providing a monitoring function. If you need specific examples, let me know.

Section 1.1

What in this MIB is profile dependent? I did not identify anything in my
review. It would be desirable. if possible,  to have a profile-independent
MIB.

TEXTUAL-CONVENTION general issues

Consider alphabetizing

ClockInstanceType TEXTUAL-CONVENTION definition

Description requires elucidation or a reference.

ClockProfileType TEXTUAL-CONVENTION definition

Consider using and OUI instead of an enumeration. IEEE 1588-1588 requires
an OUI be associated with each profile.

OBJECT-TYPE general issues

Consider being consistent about repeating TEXTUAL-CONVENTION descriptions,
explicitly referencing them or assuming readers will track down the
reference without reminder.

ptpDomainClockPortsTotal OBJECT-TYPE

I assume this is the number of ports for the managed PTP-capable system
(i.e. a router or switch). Suggest adding "in the system" to the
description to clarify scope of count.

ptpbaseClockTimePropertiesDSTable OBJECT-TYPE

s/clock Timeproperties Datasets for/clock time properties datasets for

PtpbaseClockTransDefaultDSEntry SEQUENCE

Use ClockDomainType textual convention instead of Integer32 for
ptpbaseClockTransDefaultDSPrimaryDomain

PtpbaseClockPortEntry SEQUENCE

Change ptpbaseClockPortSyncOneStep to ptpbaseClockPortSyncTwoStep to
match 1588 semantics for this boolean

ptpbaseClockPortRunningEncapsulationType OBJECT-TYPE

Needs a textual convention or description of allowed values and their meanings

ptpbaseClockPortTransDSlogMinPdelayReqInt OBJECT-TYPE

Change to ClockIntervalBase2 type

Section 5

Copy-paste error: "creation and/or manipulation of tunnels"

Section 6

To be added

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com <http://www.avanw.com/>, www.X192.org

On Thu, Aug 2, 2012 at 12:58 PM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the Timing over IP Connection and Transfer
> of Clock Working Group of the IETF.
>
>         Title           : Precision Time Protocol Version 2 (PTPv2)
> Management Information Base
>         Author(s)       : Vinay Shankarkumar
>                           Laurent Montini
>                           Tim Frost
>                           Greg Dowd
>         Filename        : draft-ietf-tictoc-ptp-mib-03.txt
>         Pages           : 65
>         Date            : 2012-07-31
>
> Abstract:
>    This memo defines a portion of the Management Information Base (MIB)
>    for use with network management protocols in TCP/IP-based internets.
>    In particular, it defines objects for managing networks using
>    Precision Time Protocol.
>
>    This memo specifies a MIB module in a manner that is both compliant
>    to the SNMPv2 SMI, and semantically identical to the peer SNMPv1
>    definitions.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tictoc-ptp-mib
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-tictoc-ptp-mib-03
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-tictoc-ptp-mib-03
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc
>

---

From: Vinay Shankarkumar <[email-masked]>
Date: Wed, 23 Jan 2013 11:58:51 -0500

Hello Kevin,
Thanks for the comments, we will address these in the next revision,

Regards,
-Vinay.

On 1/11/13 2:27 PM, Kevin Gross wrote:
> It is claimed that monitoring is not a supported function of this MIB 
> but I have identified numerous versiables in the MIB which I would 
> consider to be providing a monitoring function. If you need specific 
> examples, let me know.
>
>
> Section 1.1
>
> What in this MIB is profile dependent? I did not identify anything in 
> my review. It would be desirable. if possible,  to have a 
> profile-independent MIB.
>
>
> Consider using and OUI instead of an enumeration. IEEE 1588-1588 
> requires an OUI be associated with each profile.
>
>
> Consider being consistent about repeating TEXTUAL-CONVENTION 
> descriptions, explicitly referencing them or assuming readers will 
> track down the reference without reminder.
>
>
> I assume this is the number of ports for the managed PTP-capable 
> system (i.e. a router or switch). Suggest adding "in the system" to 
> the description to clarify scope of count.
>
>
> s/clock TimepropertiesDatasets for/clock time properties datasets for
>
>
>
> Use ClockDomainType textual convention instead of Integer32 forptpbaseClockTransDefaultDSPrimaryDomain
>
>
> Change ptpbaseClockPortSyncOneStep to ptpbaseClockPortSyncTwoStep to match 1588semantics  for this boolean
>
>
> <http://www.X192.org>
> On Thu, Aug 2, 2012 at 12:58 PM, <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>      This draft is a work item of the Timing over IP Connection and
>     Transfer of Clock Working Group of the IETF.
>
>             Title           : Precision Time Protocol Version 2
>     (PTPv2) Management Information Base
>     [email-masked] <mailto:[email-masked]>