Subject: [TICTOC] WGLC on draft-ietf-tictoc-ptp-mib-05.txt

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 16 May 2013 11:41:35 -0400

This message initiates a two week TICTOC Working Group Last Call on 
advancing:

Title : Precision Time Protocol Version 2 (PTPv2) Management Information 
Base
Author(s) : Vinay Shankarkumar, Laurent Montini, Tim Frost, Greg Dowd
Filename : draft-ietf-tictoc-ptp-mib-05.txt
Pages : 77
Date : 2013-02-25

http://datatracker.ietf.org/doc/draft-ietf-tictoc-ptp-mib/?include_text=1

as a Standards Track RFC. Substantive comments and statements of support 
for advancing this document should be directed to the mailing list. 
Editorial suggestions can be sent directly to the authors. This last 
call will end on 31 May 2013.

---

From: Kevin Gross <[email-masked]>
Date: Thu, 16 May 2013 11:08:57 -0600

I submitted comments on v03 11 January (
http://www.ietf.org/mail-archive/web/tictoc/current/msg01331.html). Vinay
indicated in a short message on 23 January the comments would be addressed
in the next version (
http://www.ietf.org/mail-archive/web/tictoc/current/msg01333.html). v04 was
published 31 January. I did not see any notes from the authors associated
with that revision. A quick check of the v03-v04 diff shows evidence that
not all my comments were directly addressed. Can I get a summary of how my
comments were addressed? I'm fine if some of these were rejected but I
would like to verify that they were given consideration.

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com <http://www.avanw.com/>, www.X192.org

On Thu, May 16, 2013 at 9:41 AM, Karen O'Donoghue <[email-masked]>wrote:

> Filename : draft-ietf-tictoc-ptp-mib-05.**txt
> Pages : 77
> Date : 2013-02-25
>
> http://datatracker.ietf.org/**doc/draft-ietf-tictoc-ptp-mib/**
> ?include_text=1<http://datatracker.ietf.org/doc/draft-ietf-tictoc-ptp-mib/?include_text=1>
>
> Editorial suggestions can be sent directly to the authors. This last call
> will end on 31 May 2013.
>
> ______________________________**_________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/tictoc<https://www.ietf.org/mailman/listinfo/tictoc>
>

---

From: "Smiley, Russell" <[email-masked]>
Date: Thu, 16 May 2013 17:17:49 +0000

I also submitted comments to V05 on the mailing list and have not received any acknowledgment as to whether they will be addressed or have been rejected.

http://www.ietf.org/mail-archive/web/tictoc/current/msg01387.html

Thanks for your help.

Russell Smiley 
Principal Systems Engineer 
+1 613 592 0859 x1831 direct
+1 613 322 9433 mobile 

Integrated Device Technology, Canada Inc. 
603 March Rd, Ottawa, Ontario Canada K2K 2M5 
www.IDT.com NASDAQ: IDTI 

CONFIDENTIAL COMMUNICATION: This email and any attachments thereto may contain private and confidential material for the sole use of the intended recipient. Any review, copying, or distribution of this email (or any attachments thereto) by others is strictly prohibited. If you are not the intended recipient, please contact the sender immediately and permanently delete the original and any copies of this email and any attachments thereto.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kevin Gross
Sent: Thursday, May 16, 2013 1:09 PM
To: Karen ODonoghue
Cc: [email-masked]
Subject: Re: [TICTOC] WGLC on draft-ietf-tictoc-ptp-mib-05.txt

I submitted comments on v03 11 January (http://www.ietf.org/mail-archive/web/tictoc/current/msg01331.html). Vinay indicated in a short message on 23 January the comments would be addressed in the next version (http://www.ietf.org/mail-archive/web/tictoc/current/msg01333.html). v04 was published 31 January. I did not see any notes from the authors associated with that revision. A quick check of the v03-v04 diff shows evidence that not all my comments were directly addressed. Can I get a summary of how my comments were addressed? I'm fine if some of these were rejected but I would like to verify that they were given consideration.

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com, www.X192.org

On Thu, May 16, 2013 at 9:41 AM, Karen O'Donoghue <[email-masked]> wrote:
This message initiates a two week TICTOC Working Group Last Call on advancing:

Title : Precision Time Protocol Version 2 (PTPv2) Management Information Base
Author(s) : Vinay Shankarkumar, Laurent Montini, Tim Frost, Greg Dowd
Filename : draft-ietf-tictoc-ptp-mib-05.txt
Pages : 77
Date : 2013-02-25

as a Standards Track RFC. Substantive comments and statements of support for advancing this document should be directed to the mailing list. Editorial suggestions can be sent directly to the authors. This last call will end on 31 May 2013.

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 16 May 2013 14:31:53 -0400

MIB Authors,

Could one of you address Kevin's comments please?

Thanks,
Karen

On 5/16/13 1:08 PM, Kevin Gross wrote:
> I submitted comments on v03 11 January 
> (http://www.ietf.org/mail-archive/web/tictoc/current/msg01331.html). 
> Vinay indicated in a short message on 23 January the comments would be 
> addressed in the next version 
> (http://www.ietf.org/mail-archive/web/tictoc/current/msg01333.html). 
> v04 was published 31 January. I did not see any notes from the authors 
> associated with that revision. A quick check of the v03-v04 diff shows 
> evidence that not all my comments were directly addressed. Can I get a 
> summary of how my comments were addressed? I'm fine if some of these 
> were rejected but I would like to verify that they were given 
> consideration.
>
> Kevin Gross
> +1-303-447-0517
> Media Network Consultant
> <http://www.X192.org>
> On Thu, May 16, 2013 at 9:41 AM, Karen O'Donoghue <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     as a Standards Track RFC. Substantive comments and statements of
>     support for advancing this document should be directed to the
>     mailing list. Editorial suggestions can be sent directly to the
>     authors. This last call will end on 31 May 2013.
>
>     [email-masked] <mailto:[email-masked]>

---

From: "Smiley, Russell" <[email-masked]>
Date: Thu, 16 May 2013 18:37:45 +0000

Apologies, my remarks below were intended to be directed to the security requirements draft, not the PTP MIB.

Russell Smiley 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Smiley, Russell
Sent: Thursday, May 16, 2013 1:18 PM
To: Karen ODonoghue
Cc: [email-masked]
Subject: Re: [TICTOC] WGLC on draft-ietf-tictoc-ptp-mib-05.txt

Thanks for your help.

Russell Smiley

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 16 May 2013 14:39:08 -0400

Russell,

You actually submitted comments on the Security Requirements document 
(not the MIB) after the close of the WGLC on that document. Yaakov and I 
discussed this, and we decided to proceed with the submission of the 
document to the IESG and to address those comments as part of the IETF 
last call process. This document has been around for a long time, and we 
wanted to proceed with getting it progressed.

Regards,
Karen

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 16 May 2013 14:40:42 -0400

No problem. I should have been a bit cleared in my message about 
progressing the document.

Regards,
Karen

---

From: Tim Frost <[email-masked]>
Date: Fri, 17 May 2013 08:33:22 +0000

Hi Kevin,

Thank you for taking the time to go through this MIB. We did consider your comments, and they were addressed in -05 (the latest version, and the subject of the last call).  I've gone through each of your comments below; it looks like we missed one, and decided against another, but the remainder have been done.

The change history from the -05 draft reads:

-05       Feb 13 Several changes in response to comments from Alun Luchuk
             and Kevin Gross:
             - Modified the use of wellKnownTransportTypes and
               wellKnownEncapsulationTypes
             - changed ptpbaseClockPortSyncOneStep to
               ptpbaseClockPortSyncTwoStep to match IEEE1588
               semantics
             - Re-ordered textual conventions to be alphabetic
             - Changed some types from Integer32 to use defined
               textual conventions
             - various minor descriptive text changes

In detail:

Abstract: Add a bracketed reference to IEEE 1588-2008 - DONE

Section 1: s/defined to monitor, measure the performance/defined to monitor and measure the performance - DONE

Section 1.1 What in this MIB is profile dependent? I did not identify anything in my review. It would be desirable. if possible,  to have a profile-independent MIB.

-    TF: Removed erroneous text about Telecom Profile - there is nothing in this MIB that is particular to that profile.

TEXTUAL-CONVENTION general issues - Consider alphabetizing - DONE

ClockInstanceType TEXTUAL-CONVENTION definition - Description requires elucidation or a reference.

-    TF: not done, looks like this one slipped through.

ClockProfileType TEXTUAL-CONVENTION definition
Consider using and OUI instead of an enumeration. IEEE 1588-1588 requires an OUI be associated with each profile.

-    TF: OUI would be specific to the organization, not the profile. If the ITU (for instance) developed more than one profile, then they would have the same OUI. Therefore it is best (in the authors' opinion) to stick to using an enumeration

OBJECT-TYPE general issues
Consider being consistent about repeating TEXTUAL-CONVENTION descriptions, explicitly referencing them or assuming readers will track down the reference without reminder.

-    TF: We've tried to be as consistent as we can. Of 17 TEXTUAL-CONVENTIONS, 13 are directly referenced to IEEE1588 sections. The remainder don't directly map onto IEEE1588 quantities, but onto associated concepts, and we have tried to explain these in the description. Certainly one could do with a better description, as you note above.

ptpDomainClockPortsTotal OBJECT-TYPE
I assume this is the number of ports for the managed PTP-capable system (i.e. a router or switch). Suggest adding "in the system" to the description to clarify scope of count. - DONE

ptpbaseClockTimePropertiesDSTable OBJECT-TYPE

s/clock Timeproperties Datasets for/clock time properties datasets for - DONE

PtpbaseClockTransDefaultDSEntry SEQUENCE

Use ClockDomainType textual convention instead of Integer32 for ptpbaseClockTransDefaultDSPrimaryDomain - DONE

PtpbaseClockPortEntry SEQUENCE

Change ptpbaseClockPortSyncOneStep to ptpbaseClockPortSyncTwoStep to match 1588 semantics for this Boolean - DONE

ptpbaseClockPortRunningEncapsulationType OBJECT-TYPE

Needs a textual convention or description of allowed values and their meanings

-    TF: Now uses an autonomous type instead of Integer32

ptpbaseClockPortTransDSlogMinPdelayReqInt OBJECT-TYPE

Change to ClockIntervalBase2 type DONE

Section 5: Copy-paste error: "creation and/or manipulation of tunnels"

-    TF: Section changed since -03, no longer has this phrase.

Section 6: To be added - DONE

Best regards,
Tim Frost

Sent: 16 May 2013 18:09

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com<http://www.avanw.com/>, www.X192.org<http://www.X192.org>

On Thu, May 16, 2013 at 9:41 AM, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
This message initiates a two week TICTOC Working Group Last Call on advancing:

_______________________________________________
TICTOC mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tictoc

---

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 29 May 2013 03:06:57 -0400

Folks,

We really need some responses to this WGLC in order to gauge consensus. 
Please speak up if you have reviewed this draft and believe it is ready 
to proceed.

Thanks!
Karen