Subject: [TICTOC] minutes for joint meeting of ntp/tictoc at IETF 88

From: Karen O'Donoghue <[email-masked]>
Date: Fri, 06 Dec 2013 16:02:41 -0500

Folks,

Below are the minutes for the joint meeting of tictoc and ntp at IETF 
88. If you have any questions or comments, feel free to provide them.

Regards,
Karen

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 9 Dec 2013 17:11:21 +0200

Hi,

I apologize for this late comment, as I could not attend the IETF meeting.

>Greg Mirsky presented his new draft from the MPLS working 
>group on Residence Time Measurement. There were a number of 
>questions related to the technical content of the draft. 
>Discussion should continue on the tictoc and mpls mailing 
>lists. (draft-mirsky-mpls-residence-time-00.txt)
>
>The subject of the current draft on Timing over MPLS that 
>is being working in the tictoc working group was addressed. 
>There are still concerns regarding a way forward for this 
>draft. After much discussion, it was decided that the draft 
>would proceed in the tictoc working group as an 
>Experimental RFC.

It looks like we are heading towards having two drafts that solve the same problem, which is most unfortunate. 
Isn't there a way to update Shahram's draft in a way that will satisfy Greg and Sasha's concerns and eliminate the need for draft-mirsky-mpls-residence-time? For example using GAL instead of a dedicated LSP in Shahram's draft is an option that has been discussed before, and may be the least painful compromise.

Honestly, the worst possible outcome is to define two different solutions. We obviously don't expect vendors to implement both solutions.

I believe it is our obligation to reach a single solution for this problem.

Thanks,
Tal.

-----Original Message-----
From: TICTOC [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Friday, December 06, 2013 11:03 PM
To: [email-masked]; NTP Working Group
Subject: [TICTOC] minutes for joint meeting of ntp/tictoc at IETF 88

Folks,

Below are the minutes for the joint meeting of tictoc and ntp at IETF 88. If you have any questions or comments, feel free to provide them.

Regards,
Karen

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 9 Dec 2013 17:14:07 +0000

Adding John.

-----Original Message-----
From: Tal Mizrahi [mailto:[email-masked]] 
Sent: Monday, December 09, 2013 7:11 AM
To: [email-masked]; [email-masked]; NTP Working Group; Shahram Davari ([email-masked]); Gregory Mirsky; Alexander Vainshtein; Stewart Bryant <[email-masked]> ([email-masked])
Subject: RE: [TICTOC] minutes for joint meeting of ntp/tictoc at IETF 88

Hi,

>Greg Mirsky presented his new draft from the MPLS working group on 
>Residence Time Measurement. There were a number of questions related to 
>the technical content of the draft.
>Discussion should continue on the tictoc and mpls mailing lists. 
>(draft-mirsky-mpls-residence-time-00.txt)
>
>The subject of the current draft on Timing over MPLS that is being 
>working in the tictoc working group was addressed.
>There are still concerns regarding a way forward for this draft. After 
>much discussion, it was decided that the draft would proceed in the 
>tictoc working group as an Experimental RFC.

Thanks,
Tal.

-----Original Message-----
From: TICTOC [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Friday, December 06, 2013 11:03 PM
To: [email-masked]; NTP Working Group
Subject: [TICTOC] minutes for joint meeting of ntp/tictoc at IETF 88

Folks,

Regards,
Karen

---

From: Karen O'Donoghue <[email-masked]>
Date: Tue, 10 Dec 2013 18:33:26 -0500

Tal,

While I understand your concerns, I believe the point that we came to 
was that there
was no clear consensus between the MPLS and TICTOC working groups regarding
the solution on the table. It also became clear that there wasn't a clearly
understood (across both working groups) set of requirements regarding
the problem to be solved. An experimental RFC gives the community a 
chance to
continue to explore the option that has been documented and discussed 
for a couple
years now while allowing additional time to develop requirements and 
consensus on
a standardized solution. Our AD suggested this as a possible way 
forward, and all
the main parties to the discussion were in agreement at the meeting.

Regards,
Karen

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 11 Dec 2013 08:21:30 +0000

Tal,
I fully agree with you that having two different drafts addressing the same problem is most unfortunate (even if this is neither the first nor, most probably the last time IETF encounters this issue :-).

At the same time I do not see any easy way to merge the two approaches:
- From my point of view the approach taken in the TICTOC WG draft breaks the MPLS data plane architecture which allows only a limited set of "alert mechanisms" for intercepting a labeled packet and manipulating its payload instead of regular forwarding
- The alternative proposal is an attempt to find a solution that, while delivering the same functionality, would stay within the boundaries of this architecture.

Regards,
     Sasha

> From: Gregory Mirsky [mailto:[email-masked]]
> Sent: Monday, December 09, 2013 7:14 PM
> To: Tal Mizrahi; [email-masked]; [email-masked]; NTP Working Group;
> Shahram Davari ([email-masked]); Alexander Vainshtein; Stewart Bryant
> <[email-masked]> ([email-masked]); John E Drake
> ([email-masked])
> To: [email-masked]; [email-masked]; NTP Working Group; Shahram Davari
> ([email-masked]); Gregory Mirsky; Alexander Vainshtein; Stewart Bryant
> <[email-masked]> ([email-masked])
> Isn't there a way to update Shahram's draft in a way that will satisfy Greg and
> Sasha's concerns and eliminate the need for draft-mirsky-mpls-residence-time?
> For example using GAL instead of a dedicated LSP in Shahram's draft is an
> option that has been discussed before, and may be the least painful
> compromise.
> 
> Honestly, the worst possible outcome is to define two different solutions. We
> obviously don't expect vendors to implement both solutions.
> 
> Below are the minutes for the joint meeting of tictoc and ntp at IETF 88. If you
> have any questions or comments, feel free to provide them.
> 
> Regards,
> Karen
>