Subject: [TICTOC] Enterprise profile update

From: Douglas Arnold <[email-masked]>
Date: Wed, 12 Mar 2014 12:41:33 -0700

Hello Everyone,

Please note that a new version of the proposed Enterprise Profile was
uploaded approximately one month ago.
http://datatracker.ietf.org/doc/draft-ietf-tictoc-ptp-enterprise-profile/

Changes, other than minor typos, are:

1. Elimination of the Unicast only and Multicast only modes of operation.
 The only mode of operation is the hybrid multicast/unicast mode.  In this
mode the master sends sync and announce as multicast, and it responds to
delay request messages "in kind".  In other words a delay response is
unicast if the delay requests is unicast, and multicast if the delay
requests is multicast.

2. The option for multiple simultaneous masters uses separate timing
domains instead of the alternate master flag.  Here I am attempting to
guess how the next revision to IEEE 1588 will go.

3.  The prohibition against distributing time zones remains unchanged.  See
the posts to the tictoc reflector by Kevin Gross and John Fletcher for a
good discussion on the pros and cons of this choice.
http://www.ietf.org/mail-archive/web/tictoc/current/maillist.html

Please take a look and tell me what you think?

-- 
Doug Arnold
Principal Technologist
*JTime!* Meinberg USA
+1-707-303-5559

---

From: Douglas Arnold <[email-masked]>
Date: Wed, 12 Mar 2014 15:39:17 -0700

Hi Greg,

I haven't heard of this idea until now.  I was under the impression that
multicast support was generally improving.  So I was hoping that the
multicast support issue was going away on its own.  Nevertheless this is an
interesting suggestion.  Do you have any feel for how often the broadcast
modes are used in NTP?

Doug

On Wed, Mar 12, 2014 at 1:01 PM, Dowd, Greg <[email-masked]> wrote:

>  Hi Doug,
>
>                 Because of some of the difficulties, or lack of support,
> in getting multicast deployed, has anyone considered directed broadcast for
> the sync/fup pairs?  That would be similar to the ntp deployment models
> that have broadcast/directed broadcast (unicast sent to network address)
> with "ranging" provided by client unicast requests.
>
>
>
>
>
> *From:* TICTOC [mailto:[email-masked]] *On Behalf Of *Douglas
> Arnold
> *Sent:* Wednesday, March 12, 2014 12:42 PM
> *To:* [email-masked]
> *Subject:* [TICTOC] Enterprise profile update
>
>
>
> Hello Everyone,
>
>
>
> 3.  The prohibition against distributing time zones remains unchanged.
>  See the posts to the tictoc reflector by Kevin Gross and John Fletcher for
> a good discussion on the pros and cons of this choice.

-- 
Doug Arnold
Principal Technologist
*JTime!* Meinberg USA
+1-707-303-5559

---

From: "Dowd, Greg" <[email-masked]>
Date: Wed, 12 Mar 2014 20:01:23 +0000

Hi Doug,
                Because of some of the difficulties, or lack of support, in getting multicast deployed, has anyone considered directed broadcast for the sync/fup pairs?  That would be similar to the ntp deployment models that have broadcast/directed broadcast (unicast sent to network address) with "ranging" provided by client unicast requests.

From: TICTOC [mailto:[email-masked]] On Behalf Of Douglas Arnold
Sent: Wednesday, March 12, 2014 12:42 PM
To: [email-masked]
Subject: [TICTOC] Enterprise profile update

Hello Everyone,

Please note that a new version of the proposed Enterprise Profile was uploaded approximately one month ago.  http://datatracker.ietf.org/doc/draft-ietf-tictoc-ptp-enterprise-profile/

1. Elimination of the Unicast only and Multicast only modes of operation.  The only mode of operation is the hybrid multicast/unicast mode.  In this mode the master sends sync and announce as multicast, and it responds to delay request messages "in kind".  In other words a delay response is unicast if the delay requests is unicast, and multicast if the delay requests is multicast.

2. The option for multiple simultaneous masters uses separate timing domains instead of the alternate master flag.  Here I am attempting to guess how the next revision to IEEE 1588 will go.

3.  The prohibition against distributing time zones remains unchanged.  See the posts to the tictoc reflector by Kevin Gross and John Fletcher for a good discussion on the pros and cons of this choice.  http://www.ietf.org/mail-archive/web/tictoc/current/maillist.html

--
Doug Arnold
Principal Technologist
JTime! Meinberg USA
+1-707-303-5559