Subject: Re: [TICTOC] Enterprise Profile

From: Douglas Arnold <[email-masked]>
Date: Thu, 23 Oct 2014 17:17:37 -0700

Hello Laurent,

Thank you for the feedback on the Enterprise Profile.  I have made the
following changes in the draft [see inline comments below].  An update will
be posted shortly.

On Mon, Oct 13, 2014 at 8:10 AM, Laurent Montini (lmontini) <
[email-masked]> wrote:

>  Hi,
>
>  I have 3 comments:
>
>  1) Clause 8, first paragraph: is the sentence correct?
> “When Preferred Master Clocks are not the Best Master in one domain, they
> SHOULD operate in another domain when they. “
> Seems something missing.
>

   Text now reads:
   When Preferred Master Clocks are not the Best Master in one domain,
   they SHOULD operate as a master in another domain.

   Further explanation of multi-domain operation is added as well.

>
>  2) Unicast Discovery
> Clause 12: Forbidden options: “Slave clocks operating in the Enterprise
> Profile SHALL NOT use Unicast Discovery to establish connection to Master
> clocks.”
> Clause 13, 3rd paragraph:
> “Clocks operating in the Enterprise profile will not interoperate with
> clocks operating in the Telecom Profile for Frequency
> Synchronization[G8265.1], because the Enterprise Profile forbids Unicast
> Message Negotiation, and Unicast Discovery.”
> As neither Enterprise nor this Telecom profile use Unicast Discovery, how
> does it make this oiption an interoperability issue?
>

    Reference of Unicast Discovery has been removed from this passage.

>
>  3) Clause 13, paragraph before last, last sentence: “the Default Profile
> is…” : there are two default profiles in IEEE 1588-2008, in Annexes J.3 and
> J.4, one using the delay mechanism the other the pdelay mechanism.
>
>    - Obviously the Enterprise profile will not interop with J.4.
>    - Should the text be “The Default Profiles are described in Annexes
>    J.3 and J.4.”
>
>    This clause has been rewritten to discuss J.3 and J.4 cases separately.

> Regards,
> Laurent

-- 
Doug Arnold
Principal Technologist
*JTime!* Meinberg USA
+1-707-303-5559

---

From: "Laurent Montini (lmontini)" <[email-masked]>
Date: Sun, 26 Oct 2014 11:09:01 +0000

Hi Doug,

Thanks for the clarifications.

1)    When Preferred Master Clocks are not the Best Master in one domain,
   they SHOULD operate as a master in another domain.

Any reason why this is not a MAY?

2) I find the draft still confusing wrt Unicast Negotiation.
>From Clauses 7 and 13, I understand the negotiation shall not be used for negotiating message rate.
But I don’t find a text mentioning this option is allowed for other matters such as to set the unicast delay mechanism communication path?
Looks implicit except that clause 14 mentions "the Enterprise Profile forbids Unicast Message Negotiation”.

If Unicast Message Negotiation is totally forbidden, why not telling so in clause 13 only and not limiting the restriction to message rate?
If Unicast Message Negotiation is not totally forbidden i.e. can be used optionally with restriction already listed, I believe this shall be explicit.

3) Wrt interoperability, why G.8275.1 and 802.1AS are not referenced as not interoperable due to pdelay mechanism and/or Ethernet mapping (as for C37.238 -and IEC 62439-3).
Any reason?

Thanks,
Laurent

From: Doug Arnold <[email-masked]<mailto:[email-masked]>>
Date: Friday 24 October 2014 02:17
To: lmontini <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Enterprise Profile

Hello Laurent,

Thank you for the feedback on the Enterprise Profile.  I have made the following changes in the draft [see inline comments below].  An update will be posted shortly.

On Mon, Oct 13, 2014 at 8:10 AM, Laurent Montini (lmontini) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

I have 3 comments:

1) Clause 8, first paragraph: is the sentence correct?
“When Preferred Master Clocks are not the Best Master in one domain, they SHOULD operate in another domain when they. “
Seems something missing.

   Text now reads:

2) Unicast Discovery
Clause 12: Forbidden options: “Slave clocks operating in the Enterprise Profile SHALL NOT use Unicast Discovery to establish connection to Master clocks.”
Clause 13, 3rd paragraph:
“Clocks operating in the Enterprise profile will not interoperate with clocks operating in the Telecom Profile for Frequency Synchronization[G8265.1], because the Enterprise Profile forbids Unicast Message Negotiation, and Unicast Discovery.”
As neither Enterprise nor this Telecom profile use Unicast Discovery, how does it make this oiption an interoperability issue?

3) Clause 13, paragraph before last, last sentence: “the Default Profile is…” : there are two default profiles in IEEE 1588-2008, in Annexes J.3 and J.4, one using the delay mechanism the other the pdelay mechanism.

  *   Obviously the Enterprise profile will not interop with J.4.
  *   Should the text be “The Default Profiles are described in Annexes J.3 and J.4.”

Regards,
Laurent

--
Doug Arnold
Principal Technologist
JTime! Meinberg USA
+1-707-303-5559

---

From: Richard Cochran <[email-masked]>
Date: Mon, 27 Oct 2014 09:37:31 +0100

> 2) I find the draft still confusing wrt Unicast Negotiation.

I agree that the unicast treatment is confusing.

In addition, I still think that the prohibition against the
standardized 1588 unicast mechanisms need some sort of justification.

The profile does explain why unicast is needed, but it fails to
explain why unicast negotiation is forbidden, for example.

Thanks,
Richard