Subject: [TICTOC] FW: New Version Notification for draft-jlx-tictoc-1588v2-yang-02.txt

From: Jiangyuanlong <[email-masked]>
Date: Tue, 27 Oct 2015 15:51:21 +0000

Dear tictocers,

We have posted a new revision of draft-jlx-tictoc-1588v2-yang, only the generic features of 1588 protocol are kept, and a number of improvements are made.
As Rodney has contributed a lot to this revision, he joined the work as a co-author upon our request.
We hope this I-D can serve as a solid start point for 1588 YANG standardization, and would like to see more comments and discussions on this mailing list.

Best regards,
Yuanlong on behalf of the authors

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, October 16, 2015 4:13 PM
To: Rodney Cummings; [email-masked]; Jiangyuanlong; Jiangyuanlong
Subject: New Version Notification for draft-jlx-tictoc-1588v2-yang-02.txt

A new version of I-D, draft-jlx-tictoc-1588v2-yang-02.txt
has been successfully submitted by Yuanlong Jiang and posted to the IETF repository.

Name:		draft-jlx-tictoc-1588v2-yang
Revision:	02
Title:		YANG Data Model for IEEE 1588v2
Document date:	2015-10-16
Group:		Individual Submission
Pages:		20
URL:            https://www.ietf.org/internet-drafts/draft-jlx-tictoc-1588v2-yang-02.txt
Status:         https://datatracker.ietf.org/doc/draft-jlx-tictoc-1588v2-yang/
Htmlized:       https://tools.ietf.org/html/draft-jlx-tictoc-1588v2-yang-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-jlx-tictoc-1588v2-yang-02

Abstract:
   This document defines a YANG data model for the configuration of
   IEEE 1588v2 devices and clocks, and also retrieval of the
   configuration information, data set and running states of IEEE
   1588v2 clocks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 28 Oct 2015 09:01:11 +0000

Hi all,

Since the deployment of 4G mobile networks, many mobile backhaul networks are providing SyncE and/or IEEE 1588 synchronization capabilities for the cells.
As these backhaul networks consist of thousands of nodes, the scalability of synchronization networks poses as a great challenge to service providers.

This I-D provides a problem statement for scalability in synchronization networks:
https://tools.ietf.org/html/draft-hjxl-ssn-ps-00

Opinions and discussions are cordially welcome, and anyone who has interest may also drop me a private email.

Best regards,
Yuanlong

---

From: Eldad Zack <[email-masked]>
Date: Wed, 28 Oct 2015 10:17:47 +0100

Hello Yuanlong,

The definition of a T-GM in this draft is incomplete.
Please look at ITU-T G.8275.1, 6.2.3. There's a mapping from T-GM to 
IEEE 1588. A T-GM can also be an OC with a single PTP port.

Cheers,
Eldad

On 28/10/2015 10:01, Jiangyuanlong wrote:
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc

-- 
Eldad Zack
Test Engineer

EANTC AG - European Advanced Networking Test Center
Salzufer 14, 10587  Berlin, Germany
phone +49.30.3180595-43, fax +49.30.3180595-10
[email-masked]    http://www.eantc.de

EANTC Aktiengesellschaft
Place of Business / Sitz der Gesellschaft: Berlin, Germany
Chairman / Vorsitzender des Aufsichtsrats: Herbert Almus
Managing Director / Vorstand: Carsten Rossenhövel, Gabriele Schrenk
Registered: HRB 73694, Amtsgericht  Charlottenburg, Berlin, Germany
EU VAT No: DE 812824025

---

From: Tal Mizrahi <[email-masked]>
Date: Wed, 28 Oct 2015 09:18:40 +0000

Hi Yuanlong,

Since some of the co-authors of this draft are operators, it would be great if you could share your deployment experience with the working group (scales, statistics, accuracy, typical problems, lessons learned). This would definitely help to better understand the scalability problem statement.

Cheers,
Tal.

>From: TICTOC [mailto:[email-masked]] On Behalf Of Jiangyuanlong
>Sent: Wednesday, October 28, 2015 11:01 AM
>To: [email-masked]'
>Cc: [email-masked]
>Subject: [TICTOC] Scalable Synchronization Networks
>
>Hi all,
>
>Since the deployment of 4G mobile networks, many mobile backhaul networks
>are providing SyncE and/or IEEE 1588 synchronization capabilities for the
>cells.
>As these backhaul networks consist of thousands of nodes, the scalability of
>synchronization networks poses as a great challenge to service providers.
>

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 28 Oct 2015 10:49:12 +0000

Eldad, 

Good catch! Thanks for providing the details on T-GM.
Though this definition will be removed from the document as it is not used in any other sections.

Cheers,
Yuanlong

-----Original Message-----
From: Eldad Zack [mailto:[email-masked]] 
Sent: Wednesday, October 28, 2015 5:18 PM
To: Jiangyuanlong; [email-masked]'
Cc: [email-masked]
Subject: Re: bulk an [email-masked] [TICTOC] Scalable Synchronization Networks

Hello Yuanlong,

Cheers,
Eldad

-- 
Eldad Zack
Test Engineer

EANTC Aktiengesellschaft

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 28 Oct 2015 11:04:12 +0000

Tal,

This I-D did introduce some typical problems in the deployment of synchronization networks. We can give more deployment analysis in other documents if the WG has interest. 
With regard to scales, several cities in China already have 10,000+ mobile backhaul packet equipments, and all those equipments are required to take part in the synchronization network.

Thanks,
Yuanlong

-----Original Message-----
From: Tal Mizrahi [mailto:[email-masked]] 
Sent: Wednesday, October 28, 2015 5:19 PM
To: Jiangyuanlong; [email-masked]'
Cc: [email-masked]
Subject: RE: Scalable Synchronization Networks

Hi Yuanlong,

Cheers,
Tal.