Subject: [TICTOC] YANG compilation issue: draft-ietf-tictoc-1588v2-yang

From: Benoit Claise <[email-masked]>
Date: Fri, 25 Nov 2016 11:21:39 +0100

Dear authors,

We can't extract the YANG module correctly out of 
draft-ietf-tictoc-1588v2-yang.
The reason is:

OLD:
     <CODE BEGINS> file "ietf-ptp-dataset@2016-11-25"

NEW:
     <CODE BEGINS> file "[email-masked]"

See RFC 6087 for the conventions and examples.
Once corrected, the YANG compilation tool chain should work fine. See 
http://www.claise.be/IETFYANGPageCompilation.html

Regards, Benoit

---

From: Jiangyuanlong <[email-masked]>
Date: Fri, 25 Nov 2016 11:23:00 +0000

Hi Benoit,

This is fixed in the new revision: https://tools.ietf.org/html/draft-ietf-tictoc-1588v2-yang-02 
BTW, the validation tool provided in http://www.yangvalidator.com/ cannot detect it.

Thanks,
Yuanlong

-----Original Message-----
From: Benoit Claise [mailto:[email-masked]] 
Sent: Friday, November 25, 2016 6:22 PM
To: [email-masked]; [email-masked]
Subject: YANG compilation issue: draft-ietf-tictoc-1588v2-yang

Dear authors,

We can't extract the YANG module correctly out of draft-ietf-tictoc-1588v2-yang.
The reason is:

OLD:

NEW:

See RFC 6087 for the conventions and examples.
Once corrected, the YANG compilation tool chain should work fine. See http://www.claise.be/IETFYANGPageCompilation.html

Regards, Benoit