Subject: Re: [TICTOC] New Version Notification for draft-jiang-tictoc-syncphy-yang-00.txt

From: Jiangyuanlong <[email-masked]>
Date: Mon, 9 Mar 2020 03:10:43 +0000

Hi Karen and all,

In the past, some people had expressed their interests in getting a YANG data model for Sync Ethernet in this mailing list.
We would like to notify the TICTOC experts that this draft initiate the work on the SyncE YANG data model, though it is now targeted at a more generic Sync-PHY data model.
We hope anyone who have interest in this work can review this document, comments are greatly appreciated and cooperation is very welcome.

Thanks,
Yuanlong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 09, 2020 10:30 AM
To: Liuyan Han <[email-masked]>; Lvjingfei <[email-masked]>; Jiangyuanlong <[email-masked]>
Subject: New Version Notification for draft-jiang-tictoc-syncphy-yang-00.txt

A new version of I-D, draft-jiang-tictoc-syncphy-yang-00.txt
has been successfully submitted by Yuanlong Jiang and posted to the IETF repository.

Name:		draft-jiang-tictoc-syncphy-yang
Revision:	00
Title:		YANG Data Model for Sync PHY
Document date:	2020-03-09
Group:		Individual Submission
Pages:		16
URL:            https://www.ietf.org/internet-drafts/draft-jiang-tictoc-syncphy-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-jiang-tictoc-syncphy-yang/
Htmlized:       https://tools.ietf.org/html/draft-jiang-tictoc-syncphy-yang-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-jiang-tictoc-syncphy-yang

Abstract:
   This document defines a YANG data model for the configuration of
   physical layer synchronization including SyncE and SyncO. The YANG
   module in this document conforms to the Network Management
   Datastore Architecture (NMDA).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 9 Mar 2020 09:52:21 +0200

Hi Yuanglong,

Thanks for putting this draft together.
In general, does the ITU-T publish YANG models?
Anyway, it would be interesting to hear the feedback of the people at
Q13 in the ITU-T.

Cheers,
Tal.

On Mon, Mar 9, 2020 at 5:11 AM Jiangyuanlong <[email-masked]> wrote:
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc

---

From: Jiangyuanlong <[email-masked]>
Date: Mon, 9 Mar 2020 09:41:44 +0000

Dear Tal,

In general, Q14 in ITU-T SG15 is responsible for developing the standards on transport equipment specific management requirements and information model, and then mapping the UML model into YANG using some tools.

There are some work items projected on data models for Ethernet transport network element, MPLS-TP, and even a work item on synchronization management data model based on G.7721.

But the models in ITU-T are top-down, and usually are based on the ONF core model. G.7721 is targeted at telecom equipment with full-fledged synchronization capability.

As shown in the following figure for G.7721:

While the data models developed in the IETF are bottom-up, and are not dependent on the ONF core model. Just as the model in this Sync-PHY shows, it is simple, independent, and decoupled from other models such as PTP models.

Thus it is more convenient to be integrated and implemented by smaller devices such as those in the industrial internet.

One of our coauthors, Jingfei, is also a regular attendee for Q13/SG15, maybe he has more to say on this topic.

Thanks,

Yuanlong

-----Original Message-----

From: Tal Mizrahi [mailto:[email-masked]]

Sent: 2020年3月9日 15:52

To: Jiangyuanlong <[email-masked]<mailto:[email-masked]>>

Cc: Karen O'Donoghue <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Liuyan Han <[email-masked]<mailto:[email-masked]>>; Lvjingfei <[email-masked]<mailto:[email-masked]>>

Subject: Re: [TICTOC] New Version Notification for draft-jiang-tictoc-syncphy-yang-00.txt

Hi Yuanglong,

Q13 in the ITU-T.

Cheers,

Tal.

On Mon, Mar 9, 2020 at 5:11 AM Jiangyuanlong <[email-masked]<mailto:[email-masked]>> wrote:

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

> To: Liuyan Han <[email-masked]<mailto:[email-masked]>>; Lvjingfei <[email-masked]<mailto:[email-masked]>>; Jiangyuanlong <[email-masked]<mailto:[email-masked]>>

> [email-masked]<mailto:[email-masked]>

---

From: Lvjingfei <[email-masked]>
Date: Mon, 9 Mar 2020 10:43:56 +0000

Dear Tal,

I’m attending Q13 (ITU-T Study Group 15 Question 13) meeting, until now, there is no documents about Sync YANG model (including physical layer sync and PTP sync).

As you know, Yuanlong and others finished PTP yang model (RFC 8575) at the past years. This reminded me whether IETF can have a document to define physical layer sync YANG model. Then Yuanlong helped to prepare this original document.

I think if TicToc group thinks this is an useful topic, and some liaisons between TicToc and Q13 may be helpful. Then, some Q13 experts can involve in this work if they’re interested.

Thanks,

Best regards,

Jingfei

From: Jiangyuanlong
Sent: 2020年3月9日 17:42
To: [email-masked]
Cc: Lvjingfei <[email-masked]>; [email-masked]
Subject: RE: [TICTOC] New Version Notification for draft-jiang-tictoc-syncphy-yang-00.txt

Dear Tal,

Thanks,

Yuanlong

-----Original Message-----

Sent: 2020年3月9日 15:52

Hi Yuanglong,

Q13 in the ITU-T.

Cheers,

Tal.

On Mon, Mar 9, 2020 at 5:11 AM Jiangyuanlong <[email-masked]<mailto:[email-masked]>> wrote: