Subject: Re: [tlp-interest] Proposed Policy on Rights in IANA Parameter Registry Data

From: Timothy Mcsweeney <[email-masked]>
Date: Sun, 20 Sep 2020 23:30:49 -0400 (EDT)

Hi Glen,
>[GD] I’ll add to what John said, that it was IANA that first brought the situation to the Trust’s attention,
>and we discussed this approach them before moving forward with the consultation with the broader community.
>The Trustees intention is that this gets as many eyes looking at this as reasonably possible.

For those eyeballs, has there been or will there be an email sent out to anyone who has an email listed in on of those registries? I think even just the provision URI scheme listings have fifty or more different emails listed.

---

From: "Deen, Glenn" <[email-masked]>
Date: Mon, 21 Sep 2020 21:11:20 +0000

Hi

Thanks for the suggestion.   I don’t know if there is a list that all of them are subscribed to – beyond the IETF and IETF-Announce lists that the announcement has already gone out to.

I’d be hesitant to direct mail that many people – it would be like sending an email to everyone listed as an IETF draft author. There is a time for doing such super broad mailings, but this doesn’t seem to be a big enough/controversial enough topic to warrant direct mails to so many people just to alert them about a clarification declaration that doesn’t actually change the current practice or  use rules.     Especially when you consider that so far not a single reason has been raised against the  proposed action.

Eyeballs are welcome, but the hope/expectation was that between the IETF lists and the IANA group that would cover enough distribution channels and have them share with anyone they felt needed to review it such as company attorneys etc. .

-glenn

On 9/21/20, 10:48 AM, "tlp-interest on behalf of Timothy Mcsweeney" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Glen,

---

From: Timothy Mcsweeney <[email-masked]>
Date: Mon, 21 Sep 2020 19:47:40 -0400 (EDT)

Hi Glenn,

>Especially when you consider that so far not a single reason has been raised against the proposed action.

Allow me to be the first.

Attempting to wipe away someone copyrights by merely saying so seems a bit agressive to me.  Then to not give others a informed opportunity to open source or license those copyrights before the change is made seems even more aggressive.  But to give away someones copyrights to the general public without even attempted contact seems to me, most agessive.  Aren't the people in those registries your customers?  I have copywritten material on those registries and I was nt under any obligation to give up copyrights when a submission was made, nor am I in any particular hurry to do so.  Or perhaps this is just for submissions going forward, is that right?

It's interesting to me to see the support for this before the the lawyers finalize the language.  Things can, and usually do, change drastically after lawyers get involved.  Wouldn't it be better for everyone to see the final product first?  One of the things that really jumps out at me is where is says that this new policy...:

Must ensure that any text that may be considered as copyrighted,
including that from an RFC or another document, is included so
that there is no ambiguity.
<tools.ietf.org/html/draft-halpern-trust-ianapolicy-00>

>Eyeballs are welcome, but the hope/expectation was that between the IETF lists and the IANA group that would cover enough distribution channels and >have them share with anyone they felt needed to review it such as company attorneys etc. .

I will do my best to get you some more eyeballs.

Tim

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 22 Sep 2020 01:01:08 +0000

> I have copywritten material on those registries and I was nt under any obligation to give up copyrights when a submission was made
I do not think is correct, for at least two reasons:

  1.  It is unlikely that the text in an IANA registry is anything other than “de minimus” and therefor not copyrightable
  2.  You seem to be ignoring the implied compilation copyright that IANA has on the collection of registry items
  3.  If the registry entry came from an RFC (which I tend to doubt yours did), then the copyright is the IETF LLC
Can you point out which specific content in the registry is yours?

---

From: "John R. Levine" <[email-masked]>
Date: 21 Sep 2020 21:06:28 -0400

On Mon, 21 Sep 2020, Timothy Mcsweeney wrote:
> Attempting to wipe away someone copyrights by merely saying so seems a 
> bit agressive to me. ...

Please review Joel's draft.  We do not believe the protocol parameters are 
subject to copyright, and this just makes that clearer.  There is nothing 
to "wipe away".

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 22 Sep 2020 01:45:49 +0000

Dropping IETF since we asked for this to be discussed on the tlp-interest list, and we don’t want to flood the main IETF list with this stuff.

On 9/21/20, 4:48 PM, "ietf on behalf of Timothy Mcsweeney" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Glenn,
Allow me to be the first.
Attempting to wipe away someone copyrights by merely saying so seems a bit agressive to me.  Then to not give others a informed opportunity to open source or license those copyrights before the change is made seems even more aggressive.  But to give away someones copyrights to the general public without even attempted contact seems to me, most agessive.  Aren't the people in those registries your customers?  I have copywritten material on those registries and I was nt under any obligation to give up copyrights when a submission was made, nor am I in any particular hurry to do so.  Or perhaps this is just for submissions going forward, is that right?
Tim, as John Levine suggested this is better explained in the Draft, but the short version is that lists of values are in general not considered to be subject to copyright under US copyright law, which is where the jurisdiction that the IETF Trust and the IANA registry operate in.     That does not mean the documents that these values originate from are not subject to copyright, as things like RFCs are clearly subject to copyright.    When you extract the protocol parameter values from RFC or other works, even though the sources are covered by copyright, the extracted lists are just lists and not subject to copyright.
       – Does that make sense?  This is the base principle that is important to the entire proposal.
So the situation here is that the IANA registries are lists of values and are already, without any action by the IETF Trust, not subject to copyright.   It’s not that anyone has taken action to remove anyone’s copyright here – they are simply not subject to copyright.     The IETF Trust is not trying to change the current IP rights status of the lists, it’s merely trying to document it officially.
Given that these lists are not subject to copyright restrictions, how do we go about communicating that clearly.    That’s what the IETF Trust proposal is all about.   Communicating to users of IANA that these lists are not protected by copyright. We want to do that in a way that doesn’t require the users to also have a background in copyright law, especially the edge cases like lists.    While there is such a thing as a copyright notice, like the ones that each RFC carries in its header, there isn’t an opposite “no copyright notice” that can be put into lists.  Even if there where, there’s no way to require such a notice to be carried along and reproduced when someone copies the list – since there is no copyright license to add such a requirement through.
So the IETF Trust is thus left with the goal of having some sort of easy to understand way of communicating this statement, and not require it to be copied along with the lists.     Hence, the choice of the Creative Commons Zero and putting that notice on the IETF Trust’s official page in the license materials.   It is a well-reviewed and understood declaration for an item that does not copyright restrictions on it.   In common parlance it’s what people call the public domain.   So just like a creative work that was subject to copyright but has passed out of copyright due to time and moved in the public domain, the lists live in the public domain today.  We are using CC0 to document that fact.
The Draft includes better wording of all of that, so please refer to it for the “official” version and not the text I quickly just wrote.
It's interesting to me to see the support for this before the the lawyers finalize the language.  Things can, and usually do, change drastically after lawyers get involved.  Wouldn't it be better for everyone to see the final product first?  One of the things that really jumps out at me is where is says that this new policy...:
The IETF Trust’s legal counsel was engaged in evaluating and developing the proposed policy.   The Trustees also ran it by several IP attorneys at companies as an extra checks.  All agreed with the legal analysis.

I hope that helps explain things a bit more.

Regards

Glenn

---

From: Dick Franks <[email-masked]>
Date: Tue, 22 Sep 2020 03:10:38 +0100

On Tue, 22 Sep 2020 at 00:47, Timothy Mcsweeney <[email-masked]> wrote:

> Attempting to wipe away someone copyrights by merely saying so seems a bit
> agressive to me.  Then to not give others a informed opportunity to open
> source or license those copyrights before the change is made seems even
> more aggressive.  But to give away someones copyrights to the general
> public without even attempted contact seems to me, most agessive.  Aren't
> the people in those registries your customers?  I have copywritten material
> on those registries and I was nt under any obligation to give up copyrights
> when a submission was made, nor am I in any particular hurry to do so.  Or
> perhaps this is just for submissions going forward, is that right?
>

Protocol registries are analogous to telephone directories.
The US Supreme Court held that white page directories are not entitled to
copyright, overturning the decisions of the District Court and Court of
Appeals.

*Feist Publications, Incorporated v. Rural Telephone Service Company,
Incorporated*, 499 U.S. 340 (1991).

---

From: Timothy Mcsweeney <[email-masked]>
Date: Mon, 21 Sep 2020 22:30:25 -0400 (EDT)

Hi John,

>Please review Joel's draft.

I already quoted text from it.  I also have a problem with this statement from Joel's draft:

"In addition some of the protocol parameter registries include text
snippets, some from RFCs or other documents, that could be considered
copyrighted and the existence of this text should not be allowed to
cause a problem."

Some may try to tell me that I'm reading that wrong but it says what it says.