Subject: [tlp-interest] A clerical correction to the IETF Trust Legal Provisions 5.0

From: "John R Levine" <[email-masked]>
Date: 23 Aug 2021 22:18:27 -0400

The IETF Trust originally published the Trust Legal Provisions in 2008 and 
has updated it four times, most recently as TLP 5.0 published in 2015.

The trustees recently noted a confusing clerical error in the TLP where it 
describes the license we offer on code components of RFCs and other IETF 
contributions.

Over the years there have been several variations of the BSD license. The 
most common are the two-clause and three-clause versions.  The license we 
use is is the three-clause BSD license, which is included in full in the 
TLP.  That license is generally known as the Revised or Modified BSD 
license, while the two-clause license is known as the Simplified license. 
For reasons lost to history, the TLP 5.0 refers to its license as the 
Simplified license, even though it is really the Revised license.  Oops. 
This name error has been copied into boilerplate in RFCs and I-Ds even 
though the license itself is correct.

We plan to make clerical corrections to the TLP to change the name to 
Revised license in all the places where the name occurs, and to change a 
URL to link to the correct license at opensource.org.  The license itself 
does not change, only the name used to refer to it.

This Google doc shows the changes:

https://docs.google.com/document/d/1FnlAk3gp8AWmwBzwhyr71MC2Jtd8rLYoJ3MVJTggfPw/edit?usp=sharing

Since this update only corrects a mistake and makes no substantive change 
to the TLP or the licenses it grants, we plan to post this as a correction 
rather than as a new version of the TLP.  Once we have done that we also 
plan to request changes to I-D and RFC boilerplate that use the wrong 
name, again, with no changes to the licenses themselves.

If you have comments or questions, please follow up to [email-masked].

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Lars Eggert <[email-masked]>
Date: Tue, 24 Aug 2021 09:38:56 +0300

Hi,

On 2021-8-24, at 5:18, John R Levine <[email-masked]> wrote:
> We plan to make clerical corrections to the TLP to change the name to Revised license in all the places where the name occurs, and to change a URL to link to the correct license at opensource.org.  The license itself does not change, only the name used to refer to it.
> 

I don't see any highlighted changes in that document, and it also still seems to talk about the Simplified BSD License - am I missing something?

> Since this update only corrects a mistake and makes no substantive change to the TLP or the licenses it grants, we plan to post this as a correction rather than as a new version of the TLP.  Once we have done that we also plan to request changes to I-D and RFC boilerplate that use the wrong name, again, with no changes to the licenses themselves.

Would those changes to boilerplate text amount to anything more than replacing "Simplified BSD License" with "Modified BSD license" in the text below?

   Code Components extracted from this document must
   include Simplified BSD License text as described in Section 4.e of
   the Trust Legal Provisions and are provided without warranty as
   described in the Simplified BSD License.

Also, is there a plan to do anything about the ~3000 RFCs that were published with this incorrect boilerplate text?

Thanks,
Lars

---

From: "John R. Levine" <[email-masked]>
Date: 24 Aug 2021 11:43:11 -0400

> I don't see any highlighted changes in that document, and it also still seems to talk about the Simplified BSD License - am I missing something?

Google Docs is doing something strange -- the Docs app on my iPad shows 
the diffs, the web site doesn't.  I'll try and get it to make a PDF.

> Would those changes to boilerplate text amount to anything more than replacing "Simplified BSD License" with "Modified BSD license" in the text below?

That's it.

> Also, is there a plan to do anything about the ~3000 RFCs that were published with this incorrect boilerplate text?

Since we don't have a way to update them, no.  The boilerplate says

TLP section 4 contains the correct license with the wrong name, for anyone 
who cares enough to look at it.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "John R. Levine" <[email-masked]>
Date: 24 Aug 2021 12:03:45 -0400

On Tue, 24 Aug 2021, John R. Levine wrote:
>> I don't see any highlighted changes in that document, and it also still 
>> seems to talk about the Simplified BSD License - am I missing something?

OK, I exported it to a docx file and printed that to a PDF that shows the 
changes.  I love software.

Regards,

---

From: Russ Housley <[email-masked]>
Date: Tue, 24 Aug 2021 13:46:47 -0400

John:

Thanks for the PDF.  The Google Doc did not make any sense to me.

The changes seem fine to me.

I wonder if the The 3-Clause BSD License license shoudl be put on a URL controlled by the IETF Trust to ensure that it not changed by anyone.

Russ

---

From: "John R. Levine" <[email-masked]>
Date: 24 Aug 2021 14:14:58 -0400

> I wonder if the The 3-Clause BSD License license shoudl be put on a URL 
> controlled by the IETF Trust to ensure that it not changed by anyone.

The license text is in the TLP so I don't think that'll be a problem.

On the other hand, if OSI changed the text of the BSD 
license, we would hardly be the first group to be upset.

Regards,

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 Aug 2021 09:19:21 +1200

John,

Thanks.

(a) Please check the "effective date" at the top of the document.
(b) I strongly suggest adding a note something like

"Between <date1> and <date2> this document erroneously referred to the Revised license as the 'Simplified' license, but the text of the license was always as intended."

Regards
   Brian Carpenter

On 25-Aug-21 04:03, John R. Levine wrote:
> _______________________________________________
> tlp-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tlp-interest
>

---

From: Lars Eggert <[email-masked]>
Date: Wed, 25 Aug 2021 10:31:34 +0300

> "Between <date1> and <date2> this document erroneously referred to the Revised license as the 'Simplified' license, but the text of the license was always as intended."

+1

We might also want to add something about some/most RFCs between 5245-9118 (but please verify these numbers) having incorrect boilerplate text.

Thanks,
Lars