Subject: Re: [tlp-interest] A clerical correction to the IETF Trust Legal Provisions 5.0

From: "John R. Levine" <[email-masked]>
Date: 1 Sep 2021 21:03:41 -0400

>> (b) I strongly suggest adding a note something like

Done, see 
https://docs.google.com/document/d/1FnlAk3gp8AWmwBzwhyr71MC2Jtd8rLYoJ3MVJTggfPw/edit?usp=sharing

> We might also want to add something about some/most RFCs between 5245-9118 (but please verify these numbers) having incorrect boilerplate text.

I put in something more generic since the wrong license name is all over 
the place.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 3 Sep 2021 09:14:49 +1200

> I put in something more generic since the wrong license name is all over 

Thanks, John. I guess the RFC Editor could usefully put a note on their own site, too.

   Brian

---

From: "John R. Levine" <[email-masked]>
Date: 2 Sep 2021 17:21:19 -0400

> Thanks, John. I guess the RFC Editor could usefully put a note on their own site, too.

I think I can make that happen.

Regards,

---

From: Lars Eggert <[email-masked]>
Date: Fri, 3 Sep 2021 16:31:06 +0300

Hi,

On 2021-9-2, at 4:03, John R. Levine <[email-masked]> wrote:
> Done, see https://docs.google.com/document/d/1FnlAk3gp8AWmwBzwhyr71MC2Jtd8rLYoJ3MVJTggfPw/edit?usp=sharing

I added some comments.

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Tue, 7 Sep 2021 15:51:10 +0300

Hi,

>> Done, see https://docs.google.com/document/d/1FnlAk3gp8AWmwBzwhyr71MC2Jtd8rLYoJ3MVJTggfPw/edit?usp=sharing

and some got merged. And all got deleted, even the ones where I asked questions?

Since my question was basically about whether the changed TLP in the Google Doc has *all* the changes highlighted compared to the current TLP, I went ahead and did a diff on the text versions (attached.)

I see three changes:

1. Addition of the note at the beginning describing the license confusion, also highlighted in the Google Doc

2. Several replacements of "Simplified" with "Revised". The Google Doc only highlights one such change.

3. A change of http://opensource.org/licenses/bsd-license.php to https://opensource.org/licenses/BSD-3-Clause, which is not highlighted in the Google Doc.

So the Google Doc is not in fact useful to understand all the changes that were made.

Thanks,
Lars

---

From: "John Levine" <[email-masked]>
Date: 7 Sep 2021 13:15:27 -0400

It appears that Lars Eggert  <[email-masked]> said:
>-=-=-=-=-=-
>-=-=-=-=-=-

>So the Google Doc is not in fact useful to understand all the changes that were made.

That's why I sent out the PDF on August 24th showing the changes.  Google Docs
sometimes shows you the diffs, sometimes doesn't, depending on your client,
what kind of account you are using, and the phase of the moon.

https://mailarchive.ietf.org/arch/msg/tlp-interest/dhoa-NDNbxYdcqiGvMmhvF8Qzek/

R's,
John

---

From: Lars Eggert <[email-masked]>
Date: Mon, 13 Sep 2021 09:53:11 +0300

Hi,

On 2021-9-7, at 20:15, John Levine <[email-masked]> wrote:
> That's why I sent out the PDF on August 24th showing the changes.

sorry, I had missed that attachment!

I think https://trustee.ietf.org/assets/licenses/license-for-open-source-repositories/ also needs to be updated, as do a bunch of other pages on trustee.ietf.org: https://www.google.com/search?client=firefox-b-d&q=Simplified+BSD+License+site%3Atrustee.ietf.org

About the boilerplate text on the bottom of https://trustee.ietf.org/assets/licenses/license-for-open-source-repositories/: since that is the canonical version, would it be possible to make it available (and keep it updated) as Markdown, for easier inclusion into various IETF-related code repositories?

Thanks,
Lars

---

From: "John Levine" <[email-masked]>
Date: 13 Sep 2021 15:15:13 -0400

It appears that Lars Eggert  <[email-masked]> said:
>I think https://trustee.ietf.org/assets/licenses/license-for-open-source-repositories/ also needs to be updated, as do a bunch of other pages on trustee.ietf.org:
>https://www.google.com/search?client=firefox-b-d&q=Simplified+BSD+License+site%3Atrustee.ietf.org

Yeah, there's a lot of places we'll need to fix.  This error has been around for a decade, after all.

>About the boilerplate text on the bottom of https://trustee.ietf.org/assets/licenses/license-for-open-source-repositories/: since that is the canonical version,
>would it be possible to make it available (and keep it updated) as Markdown, for easier inclusion into various IETF-related code repositories?

The boilerplace is just three paragraphs of text.  I don't see how would putting it in markdown would make any difference other
than perhaps making the URLs linkier.

R's,
John

---

From: Lars Eggert <[email-masked]>
Date: Tue, 14 Sep 2021 11:16:55 +0300

Hi,

On 2021-9-13, at 22:15, John Levine <[email-masked]> wrote:
> The boilerplace is just three paragraphs of text.  I don't see how would putting it in markdown would make any difference other than perhaps making the URLs linkier.

it would allow GitHub users and others to include the Markdown text directly (and ideally have it automatically update), rather than screen-scraping an HTML page.

If screen-scraping is still the way to go, could a publication timestamp be added to those pages that have boilerplate text, so one would know when something has changed?

Thanks,
Lars

---

From: "John R Levine" <[email-masked]>
Date: 14 Sep 2021 12:43:38 -0400

OK, like I said, I'm not opposed, I just don't want yet another quick hack 
that ends up with bitrot.  The trust has too many of those.

In this particular case, I really hope it does not change again.  I don't 
understand how they got it wrong in the first place.

> If screen-scraping is still the way to go, could a publication timestamp be added to those pages that have boilerplate text, so one would know when something has changed?

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Deen, Glenn" <[email-masked]>
Date: Tue, 14 Sep 2021 18:16:02 +0000

On 9/14/21, 1:17 AM, "tlp-interest on behalf of Lars Eggert" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

I don't either of the these ideas are good - Markdown formatted for including, or screen scraping are ok.

I don't think the Trust's published license material should be included in an automatic "include" / "pull-down".   Not only does that (1)  build a dependency that in the future can easily break, and result in built materials not getting any licensing information included - but it also  (2) can cause licensing conflicts if the Trust publishes UPDATE or NEW licensing materials and these automated includes either keep on including the OLD version or they incorrectly begin including the NEW version into situations where it doesn't correctly apply.

There is an important value in having a human in the loop, reading instructions, understanding applicability and making decisions.    This isn't just an updated set of header files in a build, this is legal material which carries a lot of context which must be considered.

-glenn

---

From: Lars Eggert <[email-masked]>
Date: Tue, 21 Sep 2021 11:57:08 +0300

Hi,

On 2021-8-24, at 5:18, John R Levine <[email-masked]> wrote:
> The trustees recently noted a confusing clerical error in the TLP where it describes the license we offer on code components of RFCs and other IETF contributions.
...
> Since this update only corrects a mistake and makes no substantive change to the TLP or the licenses it grants, we plan to post this as a correction rather than as a new version of the TLP.  Once we have done that we also plan to request changes to I-D and RFC boilerplate that use the wrong name, again, with no changes to the licenses themselves.

is there a timeline for this correction to happen?

I'm asking, because while for the Trust this is a relatively straightforward update to some of their web pages, on the IETF side we need some tools work to implement this change (in addition to also needing to update a larger number of web sites and open source repositories.)

Thanks,
Lars

---

From: "John Levine" <[email-masked]>
Date: 22 Sep 2021 00:26:08 -0400

It appears that Lars Eggert  <[email-masked]> said:
>rather than as a new version of the TLP.  Once we have done that we also plan to request changes to I-D and RFC boilerplate that use the wrong name,
>again, with no changes to the licenses themselves.
>

We met today and agreed to do it this week.

>I'm asking, because while for the Trust this is a relatively straightforward update to some of their web pages, on the IETF side we need some tools
>work to implement this change (in addition to also needing to update a larger number of web sites and open source repositories.)

We realize that it will take a while, perhaps a very long while, to
find and fix all the places it says "Simplified" and change them to
"Revised". There's no chance of finding and fixing everything all at
once across all of the IETF's web sites and tools (xml2rfc has to
change, for example) so it'll be a rolling fix.

Once again, the license itself has not changed and will not change, it's just
referring to it by the correct name.  Having read the TLP in detail while
reformatting it and looking for other mistakes, I do not expect that we
will make any other changes or fixes in the forseeable future.  I sure
hope not, this one word is painful enough as it is.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 23 Sep 2021 09:41:19 -0400

We published the correction to the TLP on the trust web site today.

Announcement here:

https://trustee.ietf.org/documents/trust-legal-provisions/

Corrected TLP here:

https://trustee.ietf.org/documents/trust-legal-provisions/tlp-5/

As I said before, we realize it that the old "Simplified" language appears in many places, and it will
take a while to find them and correct them.  The actual license has not changed, only the name used to
refer to it.

R's,
John