Subject: Re: [Tls-reg-review] Request to register TLS integrity only cipher suites for TLS 1.3

From: "Salz, Rich" <[email-masked]>
Date: Tue, 11 Dec 2018 18:32:13 +0000

Seems legit to me.  Anyone else have a view?

On 12/5/18, 2:54 PM, "Nancy Cam-Winget (ncamwing)" <[email-masked]> wrote:

        > Contact Name:
        > Nancy Cam-Winget
        > 
        > Contact Email:
        > [email-masked]
        > 
        > Type of Assignment:
        > "Not Recommended" TLS Cipher suite assignment
        > 
        > Registry:
        > TLS 1.3 cipher suite
        > 
        > Description:
        > At least two IoT (ODVA and IEC) forums are requesting the need for
        > enabling TLS 1.3 with integrity only protection in the data plane.
        > Under security considerations, we are not recommending this cipher
        > suite to be widely used and note that no privacy is provided when this
        > cipher suite is used and several use cases have been noted where
        > privacy is not required.
        > 
        > Additional Info:
        > We have noted the use cases and security (and privacy) considerations
        > in https://tools.ietf.org/html/draft-camwinget-tls-ts13-macciphersuites-01 as well as how the cipher suite would be used with
        > TLS 1.3

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Nick Sullivan <[email-masked]>
Date: Tue, 11 Dec 2018 18:37:50 +0000

I guess there's no requirement for a TLS 1.3 ciphersuite to be literal
AEAD, is there?

It should be fine to assign two "not recommended" points.

On Tue, Dec 11, 2018 at 6:32 PM Salz, Rich <[email-masked]> wrote:

>         > in
> https://tools.ietf.org/html/draft-camwinget-tls-ts13-macciphersuites-01
> as well as how the cipher suite would be used with
>         > TLS 1.3
>
>
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 11 Dec 2018 21:09:11 +0200

My understanding is that *if* they do both encryption and authentication, then they need to be properly specified AEADs rather than having some method of rolling them together defined in TLS itself. 

But if you don’t want the encryption, you should be fine with just the MAC.   

I think this is fine.

> On 11 Dec 2018, at 20:37, Nick Sullivan <nick=[email-masked]> wrote:
> 
> I guess there's no requirement for a TLS 1.3 ciphersuite to be literal AEAD, is there?
> 
> On Tue, Dec 11, 2018 at 6:32 PM Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
> On 12/5/18, 2:54 PM, "Nancy Cam-Winget (ncamwing)" <[email-masked] <mailto:[email-masked]>> wrote:
> 
>         > Contact Name:
>         > Nancy Cam-Winget
>         > 
>         > Contact Email:
>         > [email-masked] <mailto:[email-masked]>
>         > 
>         > Type of Assignment:
>         > in https://tools.ietf.org/html/draft-camwinget-tls-ts13-macciphersuites-01 <https://tools.ietf.org/html/draft-camwinget-tls-ts13-macciphersuites-01> as well as how the cipher suite would be used with
>         > TLS 1.3
> 
> 
> 
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>