Subject: Re: [Tls-reg-review] Request to register TLS integrity only cipher suites for TLS 1.3

From: "Salz, Rich" <[email-masked]>
Date: Tue, 11 Dec 2018 20:33:22 +0000

We discussed this and approve.  Please assign two numbers in the "not recommended" space.

Thanks!

On 12/5/18, 2:54 PM, "Nancy Cam-Winget (ncamwing)" <[email-masked]> wrote:

        > Contact Name:
        > Nancy Cam-Winget
        > 
        > Contact Email:
        > [email-masked]
        > 
        > Type of Assignment:
        > "Not Recommended" TLS Cipher suite assignment
        > 
        > Registry:
        > TLS 1.3 cipher suite
        > 
        > Description:
        > At least two IoT (ODVA and IEC) forums are requesting the need for
        > enabling TLS 1.3 with integrity only protection in the data plane.
        > Under security considerations, we are not recommending this cipher
        > suite to be widely used and note that no privacy is provided when this
        > cipher suite is used and several use cases have been noted where
        > privacy is not required.
        > 
        > Additional Info:
        > We have noted the use cases and security (and privacy) considerations
        > in https://tools.ietf.org/html/draft-camwinget-tls-ts13-macciphersuites-01 as well as how the cipher suite would be used with
        > TLS 1.3

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 12 Dec 2018 01:29:56 +0000

Hi Rich,

Which values should we assign? There are a number of ranges available, and I haven't been able to find any text in RFC 8447 or RFC 8446 that identifies which section is for "Not Recommended" assignments:

https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4

Thanks for your patience,

Amanda Baber
Lead IANA Services Specialist

On Tue Dec 11 20:34:22 2018, [email-masked] wrote:
> > in https://tools.ietf.org/html/draft-camwinget-tls-ts13-
> > macciphersuites-01 as well as how the cipher suite would be used with
> > TLS 1.3
> 
> 
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 12 Dec 2018 16:50:37 +0000

To avoid creating new holes, how about right after dragonfly:
0xC0,0xB3 	TLS_ECCPWD_WITH_AES_256_CCM_SHA384 	Y 	N 	[RFC-harkins-tls-dragonfly-03]
0xC0,0xB4-FF 	Unassigned

On 12/11/18, 8:29 PM, "Amanda Baber via RT" <[email-masked]> wrote:

    Hi Rich,

    
    
    Amanda Baber

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 12 Dec 2018 23:12:35 +0000

Hi Rich, all, 

Sorry we have one more question. Can you let us know how to fill in the "DTLS-OK" column in the TLS Cipher Suites registry?

Thanks,

Sabrina Tanamal (filling in for Amanda)
Senior IANA Services Specialist

On Wed Dec 12 16:51:20 2018, [email-masked] wrote:
> Which values should we assign? There are a number of ranges available,
> and I haven't been able to find any text in RFC 8447 or RFC 8446 that
> identifies which section is for "Not Recommended" assignments:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 13 Dec 2018 03:55:03 +0000

DLTS-OK is Y

On 12/12/18, 6:12 PM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    Hi Rich, all, 

    Thanks,

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Thu, 13 Dec 2018 17:04:16 +0000

Hi all, 

The following entries have been added to the TLS Cipher Suites registry:

Value: 0xC0,0xB4
Description: TLS_SHA256_SHA256
DTLS-OK: Y
Recommended: N
Reference: [draft-camwinget-tls-ts13-macciphersuites]

Value: 0xC0,0xB5
Description: TLS_SHA384_SHA384
DTLS-OK: Y
Recommended: N
Reference: [draft-camwinget-tls-ts13-macciphersuites]

Please see
https://www.iana.org/assignments/tls-parameters

Best regards, 

Sabrina Tanamal